Firestorm
  1. Firestorm
  2. FIRE-10962

Avatar textures taking 30 min to 1 hr to load with server side baking

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 4.4.2
    • Fix Version/s: Phoenix Firestorm 4.5.1
    • Component/s: Avatars
    • Environment:
    • SL Avatar Name:
      Argent Stonecutter
    • Reported In:
      Firestorm 4.4.2.34167 Release

      Description

      With the new "server side baking" viewers, loading avatars is extermely slow, taking as much as half an hour to an hour before all the avatars in a busy region are loaded. Avatar textures are particularly bad, but even avatar attachments seem to take much longer than they used to.

      Updated the "Environment".

      Added a screen shot of Lusk. All environment textures are loaded, and my own avatar is fine because it was already loaded in an empty sim... but all the other avatars are grey and the only colors on any of them seem to be mesh attachments. And this is not that busy a region, only about half a dozen avatars.

        Activity

        Hide
        Argent Stonecutter added a comment -

        In sims that actually have server side baking enabled, this problem doesn't happen. It seems like there's a problem in the fallback code, possibly triggered by my slow (256k DSL) internet link.

        Show
        Argent Stonecutter added a comment - In sims that actually have server side baking enabled, this problem doesn't happen. It seems like there's a problem in the fallback code, possibly triggered by my slow (256k DSL) internet link.
        Hide
        Whirly Fizzle added a comment -

        Argent, can you try changing this setting and see if it helps for now on non-SSA enabled regions:

        • Enable Advanced menu in top menu bar with CTRL+ALT+D
        • Advanced -> Debug Settings -> UseHTTPBakedTextureFetch -> set to TRUE

        Glad to hear this is not a problem for you on SSA regions. Im hoping changing that debug will tide you over until SSA is grid wide.

        Please let us know if this helps.
        Thanks!

        Show
        Whirly Fizzle added a comment - Argent, can you try changing this setting and see if it helps for now on non-SSA enabled regions: Enable Advanced menu in top menu bar with CTRL+ALT+D Advanced -> Debug Settings -> UseHTTPBakedTextureFetch -> set to TRUE Glad to hear this is not a problem for you on SSA regions. Im hoping changing that debug will tide you over until SSA is grid wide. Please let us know if this helps. Thanks!
        Hide
        Argent Stonecutter added a comment -

        It does, but that confuses me. Why would the SSA change disable HTTP download of textures from non-SSA regions? Shouldn't the regular HTTP texture option apply to ALL textures?

        Show
        Argent Stonecutter added a comment - It does, but that confuses me. Why would the SSA change disable HTTP download of textures from non-SSA regions? Shouldn't the regular HTTP texture option apply to ALL textures?
        Hide
        Jaerik added a comment -

        The fetching of client side bakes via http was not LL behavior or intended LL behavior. Using http for client side bakes was a FS added option and function from this changeset http://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/1e4b84e85d36

        It was later changed back to the standard LL behavior in this changeset http://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/a521be7889ac

        Show
        Jaerik added a comment - The fetching of client side bakes via http was not LL behavior or intended LL behavior. Using http for client side bakes was a FS added option and function from this changeset http://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/1e4b84e85d36 It was later changed back to the standard LL behavior in this changeset http://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/a521be7889ac
        Hide
        Nellie Bly added a comment - - edited

        Recently I found myself in a public place (M) with all the clothing missing on the lower half of my body. Now i check myself carefully before going out. In addition, I now see other women appearing nude first, before the clothes slowly start to appear. As an IT architect in RL, i am neither amused nor impressed with this recent change.

        Show
        Nellie Bly added a comment - - edited Recently I found myself in a public place (M) with all the clothing missing on the lower half of my body. Now i check myself carefully before going out. In addition, I now see other women appearing nude first, before the clothes slowly start to appear. As an IT architect in RL, i am neither amused nor impressed with this recent change.
        Hide
        Whirly Fizzle added a comment -

        Are you still able to reproduce this problem on the 4.5.1 beta?
        If so, please repaste all your system information from help -> About Firestorm.

        Thanks!

        Show
        Whirly Fizzle added a comment - Are you still able to reproduce this problem on the 4.5.1 beta? If so, please repaste all your system information from help -> About Firestorm. Thanks!
        Hide
        Argent Stonecutter added a comment -

        Not seeing it currently.

        Show
        Argent Stonecutter added a comment - Not seeing it currently.
        Hide
        Whirly Fizzle added a comment -

        Awesome.
        I'll close this issue Argent.

        Show
        Whirly Fizzle added a comment - Awesome. I'll close this issue Argent.

          People

          • Assignee:
            Unassigned
            Reporter:
            Argent Stonecutter
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: