Firestorm
  1. Firestorm
  2. FIRE-12365

Resubmit of 11750 - Environment settings not set correctly when RLV is enabled

    Details

    • Type: Bug Bug
    • Status: Open Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: Phoenix Firestorm 4.5.1
    • Fix Version/s: None
    • Component/s: RLVa
    • Labels:
      None
    • Environment:
    • SL Avatar Name:
      Horsey Toll
    • Reported In:
      Firestorm 4.5.1 CHUI

      Description

      When I log on, my environment setting are supposed to be following the region, but they are not, they always seem to be Midday.

      Each time I log on, I have to either change the sun position to Estate Time or go to Environment Editor/Environment Settings ... and click OK in order for the environment to be rendered correctly.

      My Environment Settings are set as Always use parcel/region settings + Use region settings.

      Additionally, it would seem that trying to save Customize my environment to use Day Cycle: Default also does not work, as each time it reverts to use parcel settings.

      It seems Environment settings is completely broken and always reverts to Midday on logon.

      The problem is consistent and can be seen at

      http://maps.secondlife.com/secondlife/DSTech/128/236/23

      When I login I get the daylight view shown in windlight_1.

      If I update my Sun Position to Estate time, I get the night view as is supposed to be in windlight_2.

      On each logon, or TP to the region it reverts to Midday.

      I haven't found any combination of settings which actually delivers estate time when I login and arrived at the region ... its supposed to be dark.

      1. environment_settings.jpg
        39 kB
      2. windlight_1.jpg
        185 kB
      3. windlight_2.jpg
        159 kB

        Issue Links

          Activity

          Hide
          Lassie added a comment -

          unable to repro with Firestorm 4.5.2 (39688) Nov 23 2013 21:29:56 (Firestorm-LassieStorm) with OpenSimulator support

          Show
          Lassie added a comment - unable to repro with Firestorm 4.5.2 (39688) Nov 23 2013 21:29:56 (Firestorm-LassieStorm) with OpenSimulator support
          Hide
          Whirly Fizzle added a comment - - edited

          Im having problems reproducing this also - with my settings matched to what you show in your images.

          However, I can reproduce in a special case and that is if I was previously on a region using a fixed sky before I TP into DSTech.
          So my repro for this is:

          • Have all environment settings exactly as you show in your images.
          • Go to a region that uses a fixed sky under World -> Region details -> Environment -> Use the following settings -> Fixed sky.
            Use a fixed sky thats really easy to spot here like Orac - drawing blue.
            Make sure you are seeing this fixed sky in the viewer.
          • Now teleport into http://maps.secondlife.com/secondlife/DSTech/126/236/23
          • Observe that you are STILL seeing the fixed sky from the last region until you either open then close about land floater, open then close Region/estate floater, open world -> environment editor -> environment settings -> click OK, or go to World -> Sun position -> estate time.

          The part I cannot reproduce is logging into DSTech and seeing the wrong fixed sky setting instead of estate setting.

          Show
          Whirly Fizzle added a comment - - edited Im having problems reproducing this also - with my settings matched to what you show in your images. However, I can reproduce in a special case and that is if I was previously on a region using a fixed sky before I TP into DSTech. So my repro for this is: Have all environment settings exactly as you show in your images. Go to a region that uses a fixed sky under World -> Region details -> Environment -> Use the following settings -> Fixed sky. Use a fixed sky thats really easy to spot here like Orac - drawing blue. Make sure you are seeing this fixed sky in the viewer. Now teleport into http://maps.secondlife.com/secondlife/DSTech/126/236/23 Observe that you are STILL seeing the fixed sky from the last region until you either open then close about land floater, open then close Region/estate floater, open world -> environment editor -> environment settings -> click OK, or go to World -> Sun position -> estate time. The part I cannot reproduce is logging into DSTech and seeing the wrong fixed sky setting instead of estate setting.
          Hide
          Horsey Toll added a comment -

          I have just re-installed Firestorm from scratch, clearing out all user settings.
          On first log in, the region was drawn correctly (Night).
          I changed some of my settings, Keys, RLVa, MouseView, Advanced Lighting and Occlusion.
          Upon logging out and logging back in, it now shows as Daytime.
          Upon going to Environment Editor/Setting Click Ok, the view then immediately changes to Night.

          Show
          Horsey Toll added a comment - I have just re-installed Firestorm from scratch, clearing out all user settings. On first log in, the region was drawn correctly (Night). I changed some of my settings, Keys, RLVa, MouseView, Advanced Lighting and Occlusion. Upon logging out and logging back in, it now shows as Daytime. Upon going to Environment Editor/Setting Click Ok, the view then immediately changes to Night.
          Hide
          Whirly Fizzle added a comment -

          Hmmm.
          Horsey, if you disable RLV and then relog, does this still reproduce? Im just wondering if you are under some kind of RLV restriction for windlight that could affect this.

          Btw, Windlight is really broken in many ways. Linden lab are planning an overhaul of windlight in the nearish future so as far as Firestorm is concerned, bugs in windlight will probably not get fixed until after LL have done their changes.
          However, it would be great to get to the bottom of whats causing this behaviour for you so its documented.

          Show
          Whirly Fizzle added a comment - Hmmm. Horsey, if you disable RLV and then relog, does this still reproduce? Im just wondering if you are under some kind of RLV restriction for windlight that could affect this. Btw, Windlight is really broken in many ways. Linden lab are planning an overhaul of windlight in the nearish future so as far as Firestorm is concerned, bugs in windlight will probably not get fixed until after LL have done their changes. However, it would be great to get to the bottom of whats causing this behaviour for you so its documented.
          Hide
          Horsey Toll added a comment -

          Well spotted ... with RLVa disabled in Firestorm, everything is correct on login.
          With RLVa enabled in Firestorm, the view is wrong.

          The only restrictions I have are

          RestrainedLove viewer v2.7.0 (RLVa 1.4.8)

          [H]arsh Fem Straitjacket (chest) (Chest):
          -> tplure:1fe6af34-aef7-4511-897b-b248ecc93fc1 [devika.selona]

          Good Behavior HUD (center 2) (Center 2):
          -> accepttp:1fe6af34-aef7-4511-897b-b248ecc93fc1 [devika.selona]
          -> tplure:1fe6af34-aef7-4511-897b-b248ecc93fc1 [devika.selona]
          -> sendim:1fe6af34-aef7-4511-897b-b248ecc93fc1 [devika.selona]
          -> recvim:1fe6af34-aef7-4511-897b-b248ecc93fc1 [devika.selona]
          -> startim:1fe6af34-aef7-4511-897b-b248ecc93fc1 [devika.selona]
          -> accepttp:83b80a9f-8fd1-4e6c-b02d-f13614c084c5 [loom.kish]
          -> tplure:83b80a9f-8fd1-4e6c-b02d-f13614c084c5 [loom.kish]
          -> sendim:83b80a9f-8fd1-4e6c-b02d-f13614c084c5 [loom.kish]
          -> recvim:83b80a9f-8fd1-4e6c-b02d-f13614c084c5 [loom.kish]
          -> startim:83b80a9f-8fd1-4e6c-b02d-f13614c084c5 [loom.kish]
          -> sendchannel:21
          -> sendchannel:876881762
          -> notify:239526827;redirchat (invalid option)

          MD - Head Harness v4.3 (nose) (Nose):
          -> detach
          -> emote
          -> accepttp:1fe6af34-aef7-4511-897b-b248ecc93fc1 [devika.selona]
          -> sendim:1fe6af34-aef7-4511-897b-b248ecc93fc1 [devika.selona]
          -> recvim:1fe6af34-aef7-4511-897b-b248ecc93fc1 [devika.selona]
          -> tplure:1fe6af34-aef7-4511-897b-b248ecc93fc1 [devika.selona]

          Dahlia's multirelay 2.1 (Bottom Right):
          -> detach
          -> sendchannel:99

          It seems to be a defect with RLV.

          Show
          Horsey Toll added a comment - Well spotted ... with RLVa disabled in Firestorm, everything is correct on login. With RLVa enabled in Firestorm, the view is wrong. The only restrictions I have are RestrainedLove viewer v2.7.0 (RLVa 1.4.8) [H] arsh Fem Straitjacket (chest) (Chest): -> tplure:1fe6af34-aef7-4511-897b-b248ecc93fc1 [devika.selona] Good Behavior HUD (center 2) (Center 2): -> accepttp:1fe6af34-aef7-4511-897b-b248ecc93fc1 [devika.selona] -> tplure:1fe6af34-aef7-4511-897b-b248ecc93fc1 [devika.selona] -> sendim:1fe6af34-aef7-4511-897b-b248ecc93fc1 [devika.selona] -> recvim:1fe6af34-aef7-4511-897b-b248ecc93fc1 [devika.selona] -> startim:1fe6af34-aef7-4511-897b-b248ecc93fc1 [devika.selona] -> accepttp:83b80a9f-8fd1-4e6c-b02d-f13614c084c5 [loom.kish] -> tplure:83b80a9f-8fd1-4e6c-b02d-f13614c084c5 [loom.kish] -> sendim:83b80a9f-8fd1-4e6c-b02d-f13614c084c5 [loom.kish] -> recvim:83b80a9f-8fd1-4e6c-b02d-f13614c084c5 [loom.kish] -> startim:83b80a9f-8fd1-4e6c-b02d-f13614c084c5 [loom.kish] -> sendchannel:21 -> sendchannel:876881762 -> notify:239526827;redirchat (invalid option) MD - Head Harness v4.3 (nose) (Nose): -> detach -> emote -> accepttp:1fe6af34-aef7-4511-897b-b248ecc93fc1 [devika.selona] -> sendim:1fe6af34-aef7-4511-897b-b248ecc93fc1 [devika.selona] -> recvim:1fe6af34-aef7-4511-897b-b248ecc93fc1 [devika.selona] -> tplure:1fe6af34-aef7-4511-897b-b248ecc93fc1 [devika.selona] Dahlia's multirelay 2.1 (Bottom Right): -> detach -> sendchannel:99 It seems to be a defect with RLV.
          Hide
          Whirly Fizzle added a comment -

          Huh very strange.
          Well, at least we are making progress!

          I tested with RLV enabled in the viewer but with no restrictions set and this does not reproduce.

          I'll poke the devs that use RLV about this one.

          Thanks Horsey!

          Show
          Whirly Fizzle added a comment - Huh very strange. Well, at least we are making progress! I tested with RLV enabled in the viewer but with no restrictions set and this does not reproduce. I'll poke the devs that use RLV about this one. Thanks Horsey!
          Hide
          Ansariel Hiller added a comment -

          Now I tried to reproduce this at the named location wearing an Open Collar, but it couldn't. I set all restrictions I could using the collar, but after a relog, the sky still seemed to be correct and using region windlight settings.

          Show
          Ansariel Hiller added a comment - Now I tried to reproduce this at the named location wearing an Open Collar, but it couldn't. I set all restrictions I could using the collar, but after a relog, the sky still seemed to be correct and using region windlight settings.
          Hide
          Krashnburn added a comment -

          The most likely cause of this issue is not a "restriction" so it will not be shown in your rlv panel it is a one shot command.
          Disable RLV and log in watch for something like "@setenv_preset:default=force"

          Show
          Krashnburn added a comment - The most likely cause of this issue is not a "restriction" so it will not be shown in your rlv panel it is a one shot command. Disable RLV and log in watch for something like "@setenv_preset:default=force"

            People

            • Assignee:
              Unassigned
              Reporter:
              Horsey Toll
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: