Firestorm
  1. Firestorm
  2. FIRE-3174

Firestorm crashes NVIDIA display drivers on any graphics setting other than 'Low'

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Waiting on Linden Lab fix
    • Affects Version/s: Phoenix Firestorm 3.0.1 Mesh Beta, Phoenix Firestorm 3.2.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
    • SL Avatar Name:
      Chetar Ruby
    • Reported In:
      Firestorm 3.0.1 22525 Mesh Beta

      Description

      I was hoping this was unique to the beta mesh release, but it's not, it's occurring on self-compiled builds from repo as well.

      I can start the viewer fine, but as soon as I click login, there's a long delay, then I get a message that my display driver has lost connection with the display and cannot continue. Firestorm closes.

      Setting graphics to LOW makes the problem go away. You can set graphics higher after you're logged in, but they must be set back to low or it'll crash as described during login.

      NVIDIA Driver version: 280.26

      This viewer from LL: Second Life 3.0.0 (238864) Aug 18 2011 13:05:38 (Second Life Release)
      Does not have any problems, I can run ultra-graphics setting with no problems.

        Activity

        Chetar Ruby added a comment -

        OK, so apparantly this is a LL issue with Viewer 2/3, though I didn't experience the problem with those viewers, only with Firestorm.

        However, I fixed it. If you go here: http://nvidia.custhelp.com/app/answers/detail/a_id/3007/kw/error%20code%208/session/L3RpbWUvMTMxNTcwMjc1OS9zaWQvNzdOVzhORGs%3D

        You will find some information about this being caused by a timeout, too much graphics work at once. From there, I learned of this page about the graphics recovery stuff in Windows: http://msdn.microsoft.com/en-us/windows/hardware/gg487368.aspx

        There I learned I can adjust the timeout. I added the registry key TdrDelay and set it to 10 seconds instead of the default of 2. Firestorm starts and logs in properly now.

        Trasee Darkwatch added a comment -

        This is a regular issue for me in Firestorm as well. It is getting downright frustrating. I set the Registry Keys, and it didn't seem to make much of a difference. I know this is an LL issue, but when I searched the JIRA, it appears that they don't care to fix the issue. I would hope the Firestorm team would be more receptive to fixing this.

        Whirly Fizzle added a comment -

        Changing the timeout setting appears to work at first for most people, but it doesnt last.

        Details on the LL issue are here: https://jira.secondlife.com/browse/SH-2276 & https://jira.secondlife.com/browse/SH-2240 & we have a list of the worst open GL bugs FS has inherited here http://wiki.phoenixviewer.com/doku.php?id=hot_ll_jira_issues.

        Things to try:

        • Roll back drivers to the Nvidia driver 260.99
        • Disable basic shaders pre-login.

        LL are working on this issue we are told, as top priority. Progress can be watched for the sub tasks on https://jira.secondlife.com/browse/SH-2240

        As soon as LL release fixes, FS will be patched & an update released.

        Whirly Fizzle added a comment -

        Please can you test the new Beta driver 8.17.0012.8527. We have had reports its curing this issue.

        Whirly Fizzle added a comment -

        Beta driver can be found here http://www.nvidia.com/Download/Find.aspx

        Chetar Ruby added a comment -

        Beta drivers don't work unless you use the featuretable.txt and gputable.txt from this page: http://wiki.phoenixviewer.com/doku.php?id=crashes_and_graphics_glitches

        Chetar Ruby added a comment -

        Hmm, it works intermittantly.

        Whirly Fizzle added a comment -

        Expect a FS update in roughly 2 weeks. LL appear close to getting a fix for this.

        Manda Vuckovic added a comment -

        There a dev version of LL viewer that appears to fix the issue, any schedule on the port to FS?

        https://jira.secondlife.com/browse/SH-2368

        Ansariel Hiller added a comment -

        The fixes from LL are already being ported into a separate Firestorm branch. Like Whirly already said: Expect an update for Firestorm soon.

        Manda Vuckovic added a comment -

        I saw that, but since the comment dated from mid-september, I was just curious, I know you guys have a tight schedule, keep up the good work

        Whirly Fizzle added a comment -

        Hi Manda,

        Firestorm has just been merged up to the LL Viewer just before they dropped in all the FUI changes. Shining fixes will merged in shortly. As far as I know, they are waiting for them to stabalise some more as there are still tweaks being done by Runatai. Shouldnt be long now though.
        As soon as the main open GL fixes are stable & merged into Firestorm, expect a release.

        Manda Vuckovic added a comment -

        FYI, I've been suggested to try the v260.99 nvidia drivers for that build and I can report it works on my system for a couple hours now, I'll be able to test it more thoroughly later but just giving a tip for those waitting to run a v3 viewer with RLV:

        Firestorm 3.0.1 (22566) Sep 11 2011 13:22:35 (Firestorm-Beta-Mesh)
        Release Notes

        You are at 222,411.2, 357,438.3, 26.3 in Oztotl E located at sim8560.agni.lindenlab.com (216.82.39.119:12035)
        Second Life Server 11.10.21.243634
        Release Notes

        CPU: Intel(R) Core(TM) i7 CPU 950 @ 3.07GHz (3064.53 MHz)
        Memory: 8191 MB
        OS Version: Microsoft Windows 7 64-bit Service Pack 1 (Build 7601)
        Graphics Card Vendor: NVIDIA Corporation
        Graphics Card: GeForce GTX 460/PCI/SSE2

        Windows Graphics Driver Version: 8.17.0012.6099
        OpenGL Version: 4.1.0

        Viewer Skin: starlight (original_orange)
        RestrainedLove API: RLV v2.7.0 / RLVa v1.4.0a
        libcurl Version: libcurl/7.21.1 OpenSSL/0.9.8q zlib/1.2.5 c-ares/1.7.1
        J2C Decoder Version: KDU
        Audio Driver Version: FMOD version 3.750000
        Qt Webkit Version: 4.7.1 (version number hard-coded)
        Voice Server Version: Vivox 2.1.3010.6270

        Built with MSVC version 1600
        Packets Lost: 69/78,452 (0.1%)

        Tested other viewers including LL's latest: https://jira.secondlife.com/browse/SH-2409

        Whirly Fizzle added a comment -

        Yes correct.
        The Nvidia driver 260.99 seems to be a pretty stable "fix" for most people with this issue.

        Kaliope Karas added a comment -

        oKay... so i was running fine until a few windows updates...

        I tried rolling back to an older driver but it says nvidia cannot continue cause its not compatible, though i did pick the right system and let it find it for me. so idk... new machine out of the box and its one issue after another with FS... waaa.. i hate V2!!! it seems to run fine there!

        Kaliope Karas added a comment -

        also... no crash on SL V2... i dont wanna go there, but they are making me do it! GRRRR

        Azucena Villota added a comment -

        Kaliope, I had the exact same problem with my NVidia card with the drivers. I could NOT get them to roll back, on a brand new machine--drove me nuts. I couldn't run SL V2, either, same crash with our friend Error 8. You might be interested in the thread here https://jira.secondlife.com/browse/SH-2276. It's an option for those of us who can't roll back the drivers. Yeah, it's a SL build, but it gives hope this will be fixed. =)


          People

          • Assignee:
            Unassigned
            Reporter:
            Chetar Ruby
          • Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: