Firestorm
  1. Firestorm
  2. FIRE-4238

Mini-Map Window Doesn't Save Position, Size And Zoom-Factor

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 3.2.2, Phoenix Firestorm 3.3.0
    • Fix Version/s: Phoenix Firestorm 4.1.1
    • Component/s: None
    • Labels:
    • Reported In:
      Firestorm 3.2.2.24336 Release

      Description

      Mini-Map window doesn't save position, size and zoom-factor.

        Issue Links

          Activity

          Ansariel Hiller added a comment -

          This has already been addressed in FIRE-2881. If the zoom level doesn't persist, try deleting the settings_per_account.xml file in the settings directory for that particular avatar.

          Raymond Martinek added a comment -

          a) That doesn't address the position and size issues.
          b) I had that before and after clean installs, so a new settings_per_account.xml file had been generated.

          Ansariel Hiller added a comment - - edited

          Position and size are stored in that file. Try deleting the file. Map parameters are properly saved, so it is an issue on your end, most probably a per account issue. I had it myself that it worked for one account, but for another one not.

          BTW: I do NOT mean settings_per_account.xml in the FS installation folder, but the individual file that is created per avatar!

          Raymond Martinek added a comment -

          » I do NOT mean settings_per_account.xml in the FS installation folder, but the individual file that is created per avatar!«

          Which is inside the avatar folder inside the Firestorm folder which I manually delete for clean installs.

          Whirly Fizzle added a comment -

          Unable to reproduce on Firestorm 4.0.1 (24226)
          Position, size & zoom factor persisting when opening/closing minimap & between relogs.

          Ansariel Hiller added a comment - - edited

          This really seems to be some weird issue in the shining version now. Although the debug setting is properly updated when the zoom level is changed, it is not written to the settings file on logout.

          EDIT: The correct zoom factor is saved if it changed in the map that is part of the radar, but not in the minimap floater.

          Ansariel Hiller added a comment -

          The scaling has been fixed in 24368 (http://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/d46337c62208). For some strange reason, during logout the scale is set by the minimap in the radar before the value is saved. Changed the behavior of the minimaps to synchronize the scaling throughout all instances (minimap floater and radar panel), thus also the correct scale is saved during logout.

          The size/position of the minimap floater is not affected by this, however. That values are persisted by the floater itself. Is that actually still an issue by now?

          Zi Ree added a comment -

          http://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/953ae9ae54b9

          Pushed a fix for floater positions. Please test if this fixes this issue, too.

          Whirly Fizzle added a comment -

          Raymond, is this issue fixed now for you on the latest QA build?

          Raymond Martinek added a comment - - edited

          No. For a few relogs it looked right, now all of a sudden it isn’t. And I didn’t crash before relog, I have just quit and logged back in.

          Raymond Martinek added a comment -

          Still not working. I don’t see a pattern here. I think I didn’t change my setup at all since I installed 24753. Hum...

          Raymond Martinek added a comment -

          Seems to work on 24830 now. Did several relogs: Mini map stays in place. Zoom factor saved, too.

          Ansariel Hiller added a comment -

          Closing as fixed then.

          Raymond Martinek added a comment -

          Shucks, that was only temporary. Same effect again. :-/

          Whirly Fizzle added a comment - - edited

          Heya Raymond,

          Can you retest again the todays QA (should be sent to Beta group shortly)

          Whirly Fizzle added a comment -

          Proposed fix at 24855-sh (http://hg.phoenixviewer.com/phoenix-firestorm-sh/rev/449d8145d161)
          Please thoughroughly test this fix on the next QA (it will be part of the smoketest).

          Raymond Martinek added a comment -

          Still in 24869.

          Whirly Fizzle added a comment -

          Reopening & pushing to 4.0.1

          Whirly Fizzle added a comment -

          Info from Norton: Minimap will save if its left open when quitting.
          Hatake also reported this still happening in Beta chat.
          Possibly Mac only?

          Whirly Fizzle added a comment -

          Is this still happening on the 4.0.1 release?

          Whirly Fizzle added a comment -

          Awaiting QA

          Raymond Martinek added a comment -

          It’s okey on 4.1.1 here now (don’t recall 4.0.1).

          Whirly Fizzle added a comment -

          Passed QA


            People

            • Assignee:
              Unassigned
              Reporter:
              Raymond Martinek
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: