Firestorm
  1. Firestorm
  2. FIRE-4773

crash after fully loading member list in group info

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Commitment Commitment
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 3.3.0, Phoenix Firestorm 4.0.1
    • Fix Version/s: Phoenix Firestorm 4.0.1
    • Component/s: None
    • Labels:
      None
    • Environment:
    • SL Avatar Name:
      Robert0 Siamendes
    • Reported In:
      Firestorm 4.0.2.24753 QA

      Description

      1. Open up group info of a large group.
      2. Go to roles tab
      3. Wait for list to populate fully
      Crash to desktop

        Issue Links

          Activity

          Gweneth Lange added a comment -

          Happened to me as well. Here's my system info and my crash log.

          Firestorm 4.0.2 (24753) Jan 16 2012 05:18:55 (Firestorm-private-devFS32)
          Release Notes

          You are at 259,245.0, 195,287.0, 62.1 in Ugle Point located at sim21050.agni.lindenlab.com (216.82.30.84:13001)
          Second Life RC Magnum 12.01.13.247734
          Release Notes

          CPU: Intel(R) Core(TM)2 Duo CPU T6400 @ 2.00GHz (1995 MHz)
          Memory: 4090 MB
          OS Version: Microsoft Windows Vista 64-bit Service Pack 2 (Build 6002)
          Graphics Card Vendor: ATI Technologies Inc.
          Graphics Card: ATI Mobility Radeon HD 4500/5100 Series

          Windows Graphics Driver Version: 8.17.0010.1083
          OpenGL Version: 3.3.10834 Compatibility Profile Context
          RestrainedLove API: RLV v2.7.0 / RLVa v1.4.3a
          libcurl Version: libcurl/7.21.1 OpenSSL/0.9.8q zlib/1.2.5 c-ares/1.7.1
          J2C Decoder Version: KDU
          Audio Driver Version: FMOD version 3.750000
          Qt Webkit Version: 4.7.1 (version number hard-coded)
          Voice Server Version: Not Connected
          Settings mode: Phoenix
          Viewer Skin: firestorm (grey)
          Font Used: Deja Vu (96)
          Draw distance : 128
          Bandwidth : 1000
          LOD factor : 2
          Built with MSVC version 1600
          Packets Lost: 139/112,825 (0.1%)

          Zi Ree added a comment -

          Looks like you're running out of handles for curl to download the names for the list. That's a common error we see with capability handling currently. I hope we can find a good solution for it.

          2012-01-20T10:33:58Z DEBUG: llmessage/llavatarnamecache.cpp(378) : LLAvatarNameCache::requestNamesViaCapability: LLAvatarNameCache::requestNamesViaCapability first 72 ids
          2012-01-20T10:33:58Z WARNING: llmessage/llcurl.cpp(1509) : LLCurl::newMultiHandle: no more handles available.
          2012-01-20T10:33:58Z WARNING: llmessage/llcurl.cpp(558) : LLCurl::Multi::Multi: curl_multi_init() returned NULL! Easy handles: 127 Multi handles: 128

          Zi Ree added a comment - - edited

          I can try analyzing the dump files when I'm home tonight, unless someone else beats me to it

          Zi Ree added a comment -

          reproduced ... analyzing.

          Zi Ree added a comment -
          Robert0 Siamendes added a comment -

          fixed in newest nightly. thanks zi.

          Whirly Fizzle added a comment -

          Okay to close this one now?

          Whirly Fizzle added a comment -

          Pushing to 4.0.1 now 3.3 is released

          Zi Ree added a comment -

          Believed to be fixed. Please reopen if things change.


            People

            • Assignee:
              Zi Ree
              Reporter:
              Robert0 Siamendes
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: