Firestorm
  1. Firestorm
  2. FIRE-5368

[PATCH] [VWR-28039/EXP-1575] Posting Snapshot to Profile Feed does not work under Linux

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 4.0.1
    • Fix Version/s: Phoenix Firestorm 4.1.1
    • Component/s: None
    • Labels:
    • Environment:
      Linux, Various FUI viewers
    • SL Avatar Name:
      Miguael Liamano
    • Patch attached:
      Patch attached
    • Reported In:
      Firestorm 4.0 FUI

      Description

      Copying from my JIRA on Secondlife:
      When I try to post a snapshot from the new Snapshot floater to my Profile Feed, I get an error saying "Failed to upload image to your Profile". The viewer log is a bit more explicative:

      2012-01-05T22:04:24Z WARNING: LLWebProfileResponders::ConfigResponder::completedRaw: Failed to parse upload config: * Line 1, Column 1
      Syntax error: value, object or array expected.

      Steps to reproduce:

      1: Run the viewer on Linux
      2: Take a snapshot
      3: Click "Post to My Profile Feed"
      4: Get frustrated because it fails 100% of the time.

      This is caused by an incompatibility in OpenSSL 1.0.0*
      The only working solution so far is to use OpenSSL 0.9.8.
      No, OpenSSL 1.0.0d, nor 1.0.0g works.

      I compiled my own OpenSSL 0.9.8, and packaged it for autobuild. It is currently hosted on my blog, feel free to copy it over on your own servers, or compile your own. As you wish.

        Issue Links

          Activity

          Whirly Fizzle added a comment -
          XenHat added a comment -

          My pleasure

          YT Recreant added a comment -

          the patch seems to fail for Ubuntu 11.10.
          I found after some readup, there has been "SSLv2" removed from OPenSSL, in the distribution. Whatever that is, can one maybe install an OPenSSL w/o SSLv2 as bundle for the linux version?

          XenHat added a comment -

          I'm as well hitting that error right now with OpenSSL 0.9.8. So right now the only way to get it compiling is to use OpenSSL 1.0.0, which breaks the snapshot upload feature. So the code itself must be fixed.

          Nicky added a comment -
          XenHat added a comment -

          Thank you <3

          YT Recreant added a comment -

          I am afraid that is not working yet. When i try to make a snapshot, the snapshot window shows "Posting" for eternity, and the terminal throws out in the background: 2012-03-30T11:23:55Z WARNING: newview/llwebprofile.cpp(225) : LLWebProfile::post: Image to upload is not a PNG

          YT Recreant added a comment -

          can the status go back to "open" or whatever please?

          Nicky added a comment -

          Hello YT. That seems to be an issue not related to OpenSSL. This warning is written when the file you try to upload is not in PNG format or does not exist at all.

          Please open a new JIRA for it and attach your log files there. Thank you.

          YT Recreant added a comment -

          the topic of this Jira entry here reads: Posting Snapshot to Profile Feed does not work under Linux
          and that is exactly what fails still.
          Why then making a new ticket?
          for the sake of making tickets?

          Nicky added a comment -

          I understand it sounds arbitrary. But the reason is being able to track what goes into the source why. It makes a lot of sense to be specific about this and not turn tickets into a huge mix of different issues.
          This one is about the OpenSSL upgrade issue (even linked to the SL Jira). But your current problem seems to be PNG related. So I'd like to have that separated for the mentioned clarity.

          Just for example someone has an issue "LLWebProfile::post: Image to upload is not a PNG". If there is a Jira for this, the can look up a solution there. If it is just buried in here, they'd first have to go through all the OpenSSL related hints, look through the SL Jira, looks through the linked FIRE-5756, just then to find out it is not really helpful for them.

          YT Recreant added a comment -

          thank you for explaining. i made a new ticket here: http://jira.phoenixviewer.com/browse/FIRE-5843


            People

            • Assignee:
              Nicky
              Reporter:
              XenHat
            • Votes:
              2 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: