Firestorm
  1. Firestorm
  2. FIRE-5635

[RLV] Issues around the #RLV folders in FS 4.01

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Intended Behavior
    • Affects Version/s: None
    • Fix Version/s: Phoenix Firestorm 4.0.1
    • Component/s: None
    • Labels:
    • Environment:
    • SL Avatar Name:
      Unya Tigerfish
    • Reported In:
      Firestorm Beta 4.0.1.27000

      Description

      Several issues appear under RLVa with FS 4.01 with regards to the #RLV folder tree (shared wear)
      1. According to the specification ( http://wiki.secondlife.com/wiki/LSL_Protocol/RestrainedLoveAPI ) , prim objects inside the #RLV folder tree must have the attachment name in their name to be attached by @attachall etc. But currently in FS 4.01 they need not. They are happily attached even without.
      2. Even with enabled "Rename Shared Item on Wear" no renaming takes place on wearing moddable items (inside #RLV tree ofc.)
      3. No moving of no-mod items to subfolders ".(attachmentslot)" takes place (of course also inside #RLV folder tree)

        Activity

        Kitty Barnett added a comment -

        The last Firestorm release had "Enable Shared Wear" flipped on by default, which removes the requirement to have any attachment point references either in the item name or the item's parent folder.

        As such (1) is by design since there's no explicit need to specify any attachment point (although it will honour any you choose to put).

        For (2) and (3): renaming items on wear (or creating folders for no modify items) was disabled when "Shared Wear" is enabled since the attachment point designation is now optional so it doesn't make much/any sense to still clutter the #RLV folder up.

        If wanted, you can still revert to the old behaviour by unchecking "Enable Shared Wear" under the RLVa / Debug menu.

        http://catznip.com/2012/03/24/rlva-sharedwear/ covers most of the same information, albeit maybe a bit less technical.

        desdemona enfield added a comment -

        I will add here that @attach and @detach will still descend into folders which contain attachment point names. You need not re-engineer your #RLV folders that were built to use this legacy technique.

        ----------------
        For historically minded people .... (smiles)

        The whole 'no mod items are in specially named sub-folders' trick was a workaround for a situation in which Rlv viewers were unable to determine the implicit attachment point of an object in inventory, thus the attach point had to be explicitly embedded in the object name or a containing folder name for no-mod objects. As an aid to setting up such folders, the Rlv viewer would also set up these special naming tricks if you wore items manually from inventory (thank you).

        Rlv viewers now can determine the implicit attach point. The trick is no longer needed. (thank you again)

        Desde


          People

          • Assignee:
            Kitty Barnett
            Reporter:
            Unya Tigerfish
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: