Firestorm
  1. Firestorm
  2. FIRE-6153

[REGRESSION] Bottom bar broken after merge

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 4.1.1
    • Fix Version/s: Phoenix Firestorm 4.1.1
    • Component/s: None
    • Labels:
      None
    • Environment:
    • SL Avatar Name:
      Whirly Fizzle
    • Reported In:
      Firestorm 4.1.1

      Description

      Setup the bottom bar as follows:
      Center aligned
      Buttons fill bar

      • The bottom chat bar cannot be dragged smaller
      • Drag the bottom chat bar fully over to the right and back

      Observe all your buttons disappear
      Also observe you cant drag and drop any buttons to the bottom bar from the sides or the toybox

      Relog!

      Change to fixed sized buttons
      Drag the chat bar over to the right & observe the buttons stack up with the 3rd row cut in half (see fig 1)

      Change to autosize buttons & observe the buttons are tiny & bunched up (see fig 2)

      1. Fig 1.png
        87 kB
      2. Fig 2.png
        34 kB

        Issue Links

          Activity

          Whirly Fizzle added a comment -

          Tested on Metaharper Cool and FS Grey

          stephanie turner added a comment -

          is confirmed to be a problem on Starlight Nostalgic blue as tested on 11/may/2012 with 4.1.1.27433

          Settings mode: Firestorm
          Viewer Skin: starlight (nostalgia_blue)
          Font Used: Deja Vu (96)
          Draw distance : 304

          Ansariel Hiller added a comment - - edited

          Fixed the chatbar not being possible to resize smaller in 27464 (http://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/6d963c4d763c): With the settings

          • user_resize = true
          • auto_resize = false
          • min_dim = -1 (default if not specified!)
            a layout panel gets the specified layout size set as minimum size, thus making it impossible to make the panel smaller. Setting a minimum size other than -1 fixes that.

          The issue with the buttons getting lost when resizing the chatbar fully to the right is caused by the same issue as FIRE-6154.

          Ansariel Hiller added a comment -

          Fixed bottom toolbar loosing its content on chatbar being resized fully to the right in 24478 (http://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/2e8ee75d0227).

          Whirly Fizzle added a comment -

          Testing on Firestorm 4.1.1 (27559) May 26 2012 21:52:41 (Firestorm-Fizzlefire)

          • Resizing bottom chat bar to maximum size and back, buttons are no longer going poof
          • Resizing chat bar smaller - this now works, however, there is a behaviour change.
            Bottom bar cant be made to totally disappear by dragging over to the left. Previously it could.
            This is the smallest bottom chat bar will resize on my screen:
          Ansariel Hiller added a comment - - edited

          I set the smallest width of the chatbar to 200px intentionally because I thought that might be a reasonable minimum size. It can be set to be allowed smaller, but seriously: We don't need to support every weird idea of "tweaking" the UI like make the chatbar 10px wide.

          Whirly Fizzle added a comment - - edited

          We will use FIRE-6259 to track the "scrunched up" button issue and FIRE-5501 for the 3rd row of buttons cut in half issue.

          Issue can go to QA


            People

            • Assignee:
              Ansariel Hiller
              Reporter:
              Whirly Fizzle
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: