Firestorm
  1. Firestorm
  2. FIRE-6261

Right click on another avatars nametag causes freezes in find widgets on 2nd level of pie menu

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 4.1.1
    • Fix Version/s: Phoenix Firestorm 4.1.1
    • Component/s: None
    • Labels:
    • Environment:
    • SL Avatar Name:
      Whirly Fizzle
    • Reported In:
      Firestorm 4.1.1

      Description

      Steps to reproduce:

      • Enable pie menu, Preferences -> User Interface -> General -> Use Pie Menu
      • Put fast timers on, CTRL+SHIFT+9
      • Right click on another avatars nametag
      • Run your mouse around the 1st level of the pie menu slices & observe no freezeups
      • Go to More> so youre on 2nd level of the pie menu
      • Observe the viewer freezes up constantly for a second or so each time & fast timers show this is in find widgets
      • Go to More> again & observe there is a one slight freeze, which shows again as find widgets, but this only happens once.

      Switching to context menu, this doesnt happen.
      There seems to be a slight freeze in find widgets when hovering mouse over Annoyance>

      Same behaviour seen running the 4.0.1 release build

        Activity

        Whirly Fizzle added a comment - - edited

        I dont know if this is related to the freezes, but on the 2nd level of the pie menu when right clicked on an avies tag, the log gets spammed with lots of:

        2012-05-10T05:44:31Z WARNING: newview/llviewerparcelmgr.cpp(1828) : LLViewerParcelMgr::processParcelAccessListReply: ONCE (900th time seen): processParcelAccessListReply for parcel 15 which isn't the selected parcel -1
        2012-05-10T05:44:32Z WARNING: newview/llviewerparcelmgr.cpp(2045) : LLViewerParcelMgr::requestParcelMediaURLFilter: can't get ParcelMediaURLFilterList cap
        2012-05-10T05:44:32Z WARNING: newview/llviewerparcelmgr.cpp(2045) : LLViewerParcelMgr::requestParcelMediaURLFilter: can't get ParcelMediaURLFilterList cap
        2012-05-10T05:44:32Z WARNING: newview/llviewerparcelmgr.cpp(2045) : LLViewerParcelMgr::requestParcelMediaURLFilter: can't get ParcelMediaURLFilterList cap
        2012-05-10T05:44:32Z WARNING: newview/llviewerparcelmgr.cpp(2045) : LLViewerParcelMgr::requestParcelMediaURLFilter: can't get ParcelMediaURLFilterList cap
        2012-05-10T05:44:32Z WARNING: newview/llviewerparcelmgr.cpp(2045) : LLViewerParcelMgr::requestParcelMediaURLFilter: can't get ParcelMediaURLFilterList cap
        2012-05-10T05:44:33Z WARNING: newview/llviewerparcelmgr.cpp(2045) : LLViewerParcelMgr::requestParcelMediaURLFilter: can't get ParcelMediaURLFilterList cap
        2012-05-10T05:44:33Z WARNING: newview/llviewerparcelmgr.cpp(2045) : LLViewerParcelMgr::requestParcelMediaURLFilter: can't get ParcelMediaURLFilterList cap
        2012-05-10T05:44:33Z WARNING: newview/llviewerparcelmgr.cpp(2045) : LLViewerParcelMgr::requestParcelMediaURLFilter: can't get ParcelMediaURLFilterList cap
        2012-05-10T05:44:33Z WARNING: newview/llviewerparcelmgr.cpp(2045) : LLViewerParcelMgr::requestParcelMediaURLFilter: can't get ParcelMediaURLFilterList cap
        2012-05-10T05:44:33Z WARNING: newview/llviewerparcelmgr.cpp(2045) : LLViewerParcelMgr::requestParcelMediaURLFilter: can't get ParcelMediaURLFilterList cap
        
        Ansariel Hiller added a comment -

        That was caused by the enabled-check method for 2 pie slices hammering the region with ParcelAccessListRequest messages every single frame!

        Extended the pie menu to allow single enable checks and not do checks every frame in 27451 (http://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/82b4feae2c23).

        This means the pie menu needs intensive testing if the pie menu items still behave properly!


          People

          • Assignee:
            Ansariel Hiller
            Reporter:
            Whirly Fizzle
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: