Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: Phoenix Viewer 1.5.0.168
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
    • SL Avatar Name:
      Georgie Greggan

      Description

      I have a horrible texture rendering problem. Three images show the problem. cube(a) is how things start out looking. cube(b) is how things deteriorate after time. img01 is at another sim showing much the same problem in a different way.

      The cube will take on random textures perhaps from my cache. Look away then look back and the textures will have changed. Now, this is impossible if you are scanning vendors for items to buy. Texture swapping screws up the shopping experience. Look at the red sign in the pics. Compare the word "New". Notice the image seen second is corrupted and soft focus. "New" will never rezz properly unless cache is cleared.

      img01 shows another aspect of the problem. The black cylinder is supposed to be white. I have no idea where those green faces are from. But the correct images that are supposed to display on those three prims are the compressed purple images seen in the top left corners of the prims.

      It looks to me to be a cacheing corruption problem. I set my Emerald/Phoenix cache sizes to 1GB. This has never been a problem with Snowglobe where I always set cache at 1GB also.

      I can travel to different sims. All will initially rezz correctly. Spend some time there and some, not all, some textures on prims will misbehave and become corrupted. Some will remain corrupted with the same textures and some will switch to other inappropriate textures.

      All can be fixed temporarily with a relog and cache clean. I auto clear my cache before every log in.

      Now which versions are affected? Most of Emerald's versions were doing this but only to a minor extent. It's turned very bad with Phoenix almost to the extent of making Phoenix unusable. Wrong textures are tolerable but a real PITA. They are the reason for frequent relogs and cache cleans. The Phoenix viewers simply don't work as intended on my Mac and I feel forced to return to Snowglobe.

      1. Corrupt_texture_01.png
        1.98 MB
      2. cube(a).png
        2.42 MB
      3. cube(b).png
        2.29 MB
      4. cube(b).png
        2.29 MB
      5. img01.png
        884 kB

        Issue Links

          Activity

          Georgie Greggan added a comment -

          Sorry, Here is cube(a). The pic cube(b) was uploaded twice

          Edward Soulstar added a comment -

          Lol @ dare Designs making JIRA

          Georgie Greggan added a comment -

          After further study, the alien textures on the cube are among those displayed at this store. So between looking at the cube for the first pic and looking again snapping the second pic, I probably looked in areas of the store where those other textures were displayed on vendors. Since others with me are not seeing this problem, It must be my viewer or hardware. A friend with me who I called over to look at these textures didn't see a problem. It's interesting that his is the same Mac as mine except it has a different video card, his being the ATI Radeon HD 5750 1GB. Can it be that my ATI Radeon HD 4850 512MB card is not being handled well by this Phoenix viewer?

          Georgie Greggan added a comment -

          Added the image Corrupt_texture_01.png
          This is a good example of a texture that initially rezzed okay when it was first looked at. Wandering away and then returning for another look results in this kind of corruption. The subsequent viewing never resolves unless a relog+ClearCache is done. After which the same thing can recur. This texture corruption happens all over SL. Emerald did this too. And investigating further, the source that both Emerald and Phoenix were forked from was Snowglobe 1.5.x which also causes the same corruption. Phoenix needs to take another fork from Snowglobe 1.42 which does not show this problem. It's my graphics card that is implicated, right? Snowglobe 1.42 is fine with my graphics card, so maybe we need to backtrack a little.

          Pilot McBride added a comment -

          Noticed this problem today, missing textures, well the textures initially loaded then some textures went 'bad' similar to the Georgies.

          System info:
          CPU: 8 x i386 (Unknown) (2930 MHz)
          Memory: 16384 MB
          OS Version: Darwin 10.4.1 Darwin Kernel Version 10.4.1: Fri Jul 16 23:04:20 PDT 2010; root:xnu-1504.7.51~1/RELEASE_I386 i386
          Graphics Card Vendor: ATI Technologies Inc.
          Graphics Card: ATI Radeon HD 5750 OpenGL Engine
          OpenGL Version: 2.1 ATI-1.6.18

          Poohsnack Parsonage added a comment -

          I have exactly this problem on my Apple iMac. This latest viewer has cured the frequent crashing, but is now corrupting textures. On arrival at a new sim all looks good for maybe 10 mins, then things start turning black. Then reverting to the correct texture a few minutes later. Then the same with red. Later I had tartan paths. Eventually becomes so bad, with textures swapping in and out, that its almost unusable. I shall have to revert to the previous much-crashing version.

          My details:
          Phoenix Viewer 1.5.1 (225) Sep 11 2010 20:18:59 (Phoenix Viewer Release)
          Release Notes

          Built with GCC version 40001

          You are at 161311.7, 301518.2, 26.3 in Mythopoeia located at sim4473.agni.lindenlab.com (216.82.22.59:12035)
          Second Life Server 1.42.0.208314
          Release Notes

          CPU: Dual i386 (Unknown) (2800 MHz)
          Memory: 4096 MB
          OS Version: Darwin 10.4.0 Darwin Kernel Version 10.4.0: Fri Apr 23 18:28:53 PDT 2010; root:xnu-1504.7.4~1/RELEASE_I386 i386

          Poohsnack Parsonage added a comment -

          Anecdotal, but this identical problem seem to be present on the PC.
          A friend was in the same location with me, and reported identical symptoms starting about 5 minutes after mine, and progressing similarly. He is using 64-bit Windows 7, 3Gig ram, cpu i7-920, 9800GTX+ graphics card.

          Kroaxai Babii added a comment -

          I am also seeing this both in past 1.5 betas and now Phoenix 1.5.1.225. The effect is very bad. I got tired of the corruption — you can only do so many relogs before this wears very thin indeed. I started using Snowglobe but Snowglobe 1.5 also has the exact same problems, So I went back to SG 1.42 which I have been using for a while. I refuse to use SL's Vwr 2 so I don't know if that does the same texture corruption.

          There are two sides to this problem.
          (1) On arrival at a new sim, it all rezzes correctly but turn around and come back to some of the original textures mostly on signage or vendors and even as I look the original correct texture reverts to a muddy mess. It's as if Phoenix thinks that final garbled mess is the last stage of full resolution which it clearly is not, because it sticks like that permanently.
          (2) Often a texture on a prim especially in stores has jumbled unrelated textures on each face, none of which are the correct texture which first showed when I entered the sim.
          (3) A vendor or sign shows a texture over the entire face of a prim but when I look a little later, that texture has shrunk to a small shape in the upper left of the prim face while another texture apparently unrelated to anything much, fills the rest of the prim face. img_01 shows that effect.

          My computer is last year's iMac with a ATI 4850 card. iMacs may be the common factor to produce these bugs. My OS is fully up to date.

          Dinda Bedrosian added a comment -

          Had initially posted this in PHOE-507 but since it is more related to this issue I'm reposting here:

          Using Phenix 1.5.1.225 on my Mac the memory leaks are not near as severe as earlier, and don't appear to casue crashes but might still be happening; real memory use rapidly goes up to about 750MB and VM to 2 GB but then seems to stabilize around those values with only a slow increase over several hours. Getting lots of new issues with textures though; textures going through cycles of rezzing and blurring, textures replaced by random (?, mostly red or black) colours, textures showing up as little thumbnails in the upper left corner instead of covering the face of a prim to mention some of the most disturbing ones. Not at all sure if the leaks and these texturing issues are related.

          Using iMac 3.06 GHz Intel Core 2 Duo with 8 GB 1067 MHz DDR3, ATI Radeon HD 4670 graphics card (256 MB VRAM), Mac OS X 10.6.4.

          Twinkling Redstar added a comment -

          I am a huge fan of Emerald and Phoenix. I had to stop using them because the late Emeralds and every Phoenix does a horrible job with textures. I agree with everything above — it is pretty-much all covered so I am just adding my vote to the issue.

          This seems to have been a problem for a long time but I don't see anyone talking about it in the Support forum. Does it only affect iMacs? I agree that Phoenix devs are building on a broken viewer — I have been using Snowglobe on and off and SG 1.5 test viewer has the exact same problem. It would make a lot of sense if the devs discarded any more work with Phoenix 1.5.x.x and started working on SG 1.4.2 which seems to be clean and stable.

          iMac - 2.8GHz Core i7 - 8GB ram - ATI 4850 GPU

          Poohsnack Parsonage added a comment -

          I forgot to mention above that the graphics card on my IMac is an ATI Radeon HD 2600 Pro.

          Also worth saying that, unlike others, this is NOT a longstanding problem with me. I am a longterm Emerald user, and have never seen this prior to this latest version of Phoenix. Others problems may be old, but mine is entirely new.

          Emerald never gave me texture problems, and it was the only viewer I used over a very long period.

          Georgie Greggan added a comment -

          Now this is too much! Phoenix 225 is turning my beautiful white knee-high prim boots black and no longer looking like leather. I had to wear something else.

          Mindy Spiritor added a comment -

          Thank you to everyone who has been posting here. The more information that we get, the better chance the development team has of finding the source of the problem.

          First and foremost, please always post your complete system information, because it helps us do comparisons on things like operating system versions and video cards. You can get this information from Help > About Phoenix Viewer.

          Georgie, can you please tell me if during this process since you first posted this JIRA, you updated your OSX? I only ask because in my research thus far, it seems that those not having the problem with your video card are on 10.4.1 as opposed to 10.4.0 as reported in your first post.

          Also, if everyone could report as to whether they are seeing this issue everywhere with most textures or just on certain sims or with certain textures, that would be greatly appreciated. If it's the latter, and you have any of those textures that you can provide to us, please let us know. This may help us narrow the issue to commonalities between textures, which may help the development team get to the root cause.

          Thank you all again for your input and patience as we attempt to sort this issue out.

          Dinda Bedrosian added a comment -

          Just wanted to add that for me too these problems began with Phoenix 225 – I've never had anything similar to this before in any viewer.

          Mindy Spiritor added a comment -

          For those who are seeing only the thumbnail view of a texture up on the corner somewhere, please make sure you have Audit Texture unchecked in Advanced, Rendering (it's the last option).

          Georgie Greggan added a comment -

          @Mindy: I admit to flirting with Audit Textures for a short period a while back but I turned it OFF and it has not been ON during any of these observations.

          As for the Darwin Kernel version, yes mine is 10.4.0. I see that Pilot's above is 10.4.1 yet he too sees the problem. It is beyond my power to "update" to 10.4.1. I already run the latest MacOSX update 10.6.4 and I have the Graphics Update installed. MacOSX 10.6.4 has always been in use from before I started using the Snowglobe 1.5 forks of Emerald/Phoenix. As to why some owners have different kernels, I'd be guessing but maybe MacOSX updates create different versions of Darwin for different hardwares. I suspect that if I bought another newer iMac or other Mac it might have a different Darwin kernel for the same MacOSX version.

          I must reinforce my finding that under my present updated MacOSX, Snowglobe 1.5 Test Build has the same problem yet earlier Snowglobes (such as SG 1.4.2) do not. Phoenix is forked from the Snowglobe Test Build, IMHO not a wise move anyway. v1.4.2 is the latest stable version of Snowglobe and this one should have been the basis of the Phoenix series.

          My regular client since these graphics problems appeared is Snowglobe 1.4.2 because Phoenix texture corruption is way to severe. I miss my Phoenix features and will keep retrying it. However it takes just five minutes to encounter the problem.

          I am led to a newer conclusion regarding this failing: the longer one spends on a particular sim the more textures become corrupted. It starts with signs on prims and extends to whole walls, floors and general surroundings — time is the factor. And texture size might also be a factor. If I am just passing through, there is no evidence of the problem on first rezzing of the scene. So I am reminded of the purpose of the texture cache which is supposed to provide textures for items on the sim you recently looked at, redrawing them as required. It's my opinion that the cache is corrupting its contents believing what it holds is the final rezzed version of textures. I have actually observed a fully rezzed texture in the corner of my screen snap to a corrupt version as it comes into full view. That must be a cache problem. I reiterate, SG 1.4.2 does not do this issue but any viewer version, 1.5.x.x does it. I recommend that the devs compare 1.5 with 1.4.2 to see what's gone wrong.

          For my next test, I am going to try varying the size of my cache. Through all this, my cache has been 1GB. Maybe that is too much. Also, I plan on doing a full clean out of everything related to Second Life viewers and then reinstall Phoenix. Since you mentioned it, maybe the debris from enabling Audit Textures is still around causing harm.

          Georgie Greggan added a comment -

          I removed every skerrick of client software and support files from the iMac and did a clean install of Phoenix 225. I expressly avoided enabling Audit Textures. My observations:—

          On first look at a sim, it all looks clean. But after five minutes of walking around and looking at things, retracing steps —

          (1) The collapse of textures to a thumbnail in the left upper corner still occurs;
          (2) Many textures on fixed prim structures get replaced with black;
          (3) Some signs just deteriorate to a garbled muddy mess after first rezzing properly.

          I am currently doing the Twisted Hunt. The main display sign for the Hunt is present at every Hunt location. If when I first see this sign and hang around for a while it will turn muddy. On all subsequent sims I TP to which shows this sign, the sign immediately shows the muddy corruption and makes no attempt to properly rezz.

          But why is it that I NEVER suffer any of these texture problems on my own parcel, in my own house? Is this corruption a permissions thing? Maybe the whole sim that my parcel is on is free from the problem for some obscure reason. Be assured, I see this texture issue on lots of sims. But one seems particularly bad... Hawk Land 90, 158, 2850 I can't do this Hunt with Phoenix so I must reinstall SG.

          Mindy Spiritor added a comment -

          Georgie, I have attempted to contact you via IM in-world while you were online, but received no response. Please IM me next time you are online.

          Pilot McBride added a comment -

          @ Mindy. Just read the above and checked "Audit Textures" Found this checked so unchecked it and will report back if anything changes.

          Thanks for your support mate

          Georgie Greggan added a comment -

          @Mindy. Sorry I missed you on line. I did the test you wanted:

          Activate AdvancedMenu/World/DumpRegionObjectCache.

          It did nothing. Well, there was a slight effect and it only worked if I had logged out, cleared cache, and relogged, then immediately used Dump Region Object Cache.

          The result was some optimism that this was a cure but all it did was (apparently) delay the onset of all my texture glitches by a few minutes.

          I have been varying many of my controls including cache size. None had any effect on this issue.

          So I installed the Windows version in Win7 on the iMac to test whether I had developed a hardware problem or not. Phoenix 225 for Windows worked flawlessly on the iMac — textures never glitched. However, that's not a solution for me as it's inconvenient and I dislike using Windows. I also noted that the FPS in the Windows version seemed much slower.

          I don't know where to go from here. If only very few Mac Phoenix users are experiencing this, it's unrealistic of us to expect the devs to solve it. I can only continue to point out that Snowglobe 1.42 doesn't do this but Snowglobe 1.5 does and has the same glitches. Would the devs consider building a new version of Phoenix on a fork of Snowglobe 1.42? That would seem to be the only answer for our iMacs.

          Kadah Coba added a comment -

          FYI, I see this same issue on windows as well.

          Georgie Greggan added a comment -

          I've been testing for several days now and finally come up with some useful information.

          The setting RenderVolumeLODFactor is implicated.

          I was going nowhere testing the iMac alone because as my finding will show, no matter what I did with the iMac's settings it was always going to corrupt textures.

          I installed Phoenix 1.5.1.225 on my Mac Pro and set it up with all the same settings I use for Phoenix on the iMac — the exact same settings all over.

          On every other viewer except the 1.5.x series of Snowglobe/Emerald/Phoenix, I have SUCCESSFULLY used a RenderVolumeLODFactor value of 6 and even 8.

          The Mac Pro displayed EXACTLY the same set of texture mishandlings and corruptions as did the iMac. The Mac Pro turned out to be a good test platform. Long story short, the Mac Pro was very happy with a RenderVolumeLODFactor of 4 but no higher. Remember that my Mac computers had happily used 6 with other browsers. Not so, Phoenix

          So the devs working on Snowglobe 1.5.x broke something which limited the range of settings available for RenderVolumeLODFactor. Forked to Emerald, several versions were created and that's where I began to see these corruption problems. And then Emerald 1.5.0.xxxx was picked up and used as the basis of Phoenix, passing on this problem for Macs, possibly all Macs. Maybe all Phoenix users on recent Macs can do the same test by winding up the RenderVolumeLODFactor value to say, 8 or 10, which should normally be quite safe.

          So with the value set at a nominal 4 on the Mac Pro, the issue does not exist.

          As for the 2009 27" iMac with core i7 CPU and ATI Radeon HD 4850 graphics, NO value of RenderVolumeLODFactor will stop the mishandling and corruption of textures. I tested with all the round number values from 0-6 — texture corruption and mishandling occurred at every increment.

          This effectively means that my iMac cannot be used in any sort of entertaining way with Phoenix 1.5.1.225. Consequently, I am obliged to use a non-Phoenix viewer.

          As I previously suggested, this bug can be overcome by abandoning any further development of the current Phoenix viewer and basing a new project on Snowglobe 1.4.2 instead.

          Aelyon Foxdale added a comment -

          I have a sculpt/texture problem as well. I fiddled with the render volume settings but they didn't help at all. Sometimes textures seem corrupted (different than they normally used to be) and sometimes sculpted prims are totally deformed. Since I have this problem with other viewers too I assume it's either an SL bug or something is wrong with my laptop. I'd appreciate any help regarding this matter.

          Kroaxai Babii added a comment -

          I see all the problems listed above on my MacBook Pro. It's not just ATI GPUs only. Mine has a nVidia chipset.

          Phoenix Viewer 1.5.1 (225) Sep 11 2010 20:18:59 (Phoenix Viewer Release)
          Release Notes

          Built with GCC version 40001

          You are at 254297.8, 330913.7, 2851.0 in Hawk Land located at sim2733.agni.lindenlab.com (216.82.0.48:13001)
          Second Life Server 1.42.0.208314
          Release Notes

          CPU: Dual i386 (Unknown) (2930 MHz)
          Memory: 4096 MB
          OS Version: Darwin 10.4.0 Darwin Kernel Version 10.4.0: Fri Apr 23 18:28:53 PDT 2010; root:xnu-1504.7.4~1/RELEASE_I386 i386
          Graphics Card Vendor: NVIDIA Corporation
          Graphics Card: NVIDIA GeForce 9600M GT OpenGL Engine
          OpenGL Version: 2.1 NVIDIA-1.6.18

          libcurl Version: libcurl/7.19.7 OpenSSL/0.9.8l zlib/1.2.3
          J2C Decoder Version: OpenJPEG: 1.4.0.635, Runtime: 1.4.0.635
          Audio Driver Version: FMOD version 3.750000
          Qt Webkit Version: 4.5.2
          Packets Lost: 211/59035 (0.4%)

          I think that the RenderVolumeLODFactor setting is connected. But my point is that at the default of 2.0 and higher I see all the texture problems mentioned. Higher setting seems to bring on the problem quicker. I suppose I'll have to try Imprudence or something else. I hate VWR2, staying right away from that.

          Kadah Coba added a comment -

          Was HTTP textures enabled?

          Irene Baldauf added a comment -

          Hmmmm ok I have been referred over to this thread as mine had been closed because it is considered a duplicate even though after reading thus far everyone seems to be running the Snow Leopard OS and I am running on the Leopard OS but have the same messed up texture issue..... And no my Audit Texture is not ticked and yes my HTTP Texture is enabled but I ALSO have the same issue when it is not enabled..... This is becoming increasingly irritating as it is affecting my hair texture now.....

          Georgie Greggan added a comment -

          Assumptions are my undoing. @Kadah questioned whether I use HTTP Get Textures. I do. And I had assumed the HTTP Textures problem had been solved. HTTP Textures IS the problem. It IS still, and disabling it of course was the answer for me. Apparently, some computers are affected worse than others by enabling this setting. And that's where some confusion lies. The 2010 iMac unlike my 2009 model is unaffected and can continue to use HTTP Textures. Likewise, my Mac Pro can use the setting provided RenderVolumeLODFactor is not set above 4. I ran the Windows viewer in Win7/BootCamp on my 2009 iMac and though it wasn't as severe, the same texture corruption appears in that version. [It may escape users' attention as it is easily missed and can be quite subtle if you are not familiar with the symptoms.] It now looks pretty clear that HTTP Get Textures is a "work-in-progress" and not very friendly. A conclusion easily formed is drawn from a comparison between the two iMacs above. One has the problem and one does not. The only real difference between the two Macs is their graphics chips. So maybe drivers on one of the Macs is inadequate. May I refer again to Snowglobe 1.42? HTTP Get Textures works well in that version so perhaps the associated code ought to be used in Phoenix.

          Mindy Spiritor added a comment -

          Can everyone experiencing this issue please disable HTTP Get Textures, log off, do a manual cache clear (locate the viewer cache on your computer and trash it), and then relog and report results here?

          Thanks!

          Robert Haggin added a comment -

          I to am have the same issue's I'll be on a sim for a while and all of sunnden texture turns black here' my stats on the machine
          Model Name: Mac Pro
          Model Identifier: MacPro3,1
          Processor Name: Quad-Core Intel Xeon
          Processor Speed: 2.8 GHz
          Number Of Processors: 2
          Total Number Of Cores: 8
          L2 Cache (per processor): 12 MB
          Memory: 2 GB
          Bus Speed: 1.6 GHz
          Boot ROM Version: MP31.006C.B05
          SMC Version (system): 1.25f4
          the ati card info

          Chipset Model: ATI Radeon HD 2600
          Type: GPU
          Bus: PCIe
          Slot: Slot-1
          PCIe Lane Width: x16
          VRAM (Total): 256 MB
          Vendor: ATI (0x1002)
          Device ID: 0x9588
          Revision ID: 0x0000
          ROM Revision: 113-B1480A-252
          EFI Driver Version: 01.00.252

          Paige Enderfield added a comment -

          I used to have problems with my mac in SL until I realized my computer wasn't automatically switching to the better graphics card.. it was using the more efficient one so I had to make the high res one the default. I also had to go into hardware options under graphics in preferences of the viewer and disable the openGL VBO. I have not had anymore messed up textures in any viewers.. and I've tried a few recently.. lol Phoenix 1.5.1.255 has been running beautifully for me ever since I started running it. No complaints. Hope that helps a few of you. I'm not enough of a geek to know why it worked for me. Maybe the more technical folk can explain why.

          Here are my specs:
          Chipset Model: NVIDIA GeForce 9600M GT
          Type: GPU
          Bus: PCIe
          PCIe Lane Width: x16
          VRAM (Total): 256 MB

          Model Name: MacBook Pro
          Model Identifier: MacBookPro5,3
          Processor Name: Intel Core 2 Duo
          Processor Speed: 2.66 GHz
          Number Of Processors: 1
          Total Number Of Cores: 2
          L2 Cache: 3 MB
          Memory: 4 GB
          Bus Speed: 1.07 GHz

          Georgie Greggan added a comment -

          With Viewer 1.5.1.373 I can no longer reproduce this problem. I have enabled HTTP Get Textures and VBO. In fact I have nothing disabled that might have been a workaround when this problem appeared. I am delighted.

          Textures appear to load faster and my frame rate is higher. Well done devs.

          I consider this problem resolved where it concerned my 2009 i7 iMac.


            People

            • Assignee:
              Unassigned
              Reporter:
              Georgie Greggan
            • Votes:
              13 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: