Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-11965

[MATBUG-252] [MAINT-3210] When advanced lighting model is on, water in adjacent region flickers

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 4.5.0, Phoenix Firestorm 4.5.1, Phoenix Firestorm 4.5.2, Phoenix Firestorm 4.6.5, Phoenix Firestorm 4.6.7, Phoenix Firestorm 4.6.8, Phoenix Firestorm 4.6.9, Phoenix Firestorm 4.7.1, Phoenix Firestorm 4.7.3
    • Fix Version/s: Phoenix Firestorm 4.7.6
    • Component/s: Rendering
    • Environment:
    • SL Avatar Name:
      Davido Chrome
    • Reported In:
      Firestorm 4.5.0.38800 QA

      Description

      When advanced lighting model is on, sims far away flicker like crazy. This becomes very pronounced when you are flying and have turned up the draw distance to see where the interesting things are.

        Issue Links

          Activity

          greatfox snowpaw Futashy added a comment - - edited

          Confirmed on Firestorm 4.5.0 (38800) Oct 23 2013 02:33:09 (Firestorm-nightly) with Havok support. Windows 7 x64, Nvidia GTX 660Ti. So it isn't just AMD or Linux. Quite annoying, but never noticed it until I just turned ALM on to check. If it's a sim with a lot of visible water, it's almost seizure inducing with how fast it flashes between white and blue.

          whirly.fizzle Whirly Fizzle added a comment -

          This is https://jira.secondlife.com/browse/MATBUG-252 and is new on Materials enabled viewers.

          There were some changes made to occlusion culling in later materials builds. I suspect this is what triggered this behaviour.
          When O-O is enabled, at certain camera angles, any terrain that is under water on the region (or other regions in the line of sight) will rapidly flicker between showing the correct image of water only and the incorrect image of the terrain being visible and the covering water has disappeared.

          Workarounds:

          • Disable Object- Object occlusion under Develop -> Rendering. or
          • Disable ALM.
          elrikmerlin Elrik Merlin added a comment -

          I can also confirm this, running GTX780, Win 7 Pro, FS 4.5.1.38838

          isha Lezisha Resident added a comment -

          Same for me, I have tried 2 different Nvidea cards GTX 670 and now GTX 780 and they both produce this sim flicker, could be the next sim away of an array of sims in the distance. the flicker will come and go depending on the angle of view, and on a mostly water sim (with islands) the whole sim will flicker between water and white, many times a second. I went back from the current beta version to 4.2.2 and the problem goes away, so it's only in the BETA. I can supple screen shots if needed but others here have already. And I know of two others I have spoken to inworld that see the same problem.

          melody melody paslong added a comment -

          I am using a GTX 760 graphics card and have experienced the same flickering o using the beta 4.5.0. I went back to 4.4.2 and have had no problems with it.

          aiaustin Ai Austin added a comment -

          Firestorm 4.5.1 OpenSimulator Beta showing water flashes when flash is not showing. Frequency of flashes is 2 or 3 flashes per second.

          aiaustin Ai Austin added a comment -

          Firestorm 4.5.1 OpenSimulator Beta showing water flashes when flash is showing. Frequency of flashes is 2 or 3 flashes per second.

          aiaustin Ai Austin added a comment - - edited

          Flashing of appearance of water surface for an adjacent sim (a real sim, not a void). Voids render correctly without flashing.

          This problem started in 4.5.1 OpenSim Beta for me. It does not show in 4.4.2 OpenSim Release.

          Turning off ALM completely stops the flashing, but leaving ALM on and trying to use other controls to have no reflections, minimal light sources, no shadows, etc has no effect on the flashing.

          Develop -> Rendering -> Disable Object-Object occlusion does stop the flickering as noted by Whirly.

          Windows 7 and 8 32 bit and 64 bit systems and Nvidia cards including GTX 580 and GTX 680 GPUs.

          aiaustin Ai Austin added a comment -

          I see the identical problem with Nvidia GTX 580 and 680 GPUs in LL viewers right up to the every latest version 3.6.11, and as in Firestorm the problem can be removed by turning off Object-Object Occlusion in the develop -> rendering settings

          davido_chrome Davido Chrome added a comment -

          What does object-object occlusion do? I am under the impression that it is stopping the rendering of objects that are hidden behind other objects, thus helping performance. I guess it could have to do with shadows though?

          whirly.fizzle Whirly Fizzle added a comment -

          Yes correct. O-O occlusion skips rendering of objects that are out of view, so disabling it could give a performance hit.
          Tbh, I have never noticed any change in performance on my system if O-O occlusion is enabled or disabled.

          aiaustin Ai Austin added a comment -

          Just to note that with the new Firestorm 4.6.1 the flashing is still present in various setups (e.g. with NVidia GTX580). I had to reset Develop -> Rendering -> Object-Object Occlusion off to stop this.

          I tested on a setup where I kept my User settings and folders too and the flashing still occurred, so the O-O Occlusion setting must be removed on a reinstall.

          rayfly Richard added a comment - - edited

          Problem is in Firestorm 4.6.7 (42398) still not fixt, why is this important fix takeing so many version. and no disable ALM is not an option, if that would work. It ruines all flying. GF670 card

          ansariel.hiller Ansariel Hiller added a comment -

          Unless this fix is already in one of the official repos, I wouldn't want to take it.

          whirly.fizzle Whirly Fizzle added a comment -

          As far as I know, this fix isn't in any project or RC viewer yet.
          I'll push this to 5.0.1 then.

          archie.lukas archie added a comment -

          Hi
          kind of kills the fying experience in SL, even with a massive bandwidth and fast gaming PC, this sucks long time!

          please push a fix

          Appreciated.

          whirly.fizzle Whirly Fizzle added a comment -

          Disabling O-O occlusion worked for Archie - ref SUP-16319.

          ansariel.hiller Ansariel Hiller added a comment -

          The linked commit (https://bitbucket.org/msavchenko/viewer-release-maint-3210/commits/0b0400a272ef2d2ddf84b9a501d48b7dbf2afd68) seems highly wrong and/or experimental with possible side-effects. It enables the GL_DEPTH_CLAMP OpenGL extension that was disabled because projectors don't work with it properly. And there is also a copy-paste-error in there. I experimented with the changes, and what seem to work is:

          diff -r 66c5366e5728 indra/newview/llvieweroctree.cpp
          --- a/indra/newview/llvieweroctree.cpp	Thu Jan 14 17:47:45 2016 +0100
          +++ b/indra/newview/llvieweroctree.cpp	Thu Jan 14 23:45:20 2016 +0100
          @@ -1202,7 +1202,8 @@
           		}
           
           		// Don't cull hole/edge water, unless we have the GL_ARB_depth_clamp extension
          -		if (earlyFail(camera, bounds))
          +		if (earlyFail(camera, bounds) || mSpatialPartition->mDrawableType == LLDrawPool::POOL_VOIDWATER || mSpatialPartition->mDrawableType == LLDrawPool::POOL_WATER)
          +		//if (earlyFail(camera, bounds))
           		{
           			LL_RECORD_BLOCK_TIME(FTM_OCCLUSION_EARLY_FAIL);
           			setOcclusionState(LLOcclusionCullingGroup::DISCARD_QUERY);
          

          But I have no idea what side-effects this might cause.

          aiaustin Ai Austin added a comment -

          Maybe a "fix" would be to change O-O Occlusion to be off by default? Though I appreciate that you wish to stay mostly in step with LL.

          ansariel.hiller Ansariel Hiller added a comment -

          Turning object occlusion off by default results in a major performance hit - that's a no-go.

          aiaustin Ai Austin added a comment - - edited

          Ah, that's a pity as I have to turn it off all the time in both LL viewer and Firestorm to stop the blue sea flickering issue on all my systems (Windows 10, and using Nvidia GTX5xx, GTX 6xx, GTX9xx, Quadro K4000). I must be seriously losing FPS then.

          elrikmerlin Elrik Merlin added a comment -

          I have to turn OO off or it does my brain in. Now rather annoyed to discover the performance his is actually quite severe! Running a GTX980Ti these days...

          This was originally notified over 2 years ago... Is there anything we can do to help hurry a fix along?

          archie.lukas archie added a comment -

          Ummm
          this is not helpful.

          Having been advised by Whirly Fizzle to turn off O-O Occlusion ..........
          and it works! No more flashing seas whilst flying at Blake Sea, Hollywood Airport

          *BUT then *
          Ansariel Hiller reckons that following this advice is not correct:
          Quote *"Turning object occlusion off by default results in a major performance hit - that's a no-go." *Unquote

          So despite conflicting theories, one solution would be helpful - what is it and is there an alternative?

          elrikmerlin Elrik Merlin added a comment -

          Basically, the deal here appears to be that turning Object Occlusion off removes the issue - and removes a significant level of performance at the same time: it's a workaround, not a solution, and it comes with severe penalties.

          Thus setting OO off by default would give _everyone _a performance hit whether they were the sort of people (aviators, mariners etc) who will notice the flashing seas effect or not. Thus making Off the default would be a bad move.

          What we need is an actual solution to this, and kudos to anyone who is working to find one - thanks for your efforts and we look forward to a solution.

          nickyd Nicky added a comment -

          Water patches have a Z extrusion of 0, this seems to lead to such a small occlusion box (128,128, 0.25) that it gets occluded so easily and then will flash in and out.
          Forcing z to 1 makes the box big enough that the flashing will stop and OO being usable.
          Ansariel's version will work as well, forcing water never to be excluded Albeit it has a chance of being slower

          --- a/indra/newview/llvieweroctree.cpp  Sat Jan 16 14:13:10 2016 +0100
          +++ b/indra/newview/llvieweroctree.cpp  Sat Jan 16 20:00:24 2016 +0100
          @@ -1257,6 +1257,12 @@
                                                          LLGLSLShader* shader = LLGLSLShader::sCurBoundShaderPtr;
                                                          llassert(shader);
          
          +                                               if( mSpatialPartition->mDrawableType == LLDrawPool::POOL_VOIDWATER || mSpatialPartition->mDrawableType == LLDrawPool::POOL_WATER )
          +                                               {
          +                                                       if( bounds[1][2] <= 0.0001 )
          +                                                               bounds[1].getF32ptr()[2] = 1;
          +                                               }
          +
          
          archie.lukas archie added a comment -

          Sorry, but *does this 'Bear fix' now exist in any viewer, *Firestorm or Linden SL viewer?

          I am not a programmer, just a health scientist - meaningless to me and many, many others.

          Thanks

          ansariel.hiller Ansariel Hiller added a comment -

          LL has this fix now in their Maintenance RC viewer. That means it will go into default release on LL's end anytime soon and also end in Firestorm, too.

          archie.lukas archie added a comment -

          *Please inform us when this happens
          _*
          Appreciated_

          whirly.fizzle Whirly Fizzle added a comment -

          Hmm bug still reproduces on the Maint-RC for me: http://wiki.secondlife.com/wiki/Release_Notes/Second_Life_Release/4.0.2.310545
          They don't actually list that as a Resolved issue on the release notes.
          Guess it failed QA.

          ansariel.hiller Ansariel Hiller added a comment -

          Or no current build yet. Try my bear merge.

          bigwalter Bigwalter1957 Drut added a comment -

          unticking object-object occlusion stops it

          ansariel.hiller Ansariel Hiller added a comment -

          See my comment further up.

          archie.lukas archie added a comment -

          Return to GO!

          Do NOT collect £200

          whirly.fizzle Whirly Fizzle added a comment -

          FS Bear built at rev 5d022ae
          Firestorm 4.7.6 (48845) Feb 20 2016 19:13:39 (Firestorm-FizzlefireBear) with OpenSimulator support

          Bug is definitely much improved but not totally fixed.
          The flicker now only seems to happen to water much further away then before - but where the sky meets the water always seems to flicker.
          Disabling O-O Occlusion or disabling ALM is the only way to totally stop it.

          https://gyazo.com/d94f806eca0d7c4dd43fc1ae87e76676

          ansariel.hiller Ansariel Hiller added a comment -
          whirly.fizzle Whirly Fizzle added a comment - - edited

          I'm going to resolve this one as fixed.
          You need to be on mainland in an area where surrounding regions have Linden water, have a pretty excessive draw distance set (1024m) to be able to reproduce this with the fix & have the camera angle just right to see any flickering.
          My gif above looks worse then it actually is because I only captured a small area of the screen.
          I feel it's acceptable to call this one fixed.

          archie.lukas archie added a comment -

          Sooooooooooooo

          When do we get a viewer with this 'fix'?

          ansariel.hiller Ansariel Hiller added a comment -

          When it's done.

          whirly.fizzle Whirly Fizzle added a comment -

          Next release Archie

          archie.lukas archie added a comment -

          Thank you

          I shall look forward to the non-flickering, seizure, causing next release.
          Appreciated

          aiaustin Ai Austin added a comment - - edited

          It does look to me as if the flickering sea issue is largely resolved in 4.7.7.48706 when Object-Object Occlusion is turned on... whereas in 4.7.5 if that was on I always got flicker for the water off each adjacent region with Windows 10 and all Nvidia GPUs I use.

          I do still notice though that when I cam round though I get the sea showing light coloured briefly as each new adjacent region comes into view at the edge of the viewer screen. It is no where near as visually disruptive as previously but it is there when OOO is on and not there when it is turned off.

          To repeat... Set OOO on, put your avatar in the air and rapidly move it round (clockwise shows it best for me) and observe the sea around adjacent regions as they come into view at the edge of the viewer screen.

          whirly.fizzle Whirly Fizzle added a comment -

          Yep. It's not 100% fixed for sure but it's a hell of a lot better then it was.

          aiaustin Ai Austin added a comment - - edited

          Can someone else test this issue in 4.7.9.50527 (preview version)... as I am seeing the sea flashing issue for nearby region sea surfaces again.. and not just briefly as I cam out or around, but constantly flashing from normal viewpoints as we used to see.

          I am seeing this even with low view distances 256m and right down 128m or short 32m! (even lower than the distance to the flashing region!) (given Whirly's comment above)

          As before turning off Object-Object Occlusion stops this.

          Under 4.7.7 I have been running with O-O Occlusion left on and have not noticed this. Did something in this area get changed or taken back out? Its odd as the fix to use an OCCLUSION_FUDGE still seems to be in the file that was changed before...

          indra/newview/llvieweroctree.cpp

          I just tested with LL recent viewers (current release and a VOB Beta version) and they don't show this flashing with O-O Occlusion turned on from the same view positions and distances.

          Worth adding that I am seeing this with Nvidia GTX1080 card and latest drivers and its the same on Second Life and OpenSim regions.

          lassie Lassie added a comment -

          I'm unable to reproduce this on 50527. I saw some flicker as I turned OOC on and off and ALM on and off but nothing persistent.

          Firestorm 4.7.9 (50527) Aug 4 2016 11:59:10 (Firestorm-Releasex64) with OpenSimulator support

          CPU: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz (4008.01 MHz)
          Memory: 63081 MB
          OS Version: Microsoft Windows 10 64-bit (Build 10586)
          Graphics Card Vendor: NVIDIA Corporation
          Graphics Card: GeForce GTX 1080/PCIe/SSE2
          Windows Graphics Driver Version: 10.18.0013.6825
          OpenGL Version: 4.5.0 NVIDIA 368.25

          willow wilder Willow Wilder added a comment -

          Unable to repro yet using Firestorm 4.7.9 (50527) Aug 4 2016 11:59:10 (Firestorm-Releasex64) with OpenSimulator support
          CPU: Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz (3411.11 MHz)
          Memory: 8173 MB
          OS Version: Microsoft Windows 10 64-bit (Build 10586)
          Graphics Card Vendor: ATI Technologies Inc.
          Graphics Card: AMD Radeon HD 6700 Series

          Windows Graphics Driver Version: 8.17.0010.1404
          OpenGL Version: 4.2.13399 Compatibility Profile Context 15.201.1151.1008

          aiaustin Ai Austin added a comment - - edited

          Thanks for testing Lassie and Willow... I am trying again on a second Windows 10 system, at home with Nvidia GTX980. My view distance happens to be set at 256m (but I can repro this at anything from 32m to 512m) and O-O Occlusion is ticked on.

          I am seeing it most clearly when I zoom out with the camera some distance (camera constraints are disabled). The terrain about 2 islands away shows, but the sea around it drops out or flickers.

          Flicker is persistent, not transitory.

          I have attached two snapshot... filenames...
          2016-08-08-Firestorm-4-7-9-50527-Sea-Flicker-1.jpg (view distance 32m)
          2016-08-08-Firestorm-4-7-9-50527-Sea-Flicker-2.jpg (view distance 512m)

          Firestorm 4.7.9 (50527) Aug 4 2016 11:59:10 (Firestorm-Releasex64) with OpenSimulator support

          You are at 151.5, 166.3, 25.6 in Vue located at sim10157.agni.lindenlab.com (216.82.49.23:13022)
          SLURL: http://maps.secondlife.com/secondlife/Vue/151/166/26
          (global coordinates 254,871.0, 233,638.0, 25.6)
          Second Life Server 16.07.06.317395
          Retrieving...

          CPU: Intel(R) Xeon(R) CPU E5-1620 v3 @ 3.50GHz (3491.91 MHz)
          Memory: 32691 MB
          OS Version: Microsoft Windows 10 64-bit (Build 10586)
          Graphics Card Vendor: NVIDIA Corporation
          Graphics Card: GeForce GTX 980/PCIe/SSE2

          Windows Graphics Driver Version: 10.18.0013.6881
          OpenGL Version: 4.5.0 NVIDIA 368.81

          aiaustin Ai Austin added a comment - - edited

          Second Life, near Vue regions, Firestorm 4.7.9.50527 drop out and flickering of sea for regions beyond focus region. This is a zoomed out picture to show it on a region with only a few nearby islands.

          2016-08-08-Firestorm-4-7-9-50527-Sea-Flicker-1.jpg
          2016-08-08-Firestorm-4-7-9-50527-Sea-Flicker-2.jpg

          lassie Lassie added a comment -

          Ok, I am finally able to reproduce this, under extreme conditions. OOO on, draw distance 1024 meters, zoom out until the center of a region with water is right at the edge of where the world is clipped.

          Water Flicker-2016-08-08_14-43-33.mp4

          aiaustin Ai Austin added a comment -

          I have done a bit more digging round... the issue is also present in 4.7.7.48704 (64 Bit SL+OS) when I reproduce the same viewing positon. So its not a new 4.7.9 issue. Its just a residual of the previous problem. And Whirly did say the problem was not fully fixed before, just reduced.

          It is easiest to replicate on a zoomed out view.. but if you have a set of regions that are three of more away from your current region, it also shows. If the avatar flies up or down (PageUp/PageDown keys) the flickering shows even from the current avatar position in 3rd person or 1st person(Mouselook) mode. So flickering on the horizon for "normal" viewpoints will show.

          The flashing water tile can be at the edge of the clipping boundary where the light blue sky starts as Lassie has replicated, or one short of that as well. See

          2016-08-09-Flashing-Water-in-Region-Before-Edge-1.jpg
          2016-08-09-Flashing-Water-in-Region-Before-Edge-2.jpg

          View distance seems to not change the situation much right from 32m up to 1024m I get the flashing water. the view distance just means I see less of the actual build on the regions in view. One the flashing can be seen, you should be able to change the view distance and still see the same water surfaces on region tiles that are flashing on and off.

          I have though tested the current Linden Labs viewer 4.0.6.31555 and VOB RC 4.0.7.318263 and I cannot get any water patch flashing to occur when I try similar view positions and tests to those used above. I do appreciate they have different view cut off


            People

            • Assignee:
              shouldbeworkingonit.linden ShouldBeWorkingOnIt Linden
              Reporter:
              davido_chrome Davido Chrome
            • Votes:
              6 Vote for this issue
              Watchers:
              14 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: