Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-12004

[BUG-7761] Upon teleport, attachment points with mulitple attachements lose some of the attachments - phantom scripted attachments after teleport.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Waiting on Linden Lab fix
    • Affects Version/s: Phoenix Firestorm 4.4.2, Phoenix Firestorm 4.6.5, Phoenix Firestorm 4.6.7, Phoenix Firestorm 4.6.9, Phoenix Firestorm 4.7.1, Phoenix Firestorm 4.7.3, Phoenix Firestorm 4.7.5
    • Fix Version/s: None
    • Labels:
    • Environment:
    • SL Avatar Name:
      Idris Georgia
    • Reported In:
      Firestorm 4.4.2.34167 Release

      Description

      For months now I've seen an issue where attachments would fail to function. Collars would fail, huds. Mostly on one user. Then another user came along, and a head harness she was wearing was working fine, until she added a hood to the same attachment point. After that the harness would fail to respond and not be visible to other users. The wearer still sees it, even though the scripts won't work. A relog clears the issue. It appears the item that was the first attached is the one that fails.

      I expect most people don't notice the issue because the attachement points they are multiply attached on don't have any scripted items. They see it on, and others don't know it should be there.

      The cases I've seen went away when the users rearranged their attachments so they don't have more than one on a given point. However since it's not a well known problem yet, there are probably others than have hit it without knowing the cause.

      One thing that may or may not be related is that all the users I've seen with the issue are using RLV. I don't know if this is affected by RLV or not though.

      1. Whirly_1.log
        1.01 MB
        Whirly Fizzle

        Issue Links

          Activity

          ansariel.hiller Ansariel Hiller added a comment -

          Are those attachments or just any others locked when it happens? Need to pin down under what circumstances exactly this happens.

          slmember1 Leona added a comment -

          May this be related to FIRE-9838 ?

          idris Idris Georgia added a comment -

          Sorry to be so long responding. Yes the items are locked. And upon rereading the above now, I realized I left an important point out. The multiple attachments work fine, until they teleport/are teleported. It's upon arriving that the issue arises. I hope this helps and, again sorry not to respond sooner.

          PS. It's still happening with the current viewer, at least I saw it again just a couple days ago.

          fizz.savira Fizz Savira added a comment -

          Just saw this on the singularity viewer page, maybe there is some help here:

          Graphics engine improvements (Shyotl)

          Experimental volume face batching changes, allow +~10% larger mean batch size
          Added adaptive vsync support (see prefs section)
          Fixed an issue where hud-attached prims would go missing after a teleport

          Maybe "Shyotl" has a fix

          ayesha.askham Ayesha Askham added a comment - - edited

          Just adding a note to say that due to Whirly's closing of the FIRE-15507 (BUG-6925) JIRA, this BUG is alive and well in FS 4.7.5

          whirly.fizzle Whirly Fizzle added a comment -

          There is an experimental fix for this bug in testing.
          If anyone would like to try the test viewer containing this fix, please leave me a comment here with your operating system and whether you require a 32bit or a 64bit build.

          From Ansariel
          I dumped an experimental fix for FIRE-12004 (attachments getting lost on TP/region crossing) into LGPL, which is based on Kitty's attempt to fix it viewer-side, but done a bit differently:

          For some reason, during a TP/region crossing, the viewer might receive a "kill object" message from the region, which will then mess up the COF and maybe even the scripts in the attachment as well.
          The idea now is: whenever the avatar is in the process of a TP/region crossing, ignore any messages of killing attached objects.
          This works quite good for TPs. For region crossings it needs some working around insufficient information if a region crossing has been successful or failed and might eventually lead into a situation of stuck attachments in some situations.
          Rebaking (CTRL+ALT+R) or changing outfits should unstick them.

          Since this is an experimental fix, I added 2 settings which are both enabled by default:

          • FSExperimentalLostAttachmentsFix enables the fix
          • FSExperimentalLostAttachmentsFixReport will report to nearby chat if a kill object message was received during TP or region crossing and also show for which object, so it allows checking if those attachments are still there and working
          whirly.fizzle Whirly Fizzle added a comment -

          Testing on Firestorm 4.7.10 (51624) Oct 26 2016 20:12:38 (Firestorm-FizzlefireBENTOx64) with OpenSimulator support
          First "event" happened today.

          • Attached Whirly_1.log
          • I flew across the region border from http://maps.secondlife.com/secondlife/Firestorm%20Dow%20Forest/208/217/43 to http://maps.secondlife.com/secondlife/Firestorm%20Ghost%20Town/156/216/24
          • Region crossing starts on line 2303
          • Just after the region crossing ended I had this in local chat
            [17:38] [Sim tried to kill attachment: [RA] Dorothy Hair - Boobs w/ materials (crossing)]
            [17:38] [Sim tried to kill attachment: [FORMANAILS] BALLERINA NAILS FOR MAITREYA  -BP - LH+RH (crossing)]
            [17:38] [Sim tried to kill attachment: Izzie's - Wounded Angel Mesh Eyes (L) (crossing)]
            [17:38] [Sim tried to kill attachment: Izzie's - Wounded Angel Mesh Eyes (R) (crossing)]
            [17:38] [Sim tried to kill attachment: (HUD AO)SLC AO Stimulus [ZHAO-II MB2.0.17mod] (crossing)]
            [17:38] [Sim tried to kill attachment: .tsg. Nurse Sugar Uniform - White [Maitreya] (crossing)]
            [17:38] [Sim tried to kill attachment: Maitreya Mesh Body - HUD V3.5 Lara (crossing)]
            
          • All those attachments seemed to be in the correct state (locally attached and server attached. I could remove and add them all back.
          • When flying back out of Ghost town region, the same thing happened again.
            [17:41] [Sim tried to kill attachment: [FORMANAILS] BALLERINA NAILS FOR MAITREYA  -BP - LH+RH (crossing)]
            [17:41] [Sim tried to kill attachment: Izzie's - Wounded Angel Mesh Eyes (L) (crossing)]
            [17:41] [Sim tried to kill attachment: Izzie's - Wounded Angel Mesh Eyes (R) (crossing)]
            [17:41] [Sim tried to kill attachment: (HUD AO)SLC AO Stimulus [ZHAO-II MB2.0.17mod] (crossing)]
            [17:41] [Sim tried to kill attachment: Maitreya Mesh Body - HUD V3.5 Lara (crossing)]
            
          • All those attachments are still in the correct state though.
          • Ghost town region temp attaches a HUD when entering for the FS Ghost Town experience. Unsure if this is what triggered it.
          • Unable to reproduce again when flying in & out of Ghost Town region.
          aiaustin Ai Austin added a comment - - edited

          I have for the first time noticed that with 4.7.10 51989 on our addon regions to OpenSim-based OSGrid, on teleport between the regions for one avatar, I get a sequence of the errors. I have never seen this before on these regions in quite a few years of operations.

          [04:19] Sim tried to kill attachment:  (tp)
          [04:19] Sim tried to kill attachment:  (tp)
          [04:19] Sim tried to kill attachment:  (tp)
          [04:19] Sim tried to kill attachment:  (tp)
          repeated 24 times with one region, 4 on another, and different numbers.

          The avatar has NO attachments or HUDS on at the time. I removed them all and reclogged for test purposes. if I go back to 4.7.9 I do not see these messages.

          The OpenSim region console log shows no warnings or message sat the default level of diagnostics.

          aiaustin Ai Austin added a comment - - edited

          OSGrid testing of tis between our own regions..

          To "Black Rock" get the message 4 times
          To "Space City" get the message 2 times
          To" Oil Rig" get the message 24 times

          This is for an avatar with no attachments of any kind, and no HUDs. Though I tried various outfits with attachments and HIDs and that doe snot seem to change the number of times this message appears. This seems the same every time for a given destination region, wherever the location is you come from.

          Oddly, I don't get this issue with another avatar for the same regions. Something avatar specific must be involved.

          Cache clear seems to have had no effect.

          Let me know if anyone can suggest tests to pin things down while its occurring for me.

          anuk2939 Kousara Virginia Kirino added a comment - - edited

          yes. Tested for Flying my Aircraft in many regions. to your airport destination. in Firestorm 4.7.7. turned AISV3 off. in 5.0.1 it's on the Coroutines Feature. Maybe. in the Serverside? Also. Still lose and attaches with FSExperimentalAttachmentsfix TRUE. in low chances. And so. I've pinned this things down for this test. in 5.0.1. I suggest the Firestorm Staff to address this issue in Server and Client to fix the infamous multiple attachment losing problem in AISV3. Please?

          Update:I Think this Problem It's on The Server Side. Not Client Side. You need Linden to Fix this kill-object Attachment Problem in Server Side AIS Appearance Messaging in Aditi Grid then Agni Grid. by Improving and Figure Out The problematic kill-object Appearance Messaging in Old Server Version too.

          Here's my Problem for Teleport.
          [Sim tried to kill attachment: (tp)]
          [Sim tried to kill attachment: (tp)]
          [Sim tried to kill attachment: (tp)]
          [Sim tried to kill attachment: (tp)]
          [Sim tried to kill attachment: (tp)]
          [Sim tried to kill attachment: [M3+] - Head (v.1.12.22) (tp)]

          That why I'm very experiencing the detaching issues. It's caused by the AISV3 API (now Included with Coroutines in 4.7.9) and Server Side Appearance kill-object messaging from the Server. LL please fix the problem from The Server side by rewriting the Server Side Appearance to fix the falling off appearance issue? Please?

          whirly.fizzle Whirly Fizzle added a comment -

          Closing this issue as "Waiting on a LL fix" per Beq's comment on issue FIRE-17550, which is essentially the same bug.
          Linden lab are soon to be working on fixing this bug server side.

          Beq Janus added a comment - 2 days ago

          We are closing this as unfixable.
          We understand it is annoying and we'd love to squish it, but anything related to region crossing and attachment loss cannot be fully fixed by the as the notion of attachments and inventory state is held on the server.

          I raised this in a Linden office hours meeting today (5/Jul/2017).
          [07:43] Oz Linden: Beq ... that attachment thing is pretty high up on our list for server side attention
          [07:43] Oz Linden: unfortunately, not quite above the line yet, but soon, I hope

          If you have additional information that may help the lab to address this and related issues please add your comments to https://jira.secondlife.com/browse/BUG-6925

          Thank you. Hopefully, we will see concrete action to address this sometime in the not too distant future


            People

            • Assignee:
              shouldbeworkingonit.linden ShouldBeWorkingOnIt Linden
              Reporter:
              idris Idris Georgia
            • Votes:
              4 Vote for this issue
              Watchers:
              11 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: