Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-12331

[BUG-4655] [MAINT-3562] Crash when updating a local texture - Substance Designer

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 4.5.1, Phoenix Firestorm 4.5.2
    • Fix Version/s: Phoenix Firestorm 4.7.1
    • Labels:
    • Environment:
    • SL Avatar Name:
      cynth
    • Reported In:
      Firestorm 4.5.1.38838 Beta Release

      Description

      When exporting updated local textures from my graphics program (Substance Designer 3), often (but not every time!) Firestorm will crash with a blank error window. Steps:

      1. Create a texture, add it to your local texture picker (does not need to be applied to a prim, just on the list)
      2. Save a new copy of that texture over the old one
      3. Wait a moment for local textures to be updated

      Included is the minidump, a screenshot of the "error", and the .png being created by Substance Designer, in case any of those are of help. The minidump says:

      Exception Code: 0xC0000005
      Exception Information: The thread tried to read from or write to a virtual address for which it does not have the appropriate access.

      1. 22a59261-ab7c-40e2-ac52-ca6f61142fdb.dmp
        85 kB
        Cynthia
      2. crash_graph.sbs
        5 kB
        Cynthia
      1. error.png
        0.9 kB
      2. GP_Miniskirt_with_Belt_Specular_Environment.png
        288 kB

        Issue Links

          Activity

          cynth Cynthia added a comment -

          This may be a red herring, but I've been toying with what causes the crash some more. The program (Substance Designer) seems to zero the file, and then write out the data, and I'm curious if the viewer is refreshing the texture mid-write, allocating a smaller amount of memory than the file will end up being, and trying to load a larger file into the smaller memory area without a bounds check?

          If this ends up being the issue, maybe the viewer can wait until there are no write locks on the file (not even shared-exclusive) before attempting to update the file (if it doesn't already)?

          cynth Cynthia added a comment -

          Okay, so, two things. I have a workaround for the moment: I'm using a synchronize tool to copy to a second directory, and then using local textures out of that directory, and whatever the sync tool is doing differently, it prevents the crashes.

          Second, I tried the latest LL v3 and it also crashes, so it's not a Firestorm problem after all. It's good to have this ticket here, though, where it might actually get seen, discussed, or fixed, heh.

          whirly.fizzle Whirly Fizzle added a comment -

          Thanks for the dmp Cynthia!

          Callstack:

          03b6f2fc 01e1ff93 18899078 0c37136e 00002000 msvcr100!memcpy+0x57 (CONV: cdecl) [f:\dd\vctools\crt_bld\SELF_X86\crt\src\INTEL\memcpy.asm @ 185]
          03b6f31c 0258c598 381f6598 18899078 00002000 Firestorm_Beta!LLPngWrapper::readDataCallback+0x23 (FPO: [Non-Fpo]) (CONV: cdecl) [c:\fs\build_fs_windows_firestorm_4_5_1\build\indra\llimage\llpngwrapper.cpp @ 91]
          03b6f330 0258e4eb 381f6598 18899078 00002000 Firestorm_Beta!png_read_data+0x18 (FPO: [Non-Fpo]) (CONV: cdecl) [g:\develop\secondlife\[libs]\3p-libpng\libpng-1.5.1\pngrio.c @ 37]
          03b6f350 02589b52 381f6598 18899078 00002000 Firestorm_Beta!png_crc_read+0x1b (FPO: [Non-Fpo]) (CONV: cdecl) [g:\develop\secondlife\[libs]\3p-libpng\libpng-1.5.1\pngrutil.c @ 195]
          03b6f3b8 02589eab 381f6598 3be63030 00000000 Firestorm_Beta!png_read_row+0x242 (FPO: [Non-Fpo]) (CONV: cdecl) [g:\develop\secondlife\[libs]\3p-libpng\libpng-1.5.1\pngread.c @ 659]
          03b6f3dc 01e2043c 00000001 1723a578 0aa069a4 Firestorm_Beta!png_read_image+0x9b (FPO: [Non-Fpo]) (CONV: cdecl) [g:\develop\secondlife\[libs]\3p-libpng\libpng-1.5.1\pngread.c @ 876]
          03b6f420 01e1992f 0c2f1030 3bc3f030 00000000 Firestorm_Beta!LLPngWrapper::readPng+0x14c (FPO: [Non-Fpo]) (CONV: thiscall) [c:\fs\build_fs_windows_firestorm_4_5_1\build\indra\llimage\llpngwrapper.cpp @ 170]
          03b6f514 018029f8 3ba08100 00000000 0aa068c8 Firestorm_Beta!LLImagePNG::decode+0x1df (FPO: [Non-Fpo]) (CONV: thiscall) [c:\fs\build_fs_windows_firestorm_4_5_1\build\indra\llimage\llimagepng.cpp @ 105]
          03b6f54c 01804101 3ba08100 0aa06874 02e84d70 Firestorm_Beta!LLLocalBitmap::decodeBitmap+0x228 (FPO: [Non-Fpo]) (CONV: thiscall) [c:\fs\build_fs_windows_firestorm_4_5_1\build\indra\newview\lllocalbitmaps.cpp @ 319]
          03b6f5f0 0180480a 00000001 34ef8170 01804b65 Firestorm_Beta!LLLocalBitmap::updateSelf+0x1a1 (FPO: [Non-Fpo]) (CONV: thiscall) [c:\fs\build_fs_windows_firestorm_4_5_1\build\indra\newview\lllocalbitmaps.cpp @ 197]
          03b6f5fc 01804b65 021279f4 0aa06bd0 00000001 Firestorm_Beta!LLLocalBitmapMgr::doUpdates+0x2a (FPO: [0,0,4]) (CONV: cdecl) [c:\fs\build_fs_windows_firestorm_4_5_1\build\indra\newview\lllocalbitmaps.cpp @ 968]
          03b6f600 021279f4 0aa06bd0 00000001 ffffffff Firestorm_Beta!LLLocalBitmapTimer::tick+0x5 (FPO: [0,0,0]) (CONV: thiscall) [c:\fs\build_fs_windows_firestorm_4_5_1\build\indra\newview\lllocalbitmaps.cpp @ 820]
          03b6f654 0149540a 0aa06b60 053fe688 02e686c0 Firestorm_Beta!LLEventTimer::updateClass+0xb4 (FPO: [Non-Fpo]) (CONV: cdecl) [c:\fs\build_fs_windows_firestorm_4_5_1\build\indra\llcommon\lleventtimer.cpp @ 73]
          03b6f6e4 01497816 0aa06510 00000010 053fe688 Firestorm_Beta!LLAppViewer::idle+0x8a (FPO: [Non-Fpo]) (CONV: thiscall) [c:\fs\build_fs_windows_firestorm_4_5_1\build\indra\newview\llappviewer.cpp @ 4968]
          03b6f894 01dbec02 02f2cebc 00d7348c 00000000 Firestorm_Beta!LLAppViewer::mainLoop+0x876 (FPO: [Non-Fpo]) (CONV: thiscall) [c:\fs\build_fs_windows_firestorm_4_5_1\build\indra\newview\llappviewer.cpp @ 1579]
          03b6f8d0 025b208d 01260000 00000000 00d7348c Firestorm_Beta!WinMain+0x1f2 (FPO: [Non-Fpo]) (CONV: stdcall) [c:\fs\build_fs_windows_firestorm_4_5_1\build\indra\newview\llappviewerwin32.cpp @ 304]
          03b6f964 7521495d fed2e000 03b6f9b4 773498ee Firestorm_Beta!__tmainCRTStartup+0x150 (FPO: [Non-Fpo]) (CONV: cdecl) [f:\dd\vctools\crt_bld\self_x86\crt\src\crtexe.c @ 547]
          03b6f970 773498ee fed2e000 0b642e8f 00000000 kernel32!BaseThreadInitThunk+0xe (FPO: [Non-Fpo])
          03b6f9b4 773498c4 00000000 00000000 00000000 ntdll!__RtlUserThreadStart+0x20 (FPO: [SEH])
          03b6f9c4 00000000 025b21d0 fed2e000 00000000 ntdll!_RtlUserThreadStart+0x1b (FPO: [Non-Fpo])
          
          whirly.fizzle Whirly Fizzle added a comment -

          Cynthia, is this the correct program? http://www.allegorithmic.com/products/substance-designer.
          There is a 30 days free trial

          whirly.fizzle Whirly Fizzle added a comment -

          Just to check, is the path that you are adding local textures from when using substance designer have any non standard characters in it?
          This is known to sometimes produce a crash - see FIRE-12173

          whirly.fizzle Whirly Fizzle added a comment - - edited

          Ok, I dont think Im going to be able to work out how to use substance designer

          Each time I try to load a background image, substance designer 3 crashes in > QtCore4.dll!60f8deb5() lol.

          cynth Cynthia added a comment -

          Hey, Whirly, thanks for looking at this. Didn't mean to make you go through all that trouble!

          My path is "C:\Users\Cynthetic\Documents\0 Models\GP Miniskirt with Belt" so I don't suspect that's the problem this time.

          I'm attaching an .sbs file, which opens in Substance Designer. I made a bad-case scenario to create big 6MB .png files, since I noticed crash chance is directly proportional to the size of the file. Once opened, right click "crash_graph" on the left, and choose "Export to bitmap". Switch file type to .png and export. Load those three files into the local texture thing, and then go back and export repeatedly until crash (usually first try.)

          whirly.fizzle Whirly Fizzle added a comment -

          Awesome! Thanks for doing that Cynthia. I shall try this shortly.

          whirly.fizzle Whirly Fizzle added a comment -

          Wonderful!
          Reproduced on 1st try.

          Logfile just cuts dead.

          Callstack:

          >	msvcr100.dll!memcpy(unsigned char * dst=0x06595620, unsigned char * src=0x2246ae2a, unsigned long count=8192)  Line 185	Asm
           	FirestormOS-Fizzlefire.exe!LLPngWrapper::readDataCallback(png_struct_def * png_ptr=0x19102e58, unsigned char * dest=0x06595620, unsigned int length=8192)  Line 91 + 0x15 bytes	C++
           	FirestormOS-Fizzlefire.exe!png_read_data(png_struct_def * png_ptr=0x19102e58, unsigned char * data=0x06595620, unsigned int length=8192)  Line 37 + 0xb bytes	C
           	FirestormOS-Fizzlefire.exe!png_crc_read(png_struct_def * png_ptr=0x19102e58, unsigned char * buf=0x06595620, unsigned int length=8192)  Line 195	C
           	FirestormOS-Fizzlefire.exe!png_read_row(png_struct_def * png_ptr=0x19102e58, unsigned char * row=0x2367b030, unsigned char * dsp_row=0x00000000)  Line 659	C
           	FirestormOS-Fizzlefire.exe!png_read_image(png_struct_def * png_ptr=0x00000001, unsigned char * * image=0x097a3750)  Line 876 + 0xb bytes	C
           	FirestormOS-Fizzlefire.exe!LLPngWrapper::readPng(unsigned char * src=0x22220030, LLImageRaw * rawImage=0x233e0030, LLPngWrapper::ImageInfo * infop=0x00000000)  Line 170	C++
           	FirestormOS-Fizzlefire.exe!LLImagePNG::decode(LLImageRaw * raw_image=0x251b1950, float decode_time=0.00000000)  Line 105 + 0x15 bytes	C++
           	FirestormOS-Fizzlefire.exe!LLLocalBitmap::decodeBitmap(LLPointer<LLImageRaw> rawimg={...})  Line 319 + 0x29 bytes	C++
           	FirestormOS-Fizzlefire.exe!LLLocalBitmap::updateSelf(LLLocalBitmap::EUpdateType optional_firstupdate=UT_REGUPDATE)  Line 197 + 0x26 bytes	C++
           	FirestormOS-Fizzlefire.exe!LLLocalBitmapMgr::doUpdates()  Line 968 + 0xa bytes	C++
           	FirestormOS-Fizzlefire.exe!LLLocalBitmapTimer::tick()  Line 820	C++
           	FirestormOS-Fizzlefire.exe!LLEventTimer::updateClass()  Line 73 + 0x9 bytes	C++
           	FirestormOS-Fizzlefire.exe!LLAppViewer::idle()  Line 5059	C++
           	FirestormOS-Fizzlefire.exe!LLAppViewer::mainLoop()  Line 1631	C++
           	FirestormOS-Fizzlefire.exe!WinMain(HINSTANCE__ * hInstance=0x00f30000, HINSTANCE__ * hPrevInstance=0x00000000, char * lpCmdLine=0x002e2d5b, int nCmdShow=1)  Line 303	C++
           	FirestormOS-Fizzlefire.exe!__tmainCRTStartup()  Line 547 + 0x1c bytes	C
           	kernel32.dll!@BaseThreadInitThunk@12()  + 0x12 bytes	
           	ntdll.dll!___RtlUserThreadStart@8()  + 0x27 bytes	
           	ntdll.dll!__RtlUserThreadStart@8()  + 0x1b bytes	
          

          Testing system:

          Firestorm 4.5.2 (39740) Dec  2 2013 00:13:12 (Firestorm-Fizzlefire) with OpenSimulator support
          Release Notes
          
          CPU: Intel(R) Core(TM)2 Quad CPU    Q8300  @ 2.50GHz (2493.75 MHz)
          Memory: 3326 MB
          OS Version: Microsoft Windows Vista 32-bit Service Pack 2 (Build 6002)
          Graphics Card Vendor: NVIDIA Corporation
          Graphics Card: GeForce GT 230/PCIe/SSE2
          
          Windows Graphics Driver Version: 9.18.0013.3193
          OpenGL Version: 3.3.0
          
          RestrainedLove API: RLV v2.7.0 / RLVa v1.4.9a
          libcurl Version: libcurl/7.24.0 OpenSSL/1.0.1e zlib/1.2.5 c-ares/1.10.0
          J2C Decoder Version: KDU v7.3.2
          Audio Driver Version: FMOD Ex 4.44.26
          Qt Webkit Version: 4.7.1 (version number hard-coded)
          Voice Server Version: Not Connected
          Settings mode: Hybrid
          Viewer Skin: Firestorm (CtrlAltStudio)
          Font Used: Deja Vu (96)
          Draw distance: 128
          Bandwidth: 1500
          LOD factor: 2
          Render quality: Medium-High (4/7)
          Texture memory: 384 MB (1)
          Built with MSVC version 1600
          
          whirly.fizzle Whirly Fizzle added a comment -

          Reproduced on Viewer 3 and filed on the LL JIRA as BUG-4655.

          cynth Cynthia added a comment -

          Thanks so much for gathering all this data and submitting that bug. Hopefully this helps more than just me.

          kf6kjg Ricky C / Cron Stardust added a comment -

          FWIW, I'm getting this crash with OSX 10.9.2 and exporting to a PNG from GIMP 2.9.1 (unstable development release): Every time, without fail, that I export and overwrite the image on disk FS crashes - instantly and hard.

          What's interesting is that it crashes before the image write progress bar in GIMP finishes. This does make me think, like the OP, that it might be a race condition: the viewer could be trying to read too early. If it is, I wonder if there's any writelocks that can be detected...

          So I did a test. The fastest way I know of to change a file is using mv on the commandline. Sure enough: when I exported my updated texture to an intermediate filename and then used mv to overwrite the file that's the source for the local texture, the viewer acts as it is supposed to: the texture updated in my in-world view and no crash happened.

          So now we have both another workaround AND a non-repro that helps narrow the scope of the problem!

          whirly.fizzle Whirly Fizzle added a comment -

            People

            • Assignee:
              shouldbeworkingonit.linden ShouldBeWorkingOnIt Linden
              Reporter:
              cynth Cynthia
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: