Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-12401

[BUG-4633] [MAINT-3529] Certain pathcuts made to a cube cause some faces to not react to sunlight or local lights

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 4.5.1, Phoenix Firestorm 4.5.2, Phoenix Firestorm 4.6.1
    • Fix Version/s: Phoenix Firestorm 4.7.2
    • Component/s: Rendering
    • Environment:
    • SL Avatar Name:
      Whirly Fizzle
    • Reported In:
      Firestorm 4.5.2

      Description

      Bug found by Linnrenate Crosby

      Steps To Reproduce

      1. Rez a cube
      2. Shift drag cube so you have 2 copies.
      3. Pathcut one cube B:0.246 (Any B pathcut 0.246-0.249 will reproduce this)
      4. Rotate the pathcut cube to X:180
      5. Observe how the upper faces of the 2 cube prims react to sunlight and local lights

      Observed Behaviour

      Sun set to Midday, ALM disabled

      • When you cam down directly onto the top of the cubes and zoom camera out, both prims display as expected.

      • Zoom camera down closer to the prims top surface and observe the pathcut prim's top surface is no longer lit by the sun

      Sun set to Midday, ALM enabled

      • When you cam down directly onto the top of the cubes and zoom camera out, both prims display as expected.

      • Zoom camera down closer to the prims top surface and observe the pathcut prim's top surface renders totally black

      • Rotate camera so it is not looking directly down on the prims and observe the pathcut prim's top surface is no longer black but it is not being lit by the sun.

      • Rez a local light or a projector light shining onto the 2 prims and observe that the top surface of the pathcut prim is not lit by the light unless tou zoom camera out.
      • Change the pathcut prim to have a B pathcut of ≤0.245 or ≥0.250 and this bug no longer reproduces.

      Expected Behaviour

      The pathcut prim should react to sunlight and local lights in the same way as a non-pathcut prim.

      Other Information.

      The fact that this bug fixes itself when you cam further away from the prims appears intermittant.
      I need to dig some more to see what is affecting whether camming further out fixes this.

      Bug only reproduces on Materials enabled viewers.
      Verified does not reproduce on Firestorm 4.4.2
      Verified does not reproduce on Second Life 3.5.3 (276452) May 24 2013 02:06:23 (PreMaterials)

        Issue Links

          Activity

          linncrosby Linn Crosby added a comment -

          This bug is still present in Firestorm 4.6.1 (40478)

          And annoying as hell i might add

          whirly.fizzle Whirly Fizzle added a comment -

          Confirmed this still reproduces on Firestorm 4.6.9.
          Also still reproduces on Firestorm 4.7.1 (45325) Apr 30 2015 19:22:46 (Firestorm-Betax64) with OpenSimulator support

          However it does not reproduce on Firestorm 4.7.2 (46338) Jun 25 2015 00:57:24 (Firestorm-Fizzlefire) with OpenSimulator support
          So looks like this was fixed in the last merge.

          Its also fixed on the latest LL viewer.

          ansariel.hiller Ansariel Hiller added a comment -

            People

            • Assignee:
              shouldbeworkingonit.linden ShouldBeWorkingOnIt Linden
              Reporter:
              whirly.fizzle Whirly Fizzle
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: