Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-13180

Screen Space Reflections makes shiny materials appear too dark and add reflections which should not be there

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: Phoenix Firestorm 4.6.1, Phoenix Firestorm 4.6.2
    • Fix Version/s: Phoenix Firestorm 4.7.0
    • Component/s: Rendering
    • Environment:
    • SL Avatar Name:
      Bax Coen
    • Reported In:
      Firestorm 4.6.1.40478 Release

      Description

      Objects using SL materials with a high glossiness setting can look radically different when enabling Screen Space Reflections. Please see the picture attached

      Both spheres have a yellow-tinted plywood texture. Both spheres have glossiness at 255 for maximum sharp reflections.

      • The left sphere has an all-white specular texture - all areas shall exhibit high shininess/reflections.
      • The right sphere has an all-black specular texture - all areas shall exhibit NO shininess/reflections.

      Firstly, without Screen Space Reflections, you see the spheres yellow as expected, the left one has the shine (reflection of the sun on top), the right one doesn't (because the specular texture is black in all places).

      Below that, we enabled Screen Space Reflections. The left sphere retains the sun reflection and adds Screen Space Reflections, seen as the gray band and the yellowish area near the other sphere. But instead of just adding the reflections, the yellow diffuse texture is not to be seen, all is black. Some of the diffuse texture will remain visible when using a lower glossiness setting but when I want sharp highlights, I need to crank it up without loosing the diffuse texture altogether. If I wanted a mirror without any diffuse texture showing like this, I'd simply use a black diffuse texture on it. On top of that, it just feels wrong when an object with valid shinyness looks radically different with SSR on.

      The sphere on the right has the specular texture all black, there should be no shininess or reflections in any area as correctly seen with no SSR. After turning on SSR however, the sun reflection appears. This might be related or a separate issue, idk

      1. SSR Issue.tga
        3.00 MB
        bax.coen
      1. shiny_sphere_projection_light.png
        539 kB
      2. SSR Issue.png
        468 kB

        Issue Links

          Activity

          ansariel.hiller Ansariel Hiller added a comment -

          Probably related to or the same issue as FIRE-13002.

          whirly.fizzle Whirly Fizzle added a comment -

          Nice repro, thanks!

          Reproduces on Firestorm 4.6.2 (40717) Mar 20 2014 14:50:06 (Firestorm-Fizzlefire) with OpenSimulator support

          Official viewer doesnt have the SSR feature.

          whirly.fizzle Whirly Fizzle added a comment -

          I dropped an IM to Tofu Buzzard about this problem.

          Vivian Rail Vivian Rail added a comment - - edited

          The SSR problems in Firestorm are a bit more extensive than that. For example my red spheres, which are illuminated normally by projection lights, but barely illuminated at all by the sun or sky. I also noticed that FIrestorm's SSR makes my Slink head, which has a nearly black specularity map look like it's made of shiny plastic any time the sun is shining on it.

          ansariel.hiller Ansariel Hiller added a comment -

          Personally I'd like to see SSR go away. Nobody here will be able to fix it anyway and if LL is changing the affected shaders, it won't work properly anyway.

          whirly.fizzle Whirly Fizzle added a comment -

          Yeah its pretty broken now since Materials.
          I never got a reply back from Tofu about this bug.

          Maybe we should remove SSR from preferences and leave it as a debug setting only for those that want to play with it? Or make SSR reset to disabled each login?
          SSR is still useful when taking photographs of certain scenes, but it isn't a setting that should be left enabled all the time. Because it does have uses for photography, I think resetting it to disabled each login would be the best idea.

          ansariel.hiller Ansariel Hiller added a comment -

          Closing as won't fix. SSR has been removed in 44608 (http://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/30f89533cb77).

          rhet0rica Qasri added a comment -

          I've played around with the specular effect (and raytracing) enough to know exactly what the bug is—the image buffer containing the specular reflections is being alpha-blended with the rest of the scene instead of additively blended, where the alpha level is the degree of shininess. It's a bit depressing to think it was removed completely instead of given (what might have been?) a one-line fix; besides that quirk, it looked perfectly fine on any opaque surface without a bump map.


            People

            • Assignee:
              ansariel.hiller Ansariel Hiller
              Reporter:
              Bax Coen bax.coen
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: