Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-1347

Off Sim water level doesn't match a changed on sim water level

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 4.1.1
    • Fix Version/s: Phoenix Firestorm 4.2.1
    • Component/s: None
    • Labels:
      None
    • Environment:
    • SL Avatar Name:
      NaughtyPrincess Milneaux
    • Reported In:
      Firestorm 2.5.1.x

      Description

      Sim water level was lowered but off sim water level stayed the same creating visual problems with off sim placed items. Can not see these problems in Phoenix, just Firestorm. I am attaching a picture that shows Off SIM islands sticking up thru the water where before they did not. Effects the total view of the SIM.

      1. SIM and Off SIM Water Level Change Bug.tga
        768 kB
        NP Milneaux
      2. Snapshot _ [NN] -Designs_ ~The Purple Elephant~ _[NN]City -Rent.tga
        768 kB
        Courtney Canton
      1. border edge _Sunset Escape, Richmond Falls (23, 251, 22.png
        415 kB
      2. Corsa (250, 130, 18) - Firestorm 1.png
        291 kB
      3. Corsa (250, 130, 18) - Firestorm 2.png
        289 kB
      4. Corsa (250, 130, 18) - Phoenix 1.png
        296 kB
      5. Corsa (250, 130, 18) - Phoenix 2.png
        289 kB
      6. Corsa (250, 130, 18) - Viewer-2 1.png
        230 kB
      7. Corsa (250, 130, 18) - Viewer-2 2.png
        309 kB
      8. Off SIM and On SIM Water Level Problem_001.png
        1.53 MB

        Issue Links

          Activity

          whirly.fizzle Whirly Fizzle added a comment -

          Do you have the same issue in Viewer 2?

          tatianahema Laura Laws added a comment -

          I have this same problem and it does not happen in Viewer 2.

          naughtyprincess milneaux NP Milneaux added a comment -

          I do not have v2 installed on my computer and changes were made in the SIM so I could see it correctly while the bug was being fixed. The linked JIRA to this one mentioned it was a v2 bug tho. If needed, I can install v2 and change our water level to check this if needed. Please advise. Thanks.

          whirly.fizzle Whirly Fizzle added a comment -

          Thanks Laura & yes please NP, If you could check against V2. This is really helpful to know if its an inherited V2 bug, or something that we are doing wrong.

          naughtyprincess milneaux NP Milneaux added a comment -

          I downloaded v2 and changed the water level on my SIM and YES, it's the same problem. The off SIM water and on SIM water levels do not match up. I took a pic of it in v2, but don't know how to add another pic. So this does seem to be a v2 inherited problem but hinders ability of SIM terraforming to some degree since I have to keep the water level on SIM as that off SIM to not have gaps in the water.

          naughtyprincess milneaux NP Milneaux added a comment -

          Figured out how to add another pic. This is from v2. Off SIM and on SIM water levels leave gaps if not set the same height.

          whirly.fizzle Whirly Fizzle added a comment -

          Thanks for the info NP

          roselee.quartz Rose Porcella added a comment -

          The issues occurred after a recent update to the Viewer 2 code (beginning-ish of June). Hence it also shows in the latest FireStorm.

          If the sea level for a sim is set below the 'standard' 20m height, the sea level is non-the-less rendered at 20m outside of the sim area, but the water on the sim itself is rendered correctly at the (lower) level. This results in a grey ribbon shown 'holding back' the wall of sea from the sim land.

          --Rose

          kainous Kainous Megadon added a comment -

          Rose is correct, I tried a version of V2 that was released before June; the issue was not present.

          whirly.fizzle Whirly Fizzle added a comment -

          Do you guys by any chance have basic shaders disabled in Avatar -> Preferences -> Graphics -> General?

          naughtyprincess milneaux NP Milneaux added a comment -

          I have basic shaders ENABLED on firestorm.

          chaos_teardrop chaos teardrop added a comment -

          Three pairs of photos of the sim in Corsa... with estate water level set to 15m... the "normal" looking ocean was a photo shot in Phoenix 1.5.2.1102 viewer and the "split-level" ocean was a photo shot in the Firestorm Beta 2 and Viewer 2

          master huldschinsky Master Huldschinsky (Nathan) added a comment - - edited

          still a issue in 2.5.2

          see below ..

          phoenix shows it correctly:

          however in firestorm and other viewer 2 viewers shows as:

          still issue in 2.5.2

          master huldschinsky Master Huldschinsky (Nathan) added a comment - - edited

          oh also there is same issue in second life viewer 3.0.0 as well...

          whirly.fizzle Whirly Fizzle added a comment -

          LL are working on this issue at the moment, see https://jira.secondlife.com/browse/VWR-26118
          Its still going through their QA process but it can be ported into Firestorm as soon as the code is available.

          whirly.fizzle Whirly Fizzle added a comment -
          whirly.fizzle Whirly Fizzle added a comment -

          Note for the next merge: LL just broke this again, they reverted the fix.

          See https://jira.secondlife.com/browse/VWR-29065

          whirly.fizzle Whirly Fizzle added a comment -

          Liny, can you double check this fix wasnt reverted with the recent V3 merge? I dont see it reverted....yet.

          whirly.fizzle Whirly Fizzle added a comment -

          The 4.1.1 release of Firestorm picked this bug back up again in the merge.

          Lets use FIRE-6946 as the working issue for this now

          whirly.fizzle Whirly Fizzle added a comment -

          Reopening this issue as the working issue for the recent regression of this bug.
          Will link all new issues here as dupes

          mei blackheart Courtney Canton added a comment - - edited

          Hi, resident of NN City here, and the bug is present at this sim as well when using the 4.1.1.28744 Firestorm viewer. Reported it to the sim owner, who had not updated her Firestorm yet. I use the Mac version. I attached the photo to this page taken at NN City.

          whirly.fizzle Whirly Fizzle added a comment - - edited

          If you would also like to see this bug fixed in Viewer 3, so V3 users also see your water levels correctly, please also comment on https://jira.secondlife.com/browse/MAINT-682

          crystalcat silverweb Kathleen Pettigrew added a comment -

          shot of border that shows in new firestorm viewer but not new phoenix viewer

          crystalcat silverweb Kathleen Pettigrew added a comment -

          sim water level different from area only in new firestorm, not in new phoenix... attached pic below "border edge - sunset escape". also messes up levels for offshore waves.

          whirly.fizzle Whirly Fizzle added a comment -
          justjinx mischievous jinx added a comment -

          We have this exact same issue that was reported by alot of our residents. We first thought it was a server issue. Any eta on when since LL has fixed this issue that a viewer issue will be pushed ?

          whirly.fizzle Whirly Fizzle added a comment -

          Hiya Mischievous,

          LL only have this fix in their development viewer atm as far as I know, its not made it into their beta viewer even yet.
          Im unable to say exactly when the next Firestorm release will be yet (which will have it refixed) but it shouldnt be too far away, as a pathfinding enabled release will need to be out fairly soon.

          toov.zadark Toov Zadark added a comment -

          My isloated “island” sim has its water level at 15 m, has had since february. I have always used only Firestorm in that period. What I learned is that, when you change the sim water level from what’s in the surrounding ocean, this effect shows — but only till you tp away and back or relog: When you back, the outside ocean is at the same level as the modified in-sim water.

          Except in this newest version of Firestorm (v. 4.1.1.28744), it is permanent. It looks like a bug: things like shadows, ambient lighting, and reflections show correct for the changed water level (15 m, in this case), but the water level itself shows at the default height (20 m).

          However, I just tried with the beta, which I had been useg before (v. 2.5.2.0), and the same error appears, in the same exatc conditions as with v. 4.1.1 and unlike its previous behaviour.

          I’m thinking this is LL’s fault. (It cannot be my sim, as so many ppl are complaining about the same.)

          whirly.fizzle Whirly Fizzle added a comment -

          This is fixed now on LL release.
          This really needs to be inline with V3 for the 4.2.0 release.

          tonya Tonya Souther added a comment -

            People

            • Assignee:
              tonya Tonya Souther
              Reporter:
              naughtyprincess milneaux NP Milneaux
            • Votes:
              7 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: