Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-13997

[Interesting-Merge] Derender functionality broken for world objects (temporary and blacklist) after Project Interesting merge

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 4.6.6, Phoenix Firestorm 4.6.7
    • Fix Version/s: Phoenix Firestorm 4.6.8
    • Component/s: Rendering
    • Environment:
    • SL Avatar Name:
      Jaerik
    • Reported In:
      Firestorm 4.6.6

      Description

      I know it is early after the Project Interesting merge but thought i would bring it to your attention in case it hasn't been noticed yet.

      If using either temporary or blacklist derender on an object inworld (not an avatar or avatar attachment) the object disappears as expected but reappears a couple of seconds later every time. This reproduces on my iMac as well as my other computer that has Windows 8.1 on it.

      I noticed that some of the other TPVs that merged Project Interesting a while back that also have derender functionality are also exhibiting the same behavior for both temporary and blacklist derender. Haven't seen a patch that has been publicly pushed by any of them yet that fixes the issue.

      1. derender.diff
        2 kB
        Whirly Fizzle

        Issue Links

          Activity

          whirly.fizzle Whirly Fizzle added a comment - - edited

          Confirmed that the interesting merge has broken derender but I am seeing different behaviour to reported here on Firestorm 4.6.6 (42152) Jun 11 2014 18:31:42 (Firestorm-FizzlefireAVX) with OpenSimulator support

          • Temporary derender does not work at all on rezzed objects - the objects disappear and pop back a second later.
          • Temporary derender works on avatars.
          • Blacklist derender works for me on objects - the objects are added to the blacklist and remain derendered.
          • Removing blacklisted objects from the asset blacklist, changing group tag and moving camera does not rerender the objects, which it should.
            Teleporting to another region and back rerenders the objects.

          Testing system:

          Firestorm 4.6.6 (42152) Jun 11 2014 18:31:42 (Firestorm-FizzlefireAVX) with OpenSimulator support
          Release Notes
          
          You are at 100.0, 97.3, 22.2 in Testylvania Sandbox located at sim7259.agni.lindenlab.com (216.82.34.7:12035)
          SLURL: http://maps.secondlife.com/secondlife/Testylvania%20Sandbox/100/97/22
          (global coordinates 332,644.0, 306,273.0, 22.2)
          Second Life Server 14.06.04.290645
          Release Notes
          
          CPU: Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz (3491.91 MHz)
          Memory: 16268 MB
          OS Version: Microsoft Windows 7 64-bit Service Pack 1 (Build 7601)
          Graphics Card Vendor: NVIDIA Corporation
          Graphics Card: GeForce GTX 750/PCIe/SSE2
          
          Windows Graphics Driver Version: 9.18.0013.3788
          OpenGL Version: 4.4.0
          
          RestrainedLove API: (disabled)
          libcurl Version: libcurl/7.24.0 OpenSSL/1.0.1h zlib/1.2.6 c-ares/1.10.0
          J2C Decoder Version: KDU v7.4
          Audio Driver Version: FMOD Ex 4.44.32
          Qt Webkit Version: 4.7.1 (version number hard-coded)
          Voice Server Version: Vivox 4.6.0009.20030
          
          Settings mode: Hybrid
          Viewer Skin: Firestorm (CtrlAltStudio)
          Font Used: Deja Vu (96)
          Draw distance: 128
          Bandwidth: 1200
          LOD factor: 2
          Render quality: Medium-High (4/7)
          Texture memory: 512 MB (1)
          VFS (cache) creation time (UTC): 2014-5-11T19:19:2 
          Built with MSVC version 1600
          Packets Lost: 0/0 (-1.0%)
          
          jaerik Jaerik added a comment -

          I wonder if there are certain kinds of objects that stay derendered via blacklist. Just logged in again and wandered all around trying to blacklist derender everything in sight and all of the objects kept popping back after being blacklisted.

          whirly.fizzle Whirly Fizzle added a comment -

          Very possibly. I only checked this really quickly (lots of bugs after interesting merge!) and the prims I tested derendering were just default cubes freshly rezzed.
          Will test this more thoughroughly when Im caught up.

          nickyd Nicky added a comment -
          jaerik Jaerik added a comment - - edited

          Things are looking good now when it comes to objects staying dead after being derendered but there are some remaining issues.

          1.) When an object is blacklisted, it re-renders again after a relog even while still showing in the asset blacklist.

          2.) When an object was blacklisted, removing the item from the blacklist does not re-render the object. Not even teleporting out and back re-renders the object. Only a relog will bring it back.

          3.) For temporary derender, there is no way to bring the object back to be seen without a relog. Teleporting out and back again, changing group tag or draw distance etc no longer work.

          whirly.fizzle Whirly Fizzle added a comment -

          Testing on Firestorm 4.6.6 (42167) Jun 13 2014 00:54:59 (Firestorm-FizzlefireAVX) with OpenSimulator support

          1.) When an object is blacklisted, it re-renders again after a relog even while still showing in the asset blacklist.

          Hmm I cant reproduce this.
          Does this happen with any object at all or just certain ones? Does it reproduce with just a default cube?
          I tried blacklisting and then relogging to the same region and blacklisting and relogging to a different region and TPing back to the region where I had derendered objects and blacklisting, teleporting to a different region and then relogging to the region I had blacklisted objects.

          2.) When an object was blacklisted, removing the item from the blacklist does not re-render the object. Not even teleporting out and back re-renders the object. Only a relog will bring it back.

          Confirmed that when an object is removed from the blacklist, the usual method to get it to rerender do not work, which is:

          • Remove object from blacklist.
          • Change active group tag.
          • Zoom or move camera a bit.

          However this does work for me:

          • Remove object from blacklist
          • Change group tag (possibly not needed)
          • TP to another region (only tested so far TPing to a region I wasnt a child agent on when removing from blacklist)
          • TP back

          3.) For temporary derender, there is no way to bring the object back to be seen without a relog. Teleporting out and back again, changing group tag or draw distance etc no longer work.

          Temp derender is now working for me.
          Confirmed that changing group tag and waggling camera do not re-render a temp derendered object
          Confirmed that TPing to another region and back do not re-render a temp derendered object (Strange! This works for me when removing from the blacklist!)
          Relogging brings back temp derendered objects.

          Testing system:

          Firestorm 4.6.6 (42167) Jun 13 2014 00:54:59 (Firestorm-FizzlefireAVX) with OpenSimulator support
          Release Notes
          
          You are at 115.0, 94.0, 21.6 in Testylvania Sandbox located at sim7259.agni.lindenlab.com (216.82.34.7:12035)
          SLURL: http://maps.secondlife.com/secondlife/Testylvania%20Sandbox/115/94/22
          (global coordinates 332,659.0, 306,270.0, 21.6)
          Second Life Server 14.06.04.290645
          Release Notes
          
          CPU: Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz (3491.91 MHz)
          Memory: 16268 MB
          OS Version: Microsoft Windows 7 64-bit Service Pack 1 (Build 7601)
          Graphics Card Vendor: NVIDIA Corporation
          Graphics Card: GeForce GTX 750/PCIe/SSE2
          
          Windows Graphics Driver Version: 9.18.0013.3788
          OpenGL Version: 4.4.0
          
          RestrainedLove API: (disabled)
          libcurl Version: libcurl/7.24.0 OpenSSL/1.0.1h zlib/1.2.6 c-ares/1.10.0
          J2C Decoder Version: KDU v7.4
          Audio Driver Version: FMOD Ex 4.44.32
          Qt Webkit Version: 4.7.1 (version number hard-coded)
          Voice Server Version: Vivox 4.6.0009.20030
          
          Settings mode: Hybrid
          Viewer Skin: Firestorm (CtrlAltStudio)
          Font Used: Deja Vu (96)
          Draw distance: 184
          Bandwidth: 1550
          LOD factor: 2
          Render quality: High (5/7)
          Texture memory: 512 MB (1)
          VFS (cache) creation time (UTC): 2014-5-11T23:20:48 
          Built with MSVC version 1600
          Packets Lost: 0/1 (0.0%)
          
          whirly.fizzle Whirly Fizzle added a comment -

          Im going to reopen this issue so it doesnt fall off the "to do" list yet.
          We can file new issues once we know whats what and what changes to behaviour are expected etc - maybe temp derender will need a relog now? Not sure.....

          jaerik Jaerik added a comment - - edited

          All of my testing and results that i posted here were in regards to items already found inworld, and not default freshly rezzed cubes. The kinds of items i did the tests on were what are commonly found inworld, such as multiprim items, sculps, mesh, etc etc. I also tested each scenario a few times before posting the results here as well.

          Since you might have been testing with only default freshly rezzed cubes, i went ahead and tested with some cubes to see if the results are any different. They are. This might explain why you have been getting different results than me from what i can tell. I am experiencing the same results that i posted before when using random items found already inworld, multi prim items, sculpts, mesh, etc. And my results seem the same as yours only when using a freshly rezzed default cube.

          jaerik Jaerik added a comment - - edited

          I just did a new controlled test using 3 specific objects at a sandbox. Here are the items i used for the test.

          Item #1 - a sculpted couch - 2 prims - already at the sandbox on arrival
          Item #2 - a simple 3 prim linked set of stairs - already at the sandbox on arrival
          Item #3 - a freshly rezzed default cube that i placed on the ground

          Test phase 1 - See if blacklist derendered items appeared after a relog. Using the pie menu i selected the blacklist option for derender on all three items then relogged.

          Results - The sculpted couch and the simple prim stairs were visible after relog. The default cube still remained derendered. I checked the asset blacklist and all three items were still listed but only the cube remained derendered.

          Test phase 2 - Blacklist derender the objects then remove them from the blacklist and see if items can be made visible again. I cleaned out my asset blacklist, relogged, then derendered each item again via the pie menu with blacklist, removed them from the blacklist, and then attempted all tricks to see if the items could be made visible again by changing group tag, zooming camera, lowering then raising draw distance, then teleporting out then back again.

          Results - The sculpted couch and the simple prim stairs were not visible after all steps performed. The default cube was the only item that became visible again.

          nickyd Nicky added a comment -

          I have some code for later which will clear the derender list on teleports. Which should bring temporary derendered items back when TP out/in again.
          That won't solve the issues with the blacklist yet

          whirly.fizzle Whirly Fizzle added a comment -

          Jaerik

          Okay I can reproduce certain objects that are blacklisted rerendering after a relog.
          Its strange though, some very prim heavy complicated builds stay derendered but some fairly simple low prim builds do not stay derendered.

          I have not tested Nicky's patch she mentioned yet, Im about to do this now.
          I'll attach the patch to this issue so you can test it too - derender.diff

          jaerik Jaerik added a comment - - edited

          I gave that patch a thorough testing after applying it to current tip 42225:ed1c6dfa2a8a. The results were very inconsistent, with objects not coming back after being temporarily derendered then teleport out/in the majority of times. Sometimes they did become visible again but those times were in the minority. Here is a set of steps that i followed that caused failures for the objects to be visible again almost every time after a teleport out/in.

          1.) Logged directly into Hippotropolis from the login screen
          2.) Temporarily derendered a few of the trees directly ahead.
          3.) Opened the world map and teleported directly to the Aqua region
          4.) After landing i turned to the right and derendered a few pieces of the railing near the water and the gold colored statue right above.
          5.) Pressed the "back" button on the navigation bar to return to Hippotropolis
          6/) Observed the trees that i temporarily derendered earlier were still not visible.
          7.) Pressed the "forward" button on the navigation bar to return to Aqua
          8.) Observed that the pieces of railing and the gold colored statue that i temporarily derendered were still not visible.

          nickyd Nicky added a comment -

          There has not happened anything public regarding this so far, Interesting enough I found out, that even resetting the items in llviewerobjectlist when teleporting away, items still would not re appear when going back to where one started.

          whirly.fizzle Whirly Fizzle added a comment -

          Ref: changeset 42233 - http://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/0a68fd93abcb
          Purge list for (temporary) derender each TP. Which in theory should bring temp. derendered items back after TP. In practice this alone does not work reliable all the time yet.

          elke Elke Wylie added a comment -

          i am not sure it depends on it, but restoring the asset blacklist does not work. i did a restore of my blacklist from 4.6.5.40833 in 4.6.6.42350 and saw all my derendered objects in the list, but the viewer did show all inworld.

          i cleared the list in 42350 then and derendered the objects again, after that the viewer did not show them.

          now with 4.6.7.42368 all happens again, all objects are still in the list but i can see them all inworld.

          whirly.fizzle Whirly Fizzle added a comment -

          Thanks Elke.
          Thats a good test for us to use once this issue is in QA.

          rsiamendes Robert0 Siamendes added a comment -

          same results for me. All in asset blacklist but still shows. I just did a test with just derendering just only a few objects but still the same.

          Firestorm 4.6.7 (42396) Aug 3 2014 14:01:45 (Firestorm-Releasex64) with OpenSimulator support
          Release Notes

          You are at 240.3, 82.6, 22.1 in Pruetti located at sim10344.agni.lindenlab.com (216.82.50.66:13009)
          SLURL: http://maps.secondlife.com/secondlife/Pruetti/240/83/22
          (global coordinates 259,568.0, 259,923.0, 22.1)
          Second Life RC LeTigre 14.08.01.292564
          Release Notes

          CPU: Intel(R) Core(TM) i7 CPU Q 740 @ 1.73GHz (1729.07 MHz)
          Memory: 6133 MB
          OS Version: Microsoft Windows 7 64-bit Service Pack 1 (Build 7601)
          Graphics Card Vendor: ATI Technologies Inc.
          Graphics Card: ATI Mobility Radeon HD 4650

          Windows Graphics Driver Version: 8.97.100.11-130429a-158498C-ATI
          OpenGL Version: 3.3.11672 Compatibility Profile Context

          RestrainedLove API: RLV v2.8.0 / RLVa v1.4.10a
          libcurl Version: libcurl/7.24.0 OpenSSL/1.0.1h zlib/1.2.6 c-ares/1.10.0
          J2C Decoder Version: KDU v7.4
          Audio Driver Version: FMOD Ex 4.44.32
          Qt Webkit Version: 4.7.1 (version number hard-coded)
          Voice Server Version: Vivox 4.6.0009.20030

          Settings mode: Firestorm
          Viewer Skin: StarLight CUI (Custom Dark)
          Font Used: Deja Vu (96)
          Draw distance: 128
          Bandwidth: 1250
          LOD factor: 2
          Render quality: Medium (3/7)
          Texture memory: 512 MB (1)
          VFS (cache) creation time (UTC): 2014-8-9T20:24:43
          Built with MSVC version 1600
          Packets Lost: 1/6,405 (0.0)

          whirly.fizzle Whirly Fizzle added a comment -

          Testing on Firestorm 4.6.8 (42499) Aug 3 2014 18:30:26 (Firestorm-FizzlefireAVX) with OpenSimulator support plus Blacklist.diff

          • Temp derendering a few avatars -> Teleport to a different region -> Teleport back
            Most avatars are re-rendered, but not all.
            Post-interesting, I think we have to accept that temp derendered avatars/objects will not always rerender after group tag change/moving cam &/or teleport to another region and back.
            A relog will be needed.
          • Blacklisting a few avatars -> Teleport to a different region -> Teleport back
            All avatars appear to stay derendered.
          • After relogging, blacklisted avatars are still derendered.
          • After removing blacklisted avatars from the blacklist, changing group tag and moving camera, all blacklisted avatars were rerendered.
          • Temp derendering a few objects -> Teleport to a different region -> Teleport back
            Some objects are rerendered, some are not.
          • After temp derendering objects &/or avatars, changing group tag and moving cam no longer appears to ever bring back the derendered objects/avatars.
          • Relogging always works to rerender temp derendered objects and avatars.
          • Blacklisting some objects -> Teleporting to a different region -> Teleporting back
            Not all objects remain derendered
            After relogging into the region, usually all the blacklisted objects are derendered but after a TP to another region and back, most objects will be rerendered again.
          whirly.fizzle Whirly Fizzle added a comment -

          One pattern that is very reproducible:

          • Go to Region A
          • Blacklist a lot of objects on Region A - everything will derender as expected.
          • TP to Region B
          • Blacklist a lot of objects on Region B - everything will derender as expected.
          • TP back to Region A - several blacklisted objects will be rerendered,
          • Relog to Region A
          • After a relog, all blacklisted objects on the region you login to will be derendered - havnt had this fail yet.
          • TP to Region B
          • TP back to Region A
          • Most objects will be rerendered on Region A

          So the blacklist appears to work correctly for the region you login to but after teleporting elsewhere and back, a large number of blacklisted objects on the region will be rerendered.

          fillediscover braveheart FilleDiscover Braveheart added a comment -

          In addition I don't know which is the expected behaviour as it's specify in the documentation : http://wiki.phoenixviewer.com/fs_derender, To rerender an object: Simply change your active group tag, or teleport out of the region, and then back. See the OR not a AND between the elements) I see that cases only tested in temporary derender, I try in both in 4.6.7.42469 and in 4.6.8.42496 unable to try in 4.6.5.40833 :
          Case A

          • I create a cube in Region A
          • I derender temporary the cube
          • I tp in Region B
          • I tp back to the Region A
          • I can't show the derendered cube (unexpected)
            Case B
          • I create a cube in region A
          • I derender temporary the cube
          • I change my group tag
          • I can't show the derendered cube (unexpected)
            Case C
          • I create a cube in Region A
          • I derender the cube
          • I change my group tag
          • I tp in Region B
          • I tp back in Region A
          • I can show the cube (as expected)
            Case D
          • I create a cube in Region A
          • I derender temporary the cube
          • I logged out
          • I logged in
          • I can show the cube (as expected)
          whirly.fizzle Whirly Fizzle added a comment -

          Pushed this to 4.6.8. Its as fixed as its going to be for the 4.6.7 release.

          willow wilder Willow Wilder added a comment - - edited

          Workaround removed. Still too flaky.

          hugsalot HUGSaLOT Valkyrie added a comment -

          on 4.6.7.42398 objects that are derendered (temp or blacklist) remain derendered for the entire session, even after teleporting, and changing group tags. Only a relog will let temp-derender reappear but blacklisted ones will remain derendered. If you remove an object from the black list you still need to relog again for that object to appear.

          katydid katydid62 resident added a comment -

          temp derender is very inconsistent in rerendering. in testing i've found that it sometimes requires a relog to get temp derendered items back. in some cases after several teleports and group tag changes temp derendered objects will come back. Another odd one, which is fairly reliable for me, is: 1) go to region A, derender several objects 2) Change group tag, tp away and back, observe that the object do not reappear with those steps. 3) tp to a different region, and temp derender several objects there; 4) return to the first region, observe that the previously temp derendered objects that didn't come back before now appear.

          mcgregorkam Keith McGregor added a comment - - edited

          For me, as of 26-Aug-2014 version 4.6.7.42398, the blacklist is very broken. My neighbor has a virtual junkyard on her land (over 380 objects). I blacklisted most of them a couple days ago. If I initially log in to my land next to hers, they are all derendered. as soon as I TP anywhere, including just to my skybox, then TP back down, all of her objects are fully rendered.

          The only way for me to derender them again is to completely log out and log back in and never TP anywhere. I do hope this gets fixed in the next release.

          rsiamendes Robert0 Siamendes added a comment -

          Blacklist working on 4.6.8 (42562) so far.

          rsiamendes Robert0 Siamendes added a comment -

          Update: I tp'd back and it rendered again but upon login, the objects are derendered. Ugh, still borked.

          zin Marjorie Sutcliffe added a comment -

          With every new update there is a new problem.

          Rosie1469 Patricia Sugel added a comment -

          I blacklist objects like tress and waterfalls from the sim I live/rp on due to lag issues with the scripts. I have to blacklist these objects everytime I love into sl now.

          panster Panster Moonshadow added a comment -

          Blacklisted objects reappear for me every time I enter this sim. I don't normally blacklist, but this particular sim is very laggy, so the problem exists on my computer:
          Firestorm 4.6.7 (42398) Aug 12 2014 02:06:18 (Firestorm-Releasex64) with OpenSimulator support
          Release Notes

          You are at 126.2, 139.9, 23.0 in Krafties located at sim10393.agni.lindenlab.com (216.82.51.43:13011)
          SLURL: http://maps.secondlife.com/secondlife/Krafties/126/140/23
          (global coordinates 247,166.0, 326,028.0, 23.0)
          Second Life Server 14.09.05.293778
          Release Notes

          CPU: Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz (3392.14 MHz)
          Memory: 32677 MB
          OS Version: Microsoft Windows 8.1 64-bit (Build 9600)
          Graphics Card Vendor: NVIDIA Corporation
          Graphics Card: GeForce GTX 760 (192-bit)/PCIe/SSE2

          Windows Graphics Driver Version: 9.18.0013.4052
          OpenGL Version: 4.4.0

          RestrainedLove API: (disabled)
          libcurl Version: libcurl/7.24.0 OpenSSL/1.0.1h zlib/1.2.6 c-ares/1.10.0
          J2C Decoder Version: KDU v7.4
          Audio Driver Version: FMOD Ex 4.44.32
          Qt Webkit Version: 4.7.1 (version number hard-coded)
          Voice Server Version: Vivox 4.6.0009.20030

          Settings mode: Firestorm
          Viewer Skin: Firestorm (Grey)
          Font Used: Deja Vu (96)
          Draw distance: 256
          Bandwidth: 500
          LOD factor: 4
          Render quality: High (5/7)
          Texture memory: 512 MB (1)
          VFS (cache) creation time (UTC): unknown
          Built with MSVC version 1600
          Packets Lost: 41/311,072 (0.0%)

          sonofanoob SonofaNoob added a comment -

          Hi. I have been wanting to report these problems for a while. I think the problems appeared for me after installing (a clean install) Firestorm 4.6.7 (42398). I'm glad to see that other people have already created a JIRA for it.

          This is what I am experiencing:

          1.) If I permanently derender objects on my sim and teleport to another sim and back, or if I log out and back in, the permanently derender objects reappear on my sim. I can go to the blacklist and see that the objects are still listed, but they are not hidden on the sim like I want them to be. If I remember correctly, if I premanently derender them a second or third time, it just makes extra copies of the same listings in the blacklist.

          2.) Also, If I temporary derender objects and then try to make the objects reappear by changing my group tag etc., the temporary derendered objects will not reappear. The only way to make the temporary derendered objects reappear is to log out and back in.

          I'm sorry. I didn't read anyone else's comments. I probably just repeated what others said, and there is probably already a fix in an upcoming version. I don't install BETA versions, so I will just wait till the next official Firestorm version to enjoy that fix. I really appreciate the Firestorm viewer and team. You guys are wonderful! Thanks for everything!!!

          whirly.fizzle Whirly Fizzle added a comment -

          Fixed rev 42813
          http://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/ab64f1390f14

          Fix seems good!
          Resolving this to go to QA.

          Note that when objects are removed from the blacklist, a relog will be necessary to rerender those objects.

          willow wilder Willow Wilder added a comment -

          Same observations as Whirly. Thank you!
          Using Firestorm 4.6.8 (42818) Oct 14 2014 14:26:07 (Firestorm-nightlyx64) with OpenSimulator support

          domitan redenblack Domitan Redenblack added a comment -

          Yes, confirmed fix on Mac OSX version of 4.6.9.42969


            People

            • Assignee:
              nickyd Nicky
              Reporter:
              jaerik Jaerik
            • Votes:
              3 Vote for this issue
              Watchers:
              19 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: