Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-14265

[CRASH] Blacklist + TP = Crash - msvcr100.dll!_aligned_free(void * memblock), FirestormOS-FizzlefireAVX.exe!LLVolumeFace::freeData() Line 4756 C++

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 4.6.8, Phoenix Firestorm 4.6.9, Phoenix Firestorm 4.7.0, Phoenix Firestorm 4.7.1, Phoenix Firestorm 4.7.2, Phoenix Firestorm 4.7.3, Phoenix Firestorm 4.7.4
    • Fix Version/s: Phoenix Firestorm 4.7.10
    • Component/s: Crashes
    • Labels:
    • Environment:
    • SL Avatar Name:
      Whirly Fizzle
    • Reported In:
      Firestorm 4.6.8

      Description

      Had this crash twice now after performing roughly the same actions.
      Both crashes were on Firestorm 4.6.8 (42451) Aug 1 2014 01:52:36 (Firestorm-FizzlefireAVX) with OpenSimulator support plus Nickys blacklist.diff - unsure if the patch is connected to the crashes. Its not, crash repros on the RC

      I logged in, temp derendered some things, changed group tag and teleported to another region.
      The first crash was just after landing on the new region.
      The second crash was as soon as I clicked the telport button, but looking at my logs it showed I had actually got to the destination region.
      Both crashes had the same callstack.

      Callstack:

      >	msvcr100.dll!_aligned_free(void * memblock)  Line 472	C
       	FirestormOS-FizzlefireAVX.exe!LLVolumeFace::freeData()  Line 4756	C++
       	FirestormOS-FizzlefireAVX.exe!LLVolumeFace::~LLVolumeFace()  Line 4737 + 0x8 bytes	C++
       	FirestormOS-FizzlefireAVX.exe!std::_Destroy_range<std::allocator<LLVolumeFace> >(LLVolumeFace * _First, LLVolumeFace * _Last, std::allocator<LLVolumeFace> & _Al, std::_Nonscalar_ptr_iterator_tag __formal)  Line 97 + 0x8 bytes	C++
       	FirestormOS-FizzlefireAVX.exe!LLVolume::~LLVolume()  Line 2153 + 0x40 bytes	C++
       	FirestormOS-FizzlefireAVX.exe!LLRiggedVolume::`scalar deleting destructor'()  + 0x14 bytes	C++
       	FirestormOS-FizzlefireAVX.exe!LLPointer<LLVolume>::unref()  Line 156 + 0x1f bytes	C++
       	FirestormOS-FizzlefireAVX.exe!`eh vector destructor iterator'(void * ptr, unsigned __int64 size, int count, void (void *)* pDtor)  + 0x49 bytes	C++
       	FirestormOS-FizzlefireAVX.exe!LLVolumeLODGroup::~LLVolumeLODGroup()  Line 265 + 0x17 bytes	C++
       	FirestormOS-FizzlefireAVX.exe!LLVolumeMgr::unrefVolume(LLVolume * volumep)  Line 165 + 0x8 bytes	C++
       	FirestormOS-FizzlefireAVX.exe!LLPrimitive::~LLPrimitive()  Line 192	C++
       	FirestormOS-FizzlefireAVX.exe!LLVOVolume::`scalar deleting destructor'()  + 0x14 bytes	C++
       	FirestormOS-FizzlefireAVX.exe!LLPointer<LLViewerObject>::unref()  Line 156 + 0x26 bytes	C++
       	FirestormOS-FizzlefireAVX.exe!LLViewerObjectList::cleanDeadObjects(int use_timer)  Line 1538 + 0x13 bytes	C++
       	FirestormOS-FizzlefireAVX.exe!LLAppViewer::idle()  Line 5756 + 0x11 bytes	C++
       	FirestormOS-FizzlefireAVX.exe!LLAppViewer::mainLoop()  Line 1665	C++
       	FirestormOS-FizzlefireAVX.exe!WinMain(HINSTANCE__ * hInstance, HINSTANCE__ * hPrevInstance, char * lpCmdLine, int nCmdShow)  Line 328	C++
       	FirestormOS-FizzlefireAVX.exe!__tmainCRTStartup()  Line 547 + 0x25 bytes	C
       	kernel32.dll!BaseThreadInitThunk()  + 0xd bytes	
       	ntdll.dll!RtlUserThreadStart()  + 0x21 bytes	
      
      1. Firestorm.log
        189 kB
        Whirly Fizzle
      2. Whirly_2.log
        460 kB
        Whirly Fizzle
      3. Whirly_4.log
        366 kB
        Whirly Fizzle

        Issue Links

          Activity

          whirly.fizzle Whirly Fizzle added a comment -

          See Whirly_2.log when I repeated the same steps - I did not crash during or after TP but the viewer hung for a loooong time during teleport and check log from line 3070 - there are lots of lines "newview/llviewerobjectlist.cpp(2383) : 2014-08-01T21:10:30Z INFO: LLViewerObjectList::findOrphans: Missing orphan child, removing from list" which corresponded to where the viewer was hanging.

          whirly.fizzle Whirly Fizzle added a comment - - edited

          Crash also reproduces on beta testers build Firestorm 4.6.7 (42390) Jul 25 2014 20:37:03 (Firestorm-Releasex64) with OpenSimulator support
          Logs from that build attached: Whirly_3.zip

          Callstack:

          Operating system: Windows NT
                            6.1.7601 Service Pack 1
          CPU: amd64
               family 6 model 60 stepping 3
               8 CPUs
          
          Crash reason:  EXCEPTION_ACCESS_VIOLATION_READ
          Crash address: 0xfffffff8
          Assertion: Unknown assertion type 0x00000000
          
          Thread 0 (crashed)
           0  msvcr100.dll + 0x68fad
              rbx = 0x00000000616cca30   r12 = 0x0000000140e09943
              r13 = 0x0000000140eb4a18   r14 = 0x00000001417a5528
              r15 = 0x0000000003497300   rip = 0x000000006dd78fad
              rsp = 0x0000000000b9f220   rbp = 0x0000000000000000
              Found by: given as instruction pointer in context
           1  Firestorm-bin.exe!LLVolumeFace::freeData() [llvolume.cpp : 4753 + 0x10]
              rip = 0x00000001407a357e   rsp = 0x0000000000b9f250
              Found by: stack scanning
           2  Firestorm-bin.exe!LLVolumeFace::~LLVolumeFace() [llvolume.cpp : 4737 + 0x7]
              rip = 0x00000001407a8db3   rsp = 0x0000000000b9f280
              Found by: call frame info
           3  Firestorm-bin.exe!std::_Destroy_range<std::allocator<LLVolumeFace> >(LLVolumeFace *,LLVolumeFace *,std::allocator<LLVolumeFace> &,std::_Nonscalar_ptr_iterator_tag) [xmemory : 97 + 0x7]
              rip = 0x00000001404dddfd   rsp = 0x0000000000b9f2c0
              Found by: call frame info
           4  Firestorm-bin.exe!LLVolume::~LLVolume() [llvolume.cpp : 2153 + 0x3f]
              rip = 0x00000001407aeca0   rsp = 0x0000000000b9f2f0
              Found by: call frame info
           5  Firestorm-bin.exe!LLVolume::`scalar deleting destructor'(unsigned int) + 0x13
              rip = 0x00000001402b6e14   rsp = 0x0000000000b9f330
              Found by: call frame info
           6  Firestorm-bin.exe!LLPointer<LLVolume>::unref() [llpointer.h : 156 + 0x1e]
              rip = 0x000000013fa6f2b5   rsp = 0x0000000000b9f360
              Found by: call frame info
           7  Firestorm-bin.exe!LLPrimitive::~LLPrimitive() [llprimitive.cpp : 192 + 0x1e]
              rip = 0x00000001404d87c2   rsp = 0x0000000000b9f3f0
              Found by: call frame info
           8  Firestorm-bin.exe!LLVOVolume::`scalar deleting destructor'(unsigned int) + 0x13
              rip = 0x00000001402c1b54   rsp = 0x0000000000b9f430
              Found by: call frame info
           9  Firestorm-bin.exe!LLPointer<LLViewerObject>::unref() [llpointer.h : 156 + 0x25]
              rip = 0x000000013f8497ec   rsp = 0x0000000000b9f460
              Found by: call frame info
          10  Firestorm-bin.exe!LLViewerObjectList::cleanDeadObjects(int) [llviewerobjectlist.cpp : 1538 + 0x12]
              rip = 0x000000014018a8d3   rsp = 0x0000000000b9f4f0
              Found by: call frame info
          11  Firestorm-bin.exe!LLAppViewer::idle() [llappviewer.cpp : 5756 + 0x10]
              rip = 0x000000013f8bca80   rsp = 0x0000000000b9f540
              Found by: call frame info
          12  Firestorm-bin.exe!LLAppViewer::mainLoop() [llappviewer.cpp : 1663 + 0x7]
              rip = 0x000000013f8be6b0   rsp = 0x0000000000b9f6c0
              Found by: call frame info
          13  Firestorm-bin.exe!WinMain [llappviewerwin32.cpp : 325 + 0x8]
              rip = 0x00000001403cd094   rsp = 0x0000000000b9fcb0
              Found by: call frame info
          14  Firestorm-bin.exe!__tmainCRTStartup [crtexe.c : 547 + 0x24]
              rip = 0x0000000140a6bf6b   rsp = 0x0000000000b9fd50
              Found by: call frame info
          15  kernel32.dll + 0x159ec
              rip = 0x00000000770059ed   rsp = 0x0000000000b9fe00
              Found by: call frame info
          16  ntdll.dll + 0x2c540
              rip = 0x000000007723c541   rsp = 0x0000000000b9fe30
              Found by: stack scanning
          17  kernel32.dll + 0x9b7df
              rip = 0x000000007708b7e0   rsp = 0x0000000000b9fe58
              Found by: stack scanning
          18  kernel32.dll + 0x9b7df
              rip = 0x000000007708b7e0   rsp = 0x0000000000b9fe60
              Found by: stack scanning
          
          miro.collas Miro Collas added a comment -

          Tested on 4.6.7.42396 - linux 64-bit. Derendered 3 mesh items, changed group tag, TPed, no crash. Log shows no "Missing orphan child".

          animorf kawadias stephanie turner added a comment -

          Firestorm 4.6.7 (42396) Aug 3 2014 11:15:12 (Firestorm-Release) with Havok support
          Release Notes

          You are at 99.1, 111.0, 28.8 in Asian Treasures located at sim9685.agni.lindenlab.com (216.82.45.19:13014)
          SLURL: http://maps.secondlife.com/secondlife/Asian%20Treasures/99/111/29
          (global coordinates 249,955.0, 316,527.0, 28.8)
          Second Life Server 14.07.18.292162
          Release Notes

          CPU: Intel(R) Core(TM) i5-3330 CPU @ 3.00GHz (3000.05 MHz)
          Memory: 8143 MB
          OS Version: Microsoft Windows 7 64-bit Service Pack 1 (Build 7601)
          Graphics Card Vendor: NVIDIA Corporation
          Graphics Card: GeForce GTX 650 Ti BOOST/PCIe/SSE2

          Windows Graphics Driver Version: 9.18.0013.4052
          OpenGL Version: 4.4.0

          RestrainedLove API: RLV v2.8.0 / RLVa v1.4.10a
          libcurl Version: libcurl/7.24.0 OpenSSL/1.0.1h zlib/1.2.5 c-ares/1.10.0
          J2C Decoder Version: KDU v7.4
          Audio Driver Version: FMOD Ex 4.44.32
          Qt Webkit Version: 4.7.1 (version number hard-coded)
          Voice Server Version: Vivox 4.6.0009.20030

          Settings mode: Firestorm
          Viewer Skin: StarLight (Nostalgia Blue)
          Font Used: Deja Vu (96)
          Draw distance: 128
          Bandwidth: 100
          LOD factor: 2
          Render quality: Medium-High (4/7)
          Texture memory: 512 MB (1)
          VFS (cache) creation time (UTC): 2014-7-19T19:50:9
          Built with MSVC version 1600
          Packets Lost: 5/43,614 (0.0%)

          I tried this on the current beta, and and went to two different regions. even activated different groups and could not reproduce, even on this cellular connection I am using through my iPhone. and am seeing a lot of this in my logs.

          newview/llvoicevivox.cpp(3243) : 2014-08-11T00:21:21Z WARNING: LLVivoxVoiceClient::mediaStreamUpdatedEvent: unknown state 6
          newview/llviewerdisplay.cpp(234) : 2014-08-11T00:21:29Z INFO: display_stats: FPS: 18.20
          newview/llvoicevivox.cpp(2748) : 2014-08-11T00:21:39Z INFO: LLVivoxVoiceClient::sessionCreateResponse: Session.Create response received (success), session handle is 4383
          newview/llvoicevivox.cpp(6951) : 2014-08-11T00:21:39Z WARNING: LLVivoxProtocolParser::processResponse: Unknown event type SessionGroupUpdatedEvent
          newview/llvoicevivox.cpp(2850) : 2014-08-11T00:21:39Z INFO: LLVivoxVoiceClient::sessionAddedEvent: session sip:confctl-138089371@bhr.vivox.com, alias , name handle 4383
          newview/llvoicevivox.cpp(2983) : 2014-08-11T00:21:39Z INFO: LLVivoxVoiceClient::sessionRemovedEvent: handle 4383
          newview/llviewerdisplay.cpp(234) : 2014-08-11T00:21:39Z INFO: display_stats: FPS: 18.50
          newview/llvoicevivox.cpp(3102) : 2014-08-11T00:21:39Z WARNING: LLVivoxVoiceClient::leftAudioSession: left session 4389 in state stateSessionTerminated
          newview/llviewerdisplay.cpp(234) : 2014-08-11T00:21:49Z INFO: display_stats: FPS: 18.40
          newview/llviewerdisplay.cpp(234) : 2014-08-11T00:21:59Z INFO: display_stats: FPS: 18.20
          newview/llviewerdisplay.cpp(234) : 2014-08-11T00:22:09Z INFO: display_stats: FPS: 28.50

          willow wilder Willow Wilder added a comment -

          No crash using Firestorm 4.6.7 (42396) Aug 3 2014 11:15:12 (Firestorm-Release) with Havok support

          Temp derendered several items, change group tag, TP to another region. Repeated a total of 16 times over 3 different regions.

          whirly.fizzle Whirly Fizzle added a comment -

          SUP-14426 reports that this crash happens for them only if they have highlight transparent enabled, derender some meshes and then teleport.

          whirly.fizzle Whirly Fizzle added a comment - - edited

          Just had this crash again on Firestorm 4.6.8 (42813) Oct 12 2014 22:43:58 (Firestorm-Fizzlefire) with OpenSimulator support

          Logged in, blacklisted a lot of objects on Region A (I blacklisted some by selecting and mass blacklisting).
          TP to Region B, blacklisted a few objects.
          TP back to Region A.
          Crash as soon as TP started.

          >	msvcr100.dll!_aligned_free(void * memblock)  Line 472	C
           	FirestormOS-Fizzlefire.exe!LLVolumeFace::freeData()  Line 4756	C++
           	FirestormOS-Fizzlefire.exe!LLVolumeFace::~LLVolumeFace()  Line 4737 + 0x8 bytes	C++
           	FirestormOS-Fizzlefire.exe!std::_Destroy_range<std::allocator<LLVolumeFace> >(LLVolumeFace * _First, LLVolumeFace * _Last, std::allocator<LLVolumeFace> & _Al, std::_Nonscalar_ptr_iterator_tag __formal)  Line 97 + 0x8 bytes	C++
           	FirestormOS-Fizzlefire.exe!LLVolume::~LLVolume()  Line 2153 + 0x40 bytes	C++
           	FirestormOS-Fizzlefire.exe!LLRiggedVolume::`scalar deleting destructor'()  + 0x14 bytes	C++
           	FirestormOS-Fizzlefire.exe!LLPointer<LLVolume>::unref()  Line 156 + 0x1f bytes	C++
           	FirestormOS-Fizzlefire.exe!`eh vector destructor iterator'(void * ptr, unsigned __int64 size, int count, void (void *)* pDtor)  + 0x49 bytes	C++
           	FirestormOS-Fizzlefire.exe!LLVolumeLODGroup::~LLVolumeLODGroup()  Line 265 + 0x17 bytes	C++
           	FirestormOS-Fizzlefire.exe!LLVolumeMgr::unrefVolume(LLVolume * volumep)  Line 165 + 0x8 bytes	C++
           	FirestormOS-Fizzlefire.exe!LLPrimitive::~LLPrimitive()  Line 192	C++
           	FirestormOS-Fizzlefire.exe!LLVOVolume::`scalar deleting destructor'()  + 0x14 bytes	C++
           	FirestormOS-Fizzlefire.exe!LLPointer<LLViewerObject>::unref()  Line 156 + 0x26 bytes	C++
           	FirestormOS-Fizzlefire.exe!LLViewerObjectList::cleanDeadObjects(int use_timer)  Line 1532 + 0x13 bytes	C++
           	FirestormOS-Fizzlefire.exe!LLAppViewer::idle()  Line 5770 + 0x11 bytes	C++
           	FirestormOS-Fizzlefire.exe!LLAppViewer::mainLoop()  Line 1665	C++
           	FirestormOS-Fizzlefire.exe!WinMain(HINSTANCE__ * hInstance, HINSTANCE__ * hPrevInstance, char * lpCmdLine, int nCmdShow)  Line 329	C++
           	FirestormOS-Fizzlefire.exe!__tmainCRTStartup()  Line 547 + 0x25 bytes	C
           	kernel32.dll!BaseThreadInitThunk()  + 0xd bytes	
           	ntdll.dll!RtlUserThreadStart()  + 0x21 bytes	
          

          Whirly_4.log attached.

          whirly.fizzle Whirly Fizzle added a comment -

          Equinox had this crash on Firestorm 4.6.9 (42969) Dec 3 2014 02:39:01 (Firestorm-Releasex64) with OpenSimulator support
          His logs and stack are on FIRE-15082

          whirly.fizzle Whirly Fizzle added a comment -

          Just reprod the crash on Firestorm 4.7.0 (44866) Jan 25 2015 19:34:20 (Firestorm-Fizzlefire) with OpenSimulator support
          I had temp derendered some trees then approx 20 mins later I TPd out of the region and FS crashed.

          Callstack:

          >	msvcr100.dll!_aligned_free(void * memblock)  Line 472	C
           	FirestormOS-Fizzlefire.exe!LLVolumeFace::freeData()  Line 4756	C++
           	FirestormOS-Fizzlefire.exe!LLVolumeFace::~LLVolumeFace()  Line 4737 + 0x8 bytes	C++
           	FirestormOS-Fizzlefire.exe!std::_Destroy_range<std::allocator<LLVolumeFace> >(LLVolumeFace * _First, LLVolumeFace * _Last, std::allocator<LLVolumeFace> & _Al, std::_Nonscalar_ptr_iterator_tag __formal)  Line 97 + 0x8 bytes	C++
           	FirestormOS-Fizzlefire.exe!LLVolume::~LLVolume()  Line 2153 + 0x40 bytes	C++
           	FirestormOS-Fizzlefire.exe!LLVolume::`scalar deleting destructor'()  + 0x14 bytes	C++
           	FirestormOS-Fizzlefire.exe!LLPointer<LLVolume>::unref()  Line 156 + 0x1f bytes	C++
           	FirestormOS-Fizzlefire.exe!LLPrimitive::~LLPrimitive()  Line 192 + 0x1f bytes	C++
           	FirestormOS-Fizzlefire.exe!LLVOVolume::`scalar deleting destructor'()  + 0x14 bytes	C++
           	FirestormOS-Fizzlefire.exe!LLPointer<LLViewerObject>::unref()  Line 156 + 0x26 bytes	C++
           	FirestormOS-Fizzlefire.exe!LLViewerObjectList::cleanDeadObjects(int use_timer)  Line 1533 + 0x13 bytes	C++
           	FirestormOS-Fizzlefire.exe!LLAppViewer::idle()  Line 5801 + 0x11 bytes	C++
           	FirestormOS-Fizzlefire.exe!LLAppViewer::mainLoop()  Line 1666	C++
           	FirestormOS-Fizzlefire.exe!WinMain(HINSTANCE__ * hInstance, HINSTANCE__ * hPrevInstance, char * lpCmdLine, int nCmdShow)  Line 329	C++
           	FirestormOS-Fizzlefire.exe!__tmainCRTStartup()  Line 547 + 0x25 bytes	C
           	kernel32.dll!00000000770759ed() 	
           	[Frames below may be incorrect and/or missing, no symbols loaded for kernel32.dll]	
           	ntdll.dll!00000000772ac541() 	
          
          whirly.fizzle Whirly Fizzle added a comment -

          Good repro for this found by SUP-15320

          Observed: You will usually crash before you reach Plontafus.

          Reprod on:
          Firestorm 4.7.2 (46135) May 8 2015 18:44:35 (Firestorm-Fizzlefire) with OpenSimulator support

          Callstack:

           	ntdll.dll!RtlReportCriticalFailure()  + 0x62 bytes	
           	ntdll.dll!RtlpReportHeapFailure()  + 0x26 bytes	
           	ntdll.dll!RtlpHeapHandleError()  + 0x12 bytes	
           	ntdll.dll!RtlpLogHeapFailure()  + 0xa4 bytes	
           	ntdll.dll!RtlFreeHeap()  + 0xb54d bytes	
           	kernel32.dll!HeapFree()  + 0xa bytes	
           	msvcr120.dll!free()  + 0x1c bytes	
           	FirestormOS-Fizzlefire.exe!LLLightParams::`scalar deleting destructor'()  + 0x1d bytes	C++
          >	FirestormOS-Fizzlefire.exe!LLViewerObject::~LLViewerObject()  Line 338	C++
           	FirestormOS-Fizzlefire.exe!LLVOVolume::`scalar deleting destructor'()  + 0x14 bytes	C++
           	FirestormOS-Fizzlefire.exe!LLPointer<LLViewerObject>::unref()  Line 156 + 0x26 bytes	C++
           	FirestormOS-Fizzlefire.exe!std::_Tree<std::_Tmap_traits<LLPointer<LLViewerObject>,LLBBox,std::less<LLPointer<LLViewerObject> >,std::allocator<std::pair<LLPointer<LLViewerObject> const ,LLBBox> >,0> >::_Erase(std::_Tree_node<std::pair<LLPointer<LLViewerObject> const ,LLBBox>,void *> * _Rootnode)  Line 2083	C++
           	FirestormOS-Fizzlefire.exe!std::_Tree<std::_Tmap_traits<LLPointer<LLViewerObject>,LLBBox,std::less<LLPointer<LLViewerObject> >,std::allocator<std::pair<LLPointer<LLViewerObject> const ,LLBBox> >,0> >::_Erase(std::_Tree_node<std::pair<LLPointer<LLViewerObject> const ,LLBBox>,void *> * _Rootnode)  Line 2079	C++
           	FirestormOS-Fizzlefire.exe!std::_Tree<std::_Tmap_traits<LLPointer<LLViewerObject>,LLBBox,std::less<LLPointer<LLViewerObject> >,std::allocator<std::pair<LLPointer<LLViewerObject> const ,LLBBox> >,0> >::_Erase(std::_Tree_node<std::pair<LLPointer<LLViewerObject> const ,LLBBox>,void *> * _Rootnode)  Line 2079	C++
           	FirestormOS-Fizzlefire.exe!std::_Tree<std::_Tmap_traits<LLPointer<LLViewerObject>,LLBBox,std::less<LLPointer<LLViewerObject> >,std::allocator<std::pair<LLPointer<LLViewerObject> const ,LLBBox> >,0> >::_Erase(std::_Tree_node<std::pair<LLPointer<LLViewerObject> const ,LLBBox>,void *> * _Rootnode)  Line 2079	C++
           	FirestormOS-Fizzlefire.exe!std::_Tree<std::_Tmap_traits<LLPointer<LLViewerObject>,LLBBox,std::less<LLPointer<LLViewerObject> >,std::allocator<std::pair<LLPointer<LLViewerObject> const ,LLBBox> >,0> >::_Erase(std::_Tree_node<std::pair<LLPointer<LLViewerObject> const ,LLBBox>,void *> * _Rootnode)  Line 2079	C++
           	FirestormOS-Fizzlefire.exe!std::_Tree<std::_Tmap_traits<LLPointer<LLViewerObject>,LLBBox,std::less<LLPointer<LLViewerObject> >,std::allocator<std::pair<LLPointer<LLViewerObject> const ,LLBBox> >,0> >::_Erase(std::_Tree_node<std::pair<LLPointer<LLViewerObject> const ,LLBBox>,void *> * _Rootnode)  Line 2079	C++
           	FirestormOS-Fizzlefire.exe!std::_Tree<std::_Tmap_traits<LLPointer<LLViewerObject>,LLBBox,std::less<LLPointer<LLViewerObject> >,std::allocator<std::pair<LLPointer<LLViewerObject> const ,LLBBox> >,0> >::_Erase(std::_Tree_node<std::pair<LLPointer<LLViewerObject> const ,LLBBox>,void *> * _Rootnode)  Line 2079	C++
           	FirestormOS-Fizzlefire.exe!std::_Tree<std::_Tmap_traits<LLPointer<LLViewerObject>,LLBBox,std::less<LLPointer<LLViewerObject> >,std::allocator<std::pair<LLPointer<LLViewerObject> const ,LLBBox> >,0> >::_Erase(std::_Tree_node<std::pair<LLPointer<LLViewerObject> const ,LLBBox>,void *> * _Rootnode)  Line 2079	C++
           	FirestormOS-Fizzlefire.exe!std::_Tree<std::_Tmap_traits<LLPointer<LLViewerObject>,LLBBox,std::less<LLPointer<LLViewerObject> >,std::allocator<std::pair<LLPointer<LLViewerObject> const ,LLBBox> >,0> >::_Erase(std::_Tree_node<std::pair<LLPointer<LLViewerObject> const ,LLBBox>,void *> * _Rootnode)  Line 2079	C++
           	FirestormOS-Fizzlefire.exe!std::_Tree<std::_Tmap_traits<LLPointer<LLViewerObject>,LLBBox,std::less<LLPointer<LLViewerObject> >,std::allocator<std::pair<LLPointer<LLViewerObject> const ,LLBBox> >,0> >::_Erase(std::_Tree_node<std::pair<LLPointer<LLViewerObject> const ,LLBBox>,void *> * _Rootnode)  Line 2079	C++
           	FirestormOS-Fizzlefire.exe!std::_Tree<std::_Tmap_traits<LLPointer<LLViewerObject>,LLBBox,std::less<LLPointer<LLViewerObject> >,std::allocator<std::pair<LLPointer<LLViewerObject> const ,LLBBox> >,0> >::_Erase(std::_Tree_node<std::pair<LLPointer<LLViewerObject> const ,LLBBox>,void *> * _Rootnode)  Line 2079	C++
           	FirestormOS-Fizzlefire.exe!std::_Tree<std::_Tmap_traits<LLPointer<LLViewerObject>,LLBBox,std::less<LLPointer<LLViewerObject> >,std::allocator<std::pair<LLPointer<LLViewerObject> const ,LLBBox> >,0> >::_Erase(std::_Tree_node<std::pair<LLPointer<LLViewerObject> const ,LLBBox>,void *> * _Rootnode)  Line 2079	C++
           	FirestormOS-Fizzlefire.exe!std::_Tree<std::_Tmap_traits<LLPointer<LLViewerObject>,LLBBox,std::less<LLPointer<LLViewerObject> >,std::allocator<std::pair<LLPointer<LLViewerObject> const ,LLBBox> >,0> >::clear()  Line 1540 + 0x1f bytes	C++
           	FirestormOS-Fizzlefire.exe!LLObjectSelection::deleteAllNodes()  Line 7210	C++
           	FirestormOS-Fizzlefire.exe!LLSelectMgr::removeAll()  Line 1462	C++
           	FirestormOS-Fizzlefire.exe!LLSelectMgr::deselectAll()  Line 4266	C++
           	FirestormOS-Fizzlefire.exe!LLViewerMediaFocus::setFocusFace(LLPointer<LLViewerObject> * objectp, int face, LLPointer<LLViewerMediaImpl> * media_impl, LLVector3 pick_normal)  Line 80	C++
           	FirestormOS-Fizzlefire.exe!LLViewerMediaFocus::clearFocus()  Line 173	C++
           	FirestormOS-Fizzlefire.exe!LLToolPie::handleMediaClick(const LLPickInfo & pick)  Line 1727 + 0xd bytes	C++
           	FirestormOS-Fizzlefire.exe!LLToolPie::handleLeftClickPick()  Line 208 + 0xb bytes	C++
           	FirestormOS-Fizzlefire.exe!LLToolPie::handleMouseDown(int x, int y, unsigned int mask)  Line 128	C++
           	FirestormOS-Fizzlefire.exe!LLMouseHandler::handleAnyMouseClick(int x, int y, unsigned int mask, LLMouseHandler::EClickType clicktype, int down)  Line 45	C++
           	FirestormOS-Fizzlefire.exe!LLViewerWindow::handleAnyMouseClick(LLWindow * window, LLCoord<LL_COORD_TYPE_GL> pos, unsigned int mask, LLMouseHandler::EClickType clicktype, int down)  Line 1102 + 0x32 bytes	C++
           	FirestormOS-Fizzlefire.exe!LLViewerWindow::handleMouseDown(LLWindow * window, LLCoord<LL_COORD_TYPE_GL> pos, unsigned int mask)  Line 1119	C++
           	FirestormOS-Fizzlefire.exe!LLWindowWin32::mainWindowProc(HWND__ * h_wnd, unsigned int u_msg, unsigned __int64 w_param, __int64 l_param)  Line 2262 + 0x14 bytes	C++
           	user32.dll!UserCallWinProcCheckWow()  + 0x11d bytes	
           	user32.dll!CallWindowProcAorW()  + 0x78 bytes	
           	user32.dll!CallWindowProcW()  + 0x18 bytes	
           	opengl32.dll!wglWndProc()  + 0x32e bytes	
           	user32.dll!UserCallWinProcCheckWow()  + 0x11d bytes	
           	user32.dll!DispatchMessageWorker()  + 0x12a bytes	
           	FirestormOS-Fizzlefire.exe!LLWindowWin32::gatherInput()  Line 1817	C++
           	FirestormOS-Fizzlefire.exe!LLAppViewer::mainLoop()  Line 1625 + 0x14 bytes	C++
           	FirestormOS-Fizzlefire.exe!WinMain(HINSTANCE__ * hInstance, HINSTANCE__ * hPrevInstance, char * lpCmdLine, int nCmdShow)  Line 329	C++
           	FirestormOS-Fizzlefire.exe!__tmainCRTStartup()  Line 618 + 0x15 bytes	C
           	kernel32.dll!BaseThreadInitThunk()  + 0xd bytes	
           	ntdll.dll!RtlUserThreadStart()  + 0x21 bytes	
          
          ansariel.hiller Ansariel Hiller added a comment -

          Is there also a working repro? Neither of the above crashed me so far.

          animorf kawadias stephanie turner added a comment -

          Ansariel I was never able to reproduce this, with the use of the blacklist. But I can certainly give it another attempt on the current build.

          whirly.fizzle Whirly Fizzle added a comment -

          Testing first on 4.7.9 release.
          I can still reproduce this crash.

          By far the easiest repro (though I suspect the cause of the crash may be different?) is the repro for FIRE-16485.
          That certain location gets reported a lot for the derender/blacklist crashes.

          Going to test on tip now.

          whirly.fizzle Whirly Fizzle added a comment -

          So far so good on Firestorm 4.7.10 (50778) Aug 12 2016 06:33:50 (Firestorm-Fizzlefirex64) with OpenSimulator support
          I'm unable to reproduce the crash after TPing into or out of a region where a lot of content is blacklisted.
          I'm also unable to reproduce the FIRE-16485 crash, which was very easy to repro on 4.7.9.

          I spoke to one of the locals at the region (Zoelien) & herself & her friends can all easily reproduce the blacklist crashes on that region, so I'm sending builds to them.
          Builds being sent to Zoelien Resident, prince Zackerly (kesha) and Zemariah (who filed FIRE-19560).

          whirly.fizzle Whirly Fizzle added a comment -

          Build also sent to lasse bang who filed SUP-15579

          whirly.fizzle Whirly Fizzle added a comment -

          Zoelien said this crash is fixed for her on the test build.
          If she has a blacklist of ~ 50kb in size, consisting soley of blacklisted trees on valkyrie region, each time she teleported to another region, 4.7.9 would crash without fail.
          She cannot reproduce the crash on the test build

          Zoelien also reported that on earlier FS builds, if her blacklist file got too big (over 100KB), she would experience stuttery performance until she purged her blacklist.
          She said this problem also seems fixed on the test build.

          whirly.fizzle Whirly Fizzle added a comment -

          I'm going to resolve this bug as fixed.
          If anyone can still reproduce this on the test viewer, comment here & 'll reopen it.


            People

            • Assignee:
              ansariel.hiller Ansariel Hiller
              Reporter:
              whirly.fizzle Whirly Fizzle
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: