Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-14871

[BUG-7653] 14.12 Release ( plus 14.9.2, 14.11.1, 14.11.2 Beta) drivers will not render rigged mesh unless hardware skinning is disabled.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 4.6.7, Phoenix Firestorm 4.6.9, Phoenix Firestorm 4.7.0
    • Fix Version/s: Phoenix Firestorm 4.7.3
    • Component/s: Rendering
    • Labels:
    • Environment:
    • SL Avatar Name:
      haylieriggles
    • Reported In:
      Firestorm 4.6.7.42398 Release

      Description

      Attached mesh objects not viewing. Basic shaders enabled.

      (This problem just began over the weekend I hadn't been on about two days. I hadn't changed anything. Upon logging in no mesh worn was in view.)

      If I disable Hardware skinning it becomes view-able, however I always have my shadows enabled. I've never had problems with this before.
      Graphics software is up to date.
      Please help.

      The only recent problem I hadn't solved was graphic spikes happening occasionally.

        Issue Links

          Activity

          rsiamendes Robert0 Siamendes added a comment -

          Hi Haylie,

          Please read here: http://wiki.phoenixviewer.com/mesh_issues.

          haylieriggles Haylie Riggles added a comment -

          I read all of those and performed all of those before even coming here. Thanks though. Still in the same boat.

          whirly.fizzle Whirly Fizzle added a comment -

          Someone reported the same problem at https://jira.secondlife.com/browse/BUG-7653 - both BUG-7653 and this issue are using the 8.17.0010.1315 driver version.

          whirly.fizzle Whirly Fizzle added a comment -

          Hmmmm is 8.17.0010.1315 the new 14.9 Catalyst version? Pretty sure it is - AMD make it difficult to find the catalyst version corresponding to the driver number >.<

          whirly.fizzle Whirly Fizzle added a comment -

          Okay, it appears the 8.17.0010.1315 driver version is the AMD Catalystâ„¢ 14.9.2 Beta - http://support.amd.com/en-us/kb-articles/Pages/AMDCatalyst14-9-2BetaWINReleaseNotes.aspx

          Can you confirm that you are indeed using the Catalyst 14.9.2 Beta driver?
          If you roll back to the 14.9 release Catalyst version (http://support.amd.com/en-us/download/desktop?os=Windows%207%20-%2064) does this fix the problem?

          whirly.fizzle Whirly Fizzle added a comment -

          Halylie, Im going to move this issue over to the bug section.
          We are sure now this is a 14.9.2 beta driver problem.

          haylieriggles Haylie Riggles added a comment -

          Thanks Whirly. I'm pretty sure thats what it is. I'm going to take out the beta driver tonite. Its the only thing that has changed with my pc.

          willow wilder Willow Wilder added a comment -

          This bug has carried over to ATI/AMD Catalyst 14.11.1 Beta driver according to users reporting on https://jira.secondlife.com/browse/BUG-7653 :/

          whirly.fizzle Whirly Fizzle added a comment -

          If that driver gets into release, its going to be "fun times...."

          whirly.fizzle Whirly Fizzle added a comment -

          Still reproduces on 14.11.2 Catalyst beta

          Neokolzia Evir Blackmore added a comment -

          I downgraded back to release driver which I believe is only 14.9.x? Doesn't seem to have issue, I'm going back to 14.11.2 now for obvious reasons of liking mantle on my Dragon Age Inquisitions, gaining alot more FPS then Dx11 specially when running Firestorm in Background.

          Trying this Disable Hardware skinning option.

          whirly.fizzle Whirly Fizzle added a comment -

          Yeah the 14.9 Catalyst release driver does not have this bug.
          Disabling hardware skinning will workaround this bug if you want to stick with the current catalyst beta driver but a lot of mesh will have ugly shading when hardware skinning is disabled, so be aware of that.

          whirly.fizzle Whirly Fizzle added a comment -

          Sigh
          AMD just promoted this buggy driver to full release - Catalyst 14.12 "Omega" package

          Catalyst 14.12
          Windows Graphics Driver Version: 8.17.0010.1333
          OpenGL Version: 4.2.13283 Compatibility Profile Context 14.501.1003.0

          azeral adamczyk Patrick G Taylor added a comment -

          Problem Remains in 14.12 Omega Driver, Already Contacted AMD Support via feedback form, (hopefully it went thru when internet went down) might submit another report just to be sure

          Also talked to AMD Support via email, they recommened for best performance in all my applications using the latest driver. So guess stuck waiting on a fix for the rigged mesh and hardware skinning.

          ronoverdrive Ron Overdrive added a comment -

          A confirmed work around is to copy the atig6txx.dll, atigktxx.dll, atio6xx.dll, atioglxx.dll libraries from the 14.9.x driver to the Firestorm directory. This is of course only a temporary fix, but its a better fix then disabling skinning.

          haylieriggles Haylie Riggles added a comment -

          I myself chose the "AMD Catalyst" driver workaround contributed by Yoho Waco. Everything seems fine now. Hopefully Amd fixes this soon so the workaround isn't necessary.

          https://modemworld.wordpress.com/2014/12/13/amd-catalyst-drivers-additional-windows-workaround/

          whirly.fizzle Whirly Fizzle added a comment -

          ObviousAltIsObvious added a comment - 04/Feb/15 2:31 PM

          Adding another to the pile. There is a beta Catalyst download in circulation intended for Alienware machines, labeled as 14.502.1002 or "15.x". It can install on some non-Dell systems too, so hardware enthusiasts have been playing with it. This driver set contains the same bugs. SL viewers will report it as OpenGL Version 4.2.13285

          anastasia.horngold Anastasia Horngold added a comment -
          whirly.fizzle Whirly Fizzle added a comment -

          Has anyone had a chance to try the proposed fix from Singularity for this bug? See https://modemworld.wordpress.com/2015/02/28/singularity-provides-update-to-address-amd-catalyst-driver-issues/

          whirly.fizzle Whirly Fizzle added a comment - - edited

          It appears the fix in Singularity does fix the rigged meshes beinbg invisible but on some rigged meshes the normals are broken and the meshes flicker like crazy: http://i.imgur.com/9eD02ou.png
          http://gyazo.com/a32d5d921c763c7cab2dd01b55bff676

          whirly.fizzle Whirly Fizzle added a comment -

          Has anyone had the chance to try this yet? http://support.amd.com/en-us/kb-articles/Pages/latest-catalyst-windows-beta.aspx

          Resolved issues:
          [413076] Second Life : Rigged mesh objects are not rendered correctly when hardware skinning is enabled in the in game settings

          liffento Liffento Eldritch added a comment - - edited

          Yes. I put back in my Radeon HD 7850 for awhile and just tried the newest beta. It does resolve the issue. I no longer need to use the opengl drivers in the firestorm directory or disable anything. This driver fixes the rigged mesh issue. Beta version is 15.3 and got it here http://support.amd.com/en-us/download/desktop?os=Windows+8.1+-+64

          marybethoceanlane Marybeth Oceanlane added a comment -

          Latest 15.3 beta is working fine on my HD6670

          liffento Liffento Eldritch added a comment -

          I am curious if anyone else is having issues with the new Beta 15.3 drivers causing random momentary freeze ups when turning around or zooming around? I didn't have this problem until after I updated to the new drivers to fix the rigged mesh issue.

          ronoverdrive Ron Overdrive added a comment - - edited

          Nope, no stuttering here. The 15.3 Beta drivers fixed everything. Using a pair of R9 290 Vapor-Xs.

          Rucy Rucy_Byron added a comment -

          I have recently been contacted by several people having this issue with some of my releases, it is effecting people with Nvidia and Intel GPU's not just AMD. I seems random. I have, for example recently released a rigged mesh top in 6 colours, and although the models are identical some people see some colour and not others. The only difference is the colour of the texture, there are no alpha channels on the textures. Exact same uploaded item. Very strange. Would love to know what to say to effected customers?

          anastasia.horngold Anastasia Horngold added a comment -

          Hi, Rucy,
          The issue you're describing is not the topic of this Jira ticket. If your affected customers are all on Firestorm, please file a new Jira and include all the information there. How to file: http://wiki.phoenixviewer.com/file_a_jira

          whirly.fizzle Whirly Fizzle added a comment -

          Rucy_Byron
          Yes, this sounds like a different bug.
          If you could file a seperate JIRA issue that would be great. We will also need a marketplace link to the affected product for testing.

          distraida distraida brionnae added a comment -

          beta driver 15.3 or up fixes the issue with mesh but causes letters to randomly disappear from the UI.

          susafox Susanne Zilz added a comment -

          beta 15.3 works fine for me . i dont have any issues with it

          willow wilder Willow Wilder added a comment -

          distraida brionnae The first report of missing letters came with Catalyst Version 14.9 as reported on FIRE-15042

          liffento Liffento Eldritch added a comment -

          The 15.4 beta drivers also is able to see rigged mesh without needing to disable hardware skinning.

          voo.oompa Alan Augustson added a comment -

          I'm currently using the 15.2 beta driver for Linux on a laptop with an AMD 5875 GPU. The 15.4 beta is not yet packaged for Linux.

          The current stable release of Singularity allows me to view rigged mesh properly.

          I have also learned that hardware skinning is essential to viewing some mesh avatars properly. While hardware skinning is disabled, some mesh avis will looks strange and blotchy, and others will not skin at all – there will simply be a stark white avatar below the neck.

          whirly.fizzle Whirly Fizzle added a comment -

          Alan Augustson
          Yep, Singularity has a viewer side fix for the AMD bug. Rigged mesh will sometimes have broken normals with this fix though so I don't think it will be added to Firestorm since the later AMD drivers fix the bug completely.
          Hopefully AMD will provide a driver update soon for Linux.

          om om added a comment -

          Using 15.3 beta for linux, and the issue still persists and disabling hardware skinning is the only solution. Can the fix from Singularity be implemented for the linux version as the Singularity fix seems to work perfectly...

          whirly.fizzle Whirly Fizzle added a comment - - edited

          Im not sure Om.
          I'll set this issue for 4.7.2 to it gets reviewed before the next release.
          The Singu fix was causing broken normals on some rigged meshes and I dont know how widespread that problem was, so it would need some carefull testing.

          Note for QA if the Singu fix gets merged: Need to test the Niramyth body which displays correctly in FS but not on Singu: https://code.google.com/p/singularity-viewer/issues/detail?id=1893
          (Also repros on Windows: https://code.google.com/p/singularity-viewer/issues/detail?id=1912)
          This may be caused by the AMD fix.

          om om added a comment - - edited

          Went to their store to test the problem on my end.. there were bots or live avatars wearing the same skin and i could see their bodies perfectly.. no distortions.. on singularity.

          As they don't have a demo skin, so maybe other testers can go and check these live avatars to see if we all can see it well.

          This is the LM: http://maps.secondlife.com/secondlife/Niramyth/53/217/26

          If anything else needs to be tested, please let me know.

          whirly.fizzle Whirly Fizzle added a comment - - edited
          voo.oompa Alan Augustson added a comment -

          I'll attempt to get hold of this right away. No way am I advanced enough to recompile a kernel, though; it'll need to be packaged... fingers crossed

          voo.oompa Alan Augustson added a comment -

          Couldn't install, and it's not packaged for my distribution yet.

          om om added a comment -

          i also have installation issues at present.. will update once i am able to install it.

          PJWales Peter added a comment -

          I has texture issue and was referred to ATI page and discovered that my drivers was the issue so did an auto-detect with AMD and claimed 14.12 was the best however did have rigged mesh issue and removed the option of hardware skinning but has an issue with alphas not showing up. So proceeded to install catalyst 15.6 beta and can confirm it seems to be for me for now. Thought I let you all know.

          whirly.fizzle Whirly Fizzle added a comment -

          Yep, the 15.6 beta is the newest Catalyst beta version and should fix this problem.
          I havn't seen anyone having problems on the 15.6 beta yet.
          AMD are taking a loooong time to get this one into release!

          om om added a comment -

          installed 15.7 today and I can also confirm this has been fixed (openSUSE Tumbleweed 64 bit)

          whirly.fizzle Whirly Fizzle added a comment -

          Great! Thanks for letting us know Om

          anastasia.horngold Anastasia Horngold added a comment -

          Om,
          Could you go to Help> About Firestorm, and copy/paste the Windows Graphics Driver Version, OpenGL Version, and Compatibility Profile Context numbers here? That will help us update our ATI chart.

          Thanks!

          om om added a comment -

          Sure

          CPU: Intel(R) Core(TM) i5-3450 CPU @ 3.10GHz (1995.26 MHz)
          Memory: 11963 MB
          OS Version: Linux 4.0.5-3-desktop #1 SMP PREEMPT Thu Jun 18 15:11:06 UTC 2015 (56152db) x86_64
          Graphics Card Vendor: ATI Technologies Inc.
          Graphics Card: AMD Radeon HD 5700 Series

          OpenGL Version: 4.5.13397 Compatibility Profile Context 15.20.1046
          AMD Catalyst 15.7 (15.200.1046-1)

          anastasia.horngold Anastasia Horngold added a comment -

          Hm, it didn't show Windows Graphics Driver Version?

          liffento Liffento Eldritch added a comment -

          om is using Linux. It won't show the windows graphics drivers.

          om om added a comment -

          When I run it on Windows 10 (which happens rarely), i will update it as well

          anastasia.horngold Anastasia Horngold added a comment - - edited

          Derp.

          I'll add the info we have, and leave the driver version blank till someone can report it.

          om om added a comment -

          But then, the Driver version is 15.7... that's what i installed

          anastasia.horngold Anastasia Horngold added a comment -

          15.7 is the Catalyst number, but "Windows graphics driver version" is a different, long number. You can see examples at http://wiki.phoenixviewer.com/ati#how_to_determine_what_version_of_catalyst_you_have

          distraida distraida brionnae added a comment -

          CPU: AMD A8-6410 APU with AMD Radeon R5 Graphics (1996.25 MHz)
          Memory: 5081 MB
          OS Version: Microsoft Windows 8.1 64-bit (Build 9600)
          Graphics Card Vendor: ATI Technologies Inc.
          Graphics Card: AMD Radeon(TM) R5 Graphics

          Windows Graphics Driver Version: 8.17.0010.1395

          That's what I've got with 15.7

          om om added a comment -

          Here it is from the Windows 10 build

          CPU: Intel(R) Core(TM) i5-3450 CPU @ 3.10GHz (3092.95 MHz)
          Memory: 12236 MB
          OS Version: Microsoft Windows 10 64-bit (Build 10011)
          *Actually it is Build 10162
          Graphics Card Vendor: ATI Technologies Inc.
          Graphics Card: AMD Radeon HD 5700 Series

          Windows Graphics Driver Version: 8.17.0010.1395
          OpenGL Version: 4.2.13397 Compatibility Profile Context 15.200.1046.0

          anastasia.horngold Anastasia Horngold added a comment -

          Thanks!

          whirly.fizzle Whirly Fizzle added a comment -

          I'm going to close this issue as AMD have fixed it in their release driver.


            People

            • Assignee:
              Unassigned
              Reporter:
              haylieriggles Haylie Riggles
            • Votes:
              3 Vote for this issue
              Watchers:
              14 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: