Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-15039

[LINUX] 32bit Havok enabled viewer crashes when opening Build -> Pathfinding -> View/Test.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Waiting on Linden Lab fix
    • Affects Version/s: Phoenix Firestorm 4.6.7
    • Fix Version/s: Phoenix Firestorm Next
    • Component/s: Crashes
    • Labels:
    • Environment:
    • SL Avatar Name:
      Renate1 Roelofs
    • Reported In:
      Firestorm 4.6.7.42398 Release

      Description

      crash when using pathfinding View / Test
      i run into other little things aswell

      1. “Viewer_logs.tar.bz2”
        214 kB
        Renate1 Roelofs

        Issue Links

          Activity

          whirly.fizzle Whirly Fizzle added a comment -

          Moving over to support

          whirly.fizzle Whirly Fizzle added a comment -

          Heya Renate,

          Do you only crash when going to Pathfinding -> View/test when on a certain region or does the viewer crash when you open view/test on any region?
          If this crash is limited to one region, please can you give me the region name.

          Can you reproduce this crash and then before relaunching the viewer, zip up your logs folder and attach it to this issue using More Actions -> Attach files.
          This page tells you where to find your logs folder: http://wiki.phoenixviewer.com/file_a_jira#how_to_give_us_your_logs

          What are the other little things that you are seeing?

          Thanks!

          Renroe Renate1 Roelofs added a comment -

          Hi Whirly Fizzle

          the crash i have, or better Freeze occurs in all sims i have tried it on
          i wanted to make 1 remark, i see you have changed the version a few times, but it is about the 4.6.7.42398 version

          i have added the attachment for Logs, i hope you can find something

          whirly.fizzle Whirly Fizzle added a comment -

          Thanks Renate, looking at your logs now.

          So does this freeze/crash only happen on 4.6.7? It doesnt happen on 4.6.5?

          Renroe Renate1 Roelofs added a comment -

          it only happens for me on the 4.6.7 and since i use the View / Test almost every day, i am using 4.6.5

          whirly.fizzle Whirly Fizzle added a comment -

          firestorm.log session

          Firestorm-Release: Phoenix_Firestorm-Release_i686_4.6.7.42398 - Linux 32 bit (with havok support)
          Hmmm this log session just cuts dead and I dont see the view/test floater being opened, there should be a line printed to log saying: "INFO: LLFloater::openFloater: Opening floater floater_pathfinding_console full path: /main_view/menu_stack/world_panel/Floater View/floater_pathfinding_console"
          The viewer may have frozen before this line printed though.

          I cannot get a stack from the .dmp file in your logs, the dmp appears to be corrupted for some reason.
          Renate, can you reproduce this crash again please and then zip up the logs folder and attach it to this issue.

          Thanks

          Renroe Renate1 Roelofs added a comment -

          i hope this is what you mean and that you can do something with this

          whirly.fizzle Whirly Fizzle added a comment -

          Hmm strange, I can't get a stack from that .dmp either. I need to ask one of the devs to look at this.

          Renate, do you have the same problem on the official Linden Lab viewer from https://secondlife.com/support/downloads/ ?

          What were the "other little things" you said you run into? Those may give a clue as to whats wrong.

          whirly.fizzle Whirly Fizzle added a comment - - edited
          C:\Users\Whirly\Desktop>minidump_stackwalk.exe C:\Users\Whirly\Desktop\12e521d9-37f5-1a2a-6ba677a2-56fcd5df.dmp I:\RELEASE_SYMBOLS\4-6-7-release\Phoenix_Firestorm-Release_4-6-7-42398_hvk_symbols-linux >callstack.txt
          2014-11-28 21:00:05: minidump_processor.cc:264: INFO: Processing minidump in file C:\Users\Whirly\Desktop\12e521d9-37f5-1a2a-6ba677a2-56fcd5df.dmp
          
          2014-11-28 21:00:05: minidump.cc:3775: INFO: Minidump opened minidump C:\Users\Whirly\Desktop\12e521d9-37f5-1a2a-6ba677a2-56fcd5df.dmp
          2014-11-28 21:00:05: minidump.cc:3807: ERROR: Minidump header signature mismatch: (0x0, 0x0) != 0x504d444d
          2014-11-28 21:00:05: minidump_processor.cc:268: ERROR: Minidump C:\Users\Whirly\Desktop\12e521d9-37f5-1a2a-6ba677a2-56fcd5df.dmp could not be read
          2014-11-28 21:00:05: minidump.cc:3747: INFO: Minidump closing minidump
          2014-11-28 21:00:05: minidump_stackwalk.cc:529: ERROR: MinidumpProcessor::Process failed
          Renroe Renate1 Roelofs added a comment - - edited

          in Second Life 3.7.20 (296094) it works fine, no problems at all
          and ofcourse in firestorm 4.6.5 i also have no problems

          one thing i can remember, i did not write anything down, is for instance inventory search, a lot of the time it does not show selection, but shows if you search for other keywords

          whirly.fizzle Whirly Fizzle added a comment -

          Renate, one of the linux devs reproduced this crash on 4.6.7 release. It appears it's Linux specific.
          Logs just cut dead and it printed a memory error to console - this is likely the reason your .dmp's were busted.

          It appears we need a new Havok blob for Linux, which needs to come from Linden Lab.

          Moving this issue over to the bug section.

          Renroe Renate1 Roelofs added a comment -

          thank you

          nickyd Nicky added a comment -

          I am closing this. I do not think LL is interested in ever updating their Havok blob or Linux. There is https://jira.secondlife.com/browse/OPEN-302 which is already open for month without any action.
          If OPEN-302 is ever resolved by LL, this one will be fixed too.


            People

            • Assignee:
              shouldbeworkingonit.linden ShouldBeWorkingOnIt Linden
              Reporter:
              Renroe Renate1 Roelofs
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: