Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-17459

"Hear voice from everyone equally" functions as "from Avatar position"

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: Phoenix Firestorm 4.7.5, Phoenix Firestorm 4.7.6
    • Fix Version/s: None
    • Component/s: Voice Chat
    • Labels:
      None
    • Environment:
    • SL Avatar Name:
      mercurylight resident
    • Reported In:
      Firestorm 4.7.5.47975 Release

      Description

      The voice option "from everyone equally" functions exactly the same as "from Avatar position". Avatar distance creates a rolloff and avatars positioned behind mine (my avatar's back facing them) completely mutes them past 5m.

        Issue Links

          Activity

          whirly.fizzle Whirly Fizzle added a comment - - edited

          Testing on Firestorm 4.7.6 (48151) Dec 9 2015 17:01:08 (Firestorm-Fizzlefire) with OpenSimulator support.

          • Hear voice from camera position is working as expected.
          • Hear voice from avatar position is working as expected.
          • Confirmed that "Hear voice equally from everyone" doesn't appear to be working - it's using the avatar position.

          Moving this over to the bug section.

          ansariel.hiller Ansariel Hiller added a comment -

          Code works correct: If "Hear voice equally from everyone" is selected, no transformation for the listener position is being applied. What the Vivox voice lib makes out of it is up to them.

          ansariel.hiller Ansariel Hiller added a comment -

          I seriously start to wonder if this ever worked at all. The code is identical to the original implementation in Singularity. And from how the code looks like, it is obvious that "Hear voice from everyone equally" functions the same as "from Avatar position" since setting that option will result in the same positional data being used that would be set as if "from Avatar position" is selected. This has also been the case in the very first implementation of this feature. So if this feature ever has worked, it is can't be an issue of our code, but may be buried in the Vivox library we don't have access to.

          ansariel.hiller Ansariel Hiller added a comment -

          Removed the option in rev. 52473 (http://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/10bcaccc6230).

          If this option really worked at some point, it must have been more or less random or magic, as the code itself behaves the same way as if avatar position is chosen as hearing position - even at the time it was implemented. Furthermore, the Vivox API specification only lists two available hearing positions: Avatar position or camera position. There is explicitely nothing mentioned to have an equal volume for every speaker.

          misteracacia Mister Acacia added a comment -

          The option title is misleading but seemed to work in a way for me. Directional information was (apparently) still used, so I knew from what direction the voice came, but spatial distance was (apparently) not used and so a voice at 50 meters was as loud as a voice at 1 meter.

          ansariel.hiller Ansariel Hiller added a comment -

          The code used did 100% exactly use the same values and calculations as the "hear from avatar position". According to the Vivox API, it is NOT possible to do what the option presumed to do - and according to the latest Vivox SDK used on Mac and Windows, it behaves like that.

          misteracacia Mister Acacia added a comment -

          OK, but I did hear a difference in audio level, that all levels were the same regardless of distance, out to the max voice range

          adeonwriter Adeon Writer added a comment -

          The original intention of "Everyone equally" was to remove the left/right panning that used to happen on "Camera Position" and "Avatar Position"

          This is all it ever did, it never let you hear people who were farther away.

          However, somewhere along the line, someone also removed the left/right panning from "Avatar Position" as well, meaning "Everyone Equally" is now identicle to "Avatar Position"

          Really the option can just be removed.


            People

            • Assignee:
              ansariel.hiller Ansariel Hiller
              Reporter:
              MercuryDoll Lumi Merkurlicht
            • Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: