Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-17522

[Win 10] [BUG-11024] [MAINT-5992] Screen is unreadable small and unusable slow on 4K display after Win10 update

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 4.7.3, Phoenix Firestorm 4.7.5, Phoenix Firestorm 4.7.6
    • Fix Version/s: Phoenix Firestorm 4.7.10
    • Component/s: User Interface
    • Labels:
    • Environment:
    • SL Avatar Name:
      Dale Innis
    • Reported In:
      Firestorm 4.7.5.47975 Release

      Description

      Firestorm has worked just fine for me on this 4K (3840 x 2160) laptop under Windows 10 for some time, but at least since the latest Windows 10 update (and perhaps related to installing the latest FS release also, but maybe not), it is basically unusable.

      All of the interface elements have become much smaller, too small to read even at the maximum 1.4 UI scale.

      Rendering FPS feels very low; it can't keep up even with slow and careful typing into chat boxes.

      And it's forgotten all of my saved usernames and passwords, and at least some of my settings (the dialogs are too small to read to be sure of all of them).

      Help help!


      Edit (Whirly):
      For details about the cause of this problem see https://jira.secondlife.com/browse/BUG-11024

      Workaround

      1. Exit Firestorm.
      2. Right-click the Firestorm application shortcut and select "Properties"
      3. In the "Shortcut" tab, find the line marked "Target" and add "--noprobe" (without quotes) to the end. For example:

      "C:\Program Files\Firestorm-Release\Firestorm-Release.exe" --set InstallLanguage en --noprobe
      

      4. In the "Compatibility" tab, find and UNCHECK the "Disable display scaling on high DPI settings" option
      5. Click "OK" to apply and launch Firestorm as normal.

      Notes:

      • You may need to repeat this after Firestorm updates.
      • Do not bring up the "Help->About Firestorm" menu option or you will need to repeat steps 1, 2, 4 and 5 above.

        Issue Links

          Activity

          DaleInnis Dale Innis added a comment -

          If I reduce the screen resolution to more like 1080p (i.e. one-quarter the virtual pixels), it works more or less fine (still a few oddities, but I suspect they are due to it having thrown away all of my settings because the win10 update made it think the network had changed, and therefore something something).

          rsiamendes Robert0 Siamendes added a comment -

          Hi Dale,

          You can try changing your UI Scaling to a higher value in Prefs > User Interface > General.

          DaleInnis Dale Innis added a comment -

          Thanks! Sadly, as I mentioned in the original report, Firestorm is still unusable even at the maximum 1.4 scale.

          whirly.fizzle Whirly Fizzle added a comment -

          Going to move this over to the bug section & Link to LL issue https://jira.secondlife.com/browse/BUG-11024

          Dale, though it's not a perfect workaround, because it will break if you open Help -> About Firestorm, see Soft's comment HERE.

          whirly.fizzle Whirly Fizzle added a comment -

          Ref: SUP-16303
          --noprobe also fixes this problem for those with lower res screens eg) 1920x1080
          This problem doesn't appear limited to 4k monitors.

          DaleInnis Dale Innis added a comment -

          Thanks much; the --noprobe and uncheck workaround has definitely helped!

          cheta.torok Cheta Torok added a comment -

          I am using a Surface Pro 4 and this was definitely an issue for me. Talk about making me feel old! that text was so tiny. Thankfully the 'imperfect' workaround is being a helpful band-aid so I am surviving at the moment. At least until I need to tell someone what I am using by pulling up Help-About

          Niccole.Inglewood Niccole Inglewood added a comment -

          Going to have to try out the --noprobe trick, however would making the UI scale to 2 or maybe 3 even help???? Asking cause i dont know

          1.4 is still way too small on the scaling will see what happens with the --noprobe trick ;3

          whirly.fizzle Whirly Fizzle added a comment -

          Niccole Inglewood
          You will be able to set the UI scaling up to 2 on the next release of Firestorm.
          This was added in http://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/e05528d6c2a7

          mizaki mizaki resident added a comment -

          Hello!

          I just wanted to pinch in that I am having similar issues. I have tried the suggestions here but it wasn't working, at least this part ( In the "Shortcut" tab, find the line marked "Target" and add "--noprobe" (without quotes) to the end. For example When i add it, it says that it is invalid, so i cant save it as it is.

          I have resorted to just bumping up the UI to the highest but that is still hard to read but better than how it was. I highly suggest there should be a possibility to control the sizes.

          Before (Lower UI): https://gyazo.com/7256e3d81cccfbc472344e4282465cb8
          After (Higher UI): https://gyazo.com/9abb761b0762fa7bac28895308d9c59c

          The font I managed to change at least using the chat menu of the preference tab, so that at least when chatting there is no much strain to the eyes. This would take some getting used too, but I believe it will be difficult for most with eye issues...hopefully there is a better fix out there to make the display texts appear readable...I can't barely see my Linden Balance xD (Maybe I need glasses. >.>)

          whirly.fizzle Whirly Fizzle added a comment -

          mizaki resident

          The text in the shortcut target path must be incorrect if you are getting an invalid error.
          Please can you paste your shortcut target path text into a comment here so I can check it.

          AlexNomad Alex added a comment -

          Thanks. --noprobe and Unchecking the "disable ..." in compatibility tab helped fix the issue.
          Sometimes my display driver stops responding and Windows fixes it. After that I need to uncheck again, as windows probably forgets the previous setting.
          All good, so far.

          ansariel.hiller Ansariel Hiller added a comment -

          According to FIRE-20382 scaling should be fine with the new DPI and scaling detection in upcoming release 4.7.10.

          ansariel.hiller Ansariel Hiller added a comment -

          Resolving this for 4.7.10 and see how it turns out in the next release.


            People

            • Assignee:
              shouldbeworkingonit.linden ShouldBeWorkingOnIt Linden
              Reporter:
              DaleInnis Dale Innis
            • Votes:
              2 Vote for this issue
              Watchers:
              9 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: