Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-19851

[BUG-37637] [MAINT-6637] DebugAvatarAppearanceMessage incorrectly reports all avatars received COF version as -1

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 4.7.9, Phoenix Firestorm 4.7.10
    • Fix Version/s: Phoenix Firestorm 4.7.10
    • Component/s: Avatars
    • Labels:
    • Environment:
    • SL Avatar Name:
      Whirly Fizzle
    • Reported In:
      Firestorm 4.7.10

      Description

      Steps to Reproduce

      • Set DebugAvatarAppearanceMessage to TRUE.
      • Observe the floating text above other avatars heads.
      • Observe the "cof rcv:" value shown in the floating text for all avatars apart from yourself.

      Observed Behaviour

      • For all avatars apart from yourself, the received COF version will show as cof rcv: -1.
      • Example:

      Expected Behaviour

      • You should be able to see the correct received cof version for other avatars when DebugAvatarAppearanceMessage is enabled.
      • This broke fairly recently, somewhere in the later coroutine updates.
      • To see expected behaviour, use Firestorm 4.7.7.
      • Observe on this build you correctly see other avatars received cof version.
      • Expected behaviour:

      Other Information

      DebugAvatarAppearanceMessage is very useful for troubleshooting appearance problems & it's important to be able to view other avatars received cof version.
      Previously, on viewers without this bug, when an avatars received cof version remained stuck on -1, it was symptom of either multiple COF folders in their inventory (SUN-99) or their cof was corrupted in some other way.
      Probably only developers & support cares that this is no longer working

        Issue Links

          Activity

          ansariel.hiller Ansariel Hiller added a comment - - edited

          Most likely because

              if (isSelf())
              {
                  // Note:
                  // locally the COF is maintained via LLInventoryModel::accountForUpdate
                  // which is called from various places.  This should match the simhost's 
                  // idea of what the COF version is.  AIS however maintains its own version
                  // of the COF that should be considered canonical. 
                  mLastUpdateReceivedCOFVersion = thisAppearanceVersion;
              }
          

          of the isSelf() condition in llvoavatar.cpp

          ansariel.hiller Ansariel Hiller added a comment -

            People

            • Assignee:
              ansariel.hiller Ansariel Hiller
              Reporter:
              whirly.fizzle Whirly Fizzle
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: