Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-1988

Spacenavigator as Flycam does'nt runs properly in Mac

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Addressed in Documentation
    • Affects Version/s: Phoenix Firestorm 2.5.2
    • Component/s: None
    • Labels:
      None
    • Environment:
      Mac OSX 10.6.8, Ram 2 GB
    • Reported In:
      Firestorm 2.5.1.x

      Description

      In the current version of Firestorm (2.5.2.16922) for Mac remains a problem that existed in previous version. If we go to preferences/move/other devices, Firestorm detects the Spacenavigator joystick working as Flycam, but there is no concorance between movements of Spacenavigator and real movements of the camera. In all versions of Phoenix it was working well.
      I mean, if you do make a move, for example, up, the camera makes other no logic movement. When, instead of to the camera (Flycam) we try to move the avatar directly with the spacenavigator, is is exactly the same problem.

      I hope this bug could be solved in next issues of Firestorm.
      Thanks in advance

        Issue Links

          Activity

          Hide
          jessica_lyon Jessica Lyon added a comment -

          I would like to know if this issue exists on the LL Viewer

          Show
          jessica_lyon Jessica Lyon added a comment - I would like to know if this issue exists on the LL Viewer
          Hide
          arian Arian Botey Prat added a comment -

          Congratulations with the new Beta Mesh of Firework, failing to study it more well we believe that is a good work.
          But note that the problem with FlyCAM spacenavigator has not been resolved, so it will be necessary to wait for another version, but we, that usually use this tool we are worried. We would like to know if it is planned in a future release of Firestorm contemplate solving this bug- For the moment we are necessary for us to continue using the very good Phoenix.

          Show
          arian Arian Botey Prat added a comment - Congratulations with the new Beta Mesh of Firework, failing to study it more well we believe that is a good work. But note that the problem with FlyCAM spacenavigator has not been resolved, so it will be necessary to wait for another version, but we, that usually use this tool we are worried. We would like to know if it is planned in a future release of Firestorm contemplate solving this bug- For the moment we are necessary for us to continue using the very good Phoenix.
          Hide
          arian Arian Botey Prat added a comment -

          I'm worried by this bug, because the jira aabout it is present from July 7th; and more than 2 month after, it remains unassigned. Have you thought in a more o less next research of this bug?
          Please, I'd like to have some info about your work in this sense. Many thanks in advance.

          Show
          arian Arian Botey Prat added a comment - I'm worried by this bug, because the jira aabout it is present from July 7th; and more than 2 month after, it remains unassigned. Have you thought in a more o less next research of this bug? Please, I'd like to have some info about your work in this sense. Many thanks in advance.
          Hide
          arian Arian Botey Prat added a comment -

          Hi all
          I know you are very bussy, but 2 month more I'm very worried about this bug, sorry if I am too insistent, but I don't see this bugg assigned and there has been 4 month of waiting; perhaps not for a solution but only for assign.
          Sorry for my bad English.
          Many thanks.

          Show
          arian Arian Botey Prat added a comment - Hi all I know you are very bussy, but 2 month more I'm very worried about this bug, sorry if I am too insistent, but I don't see this bugg assigned and there has been 4 month of waiting; perhaps not for a solution but only for assign. Sorry for my bad English. Many thanks.
          Hide
          xente Xente Aeon added a comment -

          I've been waiting for a solution that has not arrived. A friend gave me the idea to make the same JIRA to Wiever (official) of Linden Lab. So, I installed it and happily I saw that the configuration of Spacenavigator shows up the assignation of movements very clear, much more that Firestorm does. There, in the V3, I have find a settings configuration very different than the normal configuration in V3 and also in Firestorm, but it works auite well in V3 and also in Firestorm. But do that requires also some change in the settings of Spacenavigator.
          After few days of test I can say that this configuration runs well in V3 and Firestorm, so I let this JIRA closed, unless someone have interest in this solution.
          Thanks for everything

          Show
          xente Xente Aeon added a comment - I've been waiting for a solution that has not arrived. A friend gave me the idea to make the same JIRA to Wiever (official) of Linden Lab. So, I installed it and happily I saw that the configuration of Spacenavigator shows up the assignation of movements very clear, much more that Firestorm does. There, in the V3, I have find a settings configuration very different than the normal configuration in V3 and also in Firestorm, but it works auite well in V3 and also in Firestorm. But do that requires also some change in the settings of Spacenavigator. After few days of test I can say that this configuration runs well in V3 and Firestorm, so I let this JIRA closed, unless someone have interest in this solution. Thanks for everything
          Hide
          whirly.fizzle Whirly Fizzle added a comment -

          Arian,

          Are you still having problems with this on 4.0.1?

          Show
          whirly.fizzle Whirly Fizzle added a comment - Arian, Are you still having problems with this on 4.0.1?
          Hide
          xente Xente Aeon added a comment -

          The problem remains but is perfectly located. It's in the default allocation of SpaceNavigator. I needed to make the following changes:
          In the preferences of the SpaceNavigator, apply "reverse" on the button called "zoom" that actually controls the movement up and down.
          In the preferences of the viewer Firestorm, in the joystick (it appears correctly the name of the SpaceNavigator), I had to change some, like this:
          X mapping: 0
          Up-Down Mapping: 3
          Mapping Zoom: -1

          Mapping Y: 1
          Mapping left / right: 4

          Mapping Z: 2
          Mapping rotation: 0

          Leave unchecked: Direct 3D Zoom and Cursor, but check "Auto Level"

          Other features are adjusted as you want.

          VERY IMPORTANT:
          Do not ever push the button "default SpaceNavigator." When you trigger it, return to previous settings, and runs bad. Curiously, this "bad" settings are the same witch runs OK in Phoenix...

          I use the browser in Spanish, so perhaps some name which I put here not exactly match the English version.

          Once adjusted in this way it runs properly.
          I hope this is helpful.
          regards

          Show
          xente Xente Aeon added a comment - The problem remains but is perfectly located. It's in the default allocation of SpaceNavigator. I needed to make the following changes: In the preferences of the SpaceNavigator, apply "reverse" on the button called "zoom" that actually controls the movement up and down. In the preferences of the viewer Firestorm, in the joystick (it appears correctly the name of the SpaceNavigator), I had to change some, like this: X mapping: 0 Up-Down Mapping: 3 Mapping Zoom: -1 Mapping Y: 1 Mapping left / right: 4 Mapping Z: 2 Mapping rotation: 0 Leave unchecked: Direct 3D Zoom and Cursor, but check "Auto Level" Other features are adjusted as you want. VERY IMPORTANT: Do not ever push the button "default SpaceNavigator." When you trigger it, return to previous settings, and runs bad. Curiously, this "bad" settings are the same witch runs OK in Phoenix... I use the browser in Spanish, so perhaps some name which I put here not exactly match the English version. Once adjusted in this way it runs properly. I hope this is helpful. regards
          Hide
          whirly.fizzle Whirly Fizzle added a comment -

          Wonderful Xente, thanks so much for leaving instructions.

          Show
          whirly.fizzle Whirly Fizzle added a comment - Wonderful Xente, thanks so much for leaving instructions.
          Hide
          arrehn Arrehn Oberlander added a comment -

          A better fix is described in

          http://jira.phoenixviewer.com/browse/SUP-4533

          In summary, adjusting the Space Navigator control panel is a more reliable step

          Show
          arrehn Arrehn Oberlander added a comment - A better fix is described in http://jira.phoenixviewer.com/browse/SUP-4533 In summary, adjusting the Space Navigator control panel is a more reliable step
          Hide
          arrehn Arrehn Oberlander added a comment -

          http://jira.phoenixviewer.com/browse/SUP-4533

          Contains the documentation for spacenav setup on OSX

          Show
          arrehn Arrehn Oberlander added a comment - http://jira.phoenixviewer.com/browse/SUP-4533 Contains the documentation for spacenav setup on OSX
          Hide
          xente Xente Aeon added a comment -

          Dear Arrehn, unfortunately for me I can't access to the Jira SUP-4533, 'cause I have no permissions to do that. Please let me know this Spcenavigator setup on OSX, meanwhile, I try to access this Jira. Is very important for me. Txs.

          Show
          xente Xente Aeon added a comment - Dear Arrehn, unfortunately for me I can't access to the Jira SUP-4533 , 'cause I have no permissions to do that. Please let me know this Spcenavigator setup on OSX, meanwhile, I try to access this Jira. Is very important for me. Txs.
          Hide
          arrehn Arrehn Oberlander added a comment -

          I'm reposting the control panel config in this issue, as attachments

          Show
          arrehn Arrehn Oberlander added a comment - I'm reposting the control panel config in this issue, as attachments
          Hide
          whirly.fizzle Whirly Fizzle added a comment -

          Hiya Xente,

          I moved that issue over to FIRE-5845. You should be able to access it now.

          Show
          whirly.fizzle Whirly Fizzle added a comment - Hiya Xente, I moved that issue over to FIRE-5845 . You should be able to access it now.
          Hide
          xente Xente Aeon added a comment -

          Many txs for moving the issue SUP-4533 to FIRE-5845.
          I found a good modification in the change explained in the adjust of overall speed, in "device" tab of spacenavigator settings. But if I use the default set of Spacenavigator in preferences of Firestorm, it runs bad. With the changes I posted before, the Spacenavgator is perfectly usable in Firestorm. Is because that I can happily use Firestorm now, WITH the Spacenavigator as I need.
          Many txs for your helping hand and kindness.
          Xente

          Show
          xente Xente Aeon added a comment - Many txs for moving the issue SUP-4533 to FIRE-5845 . I found a good modification in the change explained in the adjust of overall speed, in "device" tab of spacenavigator settings. But if I use the default set of Spacenavigator in preferences of Firestorm, it runs bad. With the changes I posted before, the Spacenavgator is perfectly usable in Firestorm. Is because that I can happily use Firestorm now, WITH the Spacenavigator as I need. Many txs for your helping hand and kindness. Xente
          Hide
          moni duettmann Moni Duettmann added a comment -

          But why don't they make it like Phoenix? I don't understand. It's such a simple task.

          Show
          moni duettmann Moni Duettmann added a comment - But why don't they make it like Phoenix? I don't understand. It's such a simple task.
          Hide
          xente Xente Aeon added a comment -

          I am watching for a solution from the first issue, a lot of months ago, of Firestorm, but I have no one answer or solution. Really I think is ridiculous, because the solution is easy,I imagine, only with a little changes in the presets (or defaults) of the joystick spacenavigator. But no one seems to solve. Don't worry. Only changing the defaults the space runs well. I like read something about this, after a lot of time. Tks for your words.

          Show
          xente Xente Aeon added a comment - I am watching for a solution from the first issue, a lot of months ago, of Firestorm, but I have no one answer or solution. Really I think is ridiculous, because the solution is easy,I imagine, only with a little changes in the presets (or defaults) of the joystick spacenavigator. But no one seems to solve. Don't worry. Only changing the defaults the space runs well. I like read something about this, after a lot of time. Tks for your words.
          Hide
          whirly.fizzle Whirly Fizzle added a comment -

          Thanks for the feedback Xente and Moni.

          Im afraid we dont have many who use Mac and have a spavenav.

          Xente, just to clarify, if the changes are made like you describe in http://jira.phoenixviewer.com/browse/FIRE-1988?focusedCommentId=78963&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-78963 does this fix the issue and make the spacenav behave as it does in Phoenix? Or are there other problems also?

          Moni, if you follow Xente's instructions in that comment, or Arrehns suggested setup in the attached images, can you describe the problems you still have?

          Show
          whirly.fizzle Whirly Fizzle added a comment - Thanks for the feedback Xente and Moni. Im afraid we dont have many who use Mac and have a spavenav. Xente, just to clarify, if the changes are made like you describe in http://jira.phoenixviewer.com/browse/FIRE-1988?focusedCommentId=78963&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-78963 does this fix the issue and make the spacenav behave as it does in Phoenix? Or are there other problems also? Moni, if you follow Xente's instructions in that comment, or Arrehns suggested setup in the attached images, can you describe the problems you still have?
          Hide
          xente Xente Aeon added a comment -

          Hi Whirly, Moni,
          I can say yes, I am working with the settings I said, with two important actions:
          One in the spacenavigator configuration itself and the other the changes as I said in the mentioned jira.
          If don't do the change proposed for the spacenavigator, the zoom runs well but in apparently inverse mode (but perhaps this is only a personal appreciation).
          But the changes in Firestorm need to be done. I tried other configurations and I only find this one that runs well.
          Other changes an be done, i.e. I put to 20 the settings of Flycam scale X, Y and Z to obtain a more soft movements, but it depends of the preferences of each user.
          After making this changes, my Spacenavigator runs perfectly from months. No other problems detected.

          I'm using the Mac OSX 10.8.2

          Best regards

          Xente Aeon

          Show
          xente Xente Aeon added a comment - Hi Whirly, Moni, I can say yes, I am working with the settings I said, with two important actions: One in the spacenavigator configuration itself and the other the changes as I said in the mentioned jira. If don't do the change proposed for the spacenavigator, the zoom runs well but in apparently inverse mode (but perhaps this is only a personal appreciation). But the changes in Firestorm need to be done. I tried other configurations and I only find this one that runs well. Other changes an be done, i.e. I put to 20 the settings of Flycam scale X, Y and Z to obtain a more soft movements, but it depends of the preferences of each user. After making this changes, my Spacenavigator runs perfectly from months. No other problems detected. I'm using the Mac OSX 10.8.2 Best regards Xente Aeon
          Hide
          arrehn Arrehn Oberlander added a comment -

          I use Firestorm on MacOSX - (Snow Leopard, Lion, Mountain Lion) with the SpaceNav Notebook model.

          With the mac spacenav control panel configured and no other changes (no adjustments to any of the FS defaults) is how I use the spacenav.

          If Firestorm were to change the default axis to work differently, it may help save the step of needing to one-time adjust the spacenav control panel.

          However, that has to be balanced against spacenav working unususably differently when switching between LL, other TPVs, and Firestorm. In this case it would then be more complicated to configure the spacenav to work consistently in viewers, unless LL were to change the upstream behavior. There's pros and cons to each method.

          Aside from a possible code fix, the documentation above should get you up and running.

          Hope this makes sense,
          -A

          Show
          arrehn Arrehn Oberlander added a comment - I use Firestorm on MacOSX - (Snow Leopard, Lion, Mountain Lion) with the SpaceNav Notebook model. With the mac spacenav control panel configured and no other changes (no adjustments to any of the FS defaults) is how I use the spacenav. If Firestorm were to change the default axis to work differently, it may help save the step of needing to one-time adjust the spacenav control panel. However, that has to be balanced against spacenav working unususably differently when switching between LL, other TPVs, and Firestorm. In this case it would then be more complicated to configure the spacenav to work consistently in viewers, unless LL were to change the upstream behavior. There's pros and cons to each method. Aside from a possible code fix, the documentation above should get you up and running. Hope this makes sense, -A
          Hide
          xente Xente Aeon added a comment -

          I think your appreciations are very reasonable, Amehn. Perhaps it might be better do not touch the default settings in Firestorm and solve it with the Spacenavigator settings, freeing the switch settings for Firestorm and Phoenix if used simultaneously, or for other applications outside SL.
          For my part, I'll leave the matter as is, considering this affair solved.
          Thanks for your comments, I have been very useful.
          Best Regards

          Show
          xente Xente Aeon added a comment - I think your appreciations are very reasonable, Amehn. Perhaps it might be better do not touch the default settings in Firestorm and solve it with the Spacenavigator settings, freeing the switch settings for Firestorm and Phoenix if used simultaneously, or for other applications outside SL. For my part, I'll leave the matter as is, considering this affair solved. Thanks for your comments, I have been very useful. Best Regards
          Hide
          pokeitwithastick Terry O' added a comment -

          The 3DConnexion Spacenavigater controller does not work for me with FS 4.3.1 for Mac (Hybrid Mode) even with Xente's adjustments (although they are a distinct improvement over the out-of-the-box settings which are just plain crazy). There seems to be no way of toggling between avatar and cam movement - pushing the controller forward or pulling back both moves me and tilts the camera simultaneously. I've been tweaking variations on the settings both within FS and the 3DConnexion's Control Panel all afternoon, sometimes with quite hilarious effect (backflip handsprings, anyone?) but nothing yet approaching usability.

          Have there been any other updates/discussions on this issue since October? If anyone could point me to another resource for ironing out this problem it'd be much appreciated. Thanks!

          ~ Terry

          Show
          pokeitwithastick Terry O' added a comment - The 3DConnexion Spacenavigater controller does not work for me with FS 4.3.1 for Mac (Hybrid Mode) even with Xente's adjustments (although they are a distinct improvement over the out-of-the-box settings which are just plain crazy). There seems to be no way of toggling between avatar and cam movement - pushing the controller forward or pulling back both moves me and tilts the camera simultaneously. I've been tweaking variations on the settings both within FS and the 3DConnexion's Control Panel all afternoon, sometimes with quite hilarious effect (backflip handsprings, anyone?) but nothing yet approaching usability. Have there been any other updates/discussions on this issue since October? If anyone could point me to another resource for ironing out this problem it'd be much appreciated. Thanks! ~ Terry
          Hide
          xente Xente Aeon added a comment -

          Hi, Terry. I'm using happily the 3DConexion spacenavigator in FS 4.3.1. I tested it in the four modes (Firestorn, Hybrid, V3 and Phoenix) and it runs properly in the 4 options with the following adjustments.
          In the FS program, finally I let the adjustments as defect for Spacenavigator, checking "automatic level" and NOT checking direct zoom nor 3D cursor. (I'm using Firestorm in spanish and perhaps the English words I use here don't match exactly the English version). I let checked, of course, "Activate Spacenavigator".
          But, in the 3DSpacenavigator configuration I did only one change; only one but very important: go to configuration, device, and check the zoom direction with green arrows instead the one with blue arrows. (I diminish also a little the speed, you can try it as you like). I leave the other settings of 3D Spacenavigator as they are.
          With this adjustments it runs good in my case, with a Mac OSX 10.8.2. I hope this explanations can help you.

          Show
          xente Xente Aeon added a comment - Hi, Terry. I'm using happily the 3DConexion spacenavigator in FS 4.3.1. I tested it in the four modes (Firestorn, Hybrid, V3 and Phoenix) and it runs properly in the 4 options with the following adjustments. In the FS program, finally I let the adjustments as defect for Spacenavigator, checking "automatic level" and NOT checking direct zoom nor 3D cursor. (I'm using Firestorm in spanish and perhaps the English words I use here don't match exactly the English version). I let checked, of course, "Activate Spacenavigator". But, in the 3DSpacenavigator configuration I did only one change; only one but very important: go to configuration, device, and check the zoom direction with green arrows instead the one with blue arrows. (I diminish also a little the speed, you can try it as you like). I leave the other settings of 3D Spacenavigator as they are. With this adjustments it runs good in my case, with a Mac OSX 10.8.2. I hope this explanations can help you.

            People

            • Assignee:
              arrehn Arrehn Oberlander
              Reporter:
              arian Arian Botey Prat
            • Votes:
              2 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: