Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-19885

Music fades when various floaters open and close within the browser when "Loudness Equalization" is enabled.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Intended Behavior
    • Affects Version/s: Phoenix Firestorm 4.7.7, Phoenix Firestorm 4.7.9
    • Fix Version/s: Phoenix Firestorm 4.7.9
    • Component/s: Audio
    • Labels:
    • Environment:
    • SL Avatar Name:
      Thandi Rhiadra
    • Reported In:
      Firestorm 4.7.9.50527 Release

      Description

      I noticed this in 4.7.7.48706 but it persists in 4.7.9.50527 as well. When I open various floaters - it could be all floaters, but specifically with preferences, when I open the window, music fades for a while - possibly 30 seconds even. And again when the floater is closed, the music fades again. It doesn't disappear completely and fade back in like the random fading of music streams in SL right now, but it definitely affects the volume of the music. This is particularly noticeable when the music is at a low volume to begin with.

      ADDITIONAL INFORMATION: This music fade also occurs with the blue menus that pop up with group inventory offers, and when sitting on furniture with a menu that drops down.

      Steps to reproduce:

      Turn on music and lower the volume so that it's at an ambient level (like background while you're chatting in voice, for example)... fairly quiet.

      Open preferences window and listen to the music fade.

      Close preferences window and notice it fade again. It will fade even MORE if it hasn't returned to normal yet from being opened.

      It is difficult to discern the actual time the music is faded for and how long it takes to return to the set volume. It doesn't just 'bam' come back, it fades back in.

        Activity

        whirly.fizzle Whirly Fizzle added a comment -

        Heya Thandi,

        I'm unable to reproduce this problem so far.
        Do you notice this problem with any music stream or just a certain one?
        Does the problem happen at all locations?

        I suspect the problem may be triggered by a certain setting combination or ven certain audio hardware & drivers .
        Can I get your settings please so I can test using your exact set up.

        • Create a folder on your desktop named Firestorm_backup or similar.
        • While logged inworld, Go to Preferences -> Backup.
        • Set the backup path to the Firestorm _backup folder you just created.
        • Make sure all the check boxes are ticked.
        • Click the "Backup settings" button.
        • Open the Firestorm_backup folder & delete the file named bin_conf.dat - this file contains all your usernames & passwords, it's encrypted & can only be read on your system but delete it just to be safe.
        • Zip up the Firestorm_backup folder & attach it to this issue using More Actions -> Attach files.

        Thanks!

        thandi rhiadra Thandi Rhiadra added a comment -

        Here's the backup folder you requested, Whirly. I used a different avatar, but the problem exists on this one, as well.

        thandi rhiadra Thandi Rhiadra added a comment -

        The problem happens on seemingly all streams, including DJ streams and radio streams. It happens on multiple sims, though I can't say for certain ALL sims. It happens on the sim where I live (Papau West) which is a Second Life Server. It happens on Grendl (Second Life RC LeTigre 16.08.01.318271). It happens on City Plaza (Second Life Server 16.08.01.318271). I don't remember all the sims where it happened. But it happens on all the sims mentioned above for sure, and on multiple avatars I have. Thanks for looking into this.

        thandi rhiadra Thandi Rhiadra added a comment -

        There IS something I changed not too long ago, but I don't know if it coincides with the issue I'm having with my music in Second Life. I was unable to hear Game of Thrones when I was watching it online... it was WAY too quiet. My settings in Windows were maxed out for volume, so I ticked 'Loudness Equalization' in the playback devices section under enhancements. I was able to hear Game of Thrones finally and EVERYTHING became louder (including Second Life Sounds/Music/Voice, etc.) and elsewhere (like Skype). I will untick that and see if the problem resolves.

        thandi rhiadra Thandi Rhiadra added a comment -

        Well, that does resolve the issue. But it doesn't make sense that it would cause strange things to happen when I open floaters in SL. Hmmmm. I'll leave it off for now and see if it continues to fix the problem.

        whirly.fizzle Whirly Fizzle added a comment - - edited

        Huh yes!
        I can reproduce this when "Loudness equalization" is enabled in my speaker properties on Windows 7.

        This has actually solved a mystery, we have had a few other people report this.
        Now we know the probable cause

        I'm pretty sure this isn't a bug as such in the viewer.
        I'll leave this open for the devs to verify & edit the title now we know the cause.

        Good find Thandi!

        whirly.fizzle Whirly Fizzle added a comment -

        Same reproduces on the LL viewer: Second Life 4.0.7.318301 (Second Life Release)

        whirly.fizzle Whirly Fizzle added a comment -

        Liny confirmed this is expected behaviour.
        Some geek reading: https://en.m.wikipedia.org/wiki/Dynamic_range_compression


          People

          • Assignee:
            Unassigned
            Reporter:
            thandi rhiadra Thandi Rhiadra
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: