Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-20280

Multiple Avatar Physics possible, that will then break an outfit

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 4.7.9, Phoenix Firestorm 4.7.10
    • Fix Version/s: Phoenix Firestorm 4.7.10
    • Component/s: Avatars, Inventory
    • Labels:
    • Environment:
    • SL Avatar Name:
      CaithLynnSayes Resident
    • Reported In:
      Firestorm 4.7.9.50527 Release

      Description

      Steps to Reproduce

      1. Set "Add objects on double click" and "Add clothing on double click" in your Inventory settings by clicking on the gear icon.
      2. Find a few Avatar Physics in your inventory.
      3. Double click one.
      4. Double click an other one
      5. Click some more if you have.
      6. Open your Appearance window and click the "Wearing" tab
      7. Observe multiple Avatar Physics being listed, and actually worn.

      Additional Information

      You can only detach the multiple worn physics in order of attachment in the "wearing" tab. the "take off" option in the menu when right clicking will be grayed out if you try to detach one before the last you attached. so you have to trace back the order of attachment.

      Important Information

      When you save an outfit with multiple Avatar Physics worn, it will break that outfit. It will only partially load and then get stuck. You won't be able to wear an other outfit because the menu for werling an other outfit will be grayed out as the viewer thinks the outfit is still loading. A relog is the only solution.

        Activity

        CaithLynnSayes Caith Lynn added a comment -

        Not sure why this is a SUP, if possible, can this be change to a (public) BUG? Thanks

        whirly.fizzle Whirly Fizzle added a comment -

        Reproduced everything on Firestorm 4.7.10 (51624) Oct 26 2016 20:12:38 (Firestorm-FizzlefireBENTOx64) with OpenSimulator support apart from the part under "Important Information".

        whirly.fizzle Whirly Fizzle added a comment -

        Doesn't reproduce on Second Life 4.1.2.320804 (Second Life Release)
        Double click on a wearable on the LL viewer always wears not adds.

        I'll move this over to FIRE.

        willow wilder Willow Wilder added a comment -

        If you look in Current Outfit, only 1 of the physics layers is actually (worn) which, when you 'take off' activates another physics layer which you can then 'take off'.
        I also didn't experience the outfit being broken.
        Using Firestorm 4.7.10 (51526) Oct 14 2016 18:35:57 (Firestorm-bentox64) with OpenSimulator support

        ansariel.hiller Ansariel Hiller added a comment -

          People

          • Assignee:
            ansariel.hiller Ansariel Hiller
            Reporter:
            CaithLynnSayes Caith Lynn
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: