Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-3868

[SH] Alpha clothing layers not behaving properly on FSOGL

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Waiting on Linden Lab fix
    • Affects Version/s: Phoenix Firestorm 3.2.2
    • Fix Version/s: Phoenix Firestorm 3.3.0
    • Component/s: None
    • Labels:
    • Environment:
    • SL Avatar Name:
      Lette Ponnier
    • Reported In:
      Firestorm OGL 3.2.1.24119

      Description

      Most worn alpha layers do not behave correctly, as illustrated in the attached pictures. In some cases, they hide much more than the intended/expected area, such as the face or entire upper body vanishing when a foot alpha is worn. It isn't especially predictable – out of about a dozen alpha layers, two did what they were supposed to. The others exhibited this strange behavior, with the face disappearing being the most common problem.

      This occurs at the wearer's side. It looks the same whether viewed from FSOGL or a non-Shining viewer such as Phoenix. In the pictures provided, the two avatars are wearing copies of the same alpha layer. The alphas look correct on the avatar in Phoenix but not on the avatar in FSOGL (the alphas previously behaved correctly in all non-FSOGL versions of Firestorm). In the "001" picture, the alpha should cover just hands and feet. In the "002" picture, it should cover just the feet and legs below the knees.

      It happens on LL's latest Shining build as well: https://jira.secondlife.com/browse/SH-2240?focusedCommentId=293790&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-293790

      1. 2011 1110_001-fsogl alpha.jpg
        100 kB
      2. 2011 1110_002-fsogl alpha.jpg
        92 kB
      3. Closer of Top 1:2 of AV Poofs After Trying To Wear An Alpha Layer.jpg
        40 kB
      4. jacket layer w blank tex.jpg
        70 kB
      5. shoe layer on non-shining.jpg
        73 kB
      6. shoe layer on shining.jpg
        86 kB
      7. Snapshot _ Sixx Pack (Ladies Only) Male dancers Male strippers,.jpg
        63 kB

        Issue Links

          Activity

          lette Lette Ponnier added a comment -

          I have found a workaround for this issue.

          If I wear the alpha, go into Edit, and then add any solid texture to the parts of the alpha mask that do not have an alpha texture already applied to it, then the vanished parts of my body come back into view.

          That is, the problem seems to be in the way the viewer is applying blank textures to the alpha mask.

          To explain in more detail:
          1) I wear an alpha layer intended to hide only the feet and find that it makes my avatar's entire upper body disappear as well.
          2) I go into Edit Appearance to edit the alpha mask.
          3) The alpha mask has a texture in the "Lower Alpha" box but not the other four.
          4) I add a texture – any solid, non-alpha texture at all – to each of the four unspecified boxes (Upper, Head, Eye, and Hair Alpha).
          5) My head, eyes, and upper body appear. Stays fine when I exit Appearance mode.

          I can use this workaround in case a fix isn't possible, but it obviously won't work when the alpha is not modifiable. If the issue has to do with the way that blank textures are interpreted on the alpha mask, as the workaround implies, then I'm not sure why it would only affect me (or possibly other people who haven't tried the development viewers yet). But it is a clue.

          I tested this on the Linden viewer, confirmed it on Firestorm (though on Firestorm it seems to require an extra rebake).

          Currently using: Firestorm 3.2.1 (24202) Nov 13 2011 01:17:07 (Firestorm-FSOGL)

          whirly.fizzle Whirly Fizzle added a comment -
          lette Lette Ponnier added a comment -

          I was in contact with LL on this via SH-2679 for a while, but judging by Leslie Linden's comment of November 21, they probably are not going to be working actively on it anymore unless there is new information.

          The issue is still going on in Firestorm 3.2.2.24217. Is there any way possible to fix this at Firestorm's end?

          Here's what I've been able to figure out:

          1. It does not occur on an empty texture cache. If I log in after a clean install of the viewer, everything is ok until I've relogged. If I clear the texture cache again, everything will behave normally until my next relog, but any relog without a texture cache clear will result in the issue recurring. Inventory cache can remain full (thank goodness), but texture cache needs to stay empty for normal viewer functioning, which of course defeats the purpose of having a cache and is unacceptable as a long-term solution.

          2. In addition, HTTP Textures needs to remain enabled. Disabling HTTP Textures results in the same behavior as failing to clear texture cache prior to login.

          3. The issue is most noticeable with alpha masks, but it has sporadic effects with other types of clothing, such as shoe bases and jacket layers. The common factor is a failure to properly bake blank textures:

          3a. If the parts of the alpha textures that normally contain blank textures are replaced with solid textures, they end up baking correctly.

          3b. Shoe bases that use blank textures instead of transparent textures bake white. If the blank textures are replaced with transparent, the shoe bases bake normally. A jacket layer with outlines that don't conform to the line of its regular texture also bakes white in the blank parts. I haven't found a moddable jacket with this behavior yet, so I haven't been able to test, but I expect that replacing the blank texture with transparent would fix the issue as well.

          4. All of these behaviors can be observed with items straight from the Library. They have nothing to do with where the items come from. I've tested on two accounts, several LL and FS builds, and two different connections. The only common threads are the presence of blank textures and (so far) my computer.

          Why it's just me so far, I don't know. But it has to do with the Shining/OGL "fixes" and involves the caching and baking of blank textures. Until/unless this is fixed, there will be a chunk of my inventory I won't be able to use without clearing my texture cache prior to every login on which I want to use it. If this could be addressed for Firestorm it would be fabulous, especially if there are related issues affecting others but not as visibly.

          lette Lette Ponnier added a comment -

          5. In case it's not clear elsewhere, this is not a problem with how I view these things, it's a problem with how I bake. When viewed by someone on an unaffected non-Shining, non-OGL viewer, the other person sees my avatar the way I do.

          lette Lette Ponnier added a comment -

          Adding pics here that applied to the SH I had open, illustrating what the blank texture issue looks like on layers other than alphas.

          princessroxy91 Roxy Cavalieri added a comment -

          I'm having this issue too, grr so frustrating. The top appeard for a little bit but then crashed.

          lette Lette Ponnier added a comment -

          Roxy's system info:

          irestorm-Release 3.2.2.24336
          Sim: sim20250.agni.lindenlab.com(216.82.27.25:13003) Second Life Server 11.11.14.245108
          Packet loss: 1.09835% (872/79392)
          CPU: Intel(R) Core(TM)2 Duo CPU P8700 @ 2.53GHz (2530 MHz)
          Memory: 4096
          OS: Mac OS X 10.5.8 Darwin 9.8.0 Darwin Kernel Version 9.8.0: Wed Jul 15 16:55:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_I386 i386
          GPU: NVIDIA Corporation NVIDIA GeForce 9400M OpenGL Engine
          OpenGL: 2.0 NVIDIA-1.5.48
          Skin: firestorm(grey)
          Mode: Phoenix
          Font: Deja Vu
          Fontsize: 0
          Font screen DPI: 96
          Draw distance: 128
          Bandwidth: 1000
          LOD Factor: 2
          RLV: (disabled)
          Curl: libcurl/7.21.1 OpenSSL/0.9.8q zlib/1.2.5 c-ares/1.7.1
          J2C: KDU
          Audio: FMOD version 3.750000
          Webkit: 4.7.1 (version number hard-coded)
          Voice: Vivox 2.1.3010.6270
          Compiler: GCC Version 40201

          whirly.fizzle Whirly Fizzle added a comment -

          Duplicate issue FIRE-4115 is also mac user

          infinite mode Infinite Mode added a comment -

          I'm having the same issue with 3.2.2. With both "render alpha with/without light and shadow boxes" checked in low graphics settings the alpha doesn't function at all. The alphas don't show up until HIGH graphics settings and then when I rebake my face disappears! My info is listed below.

          Firestorm-Release 3.2.2.24336
          Sim: sim3545.agni.lindenlab.com(216.82.19.152:13000) Second Life RC KT 11.11.09.244706
          Packet loss: 0.622326% (80/12855)
          CPU: Intel(R) Core(TM)2 CPU T7400 @ 2.16GHz (2160 MHz)
          Memory: 2048
          OS: Mac OS X 10.5.8 Darwin 9.8.0 Darwin Kernel Version 9.8.0: Wed Jul 15 16:55:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_I386 i386
          GPU: ATI Technologies Inc. ATI Radeon X1600 OpenGL Engine
          OpenGL: 2.0 ATI-1.5.48
          Skin: firestormsidetabs(grey)
          Mode: Hybrid
          Font: Deja Vu
          Fontsize: 0
          Font screen DPI: 96
          Draw distance: 128
          Bandwidth: 1000
          LOD Factor: 2
          RLV: (disabled)
          Curl: libcurl/7.21.1 OpenSSL/0.9.8q zlib/1.2.5 c-ares/1.7.1
          J2C: KDU
          Audio: FMOD version 3.750000
          Webkit: 4.7.1 (version number hard-coded)
          Voice: Vivox 2.1.3010.6270
          Compiler: GCC Version 40201

          kerri fegte Kerri Fegte added a comment -

          I'm not sure what to write that will be helpful here, but I'm having this same issue.

          Specifically when I were an alpha layer intended for shoes, it also removes my upper torso, arms, head and eyes.

          I did notice that it worked initially (right after the clean install of FS3.2.2) but not after a relog.

          olga wunderlich Olga Wunderlich added a comment -

          Okay, I was told to add my Firestorm specifics here. I have that bug, it looks like the picture #2 if I wear an alpha layer that is supposed to hide only the feet. The whole upper body becomes invisible. It started happening when I changed clothes. Before changing clothes things looked fine. I am on Mac Os 10.5.8

          Here the details:
          Firestorm 3.2.2 (24336) Nov 27 2011 16:12:10 (Firestorm-Release)
          Versionshinweise

          Sie befinden sich in 262287.0, 251938.0, 14.9 in Jergans auf sim9249.agni.lindenlab.com (216.82.42.185:13021)
          Second Life Server 11.11.09.244706
          Versionshinweise

          CPU: Intel(R) Core(TM)2 Duo CPU T9300 @ 2.50GHz (2500 MHz)
          Speicher: 4096 MB
          Betriebssystem, Version: Mac OS X 10.5.8 Darwin 9.8.0 Darwin Kernel Version 9.8.0: Wed Jul 15 16:55:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_I386 i386
          Grafikkarten-Hersteller: NVIDIA Corporation
          Grafikkarten: NVIDIA GeForce 8600M GT OpenGL Engine

          OpenGL Version: 2.0 NVIDIA-1.5.48

          Viewer Skin: firestorm (grey)
          RestrainedLove API: (disabled)
          libcurl-Version: libcurl/7.21.1 OpenSSL/0.9.8q zlib/1.2.5 c-ares/1.7.1
          J2C-Decoderversion: KDU
          Audio-Treiberversion: FMOD version 3.750000
          Qt Webkit-Version: 4.7.1 (version number hard-coded)
          Voice-Serverversion: Nicht verbunden
          Settings mode: Phoenix
          Viewer Skin: firestorm (grey)
          Font Used: Deja Vu (96)
          Draw distance : 128
          Bandwidth : 1000
          LOD factor : 2
          Kompiliert mit GCC version 40201
          Paketverlust: 6/50651 (0.0%)

          olga wunderlich Olga Wunderlich added a comment -

          [05:16] Olga Wunderlich: (FS 3.2.1) Okay, I am back on 3.2.1.24179, I have cleared application support and caches and installed this version, the alpha layer problem still consists.

          New info settings:
          Firestorm 3.2.1 (24179) Nov 27 2011 14:39:32 (Firestorm-Release)
          Versionshinweise

          Sie befinden sich in 262287.0, 251938.0, 14.9 in Jergans auf sim9249.agni.lindenlab.com (216.82.42.185:13021)
          Second Life Server 11.11.09.244706
          Laden...

          CPU: Intel(R) Core(TM)2 Duo CPU T9300 @ 2.50GHz (2500 MHz)
          Speicher: 4096 MB
          Betriebssystem, Version: Mac OS X 10.5.8 Darwin 9.8.0 Darwin Kernel Version 9.8.0: Wed Jul 15 16:55:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_I386 i386
          Grafikkarten-Hersteller: NVIDIA Corporation
          Grafikkarten: NVIDIA GeForce 8600M GT OpenGL Engine

          OpenGL Version: 2.0 NVIDIA-1.5.48

          Viewer Skin: firestorm (grey)
          RestrainedLove API: (disabled)
          libcurl-Version: libcurl/7.21.1 OpenSSL/0.9.8q zlib/1.2.5 c-ares/1.7.1
          J2C-Decoderversion: KDU
          Audio-Treiberversion: FMOD version 3.750000
          Qt Webkit-Version: 4.7.1 (version number hard-coded)
          Voice-Serverversion: Vivox 2.1.3010.6270

          Settings mode: Phoenix
          Viewer Skin: firestorm (grey)
          Font Used: Deja Vu (96)
          Draw distance : 96
          Bandwidth : 1000
          LOD factor : 2
          Kompiliert mit GCC version 40201
          Paketverlust: 43/11350 (0.4%)

          --------
          Great, and now the whole world knows my computer settings :/

          olga wunderlich Olga Wunderlich added a comment -

          Sorry, I have to add, after a relog and changed clothes, the problem is gone.
          Using 3.2.1.24179 Firestorm.
          Cheers Olga

          whirly.fizzle Whirly Fizzle added a comment -

          Thanks for adding your info Olga.
          You wouldnt have seen the fix on the 3.2.1 build until your avatar rebaked. You can speed this up by using CTRL+ALT+R
          Glad all is well for you on 3.2.1.

          charon Johan Thorstensson added a comment -

          Just adding that I too have this issue.

          Firestorm 3.2.2 (24336) Nov 27 2011 16:12:10 (Firestorm-Release)
          Release Notes

          You are at 242244.0, 264367.0, 26.8 in Husky Isle located at sim8081.agni.lindenlab.com (216.82.37.148:13000)
          Second Life RC KT 11.11.09.244706
          Release Notes

          CPU: Intel(R) Core(TM)2 Duo CPU T9300 @ 2.50GHz (2500 MHz)
          Memory: 4096 MB
          OS Version: Mac OS X 10.5.8 Darwin 9.8.0 Darwin Kernel Version 9.8.0: Wed Jul 15 16:55:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_I386 i386
          Graphics Card Vendor: NVIDIA Corporation
          Graphics Card: NVIDIA GeForce 8600M GT OpenGL Engine

          OpenGL Version: 2.0 NVIDIA-1.5.48
          RestrainedLove API: (disabled)
          libcurl Version: libcurl/7.21.1 OpenSSL/0.9.8q zlib/1.2.5 c-ares/1.7.1
          J2C Decoder Version: KDU
          Audio Driver Version: FMOD version 3.750000
          Qt Webkit Version: 4.7.1 (version number hard-coded)
          Voice Server Version: Vivox 2.1.3010.6270

          Settings mode: Phoenix
          Viewer Skin: firestorm (grey)
          Font Used: Deja Vu (96)
          Draw distance : 128
          Bandwidth : 2000
          LOD factor : 2
          Built with GCC version 40201
          Packets Lost: 1111/75152 (1.5%)

          lindsaypinelli Lindsay Pinelli added a comment - - edited

          I am having the same issue. My specs are almost as the ones shown in the other comments. It also happens on 3.22. Nothing helps, rebaking, clearing caches and relogging, nothing accept not wearing shoes period. Attempting to attach a picture. aaaand forgot to change the name of the pic dies rofl. Also note the 2 lines on my viewer. That does not happen on any other.

          Firestorm 3.2.1 (24179) Nov 27 2011 14:39:32 (Firestorm-Release)
          Release Notes

          CPU: Intel(R) Core(TM)2 Duo CPU E8135 @ 2.66GHz (2660 MHz)
          Memory: 4096 MB
          OS Version: Mac OS X 10.5.8 Darwin 9.8.0 Darwin Kernel Version 9.8.0: Wed Jul 15 16:55:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_I386 i386
          Graphics Card Vendor: NVIDIA Corporation
          Graphics Card: NVIDIA GeForce 9400 OpenGL Engine

          OpenGL Version: 2.0 NVIDIA-1.5.48
          RestrainedLove API: RLV v2.7.0 / RLVa v1.4.3a
          libcurl Version: libcurl/7.21.1 OpenSSL/0.9.8q zlib/1.2.5 c-ares/1.7.1
          J2C Decoder Version: KDU
          Audio Driver Version: FMOD version 3.750000
          Qt Webkit Version: 4.7.1 (version number hard-coded)
          Voice Server Version: Not Connected
          Settings mode: Phoenix
          Viewer Skin: firestorm (grey)
          Font Used: Deja Vu (96)
          Draw distance : 264
          Bandwidth : 6000
          LOD factor : 4
          Built with GCC version 40201

          nicci cerise nicola neal added a comment -

          also have this problem im useing mac, i cant use firestorm only phoenix 1185

          roxmarie Rox Marie added a comment -

          I'm having the same problem described above. Adding a foot alpha makes my avatar's torso, face, and arms disappear.

          Firestorm 3.2.2 (24336) Nov 27 2011 16:12:10 (Firestorm-Release)
          Release Notes

          You are at 166941.0, 230588.0, 21.5 in New Toulouse Bayou located at sim2583.agni.lindenlab.com (216.82.4.20:12035)
          Second Life Server 12.01.06.247303
          Error fetching server release notes URL.

          CPU: Intel(R) Core(TM)2 Duo CPU P7350 @ 2.00GHz (2000 MHz)
          Memory: 4096 MB
          OS Version: Mac OS X 10.5.8 Darwin 9.8.0 Darwin Kernel Version 9.8.0: Wed Jul 15 16:55:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_I386 i386
          Graphics Card Vendor: NVIDIA Corporation
          Graphics Card: NVIDIA GeForce 9400M OpenGL Engine

          OpenGL Version: 2.0 NVIDIA-1.5.48
          RestrainedLove API: (disabled)
          libcurl Version: libcurl/7.21.1 OpenSSL/0.9.8q zlib/1.2.5 c-ares/1.7.1
          J2C Decoder Version: KDU
          Audio Driver Version: FMOD version 3.750000
          Qt Webkit Version: 4.7.1 (version number hard-coded)
          Voice Server Version: Vivox 2.1.3010.6270

          Settings mode: Phoenix
          Viewer Skin: firestorm (grey)
          Font Used: Deja Vu (96)
          Draw distance : 96
          Bandwidth : 100
          LOD factor : 2
          Built with GCC version 40201
          Packets Lost: 315/25094 (1.3%)

          arrehn Arrehn Oberlander added a comment -

          This is a macosx 10.5 specific issues, and it looks like it will not be resolved by LL. If you're affected, upgrading to macosx 10.6 should fix you.

          chrysfox Chrystina Foxdale added a comment -

          Frankly, I don't think forcing an OS upgrade should be called 'resolved', especially when it seems that LL HAS possibly sorted it out for 10.5.8 users as of 4-6 Feb

          https://jira.secondlife.com/browse/SH-2679

          whirly.fizzle Whirly Fizzle added a comment - - edited

          Hi Chrystina,

          Theres no fix been done by LL for SH-2679 as such, but its possible this was fixed as a side effect of some other changes they made. If this is the case, then Firestorm will automatically pick up those changes too on the next merge up to the V3 codebase.
          Have you tested with Viewer 3 since the other person reported they no longer had the issue? Please let us know if its also fixed for you there.
          Thanks!

          chrysfox Chrystina Foxdale added a comment -

          As of Firestorm 3.3.0 (24880) I'm still getting the vanishing face/body syndrome.
          I believe the fix was reported on a beta version of V3, which is informing me it can't/won't open.
          *********
          In V3 [Second Life 3.2.1 (244864) Nov 10 2011 10:43:02 (Second Life Release)], wearing the same alpha (no hands & no lower legs) and both the Library NoFeet alpha and several regular no-mod boot/shoe alphas, I'm all there except the parts that are supposed to be missing.
          BUT ---- in the latest download [Second Life 3.2.8 (248931) Feb 9 2012 09:07:27] it all goes missing again, unless I put on a 'fixed' alpha.

          **************
          I can fix it, in FS, by adding a texture (any texture, it seems - I've used plywood, linen and rubber from the Library) to the NON-alpha sections in the "edit appearance" window. It seems that any untextured spot is being interpreted as nothingness. That fix seems to work for the latest V3 also.

          ====================
          Second Life Server 12.02.06.248938

          CPU: Intel(R) Core(TM)2 Duo CPU E8435 @ 3.06GHz (3060 MHz)
          Memory: 4096 MB
          OS Version: Mac OS X 10.5.8 Darwin 9.8.0 Darwin Kernel Version 9.8.0: Wed Jul 15 16:55:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_I386 i386
          Graphics Card: NVIDIA GeForce GT 130 OpenGL Engine
          OpenGL Version: 2.0 NVIDIA-1.5.48
          libcurl Version: libcurl/7.21.1 OpenSSL/0.9.8q zlib/1.2.5 c-ares/1.7.1
          J2C Decoder Version: KDU
          Audio Driver Version: FMOD version 3.750000
          Qt Webkit Version: 4.7.1 (version number hard-coded)
          Settings mode: Hybrid
          Viewer Skin: vintage (classic)
          Font Used: Liberation (96)
          Draw distance : 128 Bandwidth : 900 LOD factor : 4
          Built with GCC version 40201

          chrysfox Chrystina Foxdale added a comment -

          Addendum: It seems that the default 'blank' texture no longer exists as a nice white empty surface, but rather as a blank grey space that doesn't seem as if it can be applied to anything. Related ?

          chrysfox Chrystina Foxdale added a comment -

          Not a CLUE why or how it works, but I've managed to find a possible fix for this.

            Using Dolphin Viewer, I can click a blank-textured (the 'missing/blank should be white' texture) object, and choose "Texture Refresh" and that seems to have cured it for ALL objects using that texture without a change of OS. This has held through multiple log-ins over 2 week period.

            Also, when I put on a new-to-me, no-mod alpha layer, my body instantly vanished, as expected. Much to my surprise, I clicked on the empty space where I should have been (without much hope), and >POP< there I was, complete again. It doesn't seem to work for all my no-mod alphas, but it does for about 50% of them

           This isn't Rebake Textures, it's in the right-click touch menu dropdown on objects and people.

          As I said, I don't know why, but it's a step in the right direction.


            People

            • Assignee:
              shouldbeworkingonit.linden ShouldBeWorkingOnIt Linden
              Reporter:
              lette Lette Ponnier
            • Votes:
              6 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: