Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-4043

Right click pie menu doesn't work in full screen mode on Mac

    Details

    • Type: Bug
    • Status: Passed QA
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 3.2.1, Phoenix Firestorm 3.2.2
    • Fix Version/s: Phoenix Firestorm 4.5.0
    • Component/s: None
    • Labels:
      None
    • Environment:
    • SL Avatar Name:
      Trecool Resident
    • Reported In:
      Firestorm 3.2.2.24336 Release

      Description

      Right click pie menu does not work when in full screen mode. Fine in norml window mode.

        Issue Links

          Activity

          whirly.fizzle Whirly Fizzle added a comment - - edited

          Unable to reproduce on Firestorm 4.0.1 (24196), Windows Vista 32 bit, FS Grey skin
          Please can someone else test on Mac?

          lette Lette Ponnier added a comment - - edited

          I can confirm that the pie menu isn't working in fullscreen mode on a Mac. When I right-click on something, it flashes visible briefly, sits me on whatever I'm clicking on (or says it can't seat me), and then disappears.

          The context menu works properly.

          OSX 10.5.8, Metaharper Modern skin. v3.2.1.24179

          ziree Zi Ree added a comment -

          Sounds like mouse coordinates are non-functional on mac in fullscreen ... at least the way I use them. I'll try to find a way to get more data on this one, but since I have no mac this can be tricky.

          whirly.fizzle Whirly Fizzle added a comment -

          Is this still an issue on FUI builds?

          tonya Tonya Souther added a comment -

          Yes, it is. When right-click is held, either the upper left segment of the pie is selected (the "Sit Here" segment), or none at all, at least in my testing. If the Sit Here segment is selected, then the avatar sits wherever right-click was used when the mouse button is released; if nothing is selected, then moving the mouse has no effect on the menu at all no matter where it's moved. Context menus work fine.

          This test is on Lion, OS X 10.7.3. I won't be able to test on Snow Leopard for a few days, or to build test versions.

          chaeli eyre Cherry Smith added a comment -

          I didn't know that on a mac it is borked, no one else mentioned it on here. And I thought why am I the only one having this issue?! Mine is OS X snow leopard. Its awful it always makes the "sit here" segment selected and nothing else. Plus when I right click in inventory to detach an object the drop down menu instantly disappears. This is an annoyance also when trying to unpack boxes in sandboxes.

          bakoocello bako added a comment -

          Same problem here with FS 4.2.2 on OSX 10.7.4 (lion). If I could test or do anything, let me know. Because its a very annoying bug.

          vancefburton Vance Burton added a comment -

          Not sure if this helps BUT I use the non-pie menu and it also disappears but it IS possible to HOLD right click and navigate down the menu to the selection of choice, which works.

          Only a workaround, I appreciate, but better than nothing until fixed.

          lillyteardrop Lilly Teardrop added a comment -

          No working pie menu for me too in fullscreen mode. Mid 2012 MacBook Pro 15, same on trackpad and magic mouse. Please resolve, still using Phoenix for months while this problems exists...

          lillyteardrop Lilly Teardrop added a comment -

          Thanks for hint with deactivating pie menu. Now it works in fullscreen

          vancefburton Vance Burton added a comment -

          You're welcome, Lilly. A proper fix would still be nice though?

          cinderblocks Cinder Biscuits added a comment -

            People

            • Assignee:
              cinderblocks Cinder Biscuits
              Reporter:
              trecool Tony
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: