Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-4396

[VWR-28498] [MAINT-762] Prim Edit mode rotation guides not showing in every instance of editing a prim, on multiple sim, while worn and on the ground editing.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 3.2.2, Phoenix Firestorm 3.3.0, Phoenix Firestorm 4.0.1, Phoenix Firestorm 4.1.1
    • Fix Version/s: Phoenix Firestorm 4.6.9
    • Component/s: None
    • Labels:
    • Environment:
    • SL Avatar Name:
      Shey Tiratzo
    • Reported In:
      Firestorm 3.2.2.24336 Release

      Description

      While I am editing any prim or prim link and press Ctrl to use the rotation edit mode the guides that are color coded Red, green, blue do not show. Only the transparent cirlce that is the background for the guides shows when I press Ctrl or select the radial button for rotation edit. I have duplicated this issue on many sims, while editing single prims and linked sets worn and when they are on the "ground". This issue happens at random. All other colored guides can be seen when using the other edit modes of move and align.

      EDIT (Whirly): https://jira.secondlife.com/browse/VWR-28498
      https://jira.secondlife.com/browse/MAINT-762

        Issue Links

          Activity

          whirly.fizzle Whirly Fizzle added a comment -

          Ive had another couple of people report this & they too said it was intermittant. Only seems to happen on 3.2.2, not 3.2.1.

          whirly.fizzle Whirly Fizzle added a comment - - edited

          see also FIRE-4440 for a detailed description of this issue.

          thandi rhiadra Thandi Rhiadra added a comment - - edited

          Yes, it is only on 3.2.2 that I get this issue. It only surfaced (and I've never stopped trying to rotate prims in all these years... ha ha) when I downloaded and installed and more importantly USED the Official Release of Firestorm. Thanks for asking for the clarification. It also does not happen on the latest (as I was forced to update when I logged in to check this issue) SL 3 version. Just an FYI. The issue at first seemed to affect only sculpted prims, but I discovered that wasn't the case a few days ago... affects all prims regardless of sculpted or not, regardless of texture (alpha or not). Thanks Whirly! Go get 'em tigress!

          whirly.fizzle Whirly Fizzle added a comment -

          Related LL JIRA: https://jira.secondlife.com/browse/SH-2508
          This is marked as fixed but I just saw a user on a version of V3 containing the fix that still had this problem.

          thandi rhiadra Thandi Rhiadra added a comment -

          So are you saying that LL's V3 viewer still contains this issue? I wasn't able to reproduce it when using Second Life 3.2.5 (246559). Is this a Linden Labs issue or a viewer issue? You know how LL fails to 'hear' users of third party viewers. I went to the SL jira using that link and I wouldn't know what to comment there since I don't know whose issue this is really. Help! I will gladly comment there if it's a Linden Labs issue. You don't have to twist MY arm! ha ha!

          whirly.fizzle Whirly Fizzle added a comment -

          Unsure yet Thandi. I just happened to see someone on Latest V3 release in a building group with this issue. She went off to try the V3 beta but I didnt hear back from her.

          freewee FreeWee Ling added a comment -

          I am also experiencing this problem and it's highly annoying. It is intermittent, BUT it happens more often than not in my experience. I have not been able to determine any obvious circumstances in which it it consistently there or not there. Using Firestorn 3.2.24336 on a 64-bit Win7 machine with ASUS EAH 6850 display adapter running 3 monitors. Firestorm on the central (primary) monitor. It's disruptive enough that I'm considering switching to the SL viewer (which I would really hate to do).

          harm xue Harm Xue added a comment - - edited

          I managed to reproduce this issue.
          Editing a prim cuff, camera Alt locked on the cuff, if i zoom close there are no guides showing, as i start to zoom out, after a while they begin to show.
          If i lock the camera on the floor, i can zoom as close as i want and the guides stay.
          It's a similar behavior as it happens when you zoom into a prim, when you have disable camera constrains on, the prim slowly begins to vanish as you zoom into it and reappear when you zoom out. Same with the guides for rotation.

          Edit to add: On Firestorm 3.2.2.24336

          thandi rhiadra Thandi Rhiadra added a comment -

          For me this issue has nothing to do with alt+zoom. When I'm editing prims, whether on my avi or rezzed prims, I don't use alt zoom. I simply 'edit' and 'rotate'. This issue occurs whether I'm zooming in or out. When I 'move' the prim, sometimes it takes several tries, but usually the rotation guides do appear. It seems that moving the prims far enough away from other prims solves the problem. This isn't always possible, however, such as in prims I'm wearing. And even though it 'solves' the problem, it takes an inordinate amount of time to move and check for the rotation guides then move some more and check for rotation guides again, etc. Still, I wanted to point out that at no time was I using alt+zoom. If I did zoom in, it was using my scroll wheel, and I don't usually even do that.

          molokai sharkfin Molokai Sharkfin added a comment -

          I have the same issue and found moving the prim away helped, but if I am trying to match something up with another prim, it is painfully difficult.

          gman74 Sean McNeil added a comment -

          To add,this is not an issue with just 3.2.2. I downloaded and installed the release version of FS within days of it coming out and had the problem surface immediately. At that time I threw my arms up in frustration and went back to Beta which never has this problem occur. With in the last hour of posting this I tried the most recent release of FS (3.3.0.24880) and had the same problem surface again. I had hoped by waiting this long this bug would be squashed but apparently not. :/ At any rate I saw mention that it was in 3.2.2 and not 3.2.1 and wanted to make folks aware it has been present since going from beta to release for some of us.

          tattoo lane Tattoo Lane added a comment -

          This was happening to me in November last year, then it fixed itself somehow - or your magicians fixed it. Its now happening to me again. Any time I try to rotate a prim all I get is a clear bubble.

          thandi rhiadra Thandi Rhiadra added a comment -

          I thought it might've been miraculously fixed with the newest viewer because for two days, I could rotate anything I wanted to without having the issue. But I wasn't actually 'building', just randomly trying to rotate things on the sim. But once I started actually NEEDING to rotate things, the issue resurfaced. I'm so glad to know it's 'future fixed' (smiles) ... Yay!

          krahazik Benjamin Swem added a comment -

          I have begun seeing this same issue with my version of Firestorm. As a builder this is intolerable. I can no-longer rotate prims correctly.

          Firestorm 4.0.1 (27000) Mar 19 2012 16:21:21 (Firestorm-Release)
          Release Notes

          CPU: AMD A4-3300 APU with Radeon(tm) HD Graphics (2500 MHz)
          Memory: 2046 MB
          OS Version: Microsoft Windows 7 32-bit Service Pack 1 (Build 7601)
          Graphics Card Vendor: ATI Technologies Inc.
          Graphics Card: AMD Radeon HD 6670

          Windows Graphics Driver Version: 8.17.0010.1107
          OpenGL Version: 4.2.11318 Compatibility Profile Context

          RestrainedLove API: RLV v2.7.0 / RLVa v1.4.5a
          libcurl Version: libcurl/7.21.1 OpenSSL/0.9.8q zlib/1.2.5 c-ares/1.7.1
          J2C Decoder Version: KDU
          Audio Driver Version: FMOD version 3.750000
          Qt Webkit Version: 4.7.1 (version number hard-coded)
          Voice Server Version: Not Connected
          Settings mode: Hybrid
          Viewer Skin: firestorm (dark)
          Font Used: Droid Sans (96)
          Draw distance : 224
          Bandwidth : 500
          LOD factor : 2.75
          Built with MSVC version 1600

          thandi rhiadra Thandi Rhiadra added a comment -

          temporary work around: still a pain in the butt, but...

          when you find you cannot get the guides for rotation, move the prim upwards a tiny bit and position your camera below the arrows for movement and then switch to rotate. i've been able to get the rings to appear that way.

          thandi rhiadra Thandi Rhiadra added a comment -

          still not resolved in Firestorm 4.1.1 (27155) Apr 21 2012 03:21:17 (Firestorm-private-devFS32).

          i thought it was fixed, but alas, it isn't... sighs... please fix this. it's entirely maddening to have to NOT be able to rotate without moving the prim upwards (see the trick i posted above) ... it results in several extra steps to put the prim back into the proper place after rotating it.

          it's either that or log in on Phoenix simply to be able to build. that's unacceptable

          kally skytower Kalleigh Fallen added a comment -

          first time i've experienced this.... ugh!!

          sculls evermore Sculls Evermore added a comment - - edited

          first time for me too! and i cant get it to go away – What to do ? Clean install? ( on Firestorm 4. 0. 1. 27000)

          thandi rhiadra Thandi Rhiadra added a comment -

          Sculls and Kalleigh... if it's the same thing happening to me, I've heard that it's a bug relating to ATI graphics cards (which I have ... ATI Radeon HD 5770). It happens to me often enough to make it maddening, since I'm a builder and often have to rotate things. It's most frustrating when it comes to editing prims on my own body, however - belts, shoes, hair, necklaces, etc.

          The work around that I've discovered is a bit frustrating to have to go through, but it IS 100% effective!

          When you want to rotate a prim and you aren't getting the red, green, and blue guides, do the following:

          1. Switch your edit option to 'move' instead of rotate, then use your camera to get lower than the movement guides. I find that using the camera rotate feature (the arrows on the right side of the camera controls) works best. You don't have to be WAY below, or directly below the guides, but your camera angle MUST be 'looking up at' your movement guides.

          2. Move the prim very slightly upward while in this camera position.

          3. Switch your edit mode to 'rotate' and then hit CTRL+Z to return your prim to the position it was in before you moved it up slightly.

          4. You will now have the rotate rings and they will remain as long as you don't move the prim again. Once you leave 'rotate' mode and 'move' the prim using the arrows, you may have to repeat the steps to get the rotate guides back again. It's not always the case, but sometimes it does happen.

          FRUSTRATING? You betcha! This is a Linden issue, however. Please see the following JIRA and make your comments there. VWR-28498 VWR-28303 . Both are related to this topic. This is the 'shiny bug' that's been in existence for quite some time.

          sculls evermore Sculls Evermore added a comment -

          Thank you very much for your workaround description and JIRA links! - yes to frustrating.

          aaron_of_mpls Aaron of Minneapolis (aaron.kukulcan) added a comment - - edited

          Thandi's workaround didn't seem to work for me. However, relogging /did/ work, so it seems to be a very transient/intermittent issue on my system. (Yes, I'm on an ATI card, a Radeon HD 3650.)

          whirly.fizzle Whirly Fizzle added a comment -

          Is this issue still happening on 4.2.2?

          liya.caedmon Liya Caedmon added a comment -

          Yes, I am using Firestorm 4.2.2 (29837) Aug 27 2012 19:20:05 (Firestorm-Release) and I just noticed this problem for the first time in almost 2 years of Firestorm usage. Thank you for posting the workaround – I hope it gets fixed soon.

          whirly.fizzle Whirly Fizzle added a comment -

          Thanks for confirming that Liya

          whirly.fizzle Whirly Fizzle added a comment -

          Is anyone still seeing this on 4.4.2?
          No-one has complained about this bug for a long time so I am hoping it's fixed.

          distraida distraida brionnae added a comment -

          Does not reproduce on QA build 4.7.0.44921 and my partner (who won't jira) had this bug before but hasn't had it "in awhile" he says.

          whirly.fizzle Whirly Fizzle added a comment -

          Thanks for testing that Mary.
          Well, noone has complained since my last comment well over a year ago, so lets resolve this issue.


            People

            • Assignee:
              shouldbeworkingonit.linden ShouldBeWorkingOnIt Linden
              Reporter:
              shey.tiratzo Shey Tiratzo
            • Votes:
              12 Vote for this issue
              Watchers:
              13 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: