Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-4941

[VWR-28494] "Right Click -> Add" adds -EVERYTHING- wearing full inventory

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Waiting on Linden Lab fix
    • Affects Version/s: Phoenix Firestorm 3.2.2, Phoenix Firestorm 3.3.0, Phoenix Firestorm 4.0.1
    • Component/s: None
    • Labels:
    • Environment:
    • SL Avatar Name:
      ZenithHawke Resident
    • Reported In:
      Firestorm 3.2.2.24336 Release

      Description

      This is an insanely annoying bug that happens incredibly randomly...

      I have my outfits organized by specific outfit, inside my inventory. I don't use the 'Outfits' button or anything like it. I have the items themselves as links inside the organized section, NOT the actual items. When I choose to wear an outfit, I go to the folder with the outfit in question, and right click. I think click on 'Add to Current Outfit' so that the prims don't remove already worn ones.

      When I decide to remove clothing, I do a similar operation. I right click on the folder(s) that contain my clothing and click on "Remove from Outfit"

      This tends to work perfectly fine, and wonderfully done.

      HOWEVER

      If (Heaven forbid!) I accidentally click on 'Wear All' or 'Add to Outfit' on Parent folder while trying to remove said clothing? Firestorm enjoys making the next 30 minutes of my day hellish. It tries to add on every single piece of clothing I own. Which by itself wouldn't make me frustrated. I mean, I clicked on it, right? (Who decided to make those two options so close together anyways? Highly suggest putting them somewhat apart from one another)

      Now after this you'd think it would just be a simple resolution of right-clicking on the offending folder and clicking on 'Remove from Outfit', no? I thought the same. This has happened multiple times:

      After removing all clothing, it will continue to try to add clothing and prims to my avatar for the next 5 minutes roughly. Depending on how much I tried to add. What makes it worse is even after I get through fighting my clothing off of me, when I try to add anything else, it attempts to add EVERYTHING back onto me.

      So once I am finished removing all the clothing I accidentally added, and I decide to wear a shirt? That shirt gets put on, and SO DOES EVERYTHING ELSE.

      I am sorry for the caps lock but this is frustrating me to the point of finding another viewer. I don't want to because Firestorm is great in many ways (Sans this and the horrible rendering engine).

      Please help with this issue.

      EDIT (Whirly): https://jira.secondlife.com/browse/VWR-28494

      1. Firestorm.log
        1.20 MB
        Whirly Fizzle

        Issue Links

          Activity

          nogardrevlis NogarDrevlis Lectar added a comment -

          different Folders in the My Outfit Link folder would be a workaround

          Eample: My Outfit --> Outfit Link set 1
          MY Outfit --> Outfit Link set 2

          whirly.fizzle Whirly Fizzle added a comment - - edited

          For reference: http://community.secondlife.com/t5/Technical/Somehow-wearing-my-entire-inventory-and-crashes-on-log-in-what/qaq-p/1304525

          LL Issue: https://jira.secondlife.com/browse/SVC-7661

          Hi ZenithHawke,

          Weve had a few reports of this happening to people but no ones been able to work out yet exactly how this happens & it sounds like you have a reproducible set of steps there. I cant however work out from your description how to set my inventory structure up to behave as youre describing.
          Can you write up a set of steps I can follow to reproduce this issue please.
          Maestro is also asking for a repro on https://jira.secondlife.com/browse/SVC-7661 if you can also cause this to happen with Viewer 3.
          Thanks!

          zenith Rachel Nighton added a comment -

          I will as soon as I can get near my personal computer. I apologize for the long wait in responses, been busy and such!

          whirly.fizzle Whirly Fizzle added a comment - - edited

          Got a repro of this - thanks to Kishta Aluveaux

          • Setup:
            • Create a folder named ABCDE in your "Body Parts" system folder
            • Create a folder named ABCDE in your "Objects" system folder.
            • Inside each of these folders paste in the contents of the Boy next door avatar from the Library
              Note: These folders must have the same name & the name must be unique, you must not have another folder named even with part of this folder name already.

          Steps to reproduce:

          • Search for the folder name ABCDE in your inventory window.
          • As the first folder loads, right click on it, but do not select anything & wait....

          Observed Behavior:

          • The selection switches from the single folder to the Objects folder and all sub folders shown.
          • Selecting Add to outfit at this point adds the object folder to the avatar.
          • Watch your current outfit folder as links to everything from objects folder get added. FPS will plumet. At this point, nothing new is added to my avatar, just a couple of thousand new links to COF
          • Wait till its finnished adding links to everything. Youll know when its done, your FPS will go back to normal.
          • Relog
          • Observe you are wearing many items from your objects folder.
          • Detatch some & more will appear
          • Detatch most worn prims then wear a clothing or skin layer, any will do
          • observe numerous new prim attachments will be added to your avatar
          • Try to character test
          • Crash!
          whirly.fizzle Whirly Fizzle added a comment -

          Logs attached

          whirly.fizzle Whirly Fizzle added a comment - - edited

          Vid of this happening: http://www.youtube.com/watch?v=JvnUfMiqJG0 (turn captions on - CC button)

          samanthaprater Samantha Prater added a comment -

          "(FS 4.0.1) Ok Anything with the firestorm- Phoniex Source code seems to have a small glitch with the wear all inventory fix. instead of it detaching after five times, it repeates. So the fix? Simple, wear instead of add, after hours of looking for it, we figured the bug to be ADD. Because detaching everything and wearing it, by replace. did not work. After restoring, clearing, and character testing, AND resetting, resetting the password is also atemporary fix. the website seems to have a glitch, because at least in my case, i've had to reset my password each day now. the wear option works fine, its the ADD option you dont want to touch otherwise you will get constant repeats of"Wear inventory."

          [12:48] SamanthaPrater: (FS 4.0.1) the other issue is is I get the caps lock every time I enter the same password, so the fix seems to be changing it. detaching all the items and making sure you logged with a outfit of you're choice seems to work as well.

          (FS 4.0.1) Samantha - the 'add' in Firestorm is part of LL V3 codebase (and the wear all inventory is a LL issue rather than FS) - have you tested using LLV3 viewer?
          [12:51] SamanthaPrater: (FS 4.0.1) we did every veiewer allmost that would run on my pc. Singularity hates me xD
          [12:52] SamanthaPrater: (FS 4.0.1) yes.''

          I am able to force this too happen, and the same result. so Im seeing if the wear inventory outfit (repeatedly) version is the normal ones fix. I just had a hunch, maybe if people tried what I did for my version of it, it'd work.

          https://jira.secondlife.com/browse/SINV-38 <--see my bug report on this issue here.

          whirly.fizzle Whirly Fizzle added a comment -

          Very interesting alternative repro for this bug on FIRE-7209
          Appears to behave slightly differently, so not closed as a dupe

          Also see https://jira.secondlife.com/browse/MAINT-802?focusedCommentId=337804&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-337804

          xenon Xenon Gynoid added a comment -

          hi there! i had this happen to me again today (third time). it was my error (chose 'Add to outfit' on the parent folder myself by mistake), but it takes some work to fix it (log out, relog, viewer keeps trying to attach stuff). this has happened to friends of mine a few times too, and it's really annoying, even if it's not really a bug.

          one way to help with this problem would be to have a dialog asking something like "Are you sure you want to attach 1,542 items to your Avatar?" when you try to do it. the way i imagine it the confirmation dialog would only show up when you try it with more than, say, 20 items or so.

          ansariel.hiller Ansariel Hiller added a comment -

          Closing as Waiting on Linden Lab fix.


            People

            • Assignee:
              shouldbeworkingonit.linden ShouldBeWorkingOnIt Linden
              Reporter:
              zenith Rachel Nighton
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: