Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-6401

[REGRESSION] Swapping login between Second Life grid and Second Life Beta grid doent take effect until Firestorm is relaunched.

    Details

    • Type: Bug
    • Status: Passed QA
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 4.1.1
    • Fix Version/s: Phoenix Firestorm 4.4.0
    • Component/s: None
    • Labels:
      None
    • Environment:
    • SL Avatar Name:
      Whirly Fizzle
    • Reported In:
      Firestorm 4.1.1

      Description

      Swapping login between Second Life grid and Second Life Beta grid from the login screen doent take effect until Firestorm is relaunched.
      This probably affects swapping between any grids, but I am only able to test the SL grids.

      Steps to reproduce:

      • Rename user settings to simulate a clean
      • Launch login screen and log your avatar into main grid as normal
      • Log out
      • Relaunch login screen and set avatar to login to Second Life Beta from the "Logon to grid" dropdown and login.

      Observe you login to main grid

      • Log out
      • Relaunch login screen & now observe your username is set to username @ Second Life Beta and login

      Observe you now correctly login to Beta grid

      • Log out
      • Relaunch the login screen
      • Set the grid back to Second Life from the Login to grid drop down

      Observe your username stays at username @ Second Life Beta

      This behaviour seems erratic actually
      It does occasionally log into the correct grid first try.

      This bug started pretty recently. Possibly when the grid manager was added?

      Swapping grid to login to from the Username field by choosing "username" or "username @ Second Life Beta" once you have username @ Second Life Beta set from a login on that grid appears to consistently work correctly. Its just the "Logon to grid" option thats flakey

        Issue Links

          Activity

          nogardrevlis NogarDrevlis Lectar added a comment -

          This Problem efects Other grids on the dropdown too

          Tested with OSgrid

          Nogardrevlis Lectar

          manwa pastorelli Manwa Pastorelli added a comment -

          i got around this paticular issue

          choose beta grid, add password, - notice at this point the grid resets to the main grid, change it back to beta again, click log in.

          hope it works for others.

          whirly.fizzle Whirly Fizzle added a comment -

          This ones still in effect after the grid manager stuff was backed out.
          Tested on Firestorm 4.1.1 (27984) Jun 14 2012 12:07:26 (Firestorm-Fizzlefire)

          armin Armin Weatherwax added a comment -

          I suspect this is new, what happens is telling the viewer to login second life main grid (user name choice wasn't changed) and second life beta (grid combo was changed) at the same time, and it decides for user@secondlife main. This comes with storing user@grid in the saved logins, and not showing the grid choice implicit with the username for second life main (while it is stored that way internally). This is more obvious for the user if having 2 grids both different from second life main, say foo and bar. Then the user combo shows "My User @ Foo" and the grid combo "Bar" - and it logs in "My User @ Foo" - into foo, and stores "My User @ Bar" and the last grid choice bar - and would fail to login if the passwords for both grids are different (unlike SL and SL beta).
          Choices here for a fix are:

          • clear the user field when switching grids
          • when switching the grid from "foo" to "bar" with "My User" look up if there is also "My User@bar" and select if yes.
          • have a default or a last user stored with the grid and switch to that entry when switching grid in the grid combo
          • combine all
          armin Armin Weatherwax added a comment -

          fixed in http://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/8cfd1b5d766e
          In the sense: if a saved login of a user with the same name on a different grid is present it is chosen, otherwise the user name field is cleared

          jessica_lyon Jessica Lyon added a comment -

          Lets get this tested internally quickly before pushing this into release branch. I do want it in release though.

          whirly.fizzle Whirly Fizzle added a comment -

          Testing on Firestorm Firestorm 4.3.0 (29733) Aug 20 2012 22:20:27 (Firestorm-Fizzlefire) with clean settings.

          • Small point, the Log onto grid dropdown has a gap between the grid names. Maybe this was intended
          • Logged in once to main grid making sure to tick remember my password and logged out.
          • Back at login screen I chose Beta grid from the drop down and my username and password fields (saved from last login) blanked (this is expected as I have no saved info from a beta grid login yet)
          • I entered my same avatars username as 1st login and the login to grid dropdown immediately changed itself to Secondlife from Secondlife Beta
          • I changed the dropdown to Beta grid again and my username and password fields blanked out
          • And again, I enter my username and as soon as I click in the password field to enter it again, the grid dropdown changes to Secondlife

          I am unable to login that same avatar onto beta grid!

          Going to file this as a new issue and link. Please dont merge this in yet.
          Tonya confirmed this behaviour. The same happens without clean settings.

          whirly.fizzle Whirly Fizzle added a comment -

          QA note: Unable to test until FIRE-7362 is fixed

          cinderblocks Cinder Biscuits added a comment -
          whirly.fizzle Whirly Fizzle added a comment -

          This is still happening for me on Firestorm 4.3.0 (30921) Nov 10 2012 03:23:42 (Firestorm-Fizzlefire)

          whirly.fizzle Whirly Fizzle added a comment - - edited

          Taralyn also confirmed this still occurs.

          Note: This is only a problem the first time (or on clean settings) you need to login an avatar to another grid that has the same name on another grid (also affects SL beta grid).
          Once you have the username@grid1 and username@grid2 stored in the username field, login is always possible by choosing from that field.

          You can workaround it by deleting the username entry text and retyping just your username and choosing the correct grid, but its not super obvious you can do this.

          lassie Lassie added a comment -

          Removing QA Deferred flag, FIRE-7362 has been resolved and this one will be picked up with it's next commit.

          cinderblocks Cinder Biscuits added a comment -

            People

            • Assignee:
              cinderblocks Cinder Biscuits
              Reporter:
              whirly.fizzle Whirly Fizzle
            • Votes:
              1 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: