Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-6619

[VWR-29152] Folder is retained in worn item when all the items are removed. Empty folders stay visible in Recent Items tab.

    Details

    • Type: Bug
    • Status: Passed QA
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 4.1.1
    • Fix Version/s: Phoenix Firestorm 4.3.1
    • Component/s: None
    • Labels:
    • Environment:
    • SL Avatar Name:
      katydid62
    • Reported In:
      Firestorm 4.1.1.27964 QA

      Description

      i am wearing all of the items from one particular folder, for example, a dress. i click on the folder and choose "remove from current outfit". the outfit is removed however the folder still shows in "Worn Items" tab. I can also put on a second outfit and the first one will still show in the tab. if i double click or choose add to existing outfit, i can put the items from that folder back on. if I log out, when i log back in the outfit was not wearing will no longer be in the tab and i will only be wearing the things i was wearing at log out. (eg. it does not persist through a relog)

      EDIT (Whirly): https://jira.secondlife.com/browse/VWR-29152
      Quick Repro:

      • Rez a cube and delete it
      • Open Inventory -> Recent Items tab
      • Observe your cube is sitting in the Trash folder in Recent Items
      • From Recent Items, Right click Trash -> Empty Trash

      Observe: Your now empty Trash folder still shows in Recent Items
      Expected: Trash folder doesnt show in Recent Items once empty

      Any folder that appears in Recent Items but is then emptied will remain in Recent Items until a relog.

      • Right click any folder (not containing your worn skin, eyes, baldy or shape) showing in Worn items tab -> Remove from outfit
      • Observe the now empty folder is still visible
      • Right click this folder and you can add items back also

        Issue Links

          Activity

          lette Lette Ponnier added a comment -

          Yup, confirmed for me as well.

          ****
          Firestorm 4.1.1 (27974) Jun 16 2012 04:31:04 (Firestorm-private-Romana)
          Release Notes

          You are at 258470.0, 261114.0, 50.3 in Albata located at sim9570.agni.lindenlab.com (216.82.44.27:13000)
          Second\ Life\ Server 12.06.04.258757
          Error fetching server release notes URL.

          CPU: Intel(R) Core(TM)2 Duo CPU T8300 @ 2.40GHz (2400 MHz)
          Memory: 6144 MB
          OS Version: Mac OS X 10.6.8 Darwin 10.8.0 Darwin Kernel Version 10.8.0: Tue Jun 7 16:33:36 PDT 2011; root:xnu-1504.15.3~1/RELEASE_I386 i386
          Graphics Card Vendor: NVIDIA Corporation
          Graphics Card: NVIDIA GeForce 8600M GT OpenGL Engine

          OpenGL Version: 2.1 NVIDIA-1.6.36

          RestrainedLove API: (disabled)
          libcurl Version: libcurl/7.21.1 OpenSSL/0.9.8q zlib/1.2.5 c-ares/1.7.1
          J2C Decoder Version: KDU
          Audio Driver Version: FMOD version 3.750000
          Qt Webkit Version: 4.7.1 (version number hard-coded)
          Voice Server Version: Vivox 2.1.3010.6270

          Settings mode: Firestorm
          Viewer Skin: firestorm (highcontrast)
          Font Used: Ubuntu Font Family (96)
          Draw distance: 64
          Bandwidth: 500
          LOD factor: 2
          Built with GCC version 40201
          Packets Lost: 1256/1 (0.1%)

          katydid katydid62 resident added a comment -

          Tara and i both thought it could be a convenient feature to add for people who might need to do quick changes-- just a bit faster than using the outfits function.

          a couple of days ago when testing it i was able to have 7 outfits in that tab, while only wearing one of them, and could freely change between them.

          whirly.fizzle Whirly Fizzle added a comment -

          Confirmed here too

          Firestorm 4.1.1 (27984) Jun 14 2012 12:07:26 (Firestorm-Fizzlefire)
          Release Notes

          You are at 131,159.0, 251,697.0, 35.4 in Veil of Shadows located at sim20165.agni.lindenlab.com (216.82.26.178:13011)
          Second\ Life\ Server 12.06.04.258757
          Error fetching server release notes URL.

          CPU: Intel(R) Core(TM)2 Quad CPU Q8300 @ 2.50GHz (2493.75 MHz)
          Memory: 3326 MB
          OS Version: Microsoft Windows Vista 32-bit Service Pack 2 (Build 6002)
          Graphics Card Vendor: NVIDIA Corporation
          Graphics Card: GeForce GT 230/PCIe/SSE2

          Windows Graphics Driver Version: 8.17.0012.9610
          OpenGL Version: 3.3.0

          RestrainedLove API: (disabled)
          libcurl Version: libcurl/7.21.1 OpenSSL/0.9.8q zlib/1.2.5 c-ares/1.7.1
          J2C Decoder Version: KDU
          Audio Driver Version: FMOD version 3.750000
          Qt Webkit Version: 4.7.1 (version number hard-coded)
          Voice Server Version: Vivox 2.1.3010.6270

          Settings mode: Hybrid
          Viewer Skin: metaharper (cool_ocean)
          Font Used: Deja Vu (96)
          Draw distance: 128
          Bandwidth: 1800
          LOD factor: 2
          Built with MSVC version 1600
          Packets Lost: 0/43,891 (0.0%)

          soho_spiritweaver Soho SpiritWeaver added a comment -

          I am seeing the same thing in Vintage - was changing a lot of outfits and the empty outfit folders kept adding up

          Firestorm 4.1.1 (27964) Jun 13 2012 04:31:13 (Firestorm-private-Romana)
          Release Notes

          You are at 170041.0, 331491.0, 36.8 in Beautys Release located at sim5971.agni.lindenlab.com (216.82.12.25:13003)
          Second\ Life\ Server 12.06.04.258757
          Retrieving...

          CPU: Intel(R) Core(TM)2 Duo CPU E7600 @ 3.06GHz (3060 MHz)
          Memory: 4096 MB
          OS Version: Mac OS X 10.7.4 Darwin 11.4.0 Darwin Kernel Version 11.4.0: Mon Apr 9 19:32:15 PDT 2012; root:xnu-1699.26.8~1/RELEASE_X86_64 x86_64
          Graphics Card Vendor: ATI Technologies Inc.
          Graphics Card: ATI Radeon HD 4670 OpenGL Engine

          OpenGL Version: 2.1 ATI-7.18.18

          RestrainedLove API: (disabled)
          libcurl Version: libcurl/7.21.1 OpenSSL/0.9.8q zlib/1.2.5 c-ares/1.7.1
          J2C Decoder Version: KDU
          Audio Driver Version: FMOD version 3.750000
          Qt Webkit Version: 4.7.1 (version number hard-coded)
          Voice Server Version: Not Connected
          Settings mode: Phoenix
          Viewer Skin: vintage (classic)
          Font Used: Droid Sans (96)
          Draw distance: 256
          Bandwidth: 1500
          LOD factor: 3
          Built with GCC version 40201
          Packets Lost: 265/246883 (0.1%)

          animorf kawadias stephanie turner added a comment -

          Firestorm 4.1.1 (27964) Jun 11 2012 00:51:30 (Firestorm-LassieStorm)
          Release Notes

          You are at 135,309.0, 291,792.0, 21.5 in Equalibrium Cove located at sim20965.agni.lindenlab.com (216.82.29.244:13017)
          Second\ Life\ RC\ LeTigre 12.06.09.259101
          Error fetching server release notes URL.

          CPU: Intel(R) Core(TM)2 Quad CPU Q8200 @ 2.33GHz (2327.5 MHz)
          Memory: 4091 MB
          OS Version: Microsoft Windows Vista 64-bit Service Pack 2 (Build 6002)
          Graphics Card Vendor: NVIDIA Corporation
          Graphics Card: GeForce GT 520/PCIe/SSE2

          Windows Graphics Driver Version: 8.17.0013.0142
          OpenGL Version: 4.2.0

          RestrainedLove API: RLV v2.7.0 / RLVa v1.4.5a
          libcurl Version: libcurl/7.21.1 OpenSSL/0.9.8q zlib/1.2.5 c-ares/1.7.1
          J2C Decoder Version: KDU
          Audio Driver Version: FMOD version 3.750000
          Qt Webkit Version: 4.7.1 (version number hard-coded)
          Voice Server Version: Vivox 2.1.3010.6270

          Settings mode: Firestorm
          Viewer Skin: starlight (nostalgia_blue)
          Font Used: Deja Vu (96)
          Draw distance: 304
          Bandwidth: 1200
          LOD factor: 2
          Built with MSVC version 1600
          Packets Lost: 58,540/100,865 (58.0%)

          I can reproduce it as well on Nostalgia blue skin, with RLV active

          sexyjinn Sexy Jinn added a comment - - edited

          does the Same in V3 folders do not dissappear from recent

          whirly.fizzle Whirly Fizzle added a comment -

          Thanks Sexy,

          Confirmed the same happens on V3 with the Recent Items tab.
          Looks like we picked this up on the 3.3.2 Merge.

          Editing issue to add new info.

          whirly.fizzle Whirly Fizzle added a comment -

          Issue verified by LL.
          Internal LL issue: https://jira.secondlife.com/browse/MAINT-1192

          whirly.fizzle Whirly Fizzle added a comment -


          WORKAROUND:
          While on the Worn tab, enter any search term in inventory and then cancel it with the button. The empty folders will disappear.
          This does not work in the Recent tab.

          saschy Sascha Vandyke added a comment -

          Just a comment, if you have those empty folders and change filter setting in worn tab, it messes up completely ehhe.

          beeflin Beeflin Grut added a comment -

          I have just discovered that this bug only occurs when "Hide Empty System Folders" is true. If set to false, non-worn item's folders vanish.

          whirly.fizzle Whirly Fizzle added a comment - - edited

          Ahhh thanks Beefin!

          Testing on Firestorm 4.3.0 (30603) Oct 1 2012 18:07:52 (Firestorm-Fizzlefire) it doesnt appear to matter what setting I have for "Hide Empty System Folders" under Prefs -> Firestorm -> General but toggling this setting will indeed make the empty folders poof for worn.

          This also works for getting rid of an empty trash folder from Recent tab

          beeflin Beeflin Grut added a comment -

          Odd isn't it? Two things that shouldn't be related have got tangled up.

          whirly.fizzle Whirly Fizzle added a comment -
          hilaryquerrien Hilary Querrien added a comment -

          Should this be in 4.5.1 (because it isn't)

          greatfox snowpaw Futashy added a comment - - edited

          This is confirmed back and broken again on Firestorm 4.5.2 (39841) Dec 23 2013 02:34:15 (Firestorm-nightly) with Havok support. I blame CHUI, CHUI breaks everything.

          Though there is a new jira about this issue having regressed caused by CHUI listed at FIRE-11103.


            People

            • Assignee:
              kitty.barnett Kitty Barnett
              Reporter:
              katydid katydid62 resident
            • Votes:
              11 Vote for this issue
              Watchers:
              10 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: