Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-6843

[CRASH] Polish UI - Sharing item to own avatar = crash to desktop

    Details

    • Type: Bug
    • Status: Passed QA
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 4.1.1
    • Fix Version/s: Phoenix Firestorm 4.4.5
    • Component/s: None
    • Labels:
    • Environment:
    • Reported In:
      Firestorm 4.1.1.28570 QA

      Description

      Right click on any item in inventory => "Share" in context menu => "Search" tab => type your own FULL name, like 'panterapolnocy resident' => Enter => Select the row with name and confirm by pressing on the "Select" button => crash. Reproduced 4 times, attaching logs.

      1. Pantera.7z
        36 kB
        Pantera Północy
      2. Pantera2.7z
        35 kB
        Pantera Północy
      3. Pantera3.7z
        39 kB
        Pantera Północy
      4. Pantera4.7z
        35 kB
        Pantera Północy
      1. name-not-resolved-crash.jpg
        20 kB

        Activity

        whirly.fizzle Whirly Fizzle added a comment - - edited

        I couldnt reproduce this on the English UI at all.
        Also tried with an alt with a "Resident" surname and I could successfully share with myself.

        I notice on the English UI, no "Resident" shows in the name field, as in your attached image.

        Switching to the Polish UI, I can repro this 100% with my Resident avatar, also the surname shows as Resident in the name field.

        Callstack:

        >	llcommon.dll!std::basic_string<char,std::char_traits<char>,std::allocator<char> >::assign(const std::basic_string<char,std::char_traits<char>,std::allocator<char> > & _Right={...}, unsigned int _Roff=0, unsigned int _Count=4294967295)  Line 893 + 0xa bytes	C++
         	llcommon.dll!LLAvatarName::LLAvatarName(const LLAvatarName & __that={...})  + 0x45 bytes	C++
         	Firestorm-Fizzlefire.exe!action_give_inventory::build_residents_string(std::vector<LLAvatarName,std::allocator<LLAvatarName> > avatar_names=[0](), std::basic_string<char,std::char_traits<char>,std::allocator<char> > & residents_string="")  Line 654	C++
         	Firestorm-Fizzlefire.exe!action_give_inventory::give_inventory(const std::vector<LLUUID,std::allocator<LLUUID> > & avatar_uuids=[0](), std::vector<LLAvatarName,std::allocator<LLAvatarName> > avatar_names=[0](), std::set<LLUUID,std::less<LLUUID>,std::allocator<LLUUID> > inventory_selected_uuids=[1](...))  Line 829	C++
         	Firestorm-Fizzlefire.exe!boost::detail::function::void_function_obj_invoker2<boost::_bi::bind_t<void,void (__cdecl*)(std::vector<LLUUID,std::allocator<LLUUID> > const &,std::vector<LLAvatarName,std::allocator<LLAvatarName> >,std::set<LLUUID,std::less<LLUUID>,std::allocator<LLUUID> >),boost::_bi::list3<boost::arg<1>,boost::arg<2>,boost::_bi::value<std::set<LLUUID,std::less<LLUUID>,std::allocator<LLUUID> > > > >,void,std::vector<LLUUID,std::allocator<LLUUID> > const &,std::vector<LLAvatarName,std::allocator<LLAvatarName> > const &>::invoke(boost::detail::function::function_buffer & function_obj_ptr={...}, const std::vector<LLUUID,std::allocator<LLUUID> > & a0=[0](), const std::vector<LLAvatarName,std::allocator<LLAvatarName> > & a1=[0]())  Line 153 + 0x3b bytes	C++
         	Firestorm-Fizzlefire.exe!boost::function2<void,LLUICtrl *,LLSD const &>::operator()(LLUICtrl * a0=0x009bf170, const LLSD & a1={...})  Line 1013 + 0x14 bytes	C++
         	Firestorm-Fizzlefire.exe!LLFloaterAvatarPicker::onBtnSelect()  Line 238	C++
         	Firestorm-Fizzlefire.exe!boost::signals2::detail::signal2_impl<void,LLChiclet *,LLSD const &,boost::signals2::optional_last_value<void>,int,std::less<int>,boost::function<void __cdecl(LLChiclet *,LLSD const &)>,boost::function<void __cdecl(boost::signals2::connection const &,LLChiclet *,LLSD const &)>,boost::signals2::mutex>::slot_invoker::operator()(const boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group,boost::optional<int> >,boost::signals2::slot2<void,LLChiclet *,LLSD const &,boost::function<void __cdecl(LLChiclet *,LLSD const &)> >,boost::signals2::mutex> > & connectionBody={...})  Line 340 + 0x4c bytes	C++
         	Firestorm-Fizzlefire.exe!boost::signals2::detail::slot_call_iterator_t<boost::signals2::detail::signal2_impl<void,LLChiclet *,LLSD const &,boost::signals2::optional_last_value<void>,int,std::less<int>,boost::function<void __cdecl(LLChiclet *,LLSD const &)>,boost::function<void __cdecl(boost::signals2::connection const &,LLChiclet *,LLSD const &)>,boost::signals2::mutex>::slot_invoker,std::_List_iterator<std::_List_val<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group,boost::optional<int> >,boost::signals2::slot2<void,LLChiclet *,LLSD const &,boost::function<void __cdecl(LLChiclet *,LLSD const &)> >,boost::signals2::mutex> >,std::allocator<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group,boost::optional<int> >,boost::signals2::slot2<void,LLChiclet *,LLSD const &,boost::function<void __cdecl(LLChiclet *,LLSD const &)> >,boost::signals2::mutex> > > > >,boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group,boost::optional<int> >,boost::signals2::slot2<void,LLChiclet *,LLSD const &,boost::function<void __cdecl(LLChiclet *,LLSD const &)> >,boost::signals2::mutex> >::dereference()  Line 82 + 0x1c bytes	C++
         	Firestorm-Fizzlefire.exe!boost::signals2::optional_last_value<void>::operator()<boost::signals2::detail::slot_call_iterator_t<boost::signals2::detail::signal2_impl<void,LLChiclet *,LLSD const &,boost::signals2::optional_last_value<void>,int,std::less<int>,boost::function<void __cdecl(LLChiclet *,LLSD const &)>,boost::function<void __cdecl(boost::signals2::connection const &,LLChiclet *,LLSD const &)>,boost::signals2::mutex>::slot_invoker,std::_List_iterator<std::_List_val<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group,boost::optional<int> >,boost::signals2::slot2<void,LLChiclet *,LLSD const &,boost::function<void __cdecl(LLChiclet *,LLSD const &)> >,boost::signals2::mutex> >,std::allocator<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group,boost::optional<int> >,boost::signals2::slot2<void,LLChiclet *,LLSD const &,boost::function<void __cdecl(LLChiclet *,LLSD const &)> >,boost::signals2::mutex> > > > >,boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group,boost::optional<int> >,boost::signals2::slot2<void,LLChiclet *,LLSD const &,boost::function<void __cdecl(LLChiclet *,LLSD const &)> >,boost::signals2::mutex> > >(boost::signals2::detail::slot_call_iterator_t<boost::signals2::detail::signal2_impl<void,LLChiclet *,LLSD const &,boost::signals2::optional_last_value<void>,int,std::less<int>,boost::function<void __cdecl(LLChiclet *,LLSD const &)>,boost::function<void __cdecl(boost::signals2::connection const &,LLChiclet *,LLSD const &)>,boost::signals2::mutex>::slot_invoker,std::_List_iterator<std::_List_val<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group,boost::optional<int> >,boost::signals2::slot2<void,LLChiclet *,LLSD const &,boost::function<void __cdecl(LLChiclet *,LLSD const &)> >,boost::signals2::mutex> >,std::allocator<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group,boost::optional<int> >,boost::signals2::slot2<void,LLChiclet *,LLSD const &,boost::function<void __cdecl(LLChiclet *,LLSD const &)> >,boost::signals2::mutex> > > > >,boost::signals2::detail::connection_body<std::pair<enum first={...}, boost::signals2::detail::slot_call_iterator_t<boost::signals2::detail::signal2_impl<void,LLChiclet *,LLSD const &,boost::signals2::optional_last_value<void>,int,std::less<int>,boost::function<void __cdecl(LLChiclet *,LLSD const &)>,boost::function<void __cdecl(boost::signals2::connection const &,LLChiclet *,LLSD const &)>,boost::signals2::mutex>::slot_invoker,std::_List_iterator<std::_List_val<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group,boost::optional<int> >,boost::signals2::slot2<void,LLChiclet *,LLSD const &,boost::function<void __cdecl(LLChiclet *,LLSD const &)> >,boost::signals2::mutex> >,std::allocator<boost::shared_ptr<boost::signals2::detail::connection_body<std::pair<enum boost::signals2::detail::slot_meta_group,boost::optional<int> >,boost::signals2::slot2<void,LLChiclet *,LLSD const &,boost::function<void __cdecl(LLChiclet *,LLSD const &)> >,boost::signals2::mutex> > > > >,boost::signals2::detail::connection_body<std::pair<enum last={...})  Line 65535	C++
         	Firestorm-Fizzlefire.exe!boost::signals2::detail::signal2_impl<void,LLUICtrl *,LLSD const &,boost::signals2::optional_last_value<void>,int,std::less<int>,boost::function<void __cdecl(LLUICtrl *,LLSD const &)>,boost::function<void __cdecl(boost::signals2::connection const &,LLUICtrl *,LLSD const &)>,boost::signals2::mutex>::operator()(LLUICtrl * arg1=0x22d7c300, const LLSD & arg2={...})  Line 246 + 0xa4 bytes	C++
         	Firestorm-Fizzlefire.exe!LLUICtrl::onCommit()  Line 380 + 0x27 bytes	C++
         	Firestorm-Fizzlefire.exe!LLButton::handleMouseUp(int x=65, int y=15, unsigned int mask=0)  Line 517	C++
         	Firestorm-Fizzlefire.exe!LLMouseHandler::handleAnyMouseClick(int x=65, int y=15, unsigned int mask=0, LLMouseHandler::EClickType clicktype=CLICK_LEFT, int down=0)  Line 49 + 0x13 bytes	C++
         	Firestorm-Fizzlefire.exe!LLViewerWindow::handleAnyMouseClick(LLWindow * window=0x05f4b000, LLCoord<LL_COORD_TYPE_GL> pos={...}, unsigned int mask=0, LLMouseHandler::EClickType clicktype=CLICK_LEFT, int down=0)  Line 991	C++
         	Firestorm-Fizzlefire.exe!LLViewerWindow::handleMouseUp(LLWindow * window=0x05f4b000, LLCoord<LL_COORD_TYPE_GL> pos={...}, unsigned int mask=0)  Line 1016	C++
         	Firestorm-Fizzlefire.exe!LLWindowWin32::mainWindowProc(HWND__ * h_wnd=0x008504ba, unsigned int u_msg=514, unsigned int w_param=0, long l_param=26280071)  Line 2225	C++
         	user32.dll!_InternalCallWinProc@20()  + 0x23 bytes	
         	user32.dll!_UserCallWinProcCheckWow@32()  + 0xb3 bytes	
         	user32.dll!_CallWindowProcAorW@24()  + 0x51 bytes	
         	user32.dll!_CallWindowProcW@20()  + 0x1b bytes	
         	opengl32.dll!_wglWndProc@16()  + 0x20e bytes	
         	user32.dll!_InternalCallWinProc@20()  + 0x23 bytes	
         	user32.dll!_UserCallWinProcCheckWow@32()  + 0xb3 bytes	
         	user32.dll!_DispatchMessageWorker@8()  + 0x19e bytes	
         	user32.dll!_DispatchMessageW@4()  + 0xf bytes	
         	Firestorm-Fizzlefire.exe!LLWindowWin32::gatherInput()  Line 1788	C++
         	Firestorm-Fizzlefire.exe!LLAppViewer::mainLoop()  Line 1375	C++
         	Firestorm-Fizzlefire.exe!WinMain(HINSTANCE__ * hInstance=0x00f40000, HINSTANCE__ * hPrevInstance=0x00000000, char * lpCmdLine=0x009e2ad9, int nCmdShow=1)  Line 185	C++
         	Firestorm-Fizzlefire.exe!__tmainCRTStartup()  Line 547 + 0x1c bytes	C
         	kernel32.dll!@BaseThreadInitThunk@12()  + 0x12 bytes	
         	ntdll.dll!___RtlUserThreadStart@8()  + 0x27 bytes	
         	ntdll.dll!__RtlUserThreadStart@8()  + 0x1b bytes	
        

        No crash on Polish UI sharing to myself on an avatar with an old Firstname Lastname
        No crash on German UI with my Resident noob
        No crash on Polish UI on the 4.0.1 Release

        Firestorm 4.2.0 (28601) Jul 2 2012 05:50:40 (Firestorm-Fizzlefire)
        Versionshinweise

        Sie befinden sich in 131.154,0, 251.849,0, 20,8 in Veil of Shadows auf sim20165.agni.lindenlab.com (216.82.26.178:13017)
        Second Life Server 12.06.18.259948
        Fehler beim Abrufen der URL für die Server-Versionshinweise.

        CPU: Intel(R) Core(TM)2 Quad CPU Q8300 @ 2.50GHz (2493.75 MHz)
        Speicher: 3326 MB
        Betriebssystem, Version: Microsoft Windows Vista 32-bit Service Pack 2 (Build 6002)
        Grafikkarten-Hersteller: NVIDIA Corporation
        Grafikkarte: GeForce GT 230/PCIe/SSE2

        Windows Grafiktreiber-Version: 8.17.0012.9610
        OpenGL Version: 3.3.0

        RestrainedLove API: (disabled)
        libcurl-Version: libcurl/7.21.1 OpenSSL/0.9.8q zlib/1.2.5 c-ares/1.7.1
        J2C-Decoderversion: KDU
        Audio-Treiberversion: FMOD version 3.750000
        Qt Webkit-Version: 4.7.1 (version number hard-coded)
        Voice-Serverversion: Vivox 2.1.3010.6270

        Settings mode: Hybrid
        Viewer Skin: metaharper (cool_ocean)
        Font Used: Deja Vu (96)
        Draw distance: 96
        Bandwidth: 1700
        LOD factor: 2
        Kompiliert mit MSVC version 1600
        Paketverlust: 0/3.318 (0,0%)

        miro.collas Miro Collas added a comment -

        Tested on Firestorm 4.1.1 (28570) Jun 30 2012 18:26:39 (Firestorm-Release)
        Cannot reproduce.

        whirly.fizzle Whirly Fizzle added a comment -

        This is no longer reproducible by either Pantera or myself when attempting to share with ourselves on a Resident account or when sharing with other Resident accounts.

        Tested on Firestorm 4.4.6 (34145) Jun 8 2013 15:54:49 (Firestorm-Fizzlefire) with OpenSimulator support.

        Closing as fixed


          People

          • Assignee:
            Unassigned
            Reporter:
            panterapolnocy Pantera Północy
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: