Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-7586

[3.4 Merge] [VWR-29494] Some objects disappear from regions (become invisible) while user crossing boundary of region

    Details

    • Type: Bug
    • Status: Passed QA
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 4.3.0
    • Fix Version/s: Phoenix Firestorm 4.4.0
    • Component/s: None
    • Labels:
    • Environment:
    • SL Avatar Name:
      Lassie
    • Reported In:
      Firestorm 4.3.0

      Description

      1. Login to Viewer and stand near boundary of two regions
      2. Observe how much objects you can see in the region you're currently in.
      2. Cross the sim border and notice some objects disappear.

      Actual results:
      Some objects are no longer drawn

      Expected results:
      Objects should not disappear

      Note1: Objects become visible again when user moves back to the original region.

      Tested at http://maps.secondlife.com/secondlife/Taupentown/223/254/26

        Issue Links

          Activity

          whirly.fizzle Whirly Fizzle added a comment -

          Confirmed and its pretty dramatic how much disappears.

          davido_chrome Davido Chrome added a comment - - edited

          They don't disappear I think, they are just drawn in the wrong region.

          I think this is the same as I filed "Simcrossings show objects from the other side of the previous sim right after crossing":
          http://jira.phoenixviewer.com/browse/FIRE-7608

          whirly.fizzle Whirly Fizzle added a comment -

          Yeah, I was wondering if what you were seeing was this too David.
          Do you see the same effect running Second Life 3.3.5 (264487) Sep 6 2012 15:10:37 (Second Life Development)? This is the most recent development build from https://wiki.secondlife.com/wiki/Linden_Lab_Official:Alternate_Viewers

          Direct Linux download: http://automated-builds-secondlife-com.s3.amazonaws.com/hg/repo/integration_viewer-development/arch/Linux/quicklink.html

          davido_chrome Davido Chrome added a comment - - edited

          In SecondLife-i686-3.4.0.264445 the issue was not present.

          In 3.3.5 (264487) the issue IS present. The key to getting it to snap back though is to spot the object in the new sim (cam up so you can see the other end, because it will occupy the same coordinates as in the sim where it's supposed to be), you don't have to walk back.

          whirly.fizzle Whirly Fizzle added a comment -

          You seem pretty certain FIRE-7608 is the same thing so Ill close that as a dupe, but QA note: When fix for this is pushed, check for FIRE-7608 symptoms also.

          davido_chrome Davido Chrome added a comment -

          I think it is. Good news is that it was fixed in the official viewer beta. So maybe you don't have to fix this yourself. I haven't tried that specific place in the official viewer though.

          davido_chrome Davido Chrome added a comment -

          Seems fixed in the latest beta.

          whirly.fizzle Whirly Fizzle added a comment - - edited

          Thanks David!

          Yep, I agree, looks fixed.
          I can no longer repro at the http://maps.secondlife.com/secondlife/Taupentown/223/254/26 location.

          Tested on Firestorm 4.3.0 (30634) Oct 15 2012 23:15:21 (Firestorm-Fizzlefire)

          Resolving to go through QA

          dan_threebeards Dan Threebeards added a comment -

          I am currently experiencing this with 4.3.0 (30921) on windows. On most region crossings things that were in view disappear after crossing and are replaced with objects from the same location on the previous sim, if that location was within viewable distance while you were there. Some times these phantom objects can last 2 or 3 seconds.

          davido_chrome Davido Chrome added a comment - - edited

          It's back in the Linux 4.3.0 (30921) version too. Need to be reopened as a regression I think.

          You might need to update the description. Basically what happens is that the objects from the other sim follows you over for a couple of seconds until you move. The objects you primarily see are objects that occupy the same coordinates as you although in the previous region.

          whirly.fizzle Whirly Fizzle added a comment -

          Thanks guys, issue reopened.

          Can you give me a location where you can reproduce this?
          Im not seeing the original reported issue here on Firestorm 4.3.0 (30928) at the http://maps.secondlife.com/secondlife/Taupentown/223/254/26 location.

          davido_chrome Davido Chrome added a comment -

          I do. I think you need to wait until the sims are finished loading.

          davido_chrome Davido Chrome added a comment -

          Go over this sim crossing, and back back over, a few times and you are bound to see it.

          http://maps.secondlife.com/secondlife/Viper%20Bay/4/55/25

          whirly.fizzle Whirly Fizzle added a comment -

          Oh yeah I do. Huh.... very weird!

          whirly.fizzle Whirly Fizzle added a comment -

          The issue Im seeing is different to initially reported here though.
          The original one is fixed (that was a viewer bug). However, there is now a server issue that sometimes causes prims close to the regions edge to poof when you cross a region. Im seeing this.
          Plus ontop of that I see the issue where "ghost prims" from the region I just crossed over from appear in the region I just crossed over to, as you both describe.

          It also reproduces on the latest Viewer 3 release.
          These are filed on the LL JIRA & there is discussion going on there about which parts are server and which are viewer.

          davido_chrome Davido Chrome added a comment - - edited

          It's one of those BUG jiras we can't see I take it.

          And, as I guess is expected then, it's still present in 4.3.0.30936

          whirly.fizzle Whirly Fizzle added a comment -

          Yeah, this ones going out in the beta Im afraid.

          whirly.fizzle Whirly Fizzle added a comment - - edited

          The ghost objects issue has been reported again at FIRE-8626, so lets use FIRE-8626 for the ghosting prims issue on region crossings and keep this one for the original reported bug as I think they are seperate.

          davido_chrome Davido Chrome added a comment -

          This seems fixed in the latest Beta build, and has been for a few builds I think.


            People

            • Assignee:
              Unassigned
              Reporter:
              lassie Lassie
            • Votes:
              2 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: