Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-7857

[BUG-312] [MAINT-1672] Sailboat boom not moving correctly

    Details

    • Type: Bug
    • Status: Passed QA
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 4.3.0
    • Fix Version/s: Phoenix Firestorm 4.3.1
    • Component/s: None
    • Labels:
    • Environment:
    • SL Avatar Name:
      Whirly Fizzle
    • Reported In:
      Firestorm 4.3.0

      Description

      Repro object

      MLCC Loonetta 31 created by Motor Loon

      Steps to reproduce

      • Rez the boat in SL water and sail around
      • Observe the way the boat's boom moves.
        The boom should always be connected to the sail base
        Observe that often the boom's position will not update to the sails base position and only updates its position correctly when you right click on it

      Actual behaviour

      Booms position does not update to follow the sail base position

      Expected behaviour

      Boom should align with sail base

      Reproduces on...

      • Second Life 3.4.0 (264911) Sep 19 2012 11:15:02 (Second Life Release)
      • Second Life 3.4.1 (264976) Sep 20 2012 06:51:09 (Second Life Beta Viewer)
      • Firestorm 4.3.0 (30576) Oct 1 2012 18:07:52 (Firestorm-Fizzlefire) (3.4.0 codebase)

      Bug does not reproduce on Firestorm 4.2.2 (29837) Aug 27 2012 19:20:05 (Firestorm-Release) (3.3.3 codebase)

      So this is something that sneaked in between 3.3.3 and 3.4.0

        Issue Links

          Activity

          whirly.fizzle Whirly Fizzle added a comment -

          Pixel has a copy of this boat for testing.

          Bug verified by Alexa and Stinson on Pixels boat.

          pixelprophet PixelProphet added a comment - - edited

          That's all correct. Current Firestorm Release 4.2.2 (29837) is not affected by the bug, which indicates that it's client side, and therefore a Viewer bug.

          Thank you for having a look at this Whirls

          pixelprophet PixelProphet added a comment -

          I've just had a look at the boom script of the open source version, and it turns out to be using llSetLocalRot which receives information via linked messages.

          whirly.fizzle Whirly Fizzle added a comment -

          Information from Stinson Linden:

          Actually, this issue has been in the code for as long as we have history in the mercurial repository. However, my guess is that this issue occurred after the boat's HUD display was attached to the BOOM object in the linkset.

          The issue only occurs when you call llSetLinkPrimitiveParamsFast() with PRIM_TEXT on an primitive that is also expected to move.

          For instance, if you go into the "Engine" script and find the state_entry() method and change "HOVERTEXTPRIM = BOOM;" to be "HOVERTEXTPRIM = SAIL;", you will see that the BOOM will start moving correctly, but then the SAIL will be misbehaving as described in the bug report.

          Additionally, if you change it to be "HOVERTEXTPRIM = -1;", you will see that the HUD disappears, but that all objects on the boat operate correctly.

          With the viewer fix, this should be fixed for all objects.

          Stinson

          pixelprophet PixelProphet added a comment -

          Unfortunately this bug is back in FS 4.3.0.30929 after Merge LL 3.4.1 to FS LGPL

          whirly.fizzle Whirly Fizzle added a comment -

          Fixed rev 30996 (http://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/5b015d8563b9)

          Pix, can you test on a nightly of at least rev 30996 on your boat?
          Thanks!


            People

            • Assignee:
              shouldbeworkingonit.linden ShouldBeWorkingOnIt Linden
              Reporter:
              whirly.fizzle Whirly Fizzle
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: