Details

    • Type: Bug
    • Status: Passed QA
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 4.2.2, Phoenix Firestorm 4.3.0
    • Fix Version/s: Phoenix Firestorm 4.4.5
    • Labels:
    • Environment:
    • SL Avatar Name:
      Co Starsmith
    • Reported In:
      Firestorm 4.2.2.29837 Pathfinding Hotfix

      Description

      When in firestorm It seems as if using the CONVERSATIONS box after about 5 IM boxes are createdd the next tab down is blank. This always happens

        Activity

        Hide
        cinderblocks Cinder Biscuits added a comment -

        Which skin are you using, Co? This doesn't happen for me in the default Firestorm skin.

        Show
        cinderblocks Cinder Biscuits added a comment - Which skin are you using, Co? This doesn't happen for me in the default Firestorm skin.
        Hide
        whirly.fizzle Whirly Fizzle added a comment -

        Ive seen this happen, pretty often actually.
        I know this is a duplicate but I cant find the original :/

        Ill grab a screenshot next time I see this.

        Show
        whirly.fizzle Whirly Fizzle added a comment - Ive seen this happen, pretty often actually. I know this is a duplicate but I cant find the original :/ Ill grab a screenshot next time I see this.
        Hide
        wrye Wrye Diabolito added a comment -

        I've seen this bug repeatedly – and in the default Firestorm skin – but it doesn't seem to be related to how many tabs are open, instead it seems related to whether the IM is from someone who is in the same sim (never seen it happen) or from someone in another sim (often happens). My suspicion is that since the tabs always show the 'display name', whenever there is a lag in acquiring the display name for that person, the tab is rendered blank - even though it will show "<displayname> is typing" correctly, it reverts to blank again when their message is sent.

        It also never seems to happen for group chat windows, only single avatar IMs.

        It also appears to happen much more frequently when my connection is laggy.

        Hope that helps a little.

        Show
        wrye Wrye Diabolito added a comment - I've seen this bug repeatedly – and in the default Firestorm skin – but it doesn't seem to be related to how many tabs are open, instead it seems related to whether the IM is from someone who is in the same sim (never seen it happen) or from someone in another sim (often happens). My suspicion is that since the tabs always show the 'display name', whenever there is a lag in acquiring the display name for that person, the tab is rendered blank - even though it will show "<displayname> is typing" correctly, it reverts to blank again when their message is sent. It also never seems to happen for group chat windows, only single avatar IMs. It also appears to happen much more frequently when my connection is laggy. Hope that helps a little.
        Hide
        ansariel.hiller Ansariel Hiller added a comment -

        Display names have always been troublesome. In fact, the name of the tab is not set until the callback from the namecache has returned. If the request for the name fails, the tab stays empty. Since at least the default name is transmitted in an IM, it might be possible to set that first and update the tab once the display name is returned.

        Show
        ansariel.hiller Ansariel Hiller added a comment - Display names have always been troublesome. In fact, the name of the tab is not set until the callback from the namecache has returned. If the request for the name fails, the tab stays empty. Since at least the default name is transmitted in an IM, it might be possible to set that first and update the tab once the display name is returned.
        Hide
        whirly.fizzle Whirly Fizzle added a comment -

        I always have display names disabled and I still have this issue.

        I can verify that when the tab has a blank name, it does indeed show the "username is typing" text correctly.
        When this happens, the name on the tab WILL actually display at first, for a couple of seconds and then it goes blank.
        I think the name is only displaying before you actually get the first message (I have the setting enabled to open an IM tab as soon as a sender starts typing).
        Not sure if that gives any clues on the timing thing.

        Show
        whirly.fizzle Whirly Fizzle added a comment - I always have display names disabled and I still have this issue. I can verify that when the tab has a blank name, it does indeed show the "username is typing" text correctly. When this happens, the name on the tab WILL actually display at first, for a couple of seconds and then it goes blank. I think the name is only displaying before you actually get the first message (I have the setting enabled to open an IM tab as soon as a sender starts typing). Not sure if that gives any clues on the timing thing.
        Hide
        whirly.fizzle Whirly Fizzle added a comment -

        Out of interest, has anyone seen this when using horizontal tabs? I only use vertical tabs.

        I've also never yet seen this issue on Viewer 3. However Im not on that viewer for long enough periods when Im engaging in much chat. But I feel I use it enough to have seen this happen if it was going to.
        (On Viewer 3 Im set to have tabbed Im conversations, but V3 has no vertical tabs option)

        Show
        whirly.fizzle Whirly Fizzle added a comment - Out of interest, has anyone seen this when using horizontal tabs? I only use vertical tabs. I've also never yet seen this issue on Viewer 3. However Im not on that viewer for long enough periods when Im engaging in much chat. But I feel I use it enough to have seen this happen if it was going to. (On Viewer 3 Im set to have tabbed Im conversations, but V3 has no vertical tabs option)
        Hide
        ana stubbs Ana Stubbs added a comment -

        Yes, I've seen this happen with horizontal tabs.

        Show
        ana stubbs Ana Stubbs added a comment - Yes, I've seen this happen with horizontal tabs.
        Hide
        whirly.fizzle Whirly Fizzle added a comment -

        Thanks Ana!

        Show
        whirly.fizzle Whirly Fizzle added a comment - Thanks Ana!
        Hide
        hilaryquerrien Hilary Querrien added a comment - - edited

        This happens to me too. I'm using the Metaharper Modern skin (the tab bars are vertical). I'm on Firestorm 4.3.1 (31155) Dec 2 2012 00:45:37 (Firestorm-Release) with Havok support.

        It does seem to happen to only one chat though. i've never seen it with 2 (and I had about 20 up yesterday, and the sim was being fairly laggy).

        Also, it just happened now on the 1st chat message I got, not the fifth

        Show
        hilaryquerrien Hilary Querrien added a comment - - edited This happens to me too. I'm using the Metaharper Modern skin (the tab bars are vertical). I'm on Firestorm 4.3.1 (31155) Dec 2 2012 00:45:37 (Firestorm-Release) with Havok support. It does seem to happen to only one chat though. i've never seen it with 2 (and I had about 20 up yesterday, and the sim was being fairly laggy). Also, it just happened now on the 1st chat message I got, not the fifth
        Hide
        lassie Lassie added a comment -

        6th tab down is blank, Firestorm 4.4.0 (33255) Feb 25 2013 09:58:04 (Firestorm-LassieStorm) with OpenSimulator support, with and without display names being used for the IM tab.

        Show
        lassie Lassie added a comment - 6th tab down is blank, Firestorm 4.4.0 (33255) Feb 25 2013 09:58:04 (Firestorm-LassieStorm) with OpenSimulator support, with and without display names being used for the IM tab.
        Hide
        ansariel.hiller Ansariel Hiller added a comment -

        This is apparently happening if announcing of incoming IMs is enabled and the sender's name is not available in the local avatar name cache. What seems to happen is:

        1. sender starts typing
        2. IM floater pops up and requests the name
        3. typing state is set; setting typing state stores current window title and since we don't have the name yet it's empty
        4. name request returns and set floater title to the name
        5. sender stops typing; setting typing stop state restores previously stored title, so the empty title is re-set

        Proposed fix pushed in 34048 (http://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/cbf8571e5208).

        Show
        ansariel.hiller Ansariel Hiller added a comment - This is apparently happening if announcing of incoming IMs is enabled and the sender's name is not available in the local avatar name cache. What seems to happen is: 1. sender starts typing 2. IM floater pops up and requests the name 3. typing state is set; setting typing state stores current window title and since we don't have the name yet it's empty 4. name request returns and set floater title to the name 5. sender stops typing; setting typing stop state restores previously stored title, so the empty title is re-set Proposed fix pushed in 34048 ( http://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/cbf8571e5208 ).

          People

          • Assignee:
            ansariel.hiller Ansariel Hiller
            Reporter:
            cstarsmith Co Starsmith
          • Votes:
            1 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: