Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-7937

[PATCH] DAE Import Support for Attachment Point Names

    Details

    • Type: Improvement
    • Status: Passed QA
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Phoenix Firestorm 4.3.0
    • Component/s: None
    • Labels:
      None
    • Environment:
      n/a
    • SL Avatar Name:
      Miro Collas
    • Patch attached:
      Patch attached
    • Reported In:
      Firestorm 4.2.2.29837 Pathfinding Hotfix
    1. attach_name_test.anim
      0.4 kB
      Whirly Fizzle
    2. attach_name_test.dae
      17 kB
      Whirly Fizzle
    3. FIRE-7937.patch
      1 kB
      Whirly Fizzle

      Issue Links

        Activity

        whirly.fizzle Whirly Fizzle added a comment - - edited

        Attaching test patch. Applies clean against rev 30615 and compiles.

        whirly.fizzle Whirly Fizzle added a comment - - edited

        So what does this do?

        This patch allows ALL bones including all attachment points to be weighted to mesh and animated.

        A limitation of the attachment points in the LL character is that many of them have names with spaces, like “Left Pec”. Collada 1.4 doesn’t handle bone names with spaces as space is used to delimit bone names. Avastar currently replaces spaces with an underscore in the critical places so you get “Left_Pec”, which of course SL doesn’t recognise. The patch just translates “Left_Pec” back to “Left Pec” at import time.

        Mesh uploaded on a viewer using this patch looks identical to viewers without the patch so doesnt violate the TPV policy.

        Credits

        Credit for this work goes to Magus Freston and Gaia Clary (needs checking)
        I asked for credit verification here: http://blog.machinimatrix.org/topic/help-needed-to-test-viewer-patch/#post-12107

        Test Plan

        • Save attach_name_test.dae to computer
          This mesh has two spheres in front of the hands. They are weighted to the attachment points “Left Hand” and “Right Hand”.

        • Upload attach_name_test.dae making sure "Skin Weights" are enabled in the upload options tab
        • Wear the uploaded mesh
        • Use a fidgety AO with lots of arm movement or play a dance animation etc
        • Test passes if the spheres hover in front of the hands and follow the hands with the animation playing
        • Download attach_name_test.anim to computer
        • Upload this animation into SL
        • Play attach_name_test
        • Test passes if the spheres rotate around the hands
        whirly.fizzle Whirly Fizzle added a comment -

        Passes for me on Firestorm 4.3.0 (30615) Oct 1 2012 18:07:52 (Firestorm-Fizzlefire) built with attached patch

        It was noted on http://blog.machinimatrix.org/topic/help-needed-to-test-viewer-patch/ that when uploading, there is the error message:

        2012-10-12T01:52:51Z WARNING: LLModelLoader::doLoadModel: Possibly misnamed/missing joint [Left Hand ]
        2012-10-12T01:52:51Z WARNING: LLModelLoader::doLoadModel: Possibly misnamed/missing joint [Right Hand ]

        This did not happen for me.
        No errors at all

        whirly.fizzle Whirly Fizzle added a comment -

        Marcus gave permission to use his patch under LGPL.
        Credits to go under the name Magus Freston (username Freston).

        whirly.fizzle Whirly Fizzle added a comment -
        whirly.fizzle Whirly Fizzle added a comment -

        Rev 31045 (http://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/34859834a270) - added Magus Freston to contributor credits.

        whirly.fizzle Whirly Fizzle added a comment -

        Info from Latif about problems caused by this patch: http://pastebin.com/LXbCNxuu

        whirly.fizzle Whirly Fizzle added a comment -

        Patch backed out, rev 42827
        http://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/9c82d92397ea

        This feature will be gone in the 4.6.9 release.

        rumegusc rumegusc altamura added a comment -

        news?


          People

          • Assignee:
            whirly.fizzle Whirly Fizzle
            Reporter:
            miro.collas Miro Collas
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: