Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-8203

[BUG-511] [MAINT-1760] Logging in with graphics set to Low results in both in-region and void water glowing

    Details

    • Type: Bug
    • Status: Passed QA
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 4.3.0
    • Fix Version/s: Phoenix Firestorm 4.4.0
    • Component/s: None
    • Labels:
    • Environment:
    • SL Avatar Name:
      Whirly Fizzle
    • Reported In:
      Firestorm 4.3.0

      Description

      EDIT (Whirly):

      Thanks to AylaJ Resident for finding this...
      These conditions need to be met in order to see the water glow:

      • Deferred rendering disabled (no lighting and shadows)
      • Basic shaders enabled
      • Transparent water disabled
      • To wear or be near anyone wearing a rigged mesh attachment that contains at least 1 texture that has alpha

      Steps To Reproduce

      • From the login screen, go to Avatar -> Preferences -> Graphics -> Set to Low -> Apply -> Ok
      • Login

      Observed Behviour: All in-region and void water is glowing as in the attached snaps.

      • Open Prefs -> Graphics -> Advanced -> Tick "Transparent Water"
      • Observe that the water stops glowing
      • Untick Transparent Water
      • Observe the glow is back
      • Also observe that once this bug is triggered at login, swapping between graphics quality settings will always give glowing water whenever you change to Low setting.

      Other Information

      Im getting mixed results with this.
      Sometimes if I login set to any graphics quality apart from Low, I can switch to low once logged in and not have glowing water.
      Other times as soon as I switch to low, I get glowing water.
      I can however 100% repro on builds after the 3.4.1 merge when logging in set to Low.

      Reproduces on:

      Does not reproduce on:

      • Second Life 3.3.4 (264214) Aug 31 2012 06:30:36 (Second Life Release)
      • Firestorm 4.2.2 (29837) Aug 27 2012 19:20:05 (Firestorm-Release) (V3.3.3 codebase)
      • Firestorm 4.3.0 (30671) Oct 18 2012 11:32:41 (Firestorm-Fizzlefire) (V3.4.0 codebase)

      Ill take a guess this may be caused by a change between the 3.4.0 and 3.4.1 codebase.
      Could well be card/driver dependant I guess

        Issue Links

          Activity

          panterapolnocy Pantera Północy added a comment - - edited

          I'm at High graphic settings all the time, no changing to low. I have transparent water turned off all the time as well - because it's a bit too much for my hardware. Occasionally I get this glowy water as well, it's totally unreproduceable, always appear randomly - I have this since 4.1.1, through all versions (currently self-compiled 4.3.0.30929):

          jenny1919 Jennifer added a comment - - edited

          I got this too when I tried the 4.3.0.30936 beta... Though I don't have the issue on the 4.2.29837 Normal release viewer... its very annoying and rather not turn on transparent water even though my graphics card can take the load I do combat so I want the bit higher fps

          whirly.fizzle Whirly Fizzle added a comment -

          Heya Jennifer,

          Please can you paste in all your system information from help -> About Firestorm Viewer so we can see your card and driver info.

          Also, if you wouldnt mind, can you test non Viewer 3 latest release and see if you can also reproduce this? (Im suspecting you will have the same problem).

          Thanks!

          jenny1919 Jennifer added a comment -

          Ok I tried Secondlife Viewer 3.4.1(266581) I get the result of the water looking bright white
          I tried Secondlife Beta Viewer 3.4.2(266995) Same Result water looking bright white
          Firestorm beta 4.3.0.30936.. The same issue
          Firestorm Release 4.2.29837

          Here my specs:
          CPU: Intel(R) Core(TM) i7 CPU 860 @ 2.80GHz (2792.98 MHz)
          Memory: 8188 MB
          OS Version: Microsoft Windows 8 64-bit (Build 9200)
          Graphics Card Vendor: NVIDIA Corporation
          Graphics Card: GeForce GTX 560 Ti/PCIe/SSE2

          Windows Graphics Driver Version: 9.18.0013.0697
          OpenGL Version: 4.2.0

          RestrainedLove API: RLV v2.7.0 / RLVa v1.4.7a
          libcurl Version: libcurl/7.21.1 OpenSSL/0.9.8q zlib/1.2.5 c-ares/1.7.1
          J2C Decoder Version: KDU
          Audio Driver Version: FMOD version 3.750000
          Qt Webkit Version: 4.7.1 (version number hard-coded)
          Voice Server Version: Not Connected
          Settings mode: Phoenix
          Viewer Skin: vintage (classic)
          Font Used: Deja Vu (96)
          Draw distance: 128
          Bandwidth: 3000
          LOD factor: 2
          Built with MSVC version 1600
          Packets Lost: 0/1,732 (0.0%)

          Note: I have another pc that I use occasionally with an old integrated nvida graphics card I wont be able to get the specs till Monday but I haven't seen the issue on it.. like I said its an integrated graphics card from maybe 2009/2010 not sure

          whirly.fizzle Whirly Fizzle added a comment -

          Thanks Jennifer.
          I added your system info to the LL JIRA also.

          lette Lette Ponnier added a comment -

          For me, logging on with graphics at default Low settings doesn't create the problem, but basic shaders are off by default on Low for me. If I enable basic shaders before logging in, then the water glows.

          The same thing occurs if I switch from Mid to Low graphics while already logged in and then turn basic shaders on (which I've had cause to because of FIRE-7979). I can get rid of the glow either by enabling transparent water, disabling glow, or disabling basic shaders (but disabling basic shaders takes me back to FIRE-7979).

          ********
          Firestorm 4.3.0 (30936) Nov 14 2012 00:22:35 (Firestorm-beta)
          Release Notes

          You are at 233235.0, 329925.0, 21.4 in Langston located at sim3037.agni.lindenlab.com (216.82.0.229:13001)
          Second Life Server 12.11.02.266530
          Error fetching server release notes URL.

          CPU: Intel(R) Core(TM)2 Duo CPU T8300 @ 2.40GHz (2400 MHz)
          Memory: 6144 MB
          OS Version: Mac OS X 10.6.8 Darwin 10.8.0 Darwin Kernel Version 10.8.0: Tue Jun 7 16:33:36 PDT 2011; root:xnu-1504.15.3~1/RELEASE_I386 i386
          Graphics Card Vendor: NVIDIA Corporation
          Graphics Card: NVIDIA GeForce 8600M GT OpenGL Engine

          OpenGL Version: 2.1 NVIDIA-1.6.36

          RestrainedLove API: (disabled)
          libcurl Version: libcurl/7.21.1 OpenSSL/0.9.8q zlib/1.2.5 c-ares/1.7.1
          J2C Decoder Version: KDU
          Audio Driver Version: FMOD version 3.750000
          Qt Webkit Version: 4.7.1 (version number hard-coded)
          Voice Server Version: Vivox 2.1.3010.6270

          Settings mode: Firestorm
          Viewer Skin: firestorm (highcontrast)
          Font Used: Ubuntu Font Family (96)
          Draw distance: 64
          Bandwidth: 500
          LOD factor: 2
          Built with GCC version 40201
          Packets Lost: 129/16743 (0.8%)

          whirly.fizzle Whirly Fizzle added a comment -

          Those of you seeing this issue, are you wearing mesh on your avatar?

          This is a 100% repro for me:

          • Make sure you are wearing no mesh on your avatar at all ot no one is near you wearing mesh. Rezzed mesh doesnt seem to affect this.
          • Graphics can be set to any quality level
          • Untick transparent water
          • Add some rigged mesh to your avatar
          • Water will glow
          • Take off the rigged mesh
          • Water will stop glowing

          Only appears to happen when transparent water is unticked.
          Not sure yet if its any rigged mesh that causes this. All my full rigged mesh avatars do.
          Info from FIRE-8425 indicates that other avatars nearby having rigged mesh on their avatars will cause this.

          lette Lette Ponnier added a comment -

          The rigged mesh factor repros for me too.

          If rigged mesh is not present, the water is normal at any graphics combo.

          whirly.fizzle Whirly Fizzle added a comment - - edited

          After further poking by Miro, this only repros when you wear rigged mesh with alpha textures. No alpha -> no glow.

          tank_master Tank Master added a comment -

          Also doesn't repo when differed is on

          whirly.fizzle Whirly Fizzle added a comment -

          LL dropped a fix for this bug into beta
          https://bitbucket.org/lindenlab/viewer-beta/commits/4b1fb94b8d3a/
          MAINT-1760 Fix for opaque water glowing when wearing certain rigged attachments.

          whirly.fizzle Whirly Fizzle added a comment -

            People

            • Assignee:
              shouldbeworkingonit.linden ShouldBeWorkingOnIt Linden
              Reporter:
              whirly.fizzle Whirly Fizzle
            • Votes:
              3 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: