Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-8233

[BUG-963] [MAINT-2020] secondlife:///app/agent URLs do not work in Firestorm

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: Phoenix Firestorm 4.2.2, Phoenix Firestorm 4.3.0, Phoenix Firestorm 4.3.1, Phoenix Firestorm Next
    • Fix Version/s: Phoenix Firestorm 4.3.2
    • Component/s: None
    • Labels:
    • Environment:
    • SL Avatar Name:
      Sasun Steinbeck
    • Reported In:
      Firestorm 4.2.2.29837 Pathfinding Hotfix

      Description

      Steps to Reproduce:
      -Run Firestorm 4.2.2
      -In windows, click the Start button, Run, and paste in secondlife:///app/agent/c3cf4c84-c31b-47ac-855c-3858375e0360/about. Hit return.

      -Or, try pasting it in your external browser address input.

      Result: Another instance of Firestorm launches.

      Expected behavior: Should simply pop up a profile for that avatar in Firestorm. Try pasting the same URL into open chat in Firestorm and it displays correctly after being clicked.

      This is a really annoying problem since I publish online directories of things that contains links to SL profiles that essentially do not work - they don't show a profile as expected.

      This has worked just fine in the past, I do not know when this broke.

        Issue Links

          Activity

          sasun steinbeck Sasun Steinbeck added a comment -

          Possibly related to an old Phoenix bug PHOE-2538.

          whirly.fizzle Whirly Fizzle added a comment -

          Also repros on Viewer 3.

          ansariel.hiller Ansariel Hiller added a comment -

          That is most definitely an issue with the grid manager. It hooks into the startup sequence and doesn't detect the App SLURL properly, so that the SLURL isn't handed over the running instance properly. If a different viewer like CoolVL is set as default application for SLURLs, it will properly handed over to Firestorm.

          whirly.fizzle Whirly Fizzle added a comment -

          Testing on Firestorm 5.0.1 (31163) Nov 30 2012 09:28:14 (Firestorm-Fizzlefire) with OpenSimulator support


          secondlife:///app/agent/...
          secondlife:///app/agent/2e255955-e183-48c4-b9f9-1cd1b80db94e/about
          Opens a 2nd instance

          secondlife:///app/group/...
          secondlife:///app/group/3a1be8d4-01f3-bc1a-2703-442f0cc8f2dd/about
          Opens 2nd instance - filed at FIRE-6081

          secondlife:///app/parcel/...
          secondlife:///app/parcel/510bbbc3-e2a3-1b0c-932f-16c553d5b8c7/about
          Opens 2nd instance

          Second Life 3.4.3 (267135) Nov 19 2012 13:31:37 (Second Life Beta Viewer)


          secondlife:///app/agent/2e255955-e183-48c4-b9f9-1cd1b80db94e/about
          Opens 2nd instance

          secondlife:///app/group/3a1be8d4-01f3-bc1a-2703-442f0cc8f2dd/about
          Opens 2nd instance

          secondlife:///app/parcel/510bbbc3-e2a3-1b0c-932f-16c553d5b8c7/about
          Opens 2nd instance

          whirly.fizzle Whirly Fizzle added a comment -

          I cant say for sure about the others but secondlife:///app/group/... was working on viewer 3 until recently because I tested it for FIRE-6081. I suspect V3 broke when they made their changes to the login manager to remove ability to login to non SL grids, which was pretty recently.

          whirly.fizzle Whirly Fizzle added a comment -

          Sasun, I filed this on the LL JIRA @ https://jira.secondlife.com/browse/BUG-963
          Heres a paste, seeing as the BUG issues are now not public

          BUG-963 When already logged in, using secondlife:///app/agent/, secondlife:///app/group/ or secondlife:///app/parcel/ in an external browser opens a second viewer instance.

          Steps To Reproduce

          • Login to the viewer
          • In an external web browser paste secondlife:///app/agent/2e255955-e183-48c4-b9f9-1cd1b80db94e/about into the address bar and hit enter

          Observed behaviour
          A second instance of the viewer is launched

          Expected behaviour
          The agents profile (mine in this case) opens within the running instance as it does when typing secondlife:///app/agent/2e255955-e183-48c4-b9f9-1cd1b80db94e/about into nearby chat and clicking the link

          • In an external web browser paste secondlife:///app/group/3a1be8d4-01f3-bc1a-2703-442f0cc8f2dd/about into the address bar and hit enter

          Observed behaviour
          A second instance of the viewer is launched

          Expected behaviour
          The group info floater opens within the running instance as it does when typing secondlife:///app/group/3a1be8d4-01f3-bc1a-2703-442f0cc8f2dd/about into nearby chat and clicking the link

          • In an external web browser paste secondlife:///app/parcel/510bbbc3-e2a3-1b0c-932f-16c553d5b8c7/about into the address bar and hit enter

          Observed behaviour
          A second instance of the viewer is launched

          Expected behaviour
          The Parcel Details opens within the running instance as it does when typing secondlife:///app/parcel/510bbbc3-e2a3-1b0c-932f-16c553d5b8c7/about into nearby chat and clicking the link

          Other Information

          • I'm unsure exactly when this behaviour changed
          • I know for certain that secondlife:///app/group/ was behaving as expected on Second Life 3.2.8 (248931) Feb 9 2012 09:04:17 (Second Life Release) because I tested against that for a bug in Firestorm caused by our grid manager - which basically gave the same buggy behaviour that Viewer 3 has now.
            So if I had to take a guess, I would say behaviour changed when the changes were made to disable the ability to login to non SL grids (but thats only a guess )
          • Why is this a pain in the butt?
            Many websites use this method to give links to SL profiles/groups. If you are already logged in to SL, you want the links to bring up the profile/group info within your viewer.

          Reproduces on:

          • Second Life 3.4.2 (267137) Nov 19 2012 12:24:52 (Second Life Release)
          • Second Life 3.4.3 (267135) Nov 19 2012 13:31:37 (Second Life Beta Viewer)
          sasun steinbeck Sasun Steinbeck added a comment -

          Thank you! They're going to have a lot of fun closing one billion duplicates if you can't see bugs, jeez.

          sasun steinbeck Sasun Steinbeck added a comment -

          This seems to have been fixed in Firestorm 4.3.1 (31155). Please close as resolved fixed, thanks.

          whirly.fizzle Whirly Fizzle added a comment -

          This still repros on Firestorm 4.4.0 (32328) Feb 1 2013 06:18:58 (Firestorm-Fizzlefire) with OpenSimulator support Im afraid

          ansariel.hiller Ansariel Hiller added a comment -

          Closing as duplicate of FIRE-6081. OpenSim version was fixed in 32760 (http://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/b49716fd96d6).

          sasun steinbeck Sasun Steinbeck added a comment -

          4.3.1 fixed this problem for me. I really wonder if the act of installing fixes this in some cases. All I've done lately was upgrade to 4.3.1 when it came out and it now works when clicking "secondlife:///app" style links on web pages. I'm happy

          ansariel.hiller Ansariel Hiller added a comment -

          It was fixed in the Havok release for Second Life automatically because it doesn't have the grid manager anymore. So installing the Havok version will always fix the issue.

          aiaustin Ai Austin added a comment -

          The secondlife://app/teleport/RegionName URLs on a splash page do not get selected into the location window ahead of login as I believe they should and do on most viewers.

          Example - try launching Firestorm 4.4.0 OS version and select OSGrid which has a splash page with such locations on it. Click any and note that they are NOT transferred to the location entry. Other viewers such as Kirstens do transfer this properly and I believe that Firestorm used to until recently?

          Inside Firestorm after logging in the destinations button does brig up a guide (if implemented on a grid) and properly teleport you to the indicated location using a secondlife://app/teleport link (e.g. in the Destinations guide which works now in the latest OpenSim 0.7.6 dev).


            People

            • Assignee:
              Unassigned
              Reporter:
              sasun steinbeck Sasun Steinbeck
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: