Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-8279

[PATCH] [3.4.1 Merge] [BUG-840] [MAINT-1950] Sliding doors do not update position correctly

    Details

    • Type: Bug
    • Status: Passed QA
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 4.3.0, Phoenix Firestorm 4.4.0
    • Fix Version/s: Phoenix Firestorm 4.5.0
    • Component/s: Rendering
    • Labels:
    • Environment:
    • SL Avatar Name:
      Whirly Fizzle
    • Patch attached:
      Patch attached
    • Reported In:
      Firestorm 4.3.0

      Description

      If an avatar is turned away from a sliding door when another avatar opens/closes the door, the viewer does not receive the object update or it disregards it.
      As a result avatars run against an invisible wall while trying to pass the door when they face it the next time.

      Repro

      • Create two boxes, 1.2 x 0.05 x 2.0
      • Link the Boxes
      • Drop in this script:
      integer open=FALSE;
       
      default
      {
          state_entry()
          {
          }
       
          touch_start(integer total_number)
          {
              open=!open;
              float pos=0.0;
              if(open)
                  pos=1.5;
              llSetLinkPrimitiveParams(2,
              [
                  PRIM_POS_LOCAL,<pos,0.1,0.0>
              ]);
          }
      }
      • Have one avatar operate the door
      • Have another avatar look at the boxes from 20 m distance
      • Click on the boxes to "slide the door open".
      • Turn the watching avatar 180 so it faces the opposite direction.
      • Wait for 5 seconds
      • Click the boxes to "slide the door shut".
      • Wait 5 seconds
      • Turn the watching avatar back around

      Observed:

      The "door" sometimes still appears to be open

      Expected:

      The "door" should appear closed.

      1. lldrawable.cpp
        34 kB
        MartinRJ Fayray
      2. phoenix-firestorm-lgpl rev c1f6a37c05fa.diff
        0.6 kB
        MartinRJ Fayray
      3. review.diff
        0.6 kB
        MartinRJ Fayray
      4. review cool-nipples-bug rev 57607ee.diff
        0.6 kB
        MartinRJ Fayray

        Issue Links

          Activity

          taliadavidov Talia Davidov added a comment -

          Well since my issue was closed and linked to this as a duplicate . . .

          It happens to me without me having to be facing away. I can be faced directly towards the door and not see it move.

          whirly.fizzle Whirly Fizzle added a comment -

          Talia, are you using SetLinkPrimitiveParams in your scripts too?
          Can you give me a SLURL where I can see your cages?
          Thanks!

          taliadavidov Talia Davidov added a comment -

          Yes I am using SetLinkPrimitiveParams. I also uninstalled 4.3.1 and went back to 4.3.0 and confirm it was in there.

          Slurl http://slurl.com/secondlife/Night%20Wish/226/238/48/

          Thanks

          whirly.fizzle Whirly Fizzle added a comment -

          Hiya Talia,

          I can reproduce that issue with your cage at that SLURL.
          You are right, I think this is a different issue. Im going to reopen FIRE-8528 and I will leave a comment there.
          Thanks!

          whirly.fizzle Whirly Fizzle added a comment -

          Still repros on Firestorm 4.4.0 (32680) Feb 8 2013 09:55:39 (Firestorm-Fizzlefire) with OpenSimulator support

          Reproduces on Second Life 3.4.5 (270034) Feb 5 2013 10:46:31 (Second Life Beta Viewer)

          martinrj fayray MartinRJ Fayray added a comment - - edited

          Hello,
          I've attached a fix which fixes not only the position- bug but also the bug of not-updating child-rotations(don't know the JIRA-id).
          Please add a fix for this bug asap, because my commissioners are going to kill me if this isn't fixed

          ETA: Repo is here https://bitbucket.org/MartinRJ/bug-840

          whirly.fizzle Whirly Fizzle added a comment - - edited

          Thanks Martin! <3

          Just adding the notes from Henri on Opensource-dev:

          I have a similar fix for weeks in the Cool VL Viewer, but it is alas
          not as simple as that...

          There's a problem with resizing chid primitives (they don't resize
          on screen, even when visible).
          There's a problem with rotating and moving child primitives when
          they are out of FOV, but fixing it by checking for target rot and
          position changes like you did also breaks some vehicles (when you
          or another avatar sits on such vehicles, some chil primitives
          pertaining to this vehicle "stay behind" when the vehicle moves).

          So, far, I came up with a proper fix for resizing child primitives
          and an experimental fix for moving/rotating out of FOV child
          primitives (I'm testing for flagUsePhysics() and not applying the
          fix when the flag is TRUE, which should exclude vehicles cild prims).
          By lack of vehicles to test the latter (I don't use vehicles in SL
          and the couple I got in my inventory are not affected by this bug),
          I cannot guarantee that it is "final".

          Here is the code I use, for people interested in experiencing:

          // Returns "distance" between target destination and resulting xfrom
          F32 LLDrawable::updateXform(BOOL undamped)
          {
          BOOL damped = !undamped;

          // Position
          LLVector3 old_pos(mXform.getPosition());
          LLVector3 target_pos;
          if (mXform.isRoot())

          Unknown macro: { // get root position in your agent's region target_pos = mVObjp->getPositionAgent(); }

          else

          Unknown macro: { // parent-relative position target_pos = mVObjp->getPosition(); }

          // Rotation
          LLQuaternion old_rot(mXform.getRotation());
          LLQuaternion target_rot = mVObjp->getRotation();
          bool no_target_omega = mVObjp->getAngularVelocity().isExactlyZero();

          // Scaling
          LLVector3 target_scale = mVObjp->getScale();
          LLVector3 old_scale = mCurrentScale;
          LLVector3 dest_scale = target_scale;

          // Damping
          F32 dist_squared = 0.f;
          F32 camdist2 = mDistanceWRTCamera * mDistanceWRTCamera;

          if (damped && isVisible())
          {
          F32 lerp_amt = llclamp(LLCriticalDamp::getInterpolant(OBJECT_DAMPING_TIME_CONSTANT),
          0.f, 1.f);
          LLVector3 new_pos = lerp(old_pos, target_pos, lerp_amt);
          dist_squared = dist_vec_squared(new_pos, target_pos);

          LLQuaternion new_rot = nlerp(lerp_amt, old_rot, target_rot);
          dist_squared += (1.f - dot(new_rot, target_rot)) * 10.f;

          LLVector3 new_scale = lerp(old_scale, target_scale, lerp_amt);
          dist_squared += dist_vec_squared(new_scale, target_scale);

          if (dist_squared >= MIN_INTERPOLATE_DISTANCE_SQUARED * camdist2 &&
          dist_squared <= MAX_INTERPOLATE_DISTANCE_SQUARED)

          Unknown macro: { // interpolate target_pos = new_pos; target_rot = new_rot; target_scale = new_scale; }

          else if (no_target_omega)
          {
          // snap to final position (only if no target omega is applied)
          dist_squared = 0.0f;
          if (getVOVolume() && !isRoot())

          Unknown macro: { // child prim snapping to some position, needs a rebuild gPipeline.markRebuild(this, LLDrawable}

          }
          }

          if (old_scale != target_scale)
          { // scale change requires immediate rebuild
          mCurrentScale = target_scale;
          if (!isRoot() && !isState(LLDrawable::ANIMATED_CHILD))

          Unknown macro: { setState(LLDrawable}

          gPipeline.markRebuild(this, LLDrawable::REBUILD_POSITION, TRUE);
          }
          else if (!isRoot() && !mVObjp->getRootEdit()->flagUsePhysics() &&
          (dist_squared > 0.f || old_pos != target_pos ||
          target_rot != old_rot || !no_target_omega))
          {
          // child prim moving relative to parent, tag as needing to be rendered
          // atomically and rebuild
          dist_squared = 1.f; // keep this object on the move list
          if (!isState(LLDrawable::ANIMATED_CHILD))

          Unknown macro: { setState(LLDrawable}

          }
          else if (!getVOVolume() && !isAvatar())

          Unknown macro: { movePartition(); }

          // Update
          mXform.setPosition(target_pos);
          mXform.setRotation(target_rot);
          mXform.setScale(LLVector3(1, 1, 1)); // no scale in drawable transforms (IT'S A RULE!)
          mXform.updateMatrix();

          if (mSpatialBridge)

          Unknown macro: { gPipeline.markMoved(mSpatialBridge, FALSE); }

          return dist_squared;
          }

          Henri.

          martinrj fayray MartinRJ Fayray added a comment - - edited

          Update:
          I updated the attached review-file.
          I have successfully tested it against the following bugs:
          BUG-840 [positionbug], BUG-840: Viewer 3.4.2 (Beta) breaks almost every sliding door script in SL
          MAINT-2275 [vehiclebug], Child prims are "left behind" by animated, moving physical objects
          MAINT-1742 [selection], Child object does not update position while selected.
          MAINT-2247 [selection] Child object does not update rotation while selected.

          ETA
          I also updated/recreated my repositry: https://bitbucket.org/MartinRJ/bug-840/

          martinrj fayray MartinRJ Fayray added a comment - - edited

          Update: I did some cleanup on the code, and re-created the FIRE-8279 repository, and updated the attached patch. TY!
          I created a firestorm repository with the changes here: https://bitbucket.org/MartinRJ/fire-8279
          And added a patch "phoenix-firestorm-lgpl rev c1f6a37c05fa.diff" against http://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/c1f6a37c05fa

          I uploaded a test-build: https://bitbucket.org/MartinRJ/fire-8279/downloads/Firestorm-private-secondlife.exe (here is the installer: http://sdrv.ms/XSmjHc )

          ETA: I successfully tested the patch on the LL viewer against all 5 addressed bugs (2 vehicle bugs, scale bug, rotation bug, position bug). Although the bug Henri mentioned (about not updating tiny link-prims when they change in size) doesn't either reproduce for me on the official LL release. I also bought the repro-object on the marketplace that he used to repro the bug, but I don't see any issues with scaling tiny linked prims in either a viewer with my fix nor in the current LL release (Second Life 3.4.5 (270263)).

          Thank you, Whirly!

          martinrj fayray MartinRJ Fayray added a comment - - edited

          Here is a fix for the bug that Henri mentioned (tiny linked prims that don't update in size correctly, see https://jira.secondlife.com/browse/BUG-1709 ):
          https://bitbucket.org/MartinRJ/cool-nipples-bug
          Here is a link to a test build: http://sdrv.ms/XWQsFo

          martinrj fayray MartinRJ Fayray added a comment - - edited

          Test plan ( for BUG-840 and the related BUG-1709 ):

          Get a copy of https://marketplace.secondlife.com/p/linkprims-test-set/4536674 for 0L$

          The object contains a coalesced item ("rotating child prims", "moving child prims", "resizing linked prims", "moving root prims", "rotating root prims"),
          two HUDs ("changing prims HUD", "changing prims LOOKING AWAY - HUD"),
          four test vehicles ("VEHICLE moving child prims", "VEHICLE moving root prims", "VEHICLE rotating child prims", "VEHICLE rotating root prims")
          and the following two items: "SIT ON resizing linked prims", "tiny resizing linked prims".

          The objects perform manipulations on their linkset, when the user clicks on the HUD (the HUD will blink once when it recognized a mouseclick).
          The first HUD "changing prims HUD" is meant to test the linkset manipulation while the manipulated objects are in the user's view.

          The second HUD "changing prims LOOKING AWAY - HUD" can be used to test the same test cases while the manipulated objects are not in the user's view.
          When the user clicks the latter, it will move the user's camera to 30m below the avatar's position, then shout the command to the linksets (on channel 1), and after about a second it will reset the user's view again.

          The vehicles use a Linden hovercraft script which reproduced the vehicle bug (BUG-1423) for me in the SL Release 3.4.5 viewer almost every time I tried.
          The vehicles will delete themselves when the user stands up from them ( because I tested so many times that they were spread all across my land : )

          The tests will need to check each of the following test cases...

          • ...in vehicle mode (respectively with an avatar sitting on it for the test with llSetScale, as physical objects cannot get resized) while the test-objects are being manipulated
          • ...when the user (and his camera view) is closer than 10m to the test-objects while they are being manipulated
          • ...when the user (and his camera view) is farther than 20m away from the test-objects while they are being manipulated
          • ...when the user does not have the test-objects in view while they are being manipulated
          • ...when the user does have the test-objects in view while they are being manipulated
          • ...when the user zooms very close to the test-objects while they are being manipulated (less than 0.5m)
          • ...when the user has the test-objects selected (in build mode) while they are being manipulated

          The test cases test manipulation of scale/size, position and rotation of the root prim as well as of the child prims of a linkset.


          Test

          • Rezz the coalesced item from the test box (the coalesced item consists of: "rotating child prims", "moving child prims", "resizing linked prims", "moving root prims", "rotating root prims").
          • There should be 6 big red prims visible, none of them covered from a blue or black prim.
          • Put on the "changing prims LOOKING AWAY - HUD".
          • Move more than 20m away from the rezzed items.
          • Press ESCAPE on your keyboard two or three times, so that your viewer's camera is 'free' and can be catched from the HUD's script.
          • Click the HUD and wait for a moment until your camera automatically moved 30m below your avatar's position, and until the HUD blinked.
          • Wait until the camera is reset and examine the objects.
            Expected result:
            None of the 6 big red prims should be visible anymore.
            They should be covered from the black/blue prims, respectively the two red cubes in the middle of the test objects should be so small that they can barely be seen.

          Repeat the last three steps (press ESCAPE if needed, click the HUD, wait for a moment until the camera has moved away and back again, and then examine the objects again).
          Expected result:
          The 6 big red prims should be visible again.

          Keep the objects rezzed for the next test:
          Test

          • Replace the HUD with the other one: "changing prims HUD" (which does not manipulate the user's camera)
          • Move more than 20m away from the rezzed items.
          • Keep looking at the items.
          • Click the HUD and wait for a moment until the HUD blinked.
          • Examine the objects.
            Expected result:
            None of the 6 big red prims should be visible anymore.
            They should be covered from the black/blue prims, respectively the two red cubes in the middle of the test objects should be so small that they can barely be seen.

          Repeat the last three steps (Click the HUD, wait for a moment, and then examine the objects).
          Expected result:
          The 6 big red prims should be visible again.

          Still keep the objects rezzed for the next test:
          Test

          • Move more than 20m away from the rezzed items.
          • Select all 5 test objects in edit-mode/build-mode.
          • Keep looking at the objects.
          • Shout the command "/1 test" in chat (or any other message on channel 1). Make sure you use 'shout' (CTRL+ENTER) so that the objects can receive the command even if they are far away.
          • Examine the objects.
            Expected result:
            None of the 6 big red prims should be visible anymore.
            They should be covered from the black/blue prims, respectively the two red cubes in the middle of the test objects should be so small that they can barely be seen.

          Repeat the last four steps (Keep the objects selected, shout "/1 test" in chat, wait for a moment, and then examine the objects).
          Expected result:
          The 6 big red prims should be visible again.

          Still keep the objects rezzed for the next test:
          Test

          • Move more than 20m away from the rezzed items.
          • Select all 5 test objects in edit-mode/build-mode.
          • Look in the opposite direction, so that none of the objects is in view.
          • Shout the command "/1 test" in chat (or any other message on channel 1). Make sure you use 'shout' (CTRL+ENTER) so that the objects can receive the command even if they are far away.
          • Turn around again and examine the objects.
            Expected result:
            None of the 6 big red prims should be visible anymore.
            They should be covered from the black/blue prims, respectively the two red cubes in the middle of the test objects should be so small that they can barely be seen.

          Repeat the last four steps (Keep the objects selected, look away from the objects, shout "/1 test" in chat, wait for a moment, and then turn back around and examine the objects).
          Expected result:
          The 6 big red prims should be visible again.

          Repeat all four tests from above but don't move 20m away, but stay close to the objects instead, this time (less than 10m away).


          (The following test addresses ONLY the fix for BUG-1709 and is supposed to fail in a viewer without this fix)
          Test

          • Put on the "changing prims HUD" (which does not manipulate the user's camera).
          • Rezz "tiny resizing linked prims", a very small linkset (0.06m x 0.01m) of two small red cuboids.
          • Zoom in very close to the object.
          • Click the HUD and wait for a moment until the HUD blinked.
            Expected result:
            Both prims became perfectly shaped 0.01m x 0.01m x 0.01m cubes (make sure they are not a bit smaller or bigger than they should be).

          Repeat the last step (click the HUD, wait until it blinked, and then examine the object).
          Expected result:
          Both prims are of the exact original cuboid shape as before (0.02m x 0.01m x 0.01m).

          Keep the "tiny resizing linked prims" test-object rezzed for the next test:
          (The following test addresses ONLY the fix for BUG-1709 and is supposed to fail in a viewer without this fix)
          Test

          • Replace your HUD with "changing prims LOOKING AWAY - HUD"
          • Press ESCAPE on your keyboard two or three times, to 'free' your viewer's camera so that it can be catched from the HUD's script.
          • Move the "tiny resizing linked prims" test-object very close to your camera.
          • Click the HUD and wait for a moment until your camera automatically moved 30m below your avatar's position, and until the HUD blinked.
          • Wait until the camera is reset and examine the objects.
            Expected result:
            Both prims became perfectly shaped 0.01m x 0.01m x 0.01m cubes (make sure they are not a bit smaller or bigger than they should be).

          Repeat the last three steps (press ESCAPE if needed, click the HUD, wait for a moment until the camera has moved away and back again, and then examine the object again).
          Expected result:
          Both prims are of the exact original cuboid shape as before (0.02m x 0.01m x 0.01m).

          Keep the "tiny resizing linked prims" test-object rezzed for the next test:
          (The following test addresses ONLY the fix for BUG-1709 and is supposed to fail in a viewer without this fix)
          Test

          • Select the test object in edit-mode/build-mode.
          • Keep looking at the objects.
          • Say the command "/1 test" in chat (or any other message on channel 1).
          • Examine the object.
            Expected result:
            Both prims became perfectly shaped 0.01m x 0.01m x 0.01m cubes (make sure they are not a bit smaller or bigger than they should be).

          Repeat the last step (Keep the object selected, say "/1 test" in chat, and examine the object).
          Expected result:
          Both prims are of the exact original cuboid shape as before (0.02m x 0.01m x 0.01m).

          Keep the "tiny resizing linked prims" test-object rezzed for the next test:
          (The following test addresses ONLY the fix for BUG-1709 and is supposed to fail in a viewer without this fix)
          Test

          • Select the test object in edit-mode/build-mode.
          • Look in the opposite direction, so that the test-object is not in view.
          • Say the command "/1 test" in chat (or any other message on channel 1).
          • Turn around again and examine the object.
            Expected result:
            Both prims became perfectly shaped 0.01m x 0.01m x 0.01m cubes (make sure they are not a bit smaller or bigger than they should be).

          Repeat the last two steps (Keep the object selected, look away from the object, say "/1 test" in chat, wait for a moment, and then turn back around and examine the object).
          Expected result:
          Both prims are of the exact original cuboid shape as before (0.02m x 0.01m x 0.01m).


          Test

          • Put on the "changing prims HUD" (which does not manipulate the user's camera).
          • Rezz the "SIT ON resizing linked prims" test object and sit on it.
          • Move the camera more than 20m away from the test object.
          • Click the HUD and wait for a moment until the HUD blinked.
          • Examine the object.
            Expected result:
            Both prims became very small (almost not visible).

          Repeat the last two steps (click the HUD, wait until it blinked, and then examine the object).
          Expected result:
          The two red prims returned to their original (bigger) size.

          Continue sitting on the object for the next test:
          Test

          • Move the camera more than 20m away from the test object.
          • Look in the opposite direction, so that the object is not in view.
          • Click the HUD and wait for a moment until the HUD blinked.
          • Turn around again and examine the object.
            Expected result:
            Both prims became very small (almost not visible).

          Repeat the last three steps (look in the opposite direction, click the HUD, wait until it blinked, turn around again and examine the object).
          Expected result:
          The two red prims returned to their original (bigger) size.

          Continue sitting on the object for the next test:
          Test

          • Select the test object in edit-mode/build-mode.
          • Move the camera more than 20m away from the test object.
          • Say the command "/1 test" in chat (or any other message on channel 1).
          • Examine the object.
            Expected result:
            Both prims became very small (almost not visible).

          Repeat the last two steps (Keep the object selected, say "/1 test" in chat, wait for a moment, and then examine the object).
          Expected result:
          The two red prims returned to their original (bigger) size.

          Continue sitting on the object for the next test:
          Test

          • Select the test object in edit-mode/build-mode.
          • Move the camera more than 20m away from the test object.
          • Look in the opposite direction, so that the object is not in view.
          • Say the command "/1 test" in chat (or any other message on channel 1).
          • Turn around again and examine the object.
            Expected result:
            Both prims became very small (almost not visible).

          Repeat the last four steps (Keep the object selected, look away from the object, say "/1 test" in chat, wait for a moment, and then turn back around and examine the object).
          Expected result:
          The two red prims returned to their original (bigger) size.

          Repeat all four tests from above but don't move the camera 20m away, but keep it close to the objects instead, this time (less than 10m away).


          Repeat the following tests with all four test vehicles:
          "VEHICLE moving child prims", "VEHICLE moving root prims", "VEHICLE rotating child prims", "VEHICLE rotating root prims".
          (A test with "VEHICLE rotating root prims" will fail if the avatar does NOT sit on the object, because of an other unrelated bug with failing alpha-updates: VWR-17462 - or a similar alpha bug,
          but it should work, following the test plan)

          I recommend to test the following vehicle-tests on a semi-transparent platform, because the Linden hovercraft script will in some cases put the camera position below the vehicle.

          Test

          • Put on the "changing prims HUD".
          • Rezz the vehicle, make sure the big red prim is visible.
          • Sit down on the vehicle, and wait until it starts up (it will start hovering after a couple of seconds).
          • Click the HUD and wait for a moment until the HUD blinked.
            Expected result:
            The red prim is gone (covered completely by another prim/or became very small, almost invisible).

          Repeat the last step (click the HUD, wait until it blinked, and then examine the vehicle).
          Expected result:
          The red prim is visible again.
          Stand up (the vehicle should get deleted automatically).

          Test

          • Rezz the vehicle, make sure the big red prim is visible.
          • Sit down on the vehicle, and wait until it starts up (it will start hovering after a couple of seconds).
          • Select the vehicle in edit-mode/build-mode.
          • Say the command "/1 test" in chat (or any other message on channel 1).
            Expected result:
            The red prim is gone (covered completely by another prim/or became very small, almost invisible).

          Repeat the last two steps (Keep the vehicle selected, say "/1 test" in chat, wait for a moment, and then examine the vehicle).
          Expected result:
          The red prim is visible again.
          Stand up (the vehicle should get deleted automatically).

          Test

          • Rezz the vehicle, make sure the big red prim is visible.
          • Sit down on the vehicle, and wait until it starts up (it will start hovering after a couple of seconds).
          • Select the vehicle in edit-mode/build-mode.
          • Look in the opposite direction, so that the vehicle is not in view.
          • Say the command "/1 test" in chat (or any other message on channel 1).
          • Turn around again and examine the vehicle.
            Expected result:
            The red prim is gone (covered completely by another prim/or became very small, almost invisible).

          Repeat the last four steps (Keep the vehicle selected, look away from the vehicle, say "/1 test" in chat, wait for a moment, and then turn back around and examine the vehicle).
          Expected result:
          The red prim is visible again.
          Stand up (the vehicle should get deleted automatically).

          Test

          • Put on the "changing prims LOOKING AWAY - HUD".
          • Rezz the vehicle, make sure the big red prim is visible.
          • Sit down on the vehicle, and wait until it starts up (it will start hovering after a couple of seconds).
          • Press ESCAPE on your keyboard two or three times, to 'free' your viewer's camera so that it can be catched from the HUD's script.
          • Click the HUD and wait for a moment until your camera automatically moved 30m below your avatar's position, and until the HUD blinked.
          • Wait until the camera is reset and examine the vehicle.
            Expected result:
            The red prim is gone (covered completely by another prim/or became very small, almost invisible).

          Repeat the last three steps (press ESCAPE if needed, click the HUD, wait for a moment until the camera has moved away and back again, and then examine the vehicle again).
          Expected result:
          The red prim is visible again.
          Stand up (the vehicle should get deleted automatically).

          whirly.fizzle Whirly Fizzle added a comment -

          QA note: Martin's patch will probably also fix FIRE-9445

          martinrj fayray MartinRJ Fayray added a comment -

          I think this can be closed now!

          whirly.fizzle Whirly Fizzle added a comment -

          Im not sure we have all your V3 fixes in yet for this Martin. Once we are fully merged up past CHUI we will have them.
          I want to leave this open for now until I have time to tripple check this no longer repoduces.

          whirly.fizzle Whirly Fizzle added a comment -

          We dont yet have all these issues fixed.
          Will retest when CHUI merge is more stable.

          whirly.fizzle Whirly Fizzle added a comment -

          Finally fixed with last merge! \o/

          Tested on Firestorm 4.5.0 (37931) Sep 7 2013 12:20:42 (Firestorm-Fizzlefire) with OpenSimulator support

          martinrj fayray MartinRJ Fayray added a comment - - edited

          Yay
          Thank you much!

          panterapolnocy Pantera Północy added a comment - - edited

          Sliding doors problem remained, still - or I'm just unlucky. Rev. 38066.

          Video:
          http://www.youtube.com/watch?v=ccs6ZEAKdNM

          Few inworld facts:

          • This has appeared right after logging in.
          • Doors were initially closed, obviously.
          • My floating skybox is divided into smaller two parcels. Doors are in the "privatized" one, with "you can't see avatars in this parcel" checked.
          • I've logged in on the "public" one.
          • Doors are, in addition, behind the invisible passwall (so can't even be clicked from the "public" parcel, that's why I'm camming around the door: http://i.imgur.com/wmVzfFa.jpg ), but this shouldn't have influence on the object updating.
          martinrj fayray MartinRJ Fayray added a comment -

          Hiya Chakat,
          when you have time, I'd like to meet in-world to see your test-setup. Dropped you an IM.

          martinrj fayray MartinRJ Fayray added a comment -

          I think what Chakat is seeing is https://jira.secondlife.com/browse/BUG-2116 ("Objects Intermittently Not Appearing Or Not Fully Appearing On Login") - an interest list bug.

          The doors in his video are completely invisible: http://i.imgur.com/bmy9rWL.jpg (this is a comparison to what I'm seeing).

          This fix was for doors which were visible, but didn't update their position until the user right-clicked them.

          whirly.fizzle Whirly Fizzle added a comment -

          I have been unable to repro this so far with Chakat's doors & yeah this seems to be BUG-2116 on the video at least.
          The fact that the BUG-2116 is usually affecting just the doors on login isnt that unusual - it often affects the same prims in a linkset each login & it always seems to be something close by to your usual login spot thats affected. Even after an object cache (or total cache) purge, its pretty much always the same prims affected again when it returns.
          With the BUG-2116 bug, the bounding boxes of the invisible prims will always display correctly so if you enable BB's when the doors are invisible at login, you should see those in the closed position.


            People

            • Assignee:
              shouldbeworkingonit.linden ShouldBeWorkingOnIt Linden
              Reporter:
              whirly.fizzle Whirly Fizzle
            • Votes:
              5 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: