Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-8302

[BUG-880] [MAINT-1960] Objects fail to show in inventory search when taken if the same name is entered in the inventory filter with no results shown.

    Details

    • Type: Bug
    • Status: Passed QA
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 4.2.2, Phoenix Firestorm 4.3.0, Phoenix Firestorm 4.4.0, Phoenix Firestorm 4.4.5
    • Fix Version/s: Phoenix Firestorm 4.4.2
    • Component/s: Inventory
    • Labels:
    • Reported In:
      Firestorm 4.4.0.33564 Beta

      Description

      Best explained with repro:

      Make sure you have no objects in inventory named the same as your test obejct.

      I used a test object named "zzzzzzz".

      Collapse the inventory search and enter "zzzzzzz". No results are shown.

      Rez a cube. Change the name to "zzzzzzz". Take a copy. Notice the inventory flickers for a sec as if it tried to show the object but didn't. No additional copies or taking will show the objects in inventory until the name in the search filter is changed.

        Issue Links

          Activity

          willow wilder Willow Wilder added a comment -

          Hey Lucia –
          Unable to reproduce
          Firestorm 4.3.0 (30936) Nov 13 2012 23:33:24 (Firestorm-beta)

          Followed your steps to reproduce.
          Saw the flicker you referred to.
          Folders were in collapsed state as a result of no-return search.
          Click Expand, zzzzz object in Objects folder.

          lucy daughter of the devil Lucia Nightfire added a comment -

          Hi Willow. Where that flicker occurs, the taken object should show in inventory without need of expand, but doesn't.

          In Phoenix, the object shows with this repro without need of expand.

          whirly.fizzle Whirly Fizzle added a comment -

          Confirmed on both Firestorm 4.3.0 Beta and Viewer 3 beta (Second Life 3.4.3 (267135) Nov 19 2012 13:31:37 (Second Life Beta Viewer))

          This looks like another case of FIRE-7699 but its a good repro that always works.

          Would you agree this is FIRE-7699 Lucia?

          On 4.3.0 Beta:

          On Firestorm 4.2.2 release, when you take the cube to inventory, the inventory folder expands to show the Objects folder, but the Object folder does not expand to show the actual object.

          On Phoenix 1691:

          Folders fully expand to show the object

          Hmm Not sure this is a dupe actually because this is still partly broken on 4.2.2, Ill mark as related

          whirly.fizzle Whirly Fizzle added a comment -

          Second Life 3.3.4 (264214) Aug 31 2012 06:30:36 (Second Life Release) behaves the same as 4.2.2 release

          whirly.fizzle Whirly Fizzle added a comment -

          On FS Beta Mesh 3.0.1 - same as Phoenix

          whirly.fizzle Whirly Fizzle added a comment -

          Filed on LL JIRA: https://jira.secondlife.com/browse/BUG-880

          Lucia, youve kept me busy today

          Paste of that issue...

          Objects fail to show in inventory search when taken if the objects name is entered in the inventory filter with no results shown

          Steps To Reproduce

          • Rez a cube and name it zzzzzzzzzz
            Note: You must not have any objects already in your inventory with this name
          • Open Inventory and enter zzzzzzzzzz as the search term
          • Observe no results are shown as expected
          • Right click cube -> Take Copy (or Take)

          Expected Results

          Inventory folders should expand to show object zzzzzzzzzz


          (this shot is showing behaviour on an old Firestorm, because its broken on any V3 that doesnt autoupdate atm)

          Observed Behaviour

          • Second Life 3.4.1 (266581) Nov 5 2012 12:17:12 (Second Life Release)
          • Second Life 3.4.3 (267135) Nov 19 2012 13:31:37 (Second Life Beta Viewer)
          • Firestorm 4.3.0 (30936) Nov 13 2012 23:33:24 (Firestorm-beta)

          Root inventory folder does not expand at all


          • Second Life 3.3.4 (264214) Aug 31 2012 06:30:36 (Second Life Release)
          • Firestorm 4.2.2 (29837) Aug 27 2012 19:20:05 (Firestorm-Release) [3.3.3 codebase]

          Root inventory folder expands to show objects folder, but objects folder does not expand to show the object


          • Second Life 1.23.5 (136262) Oct 14 2009 12:08:26 (Second Life Release)
          • Firestorm 3.0.1 (22566) Sep 11 2011 13:22:35 (Firestorm-Beta-Mesh)
          • Phoenix Viewer 1.6.1 (1691) Mar 19 2012 11:12:11 (Phoenix Viewer Release Mesh)

          Expected behaviour - the folders fully expand to show the object

          Other Information

          • The complete non expanding of folders on the current release and beta are probably the same issue as BUG-629, however that bug only started on the 3.4.0 codebase.
            Second Life 3.3.4 (264214) is still not giving expected behaviour
          lucy daughter of the devil Lucia Nightfire added a comment -

          Appears fixed on FS 4.4.2,FS 4.5.2 and v3 3.6.11

          greatfox snowpaw Futashy added a comment -

          Confirmed fixed on Firestorm 4.5.2 (39738) Dec 5 2013 02:34:30 (Firestorm-nightly) with Havok support

          whirly.fizzle Whirly Fizzle added a comment -

          Confirmed fixed on Firestorm 4.5.2 (39740) Dec 2 2013 00:13:12 (Firestorm-Fizzlefire) with OpenSimulator support

          Thanks Lucia


            People

            • Assignee:
              shouldbeworkingonit.linden ShouldBeWorkingOnIt Linden
              Reporter:
              lucy daughter of the devil Lucia Nightfire
            • Votes:
              1 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: