Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-8323

Firestorm 4.3.0 Beta not running anymore on 64 bit Debian Unstable or *buntu 12.10 based systems

    Details

    • Type: Story
    • Status: Closed
    • Priority: Major
    • Resolution: Out of Scope
    • Affects Version/s: Phoenix Firestorm 4.2.2
    • Component/s: None
    • Labels:
      None
    • Environment:
    • SL Avatar Name:
      Jean Horten
    • Reported In:
      Firestorm 4.3.0

      Description

      System crashed, installed a fresh one ( Linux Mint 14 64-bit, based on Ubuntu 12.10) and could not get FS to run anymore due to changes in the support of 32 bit applications in Ubuntu (Multiarch instead of ia-32 libs). Decided to switch to Debian Unstable (Sid) 64 bit,same issue, multiarch instead of ia-32 libs. I am not able to run FS anymore on my system, and I am sure many others will have this issue in teh coming future, when Übuntu 12.10 based systems are used more often. Seems it's time for a native 64 bit viewer for linux.
      Here's my Error message:
      64-bit Linux detected.
      Running from /home/jeannie/Stuff/Phoenix_Firestorm-beta_i686_4.3.0.30936
      /home/jeannie/Stuff/Phoenix_Firestorm-beta_i686_4.3.0.30936/firestorm: Zeile 89: ./etc/register_hopprotocol.sh: Datei oder Verzeichnis nicht gefunden
      bin/do-not-directly-run-firestorm-bin: error while loading shared libraries: libGL.so.1: wrong ELF class: ELFCLASS64

          • Bad shutdown ($LL_RUN_ERR). ***
            ERROR: ld.so: object '/home/jeannie/Stuff/Phoenix_Firestorm-beta_i686_4.3.0.30936/lib/libcrypto.so.1.0.0' from LD_PRELOAD cannot be preloaded: ignored.
            ERROR: ld.so: object '/home/jeannie/Stuff/Phoenix_Firestorm-beta_i686_4.3.0.30936/lib/libssl.so.1.0.0' from LD_PRELOAD cannot be preloaded: ignored.

      ERROR: ld.so: object '/home/jeannie/Stuff/Phoenix_Firestorm-beta_i686_4.3.0.30936/lib/libcrypto.so.1.0.0' from LD_PRELOAD cannot be preloaded: ignored.
      ERROR: ld.so: object '/home/jeannie/Stuff/Phoenix_Firestorm-beta_i686_4.3.0.30936/lib/libssl.so.1.0.0' from LD_PRELOAD cannot be preloaded: ignored.
      You are running the Firestorm Viewer on a x86_64 platform. The
      most common problems when launching the Viewer (particularly
      'bin/do-not-directly-run-firestorm-bin: not found' and 'error while
      loading shared libraries') may be solved by installing your Linux
      distribution's 32-bit compatibility packages.
      For example, on Ubuntu and other Debian-based Linuxes you might run:
      $ sudo apt-get install ia32-libs ia32-libs-gtk ia32-libs-kde ia32-libs-sdl
      jeannie@siductionbox:~$

        Issue Links

          Activity

          Hide
          miro.collas Miro Collas added a comment -

          Have you tried installing ia32?

          Show
          miro.collas Miro Collas added a comment - Have you tried installing ia32?
          Hide
          jean horten Jean Horten added a comment -

          I have, no success, seems multiarch breaks 32 bit compatibility

          Show
          jean horten Jean Horten added a comment - I have, no success, seems multiarch breaks 32 bit compatibility
          Hide
          whirly.fizzle Whirly Fizzle added a comment -

          Heya Jean,

          Theres been some discussion of this problem with Debian on the LL JIRA too.
          See Ratany's comment here and onwards: https://jira.secondlife.com/browse/OPEN-27?focusedCommentId=351596&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-351596

          Show
          whirly.fizzle Whirly Fizzle added a comment - Heya Jean, Theres been some discussion of this problem with Debian on the LL JIRA too. See Ratany's comment here and onwards: https://jira.secondlife.com/browse/OPEN-27?focusedCommentId=351596&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-351596
          Hide
          tonya Tonya Souther added a comment -

          A native, distributable 64-bit build is not a trivial thing to accomplish. Many libraries would have to be rebuilt as 64-bit, and that's not always easy. Take a look at the instructions on building Firestorm standalone if you don't believe me: http://wiki.phoenixviewer.com/fs_compiling_firestorm_64bit_kubuntu

          We're thinking about 64-bit builds, but they probably won't be ready for this next release.

          In any case, Debian screwed up 32-bit compatibility, and they need to fix it for lots of reasons besides Second Life.

          Show
          tonya Tonya Souther added a comment - A native, distributable 64-bit build is not a trivial thing to accomplish. Many libraries would have to be rebuilt as 64-bit, and that's not always easy. Take a look at the instructions on building Firestorm standalone if you don't believe me: http://wiki.phoenixviewer.com/fs_compiling_firestorm_64bit_kubuntu We're thinking about 64-bit builds, but they probably won't be ready for this next release. In any case, Debian screwed up 32-bit compatibility, and they need to fix it for lots of reasons besides Second Life.
          Hide
          jean horten Jean Horten added a comment -

          I know that 64 bit linux compiling link, tried to build a FS here already, but I cannot even compile Google Breakpad, compiling exits with an error

          Show
          jean horten Jean Horten added a comment - I know that 64 bit linux compiling link, tried to build a FS here already, but I cannot even compile Google Breakpad, compiling exits with an error
          Hide
          jean horten Jean Horten added a comment -

          Fixed it, installing libgl1-nvidia-glx:i386 solved it

          Show
          jean horten Jean Horten added a comment - Fixed it, installing libgl1-nvidia-glx:i386 solved it
          Hide
          miro.collas Miro Collas added a comment -

          To be sure we understand: installing the above package allows FS to run without error? Is this with ia32 or with multiarch - or both?

          I ask so that we can document your solution for others.

          Show
          miro.collas Miro Collas added a comment - To be sure we understand: installing the above package allows FS to run without error? Is this with ia32 or with multiarch - or both? I ask so that we can document your solution for others.
          Hide
          jean horten Jean Horten added a comment - - edited

          Have to correct myself, FS runs, but only very very slow ( 2-5 fps in low graphics, mid and higher deliver a black view of teh world) and only on OpenGL 2.1, not on OpenGL4.3 like other programmes, seems I need to install more i386 packages, if I only knew which.
          ia32 is not available anymore (transitional empty package only) on new debian/*buntu systems, you have to install all required i386 packages manually ( not all libs are available for multiarch though yet) , multiarch won't pull anything in, seems I will need to switch to another distro with working 32 bit compatibility

          Show
          jean horten Jean Horten added a comment - - edited Have to correct myself, FS runs, but only very very slow ( 2-5 fps in low graphics, mid and higher deliver a black view of teh world) and only on OpenGL 2.1, not on OpenGL4.3 like other programmes, seems I need to install more i386 packages, if I only knew which. ia32 is not available anymore (transitional empty package only) on new debian/*buntu systems, you have to install all required i386 packages manually ( not all libs are available for multiarch though yet) , multiarch won't pull anything in, seems I will need to switch to another distro with working 32 bit compatibility
          Hide
          miro.collas Miro Collas added a comment -

          Bleah - that sucks.

          Show
          miro.collas Miro Collas added a comment - Bleah - that sucks.
          Hide
          jean horten Jean Horten added a comment -

          It does, and the absolute ignorance that I am exposed to by debian supporters and developers is awful, for Debian it is: If it's noch packaged for Debian, don't use it, we don't care....
          My recommendation is to stay away from Debian multiarch, it was broken in the name of progress and it's not useable anymore for SL.

          Show
          jean horten Jean Horten added a comment - It does, and the absolute ignorance that I am exposed to by debian supporters and developers is awful, for Debian it is: If it's noch packaged for Debian, don't use it, we don't care.... My recommendation is to stay away from Debian multiarch, it was broken in the name of progress and it's not useable anymore for SL.
          Hide
          kool koolhoven Kool Koolhoven added a comment -

          Too bad I didn't see this JIRA before, because I just upgraded to Kubuntu 12.10 and now I can only use Singularity or other native 64 bit viewer, given I can't even build Firestorm standalone.

          Is something supposed to be fixed by Debian, LL or us? I guess not Debian, so I have tested different 32 bit apps, even some opengl windows apps under wine and they run perfectly.

          Cheers.

          Show
          kool koolhoven Kool Koolhoven added a comment - Too bad I didn't see this JIRA before, because I just upgraded to Kubuntu 12.10 and now I can only use Singularity or other native 64 bit viewer, given I can't even build Firestorm standalone. Is something supposed to be fixed by Debian, LL or us? I guess not Debian, so I have tested different 32 bit apps, even some opengl windows apps under wine and they run perfectly. Cheers.
          Hide
          serendipity Melissa Holmes added a comment -

          Hi there, I had the same problem. This: http://blog.linuxmint.com/?p=2211 fixed it for me... Hope that helps!

          Show
          serendipity Melissa Holmes added a comment - Hi there, I had the same problem. This: http://blog.linuxmint.com/?p=2211 fixed it for me... Hope that helps!
          Hide
          nico Nicoletta Schnute added a comment -

          Recomended Solution for Linux 64bit (Debian, Ubuntu, Mint)
          install ia32-libs (for now you need the 32bit libs, because Firestorm is still a 32Bit Program):

          Open Terminal (CTRL - SHIFT - T)
          Enter the following command:

          sudo apt-get install ia32-libs

          Enter root Password. (Letters are hidden)

          start Firestorm

          --------------------
          deutsch:

          Linux 64bit (Debian, Ubuntu, Mint)
          ia32-libs installieren (32bit Libs werden benötigt weil der Firestorm ein 32bit Program ist):

          Terminal öffnen mit STRG + Umschalt + T
          Folgende Zeile eingeben:
          sudo apt-get install ia32-libs
          root Passwort eingeben (wird nicht angezeigt)

          Firestorm starten

          Show
          nico Nicoletta Schnute added a comment - Recomended Solution for Linux 64bit (Debian, Ubuntu, Mint) install ia32-libs (for now you need the 32bit libs, because Firestorm is still a 32Bit Program): Open Terminal (CTRL - SHIFT - T) Enter the following command: sudo apt-get install ia32-libs Enter root Password. (Letters are hidden) start Firestorm -------------------- deutsch: Linux 64bit (Debian, Ubuntu, Mint) ia32-libs installieren (32bit Libs werden benötigt weil der Firestorm ein 32bit Program ist): Terminal öffnen mit STRG + Umschalt + T Folgende Zeile eingeben: sudo apt-get install ia32-libs root Passwort eingeben (wird nicht angezeigt) Firestorm starten
          Hide
          mystys Mysty Saunders added a comment -

          Thank you Nicoletta that is the correct solution. See the above screenshot showing FS working with Linux Mint 14.1

          Show
          mystys Mysty Saunders added a comment - Thank you Nicoletta that is the correct solution. See the above screenshot showing FS working with Linux Mint 14.1
          Hide
          krchat Rstan added a comment -

          How can I know if new release for Debian 7 x64 appear from Firestorm?

          Show
          krchat Rstan added a comment - How can I know if new release for Debian 7 x64 appear from Firestorm?
          Hide
          whirly.fizzle Whirly Fizzle added a comment -

          Heya Rstan,

          I see you have a watch on this issue. JIRA will email you whenever this issue is updated.
          Once this issue is marked as resolved, then a 64 bit Firestorm will be about to be released. One of the devs has been looking at attempting this, but it's not something that will happen in the very near future.

          You may also find the linked issues of interest.

          Show
          whirly.fizzle Whirly Fizzle added a comment - Heya Rstan, I see you have a watch on this issue. JIRA will email you whenever this issue is updated. Once this issue is marked as resolved, then a 64 bit Firestorm will be about to be released. One of the devs has been looking at attempting this, but it's not something that will happen in the very near future. You may also find the linked issues of interest.
          Hide
          krchat Rstan added a comment -

          Ok, I hope we inform us about it this thread. As for me, I'm going to set Debian 7x32 to another PC. I want to try Firestorm myself and also Standard LL viewer by Linux too.

          Show
          krchat Rstan added a comment - Ok, I hope we inform us about it this thread. As for me, I'm going to set Debian 7x32 to another PC. I want to try Firestorm myself and also Standard LL viewer by Linux too.
          Hide
          bluezy bluezy bleac added a comment -

          Ok, I have it under Debian Squeeze, you just have to make sure you install ia32-libs-gtk as there is a tiny file that you lack otherwise. I hope you will be helped with this little nugget.

          Show
          bluezy bluezy bleac added a comment - Ok, I have it under Debian Squeeze, you just have to make sure you install ia32-libs-gtk as there is a tiny file that you lack otherwise. I hope you will be helped with this little nugget.
          Hide
          mystys Mysty Saunders added a comment - - edited

          Ive only noticed this in Debian Wheezy (the testing branch) and wheezy based distros that ive installed. Ubuntu 12.10 64bit can run all the LL and 3rd party viewers ive installed and use without issues. This issue might actually be better placed as a Debian jira (at Debian not here ).

          Show
          mystys Mysty Saunders added a comment - - edited Ive only noticed this in Debian Wheezy (the testing branch) and wheezy based distros that ive installed. Ubuntu 12.10 64bit can run all the LL and 3rd party viewers ive installed and use without issues. This issue might actually be better placed as a Debian jira (at Debian not here ).
          Hide
          office@gehostet.de ANSI Soderstrom added a comment - - edited

          There is a new Ubuntu Version (3.2.0-52-generic).
          Now my Secondlife and my Firestorm won't load anymore with exact this above reported issue.
          Iam using Ubuntu 12.04LTS 3.2.0-52-generic.

          The bad thing is, if i try to boot a (working) previous Version (e.g. 3.2.0-49-generic), it also won't work anymore

          What can i do now ?

          ia32-libs is not my solution...

          xyz@THINKPAD:~$ sudo apt-get install ia32-libs
          [sudo] password for xyz:
          Paketlisten werden gelesen... Fertig
          Abhängigkeitsbaum wird aufgebaut
          Statusinformationen werden eingelesen... Fertig
          ia32-libs ist schon die neueste Version.
          Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
          language-pack-kde-de-base kde-l10n-de blender-codecs-ffmpeg1.0 libopenimageio1.1 linux-headers-3.2.0-29 linux-headers-3.2.0-29-generic libpython3.2 language-pack-kde-zh-hans-base firefox-locale-zh-hans
          language-pack-kde-de language-pack-kde-en kde-l10n-engb language-pack-zh-hans-base kde-l10n-zhcn language-pack-zh-hans language-pack-kde-zh-hans fonts-droid language-pack-kde-en-base
          Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
          0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
          xyz@THINKPAD:~$

          Show
          office@gehostet.de ANSI Soderstrom added a comment - - edited There is a new Ubuntu Version (3.2.0-52-generic). Now my Secondlife and my Firestorm won't load anymore with exact this above reported issue. Iam using Ubuntu 12.04LTS 3.2.0-52-generic. The bad thing is, if i try to boot a (working) previous Version (e.g. 3.2.0-49-generic), it also won't work anymore What can i do now ? ia32-libs is not my solution... xyz@THINKPAD:~$ sudo apt-get install ia32-libs [sudo] password for xyz: Paketlisten werden gelesen... Fertig Abhängigkeitsbaum wird aufgebaut Statusinformationen werden eingelesen... Fertig ia32-libs ist schon die neueste Version. Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt: language-pack-kde-de-base kde-l10n-de blender-codecs-ffmpeg1.0 libopenimageio1.1 linux-headers-3.2.0-29 linux-headers-3.2.0-29-generic libpython3.2 language-pack-kde-zh-hans-base firefox-locale-zh-hans language-pack-kde-de language-pack-kde-en kde-l10n-engb language-pack-zh-hans-base kde-l10n-zhcn language-pack-zh-hans language-pack-kde-zh-hans fonts-droid language-pack-kde-en-base Verwenden Sie »apt-get autoremove«, um sie zu entfernen. 0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert. xyz@THINKPAD:~$
          Hide
          mystys Mysty Saunders added a comment -

          Are you trying to run the 32bit client (like you would find on our webpage or a self compiled *.tar.bz2) or are you using the self compiled 64bit standalone version?

          Show
          mystys Mysty Saunders added a comment - Are you trying to run the 32bit client (like you would find on our webpage or a self compiled *.tar.bz2) or are you using the self compiled 64bit standalone version?
          Hide
          office@gehostet.de ANSI Soderstrom added a comment - - edited

          At the moment i fight with the precompiled 32Bit version (i solved the sibssl/libcrypto error, but hang now on the Framebuffer drivers....).
          How to get a 64Bit Version ? (sounds more easy to get it to run)

          Show
          office@gehostet.de ANSI Soderstrom added a comment - - edited At the moment i fight with the precompiled 32Bit version (i solved the sibssl/libcrypto error, but hang now on the Framebuffer drivers....). How to get a 64Bit Version ? (sounds more easy to get it to run)
          Hide
          ansariel.hiller Ansariel Hiller added a comment -

          Become a self-compiler and build it yourself: http://wiki.phoenixviewer.com/fs_compiling_firestorm_64bit_kubuntu

          Show
          ansariel.hiller Ansariel Hiller added a comment - Become a self-compiler and build it yourself: http://wiki.phoenixviewer.com/fs_compiling_firestorm_64bit_kubuntu
          Hide
          office@gehostet.de ANSI Soderstrom added a comment - - edited

          ty ... but :

          autobuild build -c ReleaseFS_open – -DSTANDALONE:BOOL=ON -DWORD_SIZE=64

          will cause the error
          /home/xyz/src/phoenix-firestorm/indra/llcommon/lleventcoro.h:36:38: critical error: boost/coroutine/future.hpp: File not found
          compiling ended.

          and end compiling...

          Now is the question :
          i dont find this file somewhere in the whole internet, whats next ?
          The #phoenixviewer-dev is very quiet.... all people sleeping there.
          I want to go online.... please

          Show
          office@gehostet.de ANSI Soderstrom added a comment - - edited ty ... but : autobuild build -c ReleaseFS_open – -DSTANDALONE:BOOL=ON -DWORD_SIZE=64 will cause the error /home/xyz/src/phoenix-firestorm/indra/llcommon/lleventcoro.h:36:38: critical error: boost/coroutine/future.hpp: File not found compiling ended. and end compiling... Now is the question : i dont find this file somewhere in the whole internet, whats next ? The #phoenixviewer-dev is very quiet.... all people sleeping there. I want to go online.... please
          Hide
          ansariel.hiller Ansariel Hiller added a comment -

          Issue reported on an outdated and not anymore supported version. If there are still issues, please create a new JIRA.

          Show
          ansariel.hiller Ansariel Hiller added a comment - Issue reported on an outdated and not anymore supported version. If there are still issues, please create a new JIRA.
          Hide
          whirly.fizzle Whirly Fizzle added a comment -

          Heya Guys,

          If any of you would like to try a test Linux 64bit build of Firestorm which should run on Debian Wheezy, please leave me a comment here and I will give you the download link.

          Show
          whirly.fizzle Whirly Fizzle added a comment - Heya Guys, If any of you would like to try a test Linux 64bit build of Firestorm which should run on Debian Wheezy, please leave me a comment here and I will give you the download link.

            People

            • Assignee:
              Unassigned
              Reporter:
              jean horten Jean Horten
            • Votes:
              2 Vote for this issue
              Watchers:
              11 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: