Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-8349

[PATCH] Icon appears outside of group notice window

    Details

    • Type: Bug
    • Status: Passed QA
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 4.3.0, Phoenix Firestorm 4.3.1
    • Fix Version/s: Phoenix Firestorm 4.4.0
    • Component/s: None
    • Labels:
      None
    • Environment:
    • SL Avatar Name:
      Dan Threebeards
    • Patch attached:
      Patch attached
    • Reported In:
      Firestorm 4.3.0.30936 Havok Beta

      Description

      Using starlight skin, when viewing a group notice the group icon is duplicated and displayed to the right of the notice (look near the X). I did not notice it on the default skin.

      Note this was found in Firestorm 4.3.0 (31071) but it was not available in the "reported in" dropdown box.

      1. panel_group_notify.xml
        2 kB
        Hitomi Tiponi
      1. group notice.png
        350 kB

        Issue Links

          Activity

          nogardrevlis NogarDrevlis Lectar added a comment - - edited

          Removed

          hitomi.tiponi Hitomi Tiponi added a comment -

          Issue replicated on Firestorm 4.3.0 Beta and latest dev version. It does not occur on StarLight for the Linden Lab viewer.

          hitomi.tiponi Hitomi Tiponi added a comment - - edited

          The patch contains a version of panel_group_notify.xml with 'icon_postioning="none"' relating to the title. I assume this was caused by some change to the underlying code.

          hitomi.tiponi Hitomi Tiponi added a comment -

          Please add the attached file (panel_group_notify.xml) to the xui/en folders of both the starlight and starlightcui themes.

          whirly.fizzle Whirly Fizzle added a comment -

          Pushed rev 31166 (http://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/3816e31b1d9d)

          Thanks Hitomi

          I'm not sure if this is normal for Starlight, but the group name shows as only dots on the notices, I think only if the sender has a long name?

          Metaharper for comparison:

          hitomi.tiponi Hitomi Tiponi added a comment -

          Yes - is only if the name of person or group is too long - may change it to the way the default skin does it some time.

          whirly.fizzle Whirly Fizzle added a comment -

          Thanks Hitomi <3
          I thought this was the case as its this way on V3 too.


            People

            • Assignee:
              whirly.fizzle Whirly Fizzle
              Reporter:
              dan_threebeards Dan Threebeards
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: