Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-8569

ascii characters appear as squares

    Details

    • Type: Support Request
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Component/s: Avatars, User Interface
    • Labels:
    • Environment:
    • SL Avatar Name:
      Axurik
    • Reported In:
      Firestorm 4.3.1.31155 Havok Release

      Description

      ascii characters appear as squares, cant not be read

        Issue Links

          Activity

          ansariel.hiller Ansariel Hiller added a comment -

          ASCII or Unicode? What characters exactly?

          astreajupiter Astrea Jupiter added a comment - - edited

          I'm having this issue too on a new installation of Firestorm on a Windows8 machine. I see some of the characters used in display names and others show up as squares. I am not sure which ones are ASCII or which are Unicode. But if you look at my display name on the website it shows the characters correctly so I don't think the problem is my computer.

          How do I tell which are ascii and which are Unicode?

          I have had this happen before when I have updated Firestorm with a clean install, but it seems to resolve itself eventually.

          ansariel.hiller Ansariel Hiller added a comment -

          For a list of ASCII characters see http://en.wikipedia.org/wiki/ASCII

          Astrea's display name is ..ครtгεค.. - it shows fine for me in Firestorm, but this is usually a font issue and depends on the fonts installed on the system if they can show such weird characters.

          P.S. - Pro Tip: Don't use such Unicode garbage - it can cause trouble.

          astreajupiter Astrea Jupiter added a comment -

          Interesting, let me see if I understand the formula: Unicode = garbage || emoticon = cute . This is a game after all. Lol

          However, as I stated, I see the characters in everything except firestorm so my system apparently sees them fine.

          whirly.fizzle Whirly Fizzle added a comment -

          Astrea,

          What font are you using in the viewer?
          Do you still see squares using the default deja vu font?

          I see your display name correctly as ..ครtгεค.. on...

          Firestorm 4.4.0 (32664) Feb 8 2013 09:55:39 (Firestorm-Fizzlefire) with OpenSimulator support
          Release Notes

          You are at 131,165.0, 251,701.0, 36.0 in Veil of Shadows located at sim9104.agni.lindenlab.com (216.82.42.40:13029)
          Second Life Server 13.01.25.269523
          Release Notes

          CPU: Intel(R) Core(TM)2 Quad CPU Q8300 @ 2.50GHz (2493.75 MHz)
          Memory: 3326 MB
          OS Version: Microsoft Windows Vista 32-bit Service Pack 2 (Build 6002)
          Graphics Card Vendor: NVIDIA Corporation
          Graphics Card: GeForce GT 230/PCIe/SSE2

          Windows Graphics Driver Version: 9.18.0013.1054
          OpenGL Version: 3.3.0

          RestrainedLove API: (disabled)
          libcurl Version: libcurl/7.21.1 OpenSSL/1.0.0d zlib/1.2.5 c-ares/1.7.1
          J2C Decoder Version: KDU v7.1
          Audio Driver Version: FMOD version 3.750000
          Qt Webkit Version: 4.7.1 (version number hard-coded)
          Voice Server Version: Vivox 2.1.3010.6270

          Settings mode: Firestorm
          Viewer Skin: MetaHarper Modern (CoolOcean)
          Font Used: Deja Vu (96)
          Draw distance: 128
          Bandwidth: 1500
          LOD factor: 2
          Render quality: Medium-High (4/7)
          Built with MSVC version 1600
          Packets Lost: 61/63,980 (0.1%)

          mahvi Mahvi Resident added a comment -

          For me it's on the Mac version of Firestorm 4.3.1.31155 with the default font (Deja Vu) previously OpenDyslexic but same issue. The unicode and ascii symbols appear fine on my web browser but as squares for some on firestorm when I try viewing notecards or display names.

          evief Evie Falconer added a comment -

          I also have this issue

          I am using Windows XP professional SP3

          I was using Deja vu font and see certain characters on SL as boxes. I changed to Liberation font and still just see boxes. I have downloaded the Deja Vu fonts to ensure they are up to date with no change

          example:

          ღ JΣההα ღ (jenna.hareshide)
          Ɗᵅᵞᵗᵒᵑᵃ (daytona.coba)

          I see the names fine in this Jira but in SL the first and last characters are boxes

          lex Alexandra Berchot added a comment -

          I ran into this issue after a fresh install.

          Im running the viewer viewer (4.4.2.34167) on a 64bit Slackware Linux System with multilib installed; Inputting Asian charachters or seeing them (Hindi/Arabic renders fine) renders the font as boxes.

          However in the logfiles and in every thing else (such as an external firefox browser, terminal)they are rendered correctly. I am stumped. It seems to be inline pretty much with this issue. The issue is persistant over 4.5.1.38838

          lex Alexandra Berchot added a comment -

          Okay, I had it sort of fixed. I found a proper unicode font after recommendeation (code2000 was recommended), although the best font to use is ArialUni.ttf. However you need to have office or buy it from microsoft. One I had that font, I installed it in /usr/share/fonts/unicode.

          To be sure I also made the following symlinks
          /usr/share/fonts/truetype to /usr/share/fonts/TTF.
          ArialUni.ttf to unicode.ttf

          that seemed to have done the job.

          ansariel.hiller Ansariel Hiller added a comment -

          Closing as apparently fixed.

          distraida distraida brionnae added a comment -

          I am on Mac OS X High Sierra (10.13.4) and FS Release X64 5.0.11.53634 (if i am reading the small print right). I /have/ Arial Unicode installed on the Mac. I alson installed the code2000 font that was mentioned above. I still am seeing some characters as boxes on this Mac. NOTE: I am usually using a PC and do not have this issue on the PC: Here's the specs for the Mac:

          Firestorm 5.0.11 (53634) Jan 12 2018 09:04:18 (Firestorm-Releasex64) with OpenSimulator support
          Release Notes

          You are at 233.8, 44.0, 245.5 in Kandor located at sim10712.agni.lindenlab.com (216.82.53.74:13011)
          SLURL: http://maps.secondlife.com/secondlife/Kandor/234/44/245
          (global coordinates 258026.0, 230956.0, 245.5)
          Second Life RC LeTigre 18.05.14.515432
          Release Notes

          CPU: Intel(R) Core(TM) i7-3740QM CPU @ 2.70GHz (2700 MHz)
          Memory: 16384 MB
          OS Version: Mac OS X 10.13.4 Darwin 17.5.0 Darwin Kernel Version 17.5.0: Fri Apr 13 19:32:32 PDT 2018; root:xnu-4570.51.2~1/RELEASE_X86_64 x86_64
          Graphics Card Vendor: NVIDIA Corporation
          Graphics Card: NVIDIA GeForce GT 650M OpenGL Engine

          OpenGL Version: 2.1 NVIDIA-10.30.25 355.11.10.10.30.120

          RestrainedLove API: RLV v3.1.4 / RLVa v2.1.0.53634
          libcurl Version: libcurl/7.47.0 OpenSSL/1.0.1i zlib/1.2.8
          J2C Decoder Version: KDU v7.9
          Audio Driver Version: FMOD Ex 4.44.61
          LLCEFLib/CEF Version: 1.5.3-(CEF-OSX-3.2171.2069-32)
          LibVLC Version: Undefined
          Voice Server Version: Vivox 4.6.0017.22050

          Settings mode: Firestorm
          Viewer Skin: StarLight CUI (Custom Dark)
          Window size: 1920x977 px
          Font Used: Noto Sans (96 dpi)
          Font Size Adjustment: 1 pt
          UI Scaling: 1.2
          Draw distance: 64 m
          Bandwidth: 500 kbit/s
          LOD factor: 1.5
          Render quality: Medium-Low (2/7)
          Advanced Lighting Model: No
          Texture memory: 768 MB (1)
          VFS (cache) creation time (UTC): 2018-5-16T4:11:11
          Built with Clang version 4.2.1 Compatible Apple LLVM 8.1.0 (clang-802.0.42)
          Packets Lost: 0/13950 (0.0%)
          May 17 2018 15:15:08 SLT

          ღĹγrαМαrie α.к.α Lσνєღ
          亗Amelia Belle Rosewood亗

          and the notecards i have for special characters are showing a lot of boxes on the Mac, none on the PC (running windows 10)

          Any suggestions?

          distraida distraida brionnae added a comment -

          just double checked, this problem does not exist on the default LL viewer. Also, on my Windows 10 PC, I haven't needed to use language packs, just the fonts I got with Office. (ArialUni as mentioned in a comment above)


            People

            • Assignee:
              Unassigned
              Reporter:
              axurik Marina CF
            • Votes:
              2 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: