Uploaded image for project: 'Firestorm'
  1. Firestorm
  2. FIRE-9951

[BUG-2365] [MAINT-2606] [SSA] Fell into ground after saving edited shape (hover)

    Details

    • Type: Bug
    • Status: Passed QA
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Phoenix Firestorm 4.4.0, Phoenix Firestorm 4.4.5
    • Fix Version/s: Phoenix Firestorm 4.5.2
    • Component/s: Avatars
    • Labels:
    • Environment:
    • SL Avatar Name:
      Lette Ponnier
    • Reported In:
      Firestorm 4.4.0.33720‏ SSA Release

      Description

      I created a new shape, saved it, all was fine... then made a standard sizing-compatible version of it, and as I saved it, my avatar went straight through the floor, even though I had not changed "Hover" from the default.

      Here were the steps, even though I wasn't able to make it happen again after that:

      • Right-click self and enter Edit Shape
      • Change some values on shape sliders. BUG-2365 suggests that "Body fat" is the key slider to reproduce this, and that was one of the sliders I adjusted. Don't change "Hover" - that would be cheating!
      • Click "Save As" at the bottom of the floater and name new shape
      • Observe entire avatar sink into floor (as pictured)

      Re-entering Appearance caused me to pop back up (double-clicking a surface, hopping on and then off a sittable object, and jumping didn't work to do this).

        Issue Links

          Activity

          lette Lette Ponnier created issue -
          whirly.fizzle Whirly Fizzle made changes -
          Field Original Value New Value
          Link This issue is duplicated by FIRE-9959 [ FIRE-9959 ]
          whirly.fizzle Whirly Fizzle made changes -
          Summary Fell into ground after saving edited shape [BUG-2365] Fell into ground after saving edited shape
          whirly.fizzle Whirly Fizzle made changes -
          Remote Link This issue links to "BUG-2365 Changing 'Body fat' value makes you fall under ground (Web Link)" [ 10718 ]
          whirly.fizzle Whirly Fizzle made changes -
          Summary [BUG-2365] Fell into ground after saving edited shape [BUG-2365] [MAINT-2606] Fell into ground after saving edited shape
          whirly.fizzle Whirly Fizzle made changes -
          Remote Link This issue links to "MAINT-2606 Internal LL Issue (Web Link)" [ 10719 ]
          whirly.fizzle Whirly Fizzle made changes -
          Remote Link This issue links to "DRTVWR-234 (Web Link)" [ 10720 ]
          whirly.fizzle Whirly Fizzle made changes -
          Labels SSAbug V3Bug
          whirly.fizzle Whirly Fizzle made changes -
          Component/s Avatars [ 10001 ]
          whirly.fizzle Whirly Fizzle made changes -
          Summary [BUG-2365] [MAINT-2606] Fell into ground after saving edited shape [BUG-2365] [MAINT-2606] [SSA] Fell into ground after saving edited shape
          whirly.fizzle Whirly Fizzle made changes -
          Fix Version/s Phoenix Firestorm 4.4.1 [ 10820 ]
          whirly.fizzle Whirly Fizzle made changes -
          Assignee ShouldBeWorkingOnIt Linden [ shouldbeworkingonit.linden ]
          whirly.fizzle Whirly Fizzle made changes -
          Affects Version/s Phoenix Firestorm 4.4.5 [ 10821 ]
          whirly.fizzle Whirly Fizzle made changes -
          Link This issue is duplicated by FIRE-10061 [ FIRE-10061 ]
          whirly.fizzle Whirly Fizzle made changes -
          Fix Version/s Phoenix Firestorm 4.4.5 [ 10821 ]
          Fix Version/s Phoenix Firestorm 4.4.1 [ 10820 ]
          Hide
          soto hax Soto Hax added a comment - - edited

          This has been happening to me too. Sometimes when I edit my shape hover and then save, the hover value just automatically drops to 13. I'm assuming this is a Linden issue, so can anyone provide a relevant link to their JIRA (the links given so far just result in a message about "Permissions Violation", even when logged in).

          Edit: Searching the LL JIRA for issues created within the past year with the word "hover" in the summary didn't turn up anything relevant.

          Show
          soto hax Soto Hax added a comment - - edited This has been happening to me too. Sometimes when I edit my shape hover and then save, the hover value just automatically drops to 13. I'm assuming this is a Linden issue, so can anyone provide a relevant link to their JIRA (the links given so far just result in a message about "Permissions Violation", even when logged in). Edit: Searching the LL JIRA for issues created within the past year with the word "hover" in the summary didn't turn up anything relevant.
          whirly.fizzle Whirly Fizzle made changes -
          Link This issue is duplicated by FIRE-10202 [ FIRE-10202 ]
          Hide
          whirly.fizzle Whirly Fizzle added a comment -

          Heya Soto,

          I'm afraid this issue was filed in the BUG section on the LL JIRA, which means its not publicly visible.
          The Hover parameter was added as part of the serverside appearance code changes so there will be no older LL JIRA issues about it.

          This bug is the same on any viewer using the new hover feature - its a Linden bug.

          Show
          whirly.fizzle Whirly Fizzle added a comment - Heya Soto, I'm afraid this issue was filed in the BUG section on the LL JIRA, which means its not publicly visible. The Hover parameter was added as part of the serverside appearance code changes so there will be no older LL JIRA issues about it. This bug is the same on any viewer using the new hover feature - its a Linden bug.
          Hide
          lewisluminos Lewis Luminos added a comment -

          I have started having this problem too. I don't even have to DO anything - I re-set it to 50, a couple of seconds later it drops to 9. Rinse and repeat, whether I'm changing any other settings, or moving, or not. As a workaround I've given myself (with the help of a friend) a no-mod version of my shape but this is an extremely unsatisfactory workaround.

          Show
          lewisluminos Lewis Luminos added a comment - I have started having this problem too. I don't even have to DO anything - I re-set it to 50, a couple of seconds later it drops to 9. Rinse and repeat, whether I'm changing any other settings, or moving, or not. As a workaround I've given myself (with the help of a friend) a no-mod version of my shape but this is an extremely unsatisfactory workaround.
          whirly.fizzle Whirly Fizzle made changes -
          Link This issue is duplicated by FIRE-10354 [ FIRE-10354 ]
          willow wilder Willow Wilder made changes -
          Summary [BUG-2365] [MAINT-2606] [SSA] Fell into ground after saving edited shape [BUG-2365] [MAINT-2606] [SSA] Fell into ground after saving edited shape (hover)
          whirly.fizzle Whirly Fizzle made changes -
          Fix Version/s Phoenix Firestorm 4.4.6 [ 10922 ]
          Fix Version/s Phoenix Firestorm 4.4.5 [ 10821 ]
          whirly.fizzle Whirly Fizzle made changes -
          Link This issue is duplicated by FIRE-10913 [ FIRE-10913 ]
          whirly.fizzle Whirly Fizzle made changes -
          Link This issue is duplicated by FIRE-10939 [ FIRE-10939 ]
          whirly.fizzle Whirly Fizzle made changes -
          Link This issue is duplicated by FIRE-10951 [ FIRE-10951 ]
          Hide
          thandi rhiadra Thandi Rhiadra added a comment -

          This is happening to me, as well - when editing clothing layers and saving. When I come out of edit appearance, my hover sets to 50 and I'm shoved through the floor (looking just like the picture provided by Lette. It doesn't happen all the time, so I'm not sure if I'm doing something odd to cause it or not. I've also experienced that sinking below the ground after hopping up from pose balls on occasion. Next time that happens, I'm going to look at my hover and see if it's changed somehow. Just putting in my two cents - that's all it's worth. lol.

          Show
          thandi rhiadra Thandi Rhiadra added a comment - This is happening to me, as well - when editing clothing layers and saving. When I come out of edit appearance, my hover sets to 50 and I'm shoved through the floor (looking just like the picture provided by Lette. It doesn't happen all the time, so I'm not sure if I'm doing something odd to cause it or not. I've also experienced that sinking below the ground after hopping up from pose balls on occasion. Next time that happens, I'm going to look at my hover and see if it's changed somehow. Just putting in my two cents - that's all it's worth. lol.
          Hide
          leelymelody LeelyMelody added a comment -

          I am having this issue too, in all SLUrl's inworld I'm "in" the floor, just like the picture of this discription! And i don't even need to edit anything, it just happen everytime I log in... And my friends see me in this way too!

          Show
          leelymelody LeelyMelody added a comment - I am having this issue too, in all SLUrl's inworld I'm "in" the floor, just like the picture of this discription! And i don't even need to edit anything, it just happen everytime I log in... And my friends see me in this way too!
          Hide
          thandi rhiadra Thandi Rhiadra added a comment -

          Leely - go into Edit Appearance/Edit Shape and look at the first tab, at the bottom - HOVER slider. It's likely changed to some ridiculous number like 5 and it needs to be set at 50 to be properly on the ground. Mine actually changes all on it's own when I come out of edit appearance mode sometimes. It's a known issue. Please check that and see if it helps!

          This is a P.S. to the earlier comment I made. I said I'd check to see if my hover setting changed, thus causing me to be in the ground with only my head showing ... lol. The hover height DOES change - on it's own - to 5. This occurs even when I'm not messing with my shape settings. If I use Edit Appearance to rebake or to modify clothing layers it can happen to me. It doesn't happen all the time and it hasn't happened lately. But when it did happen last, I looked at the hover setting and it had reverted to 5. Just an FYI.

          Show
          thandi rhiadra Thandi Rhiadra added a comment - Leely - go into Edit Appearance/Edit Shape and look at the first tab, at the bottom - HOVER slider. It's likely changed to some ridiculous number like 5 and it needs to be set at 50 to be properly on the ground. Mine actually changes all on it's own when I come out of edit appearance mode sometimes. It's a known issue. Please check that and see if it helps! This is a P.S. to the earlier comment I made. I said I'd check to see if my hover setting changed, thus causing me to be in the ground with only my head showing ... lol. The hover height DOES change - on it's own - to 5. This occurs even when I'm not messing with my shape settings. If I use Edit Appearance to rebake or to modify clothing layers it can happen to me. It doesn't happen all the time and it hasn't happened lately. But when it did happen last, I looked at the hover setting and it had reverted to 5. Just an FYI.
          Hide
          leelymelody LeelyMelody added a comment -

          Thandi - The tip you gave me about the HOVER worked perfectly, ty so much! Now I know how to fix if it happen again...lol
          Ty a looot, i was worry about it, like a never be as normal again!!hahaha

          Show
          leelymelody LeelyMelody added a comment - Thandi - The tip you gave me about the HOVER worked perfectly, ty so much! Now I know how to fix if it happen again...lol Ty a looot, i was worry about it, like a never be as normal again!!hahaha
          willow wilder Willow Wilder made changes -
          Link This issue is duplicated by SUP-12633 [ SUP-12633 ]
          willow wilder Willow Wilder made changes -
          Link This issue is duplicated by SUP-12626 [ SUP-12626 ]
          whirly.fizzle Whirly Fizzle made changes -
          Fix Version/s Phoenix Firestorm 4.5.1 [ 11021 ]
          Fix Version/s Phoenix Firestorm 4.4.6 [ 10922 ]
          whirly.fizzle Whirly Fizzle made changes -
          Link This issue is related to SUP-12695 [ SUP-12695 ]
          willow wilder Willow Wilder made changes -
          Link This issue relates to SUP-12681 [ SUP-12681 ]
          whirly.fizzle Whirly Fizzle made changes -
          Fix Version/s Phoenix Firestorm 5.0.1 [ 10721 ]
          Fix Version/s Phoenix Firestorm 4.5.1 [ 11021 ]
          whirly.fizzle Whirly Fizzle made changes -
          Link This issue is related to SUP-12862 [ SUP-12862 ]
          willow wilder Willow Wilder made changes -
          Link This issue relates to FIRE-12570 [ FIRE-12570 ]
          lassie Lassie made changes -
          Link This issue relates to FIRE-12570 [ FIRE-12570 ]
          lassie Lassie made changes -
          Link This issue is duplicated by FIRE-12570 [ FIRE-12570 ]
          Hide
          whirly.fizzle Whirly Fizzle added a comment -
          Show
          whirly.fizzle Whirly Fizzle added a comment - Fixed rev 39853 ( http://hg.phoenixviewer.com/phoenix-firestorm-lgpl/rev/e1f758ea61a3 )
          whirly.fizzle Whirly Fizzle made changes -
          Assignee ShouldBeWorkingOnIt Linden [ shouldbeworkingonit.linden ] Cinder Biscuits [ cinderblocks ]
          whirly.fizzle Whirly Fizzle made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Fix Version/s Phoenix Firestorm 4.5.2 [ 11023 ]
          Fix Version/s Phoenix Firestorm 5.0.1 [ 10721 ]
          Resolution Fixed [ 1 ]
          lassie Lassie made changes -
          Status Resolved [ 5 ] Ready for QA [ 10001 ]
          lassie Lassie made changes -
          Status Ready for QA [ 10001 ] In QA [ 10002 ]
          lassie Lassie made changes -
          Status In QA [ 10002 ] Passed QA [ 10003 ]

            People

            • Assignee:
              cinderblocks Cinder Biscuits
              Reporter:
              lette Lette Ponnier
            • Votes:
              4 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: